Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-06-2011, 20:47   #1
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
OpenCPN Version 2.4 Beta Build 611

Ahoy There, OpenCPN'ers...

OpenCPN Version 2.4 Beta Build 611 will soon be available for download from opencpn.org.

Monitor the opencpn.org Downloads page to find and download the latest Beta version.....

Source is available now on sourceforge git repo.

Changelog:

160. Correct CM93 quilted COG-Up auto-follow rendering
161. Add some missing translation strings to RouteProps
162. Move Layers directory to {PrivateDataDir}
163. Two small patches to Layers logic (FS#507)
164. Correct unintentional chart shift on Toolbar orientation toggle (FS#486)
165. Improve Toolbar Tooltip positioning logic
166. Correct sometimes crash on OCPN exit with AISTargetList open. (FS#517)
167. Correct another sometimes crash on Track delete (FS#507)
168. Improve GPS Status Window positioning logic (FS#516)
169. Correct console BRG formatting for >= 359.5 (FS#519)

Notes:

160. Note the added UpdatePeriod field in Toolbox->GPS. This period relates to how often the entire ViewPort (i.e. the displayed chart) is updated. The ownship and AIS icons are updated every second, as usual.

Language files:
One more chance to update language files for the 2.5 Release. There is at least one new string in 611 that needs to be translated.

All possible smoke tests encouraged....

Thanks to all for your testing efforts. We will soon be able to take a breather, and think bigger thoughts....

Good Luck
Dave
__________________

__________________
bdbcat is online now   Reply With Quote
Old 12-06-2011, 02:46   #2
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,249
Re: OpenCPN Version 2.4 Beta Build 611

Dave

There is a CM93 problem. In small scales large areas are grayed out, sometimes black.
I have tested a few different versions. Sometimes there are gray rectangles on the world map when zoomed out. With cm93 may 2010 it can easily be seen. Center on the English Channel. If clicking east of Greenwich all is gray, while it is OK to the west. I don't think its a new 0 degree mole, as the charts displays when zooming in. Same result with quilting on or off.
A & Z scale problem?

Thomas
__________________

__________________
cagney is offline   Reply With Quote
Old 12-06-2011, 03:29   #3
Registered User

Join Date: Sep 2009
Location: Rome
Posts: 320
Re: OpenCPN Version 2.4 Beta Build 611

Ciao Dave

I still don't see the following strings in the translation file.

In AIS Target Query:

MMSI:
IMO:


In AIS Target List:

S.

Do you plan to add them?

Ciao, Marco.
__________________
GPS-Marco is offline   Reply With Quote
Old 12-06-2011, 04:50   #4
Registered User
 
Netsurfer's Avatar

Join Date: Jan 2010
Location: Cologne, Germany
Boat: Beneteau Oceanis 331
Posts: 557
Re: OpenCPN Version 2.4 Beta Build 611

Dave ...

I have a massive problem with 611.
Only CM93 installed - when moving the chart around it is all grey suddenly (Zoom faktor 0.5, 1.0, 2.0 and 4.0). Zooming in further then the chart reappears at zoom level 1.2 and from there all is OK.
(See attached screenshots 2 and 2a - the difference between the two is just moving the chart a little bit to the left (W)).

I guess it is the same problem that Thomas already described.

IMHO this makes this version quite unusable why I did not upload it, yet.

What do you think?
Would you like to eliminate this bug first, or shall we publish it anyway?

Gunther
Attached Thumbnails
Click image for larger version

Name:	CM93-problem-01.PNG
Views:	90
Size:	185.6 KB
ID:	28393   Click image for larger version

Name:	CM93-problem-02.PNG
Views:	81
Size:	222.0 KB
ID:	28394  

Click image for larger version

Name:	CM93-problem-02a.PNG
Views:	78
Size:	147.1 KB
ID:	28395  
__________________
Deutschsprachige Community- und Support-Website unter OpenCPN.de
Netsurfer is offline   Reply With Quote
Old 12-06-2011, 06:36   #5
Registered User

Join Date: May 2011
Posts: 847
Re: OpenCPN Version 2.4 Beta Build 611

Layers - I'm not sure where to set the user directory to layers but haven't spent time looking for it. However I think I have found a couple of problems.

1. When importing a GPX to a layer the objects in the file appear as waypoints but the layer does not appear in the layers list.

2. User Icons are not shown to objects that they were previously assigned to, nor do they appear in the icons list in the waypoint properties window. Has this directory been reassigned too?

I can confirm the CM93 problem described by the others and add some information. On my system it only occurs when zero longitude (Greenwich meridian) is left of the centre of the screen. Ubuntu Linux 11.04
__________________
Littlechay is offline   Reply With Quote
Old 12-06-2011, 06:48   #6
Registered User

Join Date: May 2011
Posts: 847
Re: OpenCPN Version 2.4 Beta Build 611

Oh you import a layer with "Temporary Layer" missed that one. If I do that it is in the list as expect, but no user icons.

And no plugins. Nothing in the toolbox plugins tab - totally blank

A minor annoyance, but when I open the toolbox it is layered below the toolbar and I have to click in the toolbox to bring it to the top.
__________________
Littlechay is offline   Reply With Quote
Old 12-06-2011, 06:50   #7
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,249
Re: OpenCPN Version 2.4 Beta Build 611

Quote:
Originally Posted by Netsurfer View Post
Dave ...

I have a massive problem with 611.
Only CM93 installed - when moving the chart around it is all grey suddenly (Zoom faktor 0.5, 1.0, 2.0 and 4.0). Zooming in further then the chart reappears at zoom level 1.2 and from there all is OK.
(See attached screenshots 2 and 2a - the difference between the two is just moving the chart a little bit to the left (W)).

I guess it is the same problem that Thomas already described.

IMHO this makes this version quite unusable why I did not upload it, yet.

What do you think?
Would you like to eliminate this bug first, or shall we publish it anyway?

Gunther
Gunther
We will have to see What Dave says.
Meanwhile, I still think that users can do worthwhile testing on the new beta.
A beta is a beta, and this one isn't having users system for lunch
Thomas
__________________
cagney is offline   Reply With Quote
Old 12-06-2011, 07:02   #8
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,249
Re: OpenCPN Version 2.4 Beta Build 611

Dave

A look in my log reveals part of the problem
Quote:
10:26:18 CEST: Loaded CM93 Dictionary from /opt/navigation/Charts/CM93/CM93ed2_31May2010/CM93/
10:26:18 CEST: CM93 finds no chart of any scale present at Lat/Lon 51.8006 -19.7217
10:26:18 CEST: CM93 finds no chart of any scale present at Lat/Lon 51.8006 -19.7217
10:26:18 CEST: CM93 finds no chart of any scale present at Lat/Lon 51.8006 -19.7217
10:26:18 CEST: CM93 finds no chart of any scale present at Lat/Lon 51.8006 -19.7217
10:26:18 CEST: CM93 finds no chart of any scale present at Lat/Lon 51.8006 -19.7217
10:26:18 CEST: CM93 finds no chart of any scale present at Lat/Lon 51.8006 -19.7217
10:26:19 CEST: CM93 finds no chart of any scale present at Lat/Lon 51.7118 -20.0086
10:26:19 CEST: CM93 finds no chart of any scale present at Lat/Lon 51.7118 -20.0086
10:26:19 CEST: CM93 finds no chart of any scale present at Lat/Lon 50.7236 -24.3115
10:26:19 CEST: CM93 finds no chart of any scale present at Lat/Lon 49.8993 -28.4711
10:26:19 CEST: CM93 finds no chart of any scale present at Lat/Lon 49.8993 -28.4711
10:26:20 CEST: CM93 finds no chart of any scale present at Lat/Lon 48.9665 -33.2044
10:26:20 CEST: CM93 finds no chart of any scale present at Lat/Lon 48.4935 -35.7862
10:26:20 CEST: CM93 finds no chart of any scale present at Lat/Lon 48.4935 -35.7862
..and more of the same.

LittleChay
Quote:
And no plugins. Nothing in the toolbox plugins tab - totally blank
I have the grib, dashboard and the VDR ( self compiled).
The libchartdldr is rejected as wrong version, and it looks like the variation plugin just disappeared......
Have a look in your logfile.
The new location of the default layer file is the wiki documentation.

Thomas
__________________
cagney is offline   Reply With Quote
Old 12-06-2011, 07:20   #9
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN Version 2.4 Beta Build 611

Hello all....

Obviously a glitch on 611 with cm93.
Please stand by, I'll have a look. sigh.....

Dave
__________________
bdbcat is online now   Reply With Quote
Old 12-06-2011, 07:35   #10
Registered User

Join Date: May 2011
Posts: 847
Re: OpenCPN Version 2.4 Beta Build 611

Thanks. Missed the location of the new Layers AND the user icons directories, in the docs. Sorry for the noise.

Here are the plugin lines from my log file. A bunch of undefined symbol errors. The only plugins that worked with 606 were the dashboard, VDR, and the GRIB (well the grib plugin is almost useless without the pressure isobars but that is in the bug reports)

Quote:
10:27:24 UYT: PlugInManager searching for PlugIns in location /usr/local/share/opencpn/plugins
10:27:24 UYT: PlugInManager: Loading PlugIn: /usr/local/share/opencpn/plugins/libgrib_pi.so
10:27:24 UYT: Error: /usr/local/share/opencpn/plugins/libgrib_pi.so: undefined symbol: AddLocaleCatalog
10:27:24 UYT: PlugInManager: Cannot load library: /usr/local/share/opencpn/plugins/libgrib_pi.so
10:27:24 UYT: PlugInManager: Loading PlugIn: /usr/local/share/opencpn/plugins/libvdr_Ubuntu10-i386_pi.so
10:27:24 UYT: Error: /usr/local/share/opencpn/plugins/libvdr_Ubuntu10-i386_pi.so: undefined symbol: _ZN14opencpn_plugin11SetDefaultsEv
10:27:24 UYT: PlugInManager: Cannot load library: /usr/local/share/opencpn/plugins/libvdr_Ubuntu10-i386_pi.so
10:27:24 UYT: PlugInManager: Loading PlugIn: /usr/local/share/opencpn/plugins/liblogbook_Ubuntu10-i386_pi.so
10:27:24 UYT: Error: /usr/local/share/opencpn/plugins/liblogbook_Ubuntu10-i386_pi.so: undefined symbol: _ZN14opencpn_plugin11SetDefaultsEv
10:27:24 UYT: PlugInManager: Cannot load library: /usr/local/share/opencpn/plugins/liblogbook_Ubuntu10-i386_pi.so
10:27:24 UYT: PlugInManager: Loading PlugIn: /usr/local/share/opencpn/plugins/libdashboard_pi.so
10:27:24 UYT: Error: /usr/local/share/opencpn/plugins/libdashboard_pi.so: undefined symbol: AddLocaleCatalog
10:27:24 UYT: PlugInManager: Cannot load library: /usr/local/share/opencpn/plugins/libdashboard_pi.so
__________________
Littlechay is offline   Reply With Quote
Old 12-06-2011, 07:41   #11
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN Version 2.4 Beta Build 611

Hello, testers!

Happy Sunday morning, I think.

The cm93 problem with 611 is simple. A not-fully-considered optimization gone wrong for east longitude.....

Lets not publish 611 on the .org site. I'll have a 612 ready in a couple of hours.

Sorry for the glitch

Dave
__________________
bdbcat is online now   Reply With Quote
Old 12-06-2011, 07:44   #12
Registered User
 
Netsurfer's Avatar

Join Date: Jan 2010
Location: Cologne, Germany
Boat: Beneteau Oceanis 331
Posts: 557
Re: OpenCPN Version 2.4 Beta Build 611

Dave ...
Quote:
Originally Posted by bdbcat View Post
Happy Sunday morning, I think.

The cm93 problem with 611 is simple. ...

Lets not publish 611 on the .org site. I'll have a 612 ready in a couple of hours.
that's all good news!

Standby - waiting for 612 to compile and upload as usual!

Thanks
Gunther
__________________
Deutschsprachige Community- und Support-Website unter OpenCPN.de
Netsurfer is offline   Reply With Quote
Old 12-06-2011, 08:06   #13
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN Version 2.4 Beta Build 611

Thomas/littlechay....

Thomas, do your PlugIns work?

littlechay: I understand that the plugins worked on 606, but the same plugins do not load on 611. Is this correct?

Very strange. No change in the Plugin logic at all for 611....

Dave
__________________
bdbcat is online now   Reply With Quote
Old 12-06-2011, 08:12   #14
Registered User

Join Date: May 2011
Posts: 847
Re: OpenCPN Version 2.4 Beta Build 611

Dave,

The Dash, Grib, and VDR plugins worked with 606. But not now. I have a blank panel in the plugins tab of the toolbox.

I used the deb file so perhaps this is a smokescreen and not your problem?

The other plugins listed, logbook etc., were just parked in the directory and did not work with 606.
__________________
Littlechay is offline   Reply With Quote
Old 12-06-2011, 08:48   #15
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,249
Re: OpenCPN Version 2.4 Beta Build 611

Dave
Plugins are OK on 64 bit ubuntu.
Littlechay's problem comes from my 32 bit box where I compiled the deb he is using. Looking into that now.

Thomas
__________________

__________________
cagney is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCPN Version 2.4 Beta Build 423 bdbcat OpenCPN 66 05-05-2011 06:45
OpenCPN Version 2.4 Beta Build 412 bdbcat OpenCPN 63 22-04-2011 19:19
OpenCPN Version 2.4 Beta Build 324 bdbcat OpenCPN 141 12-04-2011 15:15
OpenCPN Version 2.4 Beta Build 310 bdbcat OpenCPN 53 27-03-2011 12:05



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 08:30.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.