Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-07-2010, 15:40   #1
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
OpenCPN Version 2.2 Beta Test Bugs / Discussion

Please post bugs and related discussion regarding OpenCPN Version 2.2 Beta testing here.

Thanks
Dave
__________________

__________________
bdbcat is offline   Reply With Quote
Old 11-07-2010, 17:43   #2
Registered User
 
Viking Sailor's Avatar

Join Date: Nov 2006
Location: San Francisco Bay
Boat: Fantasia 35 - s/v Feeling Good
Posts: 1,074
Dave,

Found this small problem when zooming out with quilting enabled. I haven't been unable to locate the 2.2 source so that I can build a debug version of the code. Sorry, but without it, I am unable to home in on the source of this problem.

Paul



Code:
[Settings]
ConfigVersionString=Version 2.2 Build 710
NavMessageShown=1
ShowDebugWindows=1
ShowPrintIcon=0
SetSystemTime=0
ShowDepthUnits=1
AutoAnchorDrop=0
ShowChartOutlines=1
GarminPersistance=0
CM93DetailFactor=0
CM93DetailZoomPosX=200
CM93DetailZoomPosY=200
ShowCM93DetailSlider=0
AllowExtremeOverzoom=1
ChartQuilting=1
UseRasterCharts=1
UseVectorCharts=0
UseCM93Charts=0
CourseUpMode=0
LookAheadMode=0
COGUPAvgSeconds=15
OwnshipCOGPredictorMinutes=5
NMEALogWindowSizeX=400
NMEALogWindowSizeY=100
NMEALogWindowPosX=10
NMEALogWindowPosY=10
PreserveScaleOnX=0
StartWithTrackActive=0
InitialStackIndex=0
AnchorWatch1GUID=
AnchorWatch2GUID=
PlanSpeed=6
Locale=en_US
GRIBUseHiDef=0
ShowGRIBIcon=1
GRIBDialogSizeX=300
GRIBDialogSizeY=540
GRIBDialogPosX=20
GRIBDialogPosY=20
[Settings/GlobalState]
VPLatLon="   37.4938, -122.4824"
VPScale=0.1536
OwnShipLatLon="   37.4922,  -122.4822"
bFollow=0
nColorScheme=0
FrameWinX=894
FrameWinY=695
FrameMax=0
bShowS57Text=1
bShowS57ImportantTextOnly=0
nDisplayCategory=77
nSymbolStyle=82
nBoundaryStyle=78
bShowSoundg=1
bShowMeta=1
bUseSCAMIN=1
bShowAtonText=1
bShowLightDescription=1
bDeClutterText=0
S52_MAR_SAFETY_CONTOUR=8
S52_MAR_SHALLOW_CONTOUR=3
S52_MAR_DEEP_CONTOUR=10
S52_MAR_TWO_SHADES=0
S52_DEPTH_UNIT_SHOW=0
[Settings/AIS]
bNoCPAMax=0
NoCPAMaxNMi=20
bCPAWarn=0
CPAWarnNMi=2
bTCPAMax=0
TCPAMaxMinutes=30
bMarkLostTargets=1
MarkLost_Minutes=8
bRemoveLostTargets=1
RemoveLost_Minutes=10
bShowCOGArrows=1
CogArrowMinutes=6
bShowTargetTracks=0
TargetTracksMinutes=0
bShowMooredTargets=1
MooredTargetMaxSpeedKnots=0.2
bAISAlertDialog=0
bAISAlertAudio=0
AISAlertAudioFile=
bAISAlertSuppressMoored=0
AlertDialogSizeX=200
AlertDialogSizeY=200
AlertDialogPosX=200
AlertDialogPosY=200
QueryDialogPosX=200
QueryDialogPosY=200
bAISRolloverShowClass=0
bAISRolloverShowCOG=0
bAISRolloverShowCPA=0
[Settings/NMEADataSource]
Source=AIS Port (Shared)
BaudRate=4800
[Settings/NMEAAutoPilotPort]
Port=None
[Settings/WiFiServer]
Server=NONE
[Settings/AISPort]
Port=None
[Settings/MSWFonts]
FontConsoleLegend=Console Legend:0;-13;0;0;0;400;0;0;0;0;0;0;0;0;MS Sans Serif:rgb(0, 0, 0)
FontConsoleValue=Console Value:0;-13;0;0;0;400;0;0;0;0;0;0;0;0;MS Sans Serif:rgb(0, 0, 0)
FontToolTips=ToolTips:0;-13;0;0;0;400;0;0;0;0;0;0;0;0;MS Sans Serif:rgb(0, 0, 0)
[Settings/Others]
ShowRadarRings=0
RadarRingsNumberVisible=1
RadarRingsStep=1
RadarRingsStepUnits=0
WaypointPreventDragging=0
EnableZoomToCursor=0
ShowTrackIcon=0
TrackIntervalSeconds=60
TrackDeltaDistance=0.1
EnableTrackByTime=1
EnableTrackByDistance=0
[Settings/ObjectFilter]
vizM_PROD=1
vizM_COVR=1
vizDEPARE=1
vizLNDARE=1
vizCOALNE=1
vizDEPCNT=1
viz_texto=1
vizUWTROC=1
vizLAKARE=1
vizRIVERS=1
vizLAKSHR=1
viz\$LINES=1
vizRIVBNK=1
vizM_SREL=1
viz\$AREAS=1
vizSEAARE=1
vizEXEZNE=1
vizNATARE=1
vizTESARE=1
vizCONZNE=1
vizRESARE=1
vizDMPGRD=1
vizTSEZNE=1
vizTSSLPT=1
vizLNDRGN=1
vizCTNARE=1
vizMIPARE=1
vizBUAARE=1
vizBRIDGE=1
vizPILBOP=1
vizCBLSUB=1
vizPIPSOL=1
vizRECTRC=1
vizSLCONS=1
vizSTSLNE=1
vizTSSBND=1
vizOBSTRN=1
vizWRECKS=1
vizBUISGL=1
vizSBDARE=1
vizTOWERS=1
vizBCNLAT=1
vizBCNSPP=1
vizBOYLAT=1
vizBOYSAW=1
vizBOYSPP=1
vizFOGSIG=1
vizLIGHTS=1
vizOFSPLF=1
vizPILPNT=1
vizRADRFL=1
vizRTPBCN=1
vizRDOSTA=1
vizTOPMAR=1
viz\$COMPS=1
viz_extgn=1
vizSOUNDG=1
vizLITHOU=1
vizNAMFLO=1
vizNAMFIX=1
vizDRGARE=1
vizPRCARE=1
vizWEDKLP=1
vizZEMCNT=1
vizAIRARE=1
vizBUIREL=1
vizCHIMNY=1
vizPYLONS=1
vizTNKCON=1
vizWATTUR=1
vizWNDMIL=1
vizLOCMAG=1
vizCGUSTA=1
vizCTRPNT=1
vizDSHAER=1
vizMONUMT=1
vizCBLARE=1
vizPIPARE=1
vizDWRTPT=1
vizFAIRWY=1
vizACHARE=1
vizDAMCON=1
vizCBLOHD=1
vizDWRTCL=1
vizFNCLNE=1
vizFERYRT=1
vizNAVLNE=1
vizTSELNE=1
vizMORFAC=1
vizPRDINS=1
vizHRBFAC=1
vizSILBUI=1
vizFLGSTF=1
vizACHBRT=1
vizRMPARE=1
vizSMCFAC=1
[Directories]
S57DataLocation=C:\\Program Files\\OpenCPN\\s57data
SENCFileLocation=C:\\Documents and Settings\\paul\\Application Data\\opencpn\\SENC
PresentationLibraryData=
CM93DictionaryLocation=C:\\Charts\\CM93-2010\\
InitChartDir=C:\\Charts\\CM93-2010
GPXIODir=
GRIBDirectory=
[ChartDirectories]
ChartDir1=C:\\Charts\\CM93-2010^
Code:
15:48:39: 2010-07-11
15:48:39:  -------Starting opencpn-------
15:48:39: Version 2.2 Build 710
15:48:39: SData_Locn is C:\Program Files\OpenCPN\
15:48:39: Using existing Config_File: C:\Documents and Settings\paul\Application Data\opencpn\opencpn.ini
15:48:39: Setting Viewpoint Lat/Lon 37.4938, -122.482
15:48:39: Setting Ownship Lat/Lon 37.4922, -122.482
15:48:39: System default Language:  en_US
3:48:39 PM: Opencpn language set to:  en_US
3:48:39 PM: Using s57data in C:\Program Files\OpenCPN\s57data
3:48:39 PM: Using Tide/Current data from:  C:\Program Files\OpenCPN\tcdata\
3:48:39 PM: Setting Viewpoint Lat/Lon 37.4938, -122.482
3:48:39 PM: Setting Ownship Lat/Lon 37.4922, -122.482
3:48:39 PM: NMEA Data Source is....AIS Port (Shared)
3:48:39 PM: AIS Data Source is....None
3:48:39 PM: Using WVSChart datafile: C:\Program Files\OpenCPN\wvsdata\wvs43.dat
3:48:39 PM: NMEA AutoPilot Port is....None
3:48:39 PM: PlugInManager: Loading PlugIn: C:\Program Files\OpenCPN\plugins/grib_pi.dll
3:48:39 PM: PlugInManager: Loading PlugIn: C:\Program Files\OpenCPN\plugins/demo_pi.dll
3:48:39 PM: Loading chart db version: V016
3:48:39 PM: Chart directory C:\Charts\CM93-2010
3:48:39 PM: GPS Watchdog Timeout is: 6 sec.
3:48:39 PM: Initializing Chart C:\Charts\CM93-2010\00300360\A\00300360.A
3:48:39 PM: CM93Composite Chart Root is C:\Charts\CM93-2010\
3:48:39 PM:  Looking for CM93 dictionary in C:\
3:48:39 PM:  Looking for CM93 dictionary in C:\Charts\
3:48:39 PM:  Looking for CM93 dictionary in C:\Charts\CM93-2010\
3:48:39 PM: Loaded CM93 Dictionary from C:\Charts\CM93-2010\
3:48:39 PM: Loading CM93 cell C:\Charts\CM93-2010\03300660/E/03820712.E
3:48:39 PM: Loading CM93 cell C:\Charts\CM93-2010\03300660/D/03810711.D
Attached Thumbnails
Click image for larger version

Name:	a711b.JPG
Views:	185
Size:	138.8 KB
ID:	17710   Click image for larger version

Name:	a711c.JPG
Views:	190
Size:	169.0 KB
ID:	17711  

Click image for larger version

Name:	a711d.JPG
Views:	166
Size:	144.6 KB
ID:	17712   Click image for larger version

Name:	a711e.JPG
Views:	170
Size:	161.5 KB
ID:	17713  

Click image for larger version

Name:	a711f.JPG
Views:	167
Size:	161.7 KB
ID:	17714   Click image for larger version

Name:	a711g.JPG
Views:	157
Size:	157.4 KB
ID:	17715  

__________________

__________________
Viking Sailor is online now   Reply With Quote
Old 11-07-2010, 19:21   #3
Registered User
 
Viking Sailor's Avatar

Join Date: Nov 2006
Location: San Francisco Bay
Boat: Fantasia 35 - s/v Feeling Good
Posts: 1,074
Dave,

I used the GIT command line interface to download the 2.2 files. Was never able to do so via the GUI. I've been able to build the WX DLL's by copying a .lib file to the vc_dll folder. However, still having problems building OpenCPN using Cmake. Will continue working on this mañana.

Paul
__________________
Viking Sailor is online now   Reply With Quote
Old 12-07-2010, 05:50   #4
Registered User

Join Date: Aug 2008
Location: the Netherlands
Boat: Will cut the land lines in 2012
Posts: 3
I am a novice user and only recently installed Ubuntu on a dedicated notebook. This is my first compilation of OpenCPN on Ubuntu. v 2.20 build 710.

Found a minor optical problem: when hovering over the Grib Icon, the explanation/help that shows-up reads 'garbage'. (screen capture attached)

Still testing and so far love it. Its like being a 'kid in a candy store'. A big thanks to everybody who has made and still are making this possible.

Rgds,

Arno
Attached Thumbnails
Click image for larger version

Name:	Screenshot-OpenCPN.png
Views:	197
Size:	212.5 KB
ID:	17724  
__________________
MarBas is offline   Reply With Quote
Old 13-07-2010, 00:25   #5
Registered User

Join Date: Mar 2009
Posts: 83
OpenCPN beta 2.2 build 710

HI

Would welcome some help with the following problem

Downloaded the current windows beta 710 and installed it. When I try to open it I get the following error message - "This application has failed to start because wxbase28_vc_custom.dll was not found."

Removed and re-installed but the problem remains. Also did a file search for - wxbase28_vc_custom.dll - on my computer but it was not there.

Does the installer come complete with this file or do we have to obtain it from another source ???????

Regards ............ Doug
__________________
dougwm10 is offline   Reply With Quote
Old 13-07-2010, 03:36   #6
Registered User
 
petermoree's Avatar

Join Date: Apr 2010
Location: Netherlands
Boat: TINTEL (36ft Hoek design) see http://www.moree.nl/tintel
Posts: 126
Build 710 crashes in Vista when scrollwheel zooming

Build 710 crashes consistently in Vista when scrollwheel zooming
__________________
petermoree is offline   Reply With Quote
Old 13-07-2010, 03:47   #7
Registered User
 
Netsurfer's Avatar

Join Date: Jan 2010
Location: Cologne, Germany
Boat: Beneteau Oceanis 331
Posts: 557
Quote:
Originally Posted by dougwm10 View Post
Downloaded the current windows beta 710 and installed it. When I try to open it I get the following error message - "This application has failed to start because wxbase28_vc_custom.dll was not found."

Also did a file search for - wxbase28_vc_custom.dll - on my computer but it was not there.

Does the installer come complete with this file or do we have to obtain it from another source ???????
Copy that!

I guess the file need to be included in the installer => it is missing.
(AFAIK this file couldn't be compiled from wx_dll.dsw, but I have very low knowledge of these things ... )

Gunther
__________________
Deutschsprachige Community- und Support-Website unter OpenCPN.de
Netsurfer is offline   Reply With Quote
Old 13-07-2010, 03:49   #8
Registered User
 
Netsurfer's Avatar

Join Date: Jan 2010
Location: Cologne, Germany
Boat: Beneteau Oceanis 331
Posts: 557
Peter,

Quote:
Originally Posted by petermoree View Post
Build 710 crashes consistently in Vista when scrollwheel zooming
So you managed to start the program at least. Would you please be so kind and have a look if the file "wxbase28_vc_custom.dll" exists on your system and if so attach it here?

Thanks in advance,

Gunther
__________________
Deutschsprachige Community- und Support-Website unter OpenCPN.de
Netsurfer is offline   Reply With Quote
Old 13-07-2010, 05:30   #9
Registered User

Join Date: Jul 2009
Posts: 10
I just installed Build 710 on my Windows 7 PC. The new route manager button causes the program to immediately lock-up and then crash as soon as it is pressed.
__________________
jimbo3123 is offline   Reply With Quote
Old 13-07-2010, 07:32   #10
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
This is Windows DLL hell...

From the windows Inno Setup installer script:

Code:
Source: "e:\opencpn_cmake\release\wxbase28_vc_custom.dll"; DestDir: "{app}";  Components: normal
Source: "e:\opencpn_cmake\release\wxbase28_net_vc_custom.dll"; DestDir: "{app}";  Components: normal
Source: "e:\opencpn_cmake\release\wxbase28_xml_vc_custom.dll"; DestDir: "{app}";  Components: normal
Source: "e:\opencpn_cmake\release\wxmsw28_adv_vc_custom.dll"; DestDir: "{app}";  Components: normal
Source: "e:\opencpn_cmake\release\wxmsw28_core_vc_custom.dll"; DestDir: "{app}";  Components: normal
You should find all these dlls in the directory where opencpn is installed, e.g. c:\Program Files\opencpn

If opencpn fails to load, it is because (modern) Windows does not like simple inclusion of DLLs, but needs them to be installed and registered with the SXS system. I need to research this some more.

Any Windows experts out there?

Working....
Dave
__________________
bdbcat is offline   Reply With Quote
Old 13-07-2010, 10:09   #11
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,250
Not a win expert , but this is what I would test if I had a Vista or 7 system, based on a bit of googling.


For each of the dll:s in Daves list
Quote:
regsvr32.exe [path:]\filename.dll
other versions of the same
Quote:
Go to c:\windows\system and look for the file "regsvr32.exe".
Find the DLL that you want to register and drag and drop it into the regsvr32 icon.
You should get a message saying "Filename.dll registration successful" or something to that effect.
or
Quote:
1. rightclick the DLL-file
2. Open with Regsvr32
It would be nice if someone could test this.

Thomas
__________________
cagney is offline   Reply With Quote
Old 13-07-2010, 10:14   #12
Registered User
 
Netsurfer's Avatar

Join Date: Jan 2010
Location: Cologne, Germany
Boat: Beneteau Oceanis 331
Posts: 557
Thomas,

Quote:
Originally Posted by cagney View Post
Find the DLL that you want to register and drag and drop it ...
or
1. rightclick the DLL-file
It would be nice if someone could test this.
Quote:
Also did a file search for - wxbase28_vc_custom.dll - on my computer but it was not there.
so when you tell me how to test it, it would be a favour to me to do so ...!

Gunther
__________________
Deutschsprachige Community- und Support-Website unter OpenCPN.de
Netsurfer is offline   Reply With Quote
Old 13-07-2010, 10:35   #13
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,250
Gunther

I don't know what is up with your installation.
I downloaded the windows version, and installed it with Wine.
The "wxbase28_vc_custom.dll" is there among the other dll's in
C:\Program Files\OpenCPN\, the location will probably be different for you, but this dll is not missing in the installer.

Thomas
__________________
cagney is offline   Reply With Quote
Old 13-07-2010, 10:46   #14
Registered User
 
Netsurfer's Avatar

Join Date: Jan 2010
Location: Cologne, Germany
Boat: Beneteau Oceanis 331
Posts: 557
Thomas,

Quote:
Originally Posted by cagney View Post
Gunther

I don't know what is up with your installation.
I downloaded the windows version, and installed it with Wine.
The "wxbase28_vc_custom.dll" is there among the other dll's in
C:\Program Files\OpenCPN\, the location will probably be different for you, but this dll is not missing in the installer.
now I found out what is going on ...!

If I (or someone else) choose the "Full installation ..." option then the files (the 5 .dll files) are completly missing.

So if I re-install the program with the "Standard installation .." option then the files are there and everything works as expected.

Maybe this helps to find the problem.

Gunther
__________________
Deutschsprachige Community- und Support-Website unter OpenCPN.de
Netsurfer is offline   Reply With Quote
Old 13-07-2010, 14:11   #15
Registered User

Join Date: Mar 2009
Posts: 83
OpenCPN beta 2.2 build 710

Hi Gunther

You have solved the missing file problem - I re-installed using the standard installation and the files are now there.

For future releases the installation file will need to be modified to solve this problem.

I have run the program now and it starts up OK but when I tyry to zoom in on my CM93 charts it will only allow 3 levels of zomm before the program crashes - I am using winXP pro fully updated 32bit version

Doug
__________________

__________________
dougwm10 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Beta Test / Technical bdbcat OpenCPN 2072 12-12-2017 18:48
OpenCPN Version 2.2 Beta Test bdbcat OpenCPN 437 15-12-2010 20:17
OpenCPN Version 2.1.0 Beta bdbcat OpenCPN 1045 25-06-2010 11:09
OpenCPN Version 1.3.5 Beta Technical bdbcat OpenCPN 544 24-03-2010 11:34



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 14:45.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.