Cruisers Forum
 


Join CruisersForum Today

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 07-04-2010, 07:00   #121
Registered User

Join Date: Sep 2009
Location: Angers - France
Boat: Beneteau First 29 Ptizef
Posts: 743
test 331 (XP and Vista

Hi Dave

Many thanks for the great job
For the WE , I tested 210-131 on board , bet I'll not repeat what's already known , just add some example of what seams not working properly if that can help :
1)Cm93 offset : see screen shots cm93-136 and cm93-210-331 . positions of both track and depth line are not correct with 210-331
2)Quilting seams not working for low scales : see screen shots quilting1 to quilting4 . behavior looks like without quilting
3) I had crashes with Xp and course up and GPS activated

Best Regards
Jean pierre
Attached Thumbnails
Click image for larger version

Name:	CM93-136.jpg
Views:	93
Size:	93.6 KB
ID:	15173   Click image for larger version

Name:	CM93-210-331.jpg
Views:	89
Size:	94.9 KB
ID:	15174  

Click image for larger version

Name:	quilting3.jpg
Views:	82
Size:	82.8 KB
ID:	15177   Click image for larger version

Name:	quilting4.jpg
Views:	89
Size:	163.3 KB
ID:	15178  

Click image for larger version

Name:	quilting1.jpg
Views:	85
Size:	121.2 KB
ID:	15180   Click image for larger version

Name:	quilting2.jpg
Views:	84
Size:	209.1 KB
ID:	15181  

__________________

__________________
Ptizef is offline  
Old 07-04-2010, 08:27   #122
Senior Cruiser
 
idpnd's Avatar

Cruisers Forum Supporter

Join Date: Sep 2007
Location: Almería, ES
Boat: Chiquita 46 - Libertalia
Posts: 1,551
Quote:
Originally Posted by bdbcat View Post
10. More comments on Will's "North-Up" icon? (#103). Looks nice, but I dunno...I had to really search to find it. Seems a little too subtle for me....Comments?
I like it, it seems in line with the light and unobtrusive interface of opencpn. Perhaps a slightly more aggressive colour/contrast on the actual north pointer would make it more eye-catching..

IMO You will only be looking for it once the very first time you use it, from then on you want it to be as subtle as possible really
__________________

__________________
sv Libertalia
idpnd is offline  
Old 07-04-2010, 09:05   #123
Registered User

Join Date: Sep 2009
Location: Angers - France
Boat: Beneteau First 29 Ptizef
Posts: 743
Hi Dave

When I have a situation as described in my #121 in screen shots quiting1 to quiting4 , and if I right click on a part of the screen when there is no maps , I get immediately a crash
Regards
Jean Pierre
__________________
Ptizef is offline  
Old 07-04-2010, 12:33   #124
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,882
French charts....

Ptizef....

Thanks for your report.

Are the French charts which you have shown available for download online? This could help my testing.....

Thanks
Dave
__________________
bdbcat is offline  
Old 07-04-2010, 12:48   #125
Senior Cruiser
 
idpnd's Avatar

Cruisers Forum Supporter

Join Date: Sep 2007
Location: Almería, ES
Boat: Chiquita 46 - Libertalia
Posts: 1,551
Regarding quilting

When I have several competing sets of raster charts for the same area, the display gets horribly confused. I accept this would be quite a rare condition where the user has too many charts, is too lazy to select the best ones, or is testing functionality such as myself..
__________________
sv Libertalia
idpnd is offline  
Old 07-04-2010, 12:51   #126
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,016
SENC creation problem with quilting on

I'm not sure whether it's the same as last time, but I'm getting this reproducible problem on both my machines. When with quilting on I scroll or zoom to an area where SENCs are not yet generated, OpenCPN sooner or later freezes and an "infinite" number of errors is reported in the log. When I kill the application the error happens again after a new start as you can see in the attached log snippet.

Code:
20:38:03: 2010-04-07
20:38:03:  -------Starting opencpn-------
20:38:03: Version 2.1.0 Build 331
20:38:03: SData_Locn is C:\Program Files\OpenCPN\
20:38:03: Using bells sound file: C:\Program Files\OpenCPN\sounds\1bells.wav
20:38:03: Using bells sound file: C:\Program Files\OpenCPN\sounds\2bells.wav
20:38:03: Using bells sound file: C:\Program Files\OpenCPN\sounds\3bells.wav
20:38:03: Using bells sound file: C:\Program Files\OpenCPN\sounds\4bells.wav
20:38:03: Using bells sound file: C:\Program Files\OpenCPN\sounds\5bells.wav
20:38:03: Using bells sound file: C:\Program Files\OpenCPN\sounds\6bells.wav
20:38:03: Using bells sound file: C:\Program Files\OpenCPN\sounds\7bells.wav
20:38:03: Using bells sound file: C:\Program Files\OpenCPN\sounds\8bells.wav
20:38:03: Using existing Config_File: C:\Users\nohal\AppData\Roaming\opencpn\opencpn.ini
20:38:03: Setting Viewpoint Lat/Lon 18.0777, -65.9188
20:38:03: Setting Ownship Lat/Lon 49.8344, 14.4472
20:38:03: System default Language:  cs_CZ
20:38:03: Opencpn language set to:  cs_CZ
20:38:03: Using s57data in C:\Program Files\OpenCPN\s57data
20:38:03: Using Tide/Current data from:  C:\Program Files\OpenCPN\tcdata\
20:38:03: Setting Viewpoint Lat/Lon 18.0777, -65.9188
20:38:03: Setting Ownship Lat/Lon 49.8344, 14.4472
20:38:03: NMEA Data Source is....Serial:AIS Port (Shared)
20:38:03: AIS Data Source is....None
20:38:03: Using WVSChart datafile: C:\Program Files\OpenCPN\wvsdata\wvs43.dat
20:38:03: NMEA AutoPilot Port is....None
20:38:03: Loading chart db version: V016
20:38:03: Chart directory C:\charts\ENC_US_2009_12
20:38:03: GPS Watchdog Timeout is: 6 sec.
20:38:04: Initializing Chart C:\charts\ENC_US_2009_12\ENC_ROOT\US4PR30M\US4PR30M.000
20:38:04: Initializing Chart C:\charts\ENC_US_2009_12\ENC_ROOT\US3PR10M\US3PR10M.000
20:38:05: Initializing Chart C:\charts\ENC_US_2009_12\ENC_ROOT\US4PR41M\US4PR41M.000
20:38:05: Building SENC file for C:\charts\ENC_US_2009_12\ENC_ROOT\US4PR41M\US4PR41M.000 to C:\Users\nohal\AppData\Roaming\opencpn\SENC\US4PR41M.S57
20:38:05: Initializing Chart C:\charts\ENC_US_2009_12\ENC_ROOT\US4PR41M\US4PR41M.000
20:38:05:    OpenChartFromStack...Error opening chart C:\charts\ENC_US_2009_12\ENC_ROOT\US4PR41M\US4PR41M.000... return code 1
20:38:05: Initializing Chart C:\charts\ENC_US_2009_12\ENC_ROOT\US4PR41M\US4PR41M.000
20:38:05:    OpenChartFromStack...Error opening chart C:\charts\ENC_US_2009_12\ENC_ROOT\US4PR41M\US4PR41M.000... return code 1
20:38:05: Initializing Chart C:\charts\ENC_US_2009_12\ENC_ROOT\US4PR41M\US4PR41M.000
20:38:05:    OpenChartFromStack...Error opening chart C:\charts\ENC_US_2009_12\ENC_ROOT\US4PR41M\US4PR41M.000... return code 1
20:38:05: Initializing Chart C:\charts\ENC_US_2009_12\ENC_ROOT\US4PR41M\US4PR41M.000
20:38:05:    OpenChartFromStack...Error opening chart C:\charts\ENC_US_2009_12\ENC_ROOT\US4PR41M\US4PR41M.000... return code 1
20:38:05: Initializing Chart C:\charts\ENC_US_2009_12\ENC_ROOT\US4PR41M\US4PR41M.000
Pavel
__________________
nohal is offline  
Old 07-04-2010, 15:45   #127
Registered User
 
jonasaberg's Avatar

Join Date: Jul 2008
Location: Kristiansand, Norway
Boat: Wasa 410
Posts: 305
Problems running at 9600bd

Just relaying a bug report on a Swedish site that has been mentioned in this forum but I think is not mentioned by Dave in his list:

A user reports problems running 2.1.0 with a Navibe GM720 GPS.
The GPS runs nativelly at 9600 and works fine with Seaclear and other tested nav prorams that can be manually set to 9600bd. It also, as far as I understand, works to view the data stream in hyperterminal.

After manually setting the GPS to send at 4800 or 38400bd OpenCPN works with the GPS. (Problem for the user is that after a while of not being used the GPS resets to 9600bd.)

So, it seems there is a problem with CPN not finding the correct speed of this GPS.

Site adress (In swedish)
GPS Baud - ÖvrigtSnack - BryggSnack - Forum - Maringuiden

/Jonas
__________________
jonasaberg is offline  
Old 07-04-2010, 17:49   #128
Registered User

Join Date: Sep 2009
Location: Angers - France
Boat: Beneteau First 29 Ptizef
Posts: 743
Quote:
Originally Posted by bdbcat View Post
Ptizef....

Thanks for your report.

Are the French charts which you have shown available for download on line? This could help my testing.....

Thanks
Dave
Unfortunately no
but I'll send you a limited set of charts
Jean pierre
__________________
Ptizef is offline  
Old 07-04-2010, 19:36   #129
Registered User

Join Date: Nov 2008
Location: Tampa, Florida
Posts: 36
+1 on Nohal's report, or make that two as it happens on both my PCs. One XP Pro the other XP media center,

also program crashes when course up is enabled on both as well.

Thanks
Dan
__________________
raisin56 is offline  
Old 07-04-2010, 20:28   #130
Registered User
 
manimaul's Avatar

Join Date: Feb 2008
Location: Seattle, WA
Posts: 416
Quote:
Originally Posted by bdbcat View Post
10. More comments on Will's "North-Up" icon? (#103). Looks nice, but I dunno...I had to really search to find it. Seems a little too subtle for me....Comments?
Dave
Some color might make it stand out a bit...



Any ideas for inspiration are appreciated.
__________________
Marine Navigation for Android:
http://mxmariner.com
manimaul is offline  
Old 08-04-2010, 04:26   #131
Registered User

Join Date: Mar 2010
Location: Normandy, France
Boat: Flush Poker, 8.25m (Point Barre)
Posts: 335
CVS

Quote:
Originally Posted by Psyches View Post
P.S. SethDart, can you PM me with your sf.net post? The only one I see has locale build changes, not core code changes that idpnd was referring to.
Dave pushed the diff I sent and added both missing .po files. To my knowledge, there's no core code change awaiting push yet.

Now, a few thoughts about CVS:
1/ It'd be helpfull to have a .cvsignore in CVS with appropriate content, at least this (depends on point 2 below)
Code:
.deps
Makefile
config.log
config.status
opencpn
Then it'd be easier for us to provide diff after a local change.

2/ Currently the following files are available on CVS:
Makefile.in aclocal.m4 configure
IMHO, they should be removed. The patch I provided a few days ago changed both Makefile.am and Makefile.in but Dave only changed the former because the latter would be rebuilt with automake. The problem is that if some user run configure without runing automake/autoconf first, it may not work properly.
I just tested with current CVS, running ./configure uses Makefile.in (that's not updated with correct path) not Makefile.ac (the only one Dave patched last time)
Those 3 files should also be added to .cvsignore

Correct me if I'm wrong, I don't use autotools every day, nor CVS.
__________________
SethDart is offline  
Old 08-04-2010, 11:57   #132
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,247
Sounds

Sounds set in ToolBox -> AIS ->CPA/TCPA Alerts are working again for me on Kubuntu 9:10 Build 331.

What is the option ToolBox -> Etc -> GUI Options -> Play Ships Bells supposed to do ??

Strange lines in my logg:

Quote:
07:33:35 PM: Error: can't open file '/usr/local/share/opencpn/sounds/1bells.wav' (error 2: No such file or directory)
07:33:35 PM: Using bells sound file: /usr/local/share/opencpn/sounds/1bells.wav
07:33:35 PM: Error: can't open file '/usr/local/share/opencpn/sounds/2bells.wav' (error 2: No such file or directory)
07:33:35 PM: Using bells sound file: /usr/local/share/opencpn/sounds/2bells.wav
07:33:35 PM: Error: can't open file '/usr/local/share/opencpn/sounds/3bells.wav' (error 2: No such file or directory)
07:33:35 PM: Using bells sound file: /usr/local/share/opencpn/sounds/3bells.wav
07:33:35 PM: Error: can't open file '/usr/local/share/opencpn/sounds/4bells.wav' (error 2: No such file or directory)
07:33:35 PM: Using bells sound file: /usr/local/share/opencpn/sounds/4bells.wav
07:33:35 PM: Error: can't open file '/usr/local/share/opencpn/sounds/5bells.wav' (error 2: No such file or directory)
07:33:35 PM: Using bells sound file: /usr/local/share/opencpn/sounds/5bells.wav
07:33:35 PM: Error: can't open file '/usr/local/share/opencpn/sounds/6bells.wav' (error 2: No such file or directory)
07:33:35 PM: Using bells sound file: /usr/local/share/opencpn/sounds/6bells.wav
07:33:35 PM: Error: can't open file '/usr/local/share/opencpn/sounds/7bells.wav' (error 2: No such file or directory)
07:33:35 PM: Using bells sound file: /usr/local/share/opencpn/sounds/7bells.wav
07:33:35 PM: Error: can't open file '/usr/local/share/opencpn/sounds/8bells.wav' (error 2: No such file or directory)
07:33:35 PM: Using bells sound file: /usr/local/share/opencpn/sounds/8bells.wav
Why is OCPN trying to open these non-existing Xbells.wav files?
From my conf (ini) file:
Quote:
AISAlertAudioFile=/usr/local/share/opencpn/sounds/alarm1.wav
Without digging into the subject, it looks to me like some test code, that ought to be commented out, is responsible.

Thomas
__________________
cagney is offline  
Old 08-04-2010, 13:59   #133
Registered User
 
LeaseOnLife's Avatar

Join Date: Apr 2008
Location: out cruising again
Boat: Sailboat
Posts: 1,046
Ditto on windows. It tries to open
Code:
15:01:57: Using bells sound file: C:\Program Files\OpenCPN\sounds\1bells.wav
15:01:57: Using bells sound file: C:\Program Files\OpenCPN\sounds\2bells.wav
15:01:57: Using bells sound file: C:\Program Files\OpenCPN\sounds\3bells.wav
15:01:57: Using bells sound file: C:\Program Files\OpenCPN\sounds\4bells.wav
15:01:57: Using bells sound file: C:\Program Files\OpenCPN\sounds\5bells.wav
15:01:57: Using bells sound file: C:\Program Files\OpenCPN\sounds\6bells.wav
15:01:57: Using bells sound file: C:\Program Files\OpenCPN\sounds\7bells.wav
15:01:57: Using bells sound file: C:\Program Files\OpenCPN\sounds\8bells.wav
but none of these files are installed with build 331

Dare I say, this must have come from some oldtimers having served on larger ships, using bells to announce watches and times. 8-bells = a sailor's watch is over, or "finished".
__________________
LeaseOnLife is offline  
Old 09-04-2010, 05:07   #134
Long Range Cruiser
 
MarkJ's Avatar

Cruisers Forum Supporter

Join Date: Dec 2007
Location: Australian living on "Sea Life" currently in England.
Boat: Beneteau 393 "Sea Life"
Posts: 12,828
Images: 25
Hi guys

We have just finished a fairly long, intricate trip up the Suez Canal and accross the Mediterranean to Turkey in some fairly difficult weather, on the nose.
It was probably a great trip to test equipement.

So these thoughts are getting quite confirmed in my mind and I would really like some dedicated thought to them as the problems, as they appear to me, to be general and are holding back OpenCpn. Previous posts, though answered, have indicated I must show more clearly my difficulties.

I understand many posts I have seen on this forum deal with technical difficulties and things far above my appreciation and computer knowledge level. I would obviously like to say delete all Geek thoughts! I say: please look to the usability of the program.


Things that make the program less usable:

Hibernation/Sleep makes the GPS disconnect.

Track doesn't work properly

Projected Course not long enough/ adjustable

No Course/Speed filtering

"Delete All" button position wrong.



1) Hibernation/Sleep makes the GPS disconnect.
The laptop is, obviously, below in the nav station not on deck. So when **** hits the fan I am at the wheel. NOT in the nav station. Then I need to QUICKLY see where I am I bolt below and look at the screen. Its gone blank in Hibernation or Sleep or whatever it does and I have to get that going again and then pull the GPS USB plug out and replug it because its disconnected.
I NEED the GPS connection to keep connected in a low power state.
tell me what power state and how to adjust it. Remember at sea electricity is a problem. Computers are best not on 24/7


2) Track doesn't work properly

Track keeps disconnecting itself and the track Button does not stay selected when I restart the program (AIS does stay connected but I dont want it to be as I dont have AIS). I NEED Track to be Auto ON.

Every time the computer hibernates/sleeps (see (1) above), the track changes from red to purple, there is a gap, I am told something about logs, to save etc.
EVERY boat moving NEEDS a track! how can we know whats going on without a track? So it needs to be (selectable) always on.
AIS does not need to be always on, but again selectable.
I can not save 10 track snippets. I would be doing it all watch.


3)Projected Course not long enough/ adjustable
The red nose out the boats front is as long as a bees dick. It needs to be longer and/or adjustable.
My Chart Plotter has 10 mins, 30 mins, 1 hour, and 2 hours.


4) No Course/Speed filtering
The wiggle course and flutaution of speed from the raw information makes the program useless for real time navigating. OK I remember someone said that its the information direct from the GPS, but if there is no internal GPS filtering can something be done to give filtering on OpenCpn? Its utterly important as at low speed especially the course and speed waver dramatically.
To get propper course I must use the Track and Measure against it (but see my problem with Track!)

5) "Delete All" button position wrong

The Delete All button on the right click context menu is so close to everything else that in a seaway we are always in fear of deleting all! Just think: Your fingers are frozen, wet, you have gloves on, full wet weather gear, the decks pitching, you are meant to be on the wheel instead of runing down the companionway to get to the computer where you need to click on Waypoint Properties to see its Lat Lon and as the nav station rolls you hit Delete All!!!!!!!!


Now just to tell you that these problems are not unsolvable let me point out: No chart plotter I've used has these difficulties. Track remains, No delete all where it can be easily used, no disconnections, and adjustable filtering. Nor does Maxsea or the computer based plotters I've seen or played with.

Thanks for your consideration and I'm sorry that my post is more direct than tactful.


Mark
__________________
Notes on a Circumnavigation.
OurLifeAtSea.com

Somalia Pirates and our Convoy
MarkJ is offline  
Old 09-04-2010, 05:58   #135
Registered User
 
HamishB's Avatar

Join Date: Jan 2010
Location: New Zealand
Posts: 286
Quote:
Originally Posted by MarkJ View Post
The red nose out the boats front is as long as a bees dick. It needs to be longer and/or adjustable. My Chart Plotter has 10 mins, 30 mins, 1 hour, and 2 hours.
fwiw in the past for nav programs I've written I've used a D.R. 20 minute distance to place the tip of the trend arrow. From that you can instantly estimate a quarter of its length to see where you will be in 5 minutes, or triple it to see where you will be in an hour. Very good for human timescales. Also it is exactly how long it takes our divers to get ready before arriving on station, get the lunch cleaned up before leaving protected waters, etc.

as for hibernating laptops, if you are running linux or probably on Mac too it is fairly trivial to write a stay-awake script. no idea about doing that on a modern ms windows.
that won't help save any power, but but I'm hoping the new breed of ARM netbooks which got for 12 hours on a charge will run in the 5-20 watt range.

with gpsd on linux you need to set up a hotplug rule which tells it always to connect to /dev/gps, other wise every time it wakes up it sees the old stale connection and makes the new device USB1,2,3,4,... etc. one bigger than the one before. I think they have a FAQ entry about that, if not it is in the mailing list archives for sure. I think fundamentally it's an OS/gpsd problem, and the best that opencpn could do would be send out a keep-alive tick once a minute or so..


Hamish
__________________

__________________
HamishB is offline  
Closed Thread

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCPN Version 1.3.5 Beta Technical bdbcat OpenCPN 544 24-03-2010 11:34
OpenCPN Version 1.3.6 Release bdbcat OpenCPN 32 30-01-2010 06:07



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 20:58.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.