Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-06-2010, 15:32   #1
Registered User

Join Date: May 2010
Posts: 8
OpenCPN Test with Nema Studio GPS Simulator

I am trying to test Open CPN using NemaStudio to simulate GPS and AIS sentences.

I can not get it to recognize the NemaStudio GPS and AIS sentences although SeaClear (AIS and GPS) & Mapsource (GPS only) and other programs see them and can interpret them.

Any ideas so I can bench test Open CPN
__________________

__________________
jimcreed is offline   Reply With Quote
Old 07-06-2010, 16:21   #2
Registered User
 
Netsurfer's Avatar

Join Date: Jan 2010
Location: Cologne, Germany
Boat: Beneteau Oceanis 331
Posts: 557
Hi,

Quote:
Originally Posted by jimcreed View Post
I am trying to test Open CPN using NemaStudio to simulate GPS and AIS sentences.

I can not get it to recognize the NemaStudio GPS and AIS sentences although SeaClear (AIS and GPS) & Mapsource (GPS only) and other programs see them and can interpret them.

Any ideas so I can bench test Open CPN
what version of OpenCPN and which baud rate do you use?
Be aware of the fact that OCPN did not support other baud rates (for GPS) than 4800 bps before 2.1.0 build 604.

Have you tried (if Nema Studio supports it) to use the AIS Port (shared) option in OCPN?

Gunther
__________________

__________________
Deutschsprachige Community- und Support-Website unter OpenCPN.de
Netsurfer is offline   Reply With Quote
Old 07-06-2010, 17:05   #3
Registered User

Join Date: May 2010
Posts: 8
Running Version 2.1.0 Build RC607a I have tried other versions also.

Tried ais and gps ports separately and ais port shared. The sentences have check sums.

I have set all output to 4800bps via software and the device manager in both computers. the one supplying data sentences and the one running Open CPN
__________________
jimcreed is offline   Reply With Quote
Old 07-06-2010, 20:23   #4
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
1. Try NMEA data window check box in Toolbox->GPS

2. Add DebugNMEA=1000 in config file, then look at logfile.


Gunther....

Sure could use a Wiki section on debugging NMEA generally. Same issues over and over..... Volunteers?

Dave
__________________
bdbcat is offline   Reply With Quote
Old 07-06-2010, 21:18   #5
Registered User

Join Date: May 2010
Posts: 8
I can not find a logfile or config file listed in the Open CPN program file folder. Obviously it is somewhere, since it remembers my changes when I restart the program

No data shows when I click on show the NMEA data stream (I can get a data stream to show if I attach a gps to the computer).

Here are the sentences that SeaClear sees when I have it view the same port with the same configuration as Open CPN (only 1 AIS target is simulated).


$GPGLL,4125.05316,N,07016.51022,W,225155.55,A*15
$GPRMC,225155.58,A,4125.05316,N,07016.51022,W,0002 .0,003.0,070610,000.0,W*67
$GPZDA,225155.11,07,06,2010,10,51*65
!AIVDM,1,1,,A,1>wTTCw00NJvCUpGdkr0:09h050l,0*76
$GPGLL,4125.05371,N,07016.51018,W,225157.18,A*16
$GPRMC,225157.71,A,4125.05371,N,07016.51018,W,0002 .0,003.0,070610,000.0,W*66
$GPZDA,225157.24,07,06,2010,10,51*61
!AIVDM,1,1,,A,1>wTTCw00NJvCUrGdkt@:09l050l,0*06
$GPGLL,4125.05426,N,07016.51014,W,225159.32,A*19
$GPRMC,225159.83,A,4125.05426,N,07016.51014,W,0002 .0,003.0,070610,000.0,W*6C
$GPZDA,225159.36,07,06,2010,10,51*6C
!AIVDM,2,1,7,A,5>wTTCl1KoQd4U?62204U?6222222222222 22200,0*63
!AIVDM,2,2,7,A,:0D5?1QBS<Q1APEC588888888888882,2*5 2
!AIVDM,1,1,,A,1>wTTCw00NJvCUtGdkv@:082050l,0*5D
$GPGLL,4125.05481,N,07016.51010,W,225202.49,A*11
$GPRMC,225202.02,A,4125.05481,N,07016.51010,W,0002 .0,003.0,070610,000.0,W*61
$GPZDA,225202.55,07,06,2010,10,52*67
!AIVDM,1,1,,A,1>wTTCw00NJvCUtGdl0@:088050l,0*16
$GPGLL,4125.05536,N,07016.51006,W,225204.61,A*17
$GPRMC,225204.14,A,4125.05536,N,07016.51006,W,0002 .0,003.0,070610,000.0,W*6A
$GPZDA,225204.68,07,06,2010,10,52*6F
!AIVDM,1,1,,A,1>wTTCw00NJvCUvGdl2P:08<050l,0*02
$GPGLL,4125.05591,N,07016.51002,W,225206.74,A*18
$GPRMC,225206.28,A,4125.05591,N,07016.51002,W,0002 .0,003.0,070610,000.0,W*6E
$GPZDA,225206.80,07,06,2010,10,52*6B
!AIVDM,1,1,,A,1>wTTCw00NJvCV0Gdl4P:08@050l,0*3D
$GPGLL,4125.05646,N,07016.50998,W,225208.86,A*19
$GPRMC,225208.39,A,4125.05646,N,07016.50998,W,0002 .0,003.0,070610,000.0,W*62
__________________
jimcreed is offline   Reply With Quote
Old 08-06-2010, 09:34   #6
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
Jim....

Those sentences look all right to me.

on windowsXP, the config file in in

Documents and settings\{user}\Application Data\opencpn

opencpn.ini is config file.

add a line in [Settings] section

DebugNMEA=1000

run opencpn
close opencpn

look at opencpn.log

Is there any possiblity to get an evaluation version of NMEAStudio? Can't find it on the web...

Dave
__________________
bdbcat is offline   Reply With Quote
Old 08-06-2010, 10:17   #7
Registered User

Join Date: May 2010
Posts: 8
Ok I got the opencpn.ini file.

Here is what happened I started the opencpn with input from a garmin GPS and then switch the cable input to the NEMA studio ouput and can see the NMEA sentences. Open CPN tracks the simulated boat.

I had to set the the input to GPS only (on Com1) and remove the AIS both. Now when I start up opencpn it can see the NMEA Studio input and can track the boat.

I have not been able to get it to use the AIS messages yet since setting the AIS port to com 1 and then using the AIS port shared option goes back to not receiving sentences.

NEMA Studio has a trial version (note spelling)
Down load site is NemaStudio from Sailsoft

I participated in some of the debugging of this product.
__________________
jimcreed is offline   Reply With Quote
Old 08-06-2010, 18:10   #8
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
Jim....

Thanks for the info. I'll get the trial version.

AIS data can only be received at 38400 baud. This is the normal standard for AIS receivers.

If you set AIS to com1, and GPS to shared, and send the data to com1 at 38400, maybe it will work? Can't remember if you tried that....

Please note that the sharing does not go the other way. That is, AIS sentences sent to the GPS port are not sent to the AIS decoder subsystem. But, GPS sentences sent to the AIS port are send to the GPS input subsystem if the GPS port is set to shared. I hope that my mushy explanation is clear. A diagram would help....


Good luck
Dave
__________________
bdbcat is offline   Reply With Quote
Old 08-06-2010, 20:10   #9
Registered User

Join Date: May 2010
Posts: 8
Dave

OK I got it working. Thanks for your help. I be running some experiments and will let the forum know of any anomalies.

Jim
__________________

__________________
jimcreed is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Twin Screw Simulator unbusted67 Seamanship & Boat Handling 20 06-06-2010 08:58
Best Sailing Simulator? tomperanteau General Sailing Forum 4 28-01-2010 09:46
Sailing Simulator! virginia boy Marine Electronics 6 31-08-2009 06:33
NEMA In, NEMA Out..... beetlejuice30 Marine Electronics 23 07-03-2009 09:11



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 02:08.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.