Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 21-06-2014, 13:35   #256
Registered User
 
it-slav's Avatar

Join Date: May 2014
Posts: 46
Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by boat_alexandra View Post
Are you sure you are using my fork of glshim? I got this error with the mainstream. Otherwise, you will have to debug glshim and find why it cannot initialize the EGL display.

Does glxgears work?
Glxears does not work anymore.
I will start again with a fresh system, I think the system started behave strange after a apt-get update; apt-get upgrade.

I will use cubian and follow the instructions at http://opencpn.org/ocpn/node/299

I would be very grateful if you could upload a working cubietruck SD image somewhere.

Regards
Peter
__________________

__________________
it-slav is offline   Reply With Quote
Old 22-06-2014, 15:40   #257
Registered User
 
it-slav's Avatar

Join Date: May 2014
Posts: 46
Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by it-slav View Post
Glxears does not work anymore.
I will start again with a fresh system, I think the system started behave strange after a apt-get update; apt-get upgrade.

I will use cubian and follow the instructions at Building and installing on Cubieboard 2 with HW acceleration | Official OpenCPN Homepage

I would be very grateful if you could upload a working cubietruck SD image somewhere.

Regards
Peter
Now I started all over again.



On my cubietruck: installed cubian and followed Building and installing on Cubieboard 2 with HW acceleration | Official OpenCPN Homepage.

Code:
export LD_LIBRARY_PATH=/usr/local/lib
glxgears -fullscreen
gives fps 100

Started opencpn:
Code:
export LD_LIBRARY_PATH=/usr/local/lib
opencpn -fullscreen
When enabling hw accelerated opengl, it looks like this on parts of Stockholm area: http://www.it-slav.net/~peter/opencp...ith-opengl.png

With non hw accelerated opengl, it looks like this: http://www.it-slav.net/~peter/opencp....no-opengl.png

Regards
Peter
__________________

__________________
it-slav is offline   Reply With Quote
Old 22-06-2014, 20:32   #258
Registered User
 
boat_alexandra's Avatar

Join Date: Aug 2009
Location: chesapeake bay
Boat: bristol 27
Posts: 2,816
Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by it-slav View Post
Now I started all over again.



On my cubietruck: installed cubian and followed Building and installing on Cubieboard 2 with HW acceleration | Official OpenCPN Homepage.

Code:
export LD_LIBRARY_PATH=/usr/local/lib
glxgears -fullscreen
gives fps 100

Started opencpn:
Code:
export LD_LIBRARY_PATH=/usr/local/lib
opencpn -fullscreen
When enabling hw accelerated opengl, it looks like this on parts of Stockholm area: http://www.it-slav.net/~peter/opencp...ith-opengl.png

With non hw accelerated opengl, it looks like this: http://www.it-slav.net/~peter/opencp....no-opengl.png

Regards
Peter
What about raster charts?
__________________
boat_alexandra is offline   Reply With Quote
Old 23-06-2014, 01:10   #259
Registered User
 
it-slav's Avatar

Join Date: May 2014
Posts: 46
Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by boat_alexandra View Post
What about raster charts?
Sure, what do you want me to test?

/Peter
__________________
it-slav is offline   Reply With Quote
Old 23-06-2014, 02:43   #260
Registered User

Join Date: May 2014
Posts: 7
Re: OpenCPN Runs on Embedded ARM

Hi , I have OpenCPN compiled under Ubuntu 12.04 on the Trimslice from Compulab which has the Tegra ARM chip. It seems to perform well in all respects. I have got GPS and AIS working and can use all the charts I have (CMap and the Brazil navy ones, as well as the routing charts for the South Atlantic). I have it set up as a wireless router so I can connect to it wirelessly using a tablet from the cockpit. My only problem has been that it does not want to change it's AIS alarm from the supplied 'ship's bells' - any other sound file will just not play at all. Any suggestions?
__________________
andydunlop is offline   Reply With Quote
Old 23-06-2014, 22:37   #261
Registered User
 
boat_alexandra's Avatar

Join Date: Aug 2009
Location: chesapeake bay
Boat: bristol 27
Posts: 2,816
Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by andydunlop View Post
Hi , I have OpenCPN compiled under Ubuntu 12.04 on the Trimslice from Compulab which has the Tegra ARM chip. It seems to perform well in all respects. I have got GPS and AIS working and can use all the charts I have (CMap and the Brazil navy ones, as well as the routing charts for the South Atlantic). I have it set up as a wireless router so I can connect to it wirelessly using a tablet from the cockpit. My only problem has been that it does not want to change it's AIS alarm from the supplied 'ship's bells' - any other sound file will just not play at all. Any suggestions?
If it can play the ships bells you should be able to configure any sound. Ensure portaudio is detected when you run cmake.

I'm not really sure if this will help, but you could try the watchdog plugin, and see if you can get other sounds to work with it. It uses the exact same method to play audio, so from there we could start to narrow down the problem.
__________________
boat_alexandra is offline   Reply With Quote
Old 24-06-2014, 02:04   #262
Registered User
 
it-slav's Avatar

Join Date: May 2014
Posts: 46
Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by it-slav View Post
Sure, what do you want me to test?

/Peter
Now I've tested with raster charts aswell, and it looks like it works.

Cut'n paste from opencpn.log
Code:
18:54:40 UTC: OpenGL-> Renderer String: Software Rasterizer
18:54:40 UTC: OpenGL-> Texture rectangle format: de1
18:54:40 UTC: OpenGL-> Using Framebuffer Objects
18:54:40 UTC: OpenGL-> FBO Stencil buffer unavailable
18:54:40 UTC: OpenGL-> Using Depth buffer clipping
18:54:40 UTC: OpenGL-> Not Using compression
18:55:12 UTC: OpenGL-> Using 3dfx fxt1 compression
18:55:13 UTC: OpenGL-> Compressed tile size: 128kb (6:1)
I've noted that the vector charts worked better when I've loaded raster charts. The grey are was not there any more and another example is that the icon for waypoints now is there on the chart.

Next week I will be sailing and then my home built navigation system will be field tested.
Some pics can be seen at: Index of /~peter/opencpn/pics


Regards
Peter
__________________
it-slav is offline   Reply With Quote
Old 24-06-2014, 02:07   #263
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,766
Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by it-slav View Post

Some pics can be seen at: Index of /~peter/opencpn/pics


Regards
Peter
seems that the permissions are not ok: access denied
__________________
bcn is offline   Reply With Quote
Old 24-06-2014, 02:14   #264
Registered User
 
it-slav's Avatar

Join Date: May 2014
Posts: 46
Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by bcn View Post
seems that the permissions are not ok: access denied
Fixed

Regards
Peter
__________________
it-slav is offline   Reply With Quote
Old 24-06-2014, 03:19   #265
Registered User
 
boat_alexandra's Avatar

Join Date: Aug 2009
Location: chesapeake bay
Boat: bristol 27
Posts: 2,816
Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by it-slav View Post
Now I've tested with raster charts aswell, and it looks like it works.

Cut'n paste from opencpn.log
Code:
18:54:40 UTC: OpenGL-> Renderer String: Software Rasterizer
18:54:40 UTC: OpenGL-> Texture rectangle format: de1
18:54:40 UTC: OpenGL-> Using Framebuffer Objects
18:54:40 UTC: OpenGL-> FBO Stencil buffer unavailable
18:54:40 UTC: OpenGL-> Using Depth buffer clipping
18:54:40 UTC: OpenGL-> Not Using compression
18:55:12 UTC: OpenGL-> Using 3dfx fxt1 compression
18:55:13 UTC: OpenGL-> Compressed tile size: 128kb (6:1)
You should be using etc1 compression not fxt1. Should not be using depth buffer either, and the renderer string: "Software Rasterizer" is a big clue that you don't have hardware acceleration.
__________________
boat_alexandra is offline   Reply With Quote
Old 24-06-2014, 03:58   #266
Registered User

Join Date: May 2014
Posts: 7
Re: OpenCPN Runs on Embedded ARM

Thanks. I have put the libwatchdog_xxx.so file in the usr/local/lib/opencpn directory next to the ones for the dashboard and the grib plugins, but it does not come up when I start OpenCPN and look in the plugins button. I did the same with the sound files I tried, which perhaps means that I have some problem reading the directories? The permissions are the same on all the files. If I remove them all from the directory then nothing comes up in the plugin button, when I put them back, only the standard ones come up! )
__________________
andydunlop is offline   Reply With Quote
Old 24-06-2014, 05:09   #267
Registered User
 
boat_alexandra's Avatar

Join Date: Aug 2009
Location: chesapeake bay
Boat: bristol 27
Posts: 2,816
Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by andydunlop View Post
Thanks. I have put the libwatchdog_xxx.so file in the usr/local/lib/opencpn directory next to the ones for the dashboard and the grib plugins, but it does not come up when I start OpenCPN and look in the plugins button. I did the same with the sound files I tried, which perhaps means that I have some problem reading the directories? The permissions are the same on all the files. If I remove them all from the directory then nothing comes up in the plugin button, when I put them back, only the standard ones come up! )
Where do you get this .so file? What says the log file?
__________________
boat_alexandra is offline   Reply With Quote
Old 24-06-2014, 05:41   #268
Registered User

Join Date: May 2014
Posts: 28
Re: OpenCPN Runs on Embedded ARM

Hi.
Perhaps off topic - and most likely utterly stupid - question, but is there a way to start OpenCPN on my RPi without starting the GUI of Rasbian first?

Thanks!

Sent from my GT-I9505 using Cruisers Sailing Forum mobile app
__________________
seglar-lulle is offline   Reply With Quote
Old 24-06-2014, 05:43   #269
Registered User
 
it-slav's Avatar

Join Date: May 2014
Posts: 46
Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by boat_alexandra View Post
You should be using etc1 compression not fxt1. Should not be using depth buffer either, and the renderer string: "Software Rasterizer" is a big clue that you don't have hardware acceleration.

AAArgh, forgot
Code:
export LD_LIBRARY_PATH=/usr/local/lib
Will update when I get home.

Regards
Peter
__________________
it-slav is offline   Reply With Quote
Old 24-06-2014, 07:52   #270
Registered User
 
jonasaberg's Avatar

Join Date: Jul 2008
Location: Kristiansand, Norway
Boat: Wasa 410
Posts: 305
Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by it-slav View Post
Fixed
I like the suitcase proto-build!
Which model of the On-Lap did you get? Is it bright enough?

/J
__________________

__________________
jonasaberg is offline   Reply With Quote
Reply

Tags
opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Open CPN and Google Earth bgrimwade OpenCPN 19 09-12-2011 16:32
OpenCPN Version 2.5 Release bdbcat OpenCPN 86 02-09-2011 19:14
OpenCPN Stops Running BobLarkin OpenCPN 2 31-08-2011 00:38
Route Properties, Missing Functions James Baines OpenCPN 13 13-07-2011 05:31



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 05:49.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.