Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 12-06-2014, 01:26   #241
Registered User
 
it-slav's Avatar

Join Date: May 2014
Posts: 46
Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by sbfreddie View Post
Peter:
Have you looked on the Cubie Forums? Here is a link to the posted CubieTruck images:
http://www.cubieforums.com/index.php?board=32.0

I like the Qbee-X image because everything works including sound, 1080p video and preinstalled Mali stuff.

I wrote an instruction for installing the OpenGLES stuff on this image, and I get glxgears frame rate of 500-550 FPS.
After installing OpenCPN and updating the raster charts with the cache (It took about 6 Hrs) OpenCPN works quite well, very smooth panning and moving of charts.

I just finished making a shell script to install all of Sean's Plugins and they work well.

If you have any questions, just ask.

Thanks,
Freddie
VICTORY!!
I got OpenGL accelerated OpenCPN running on my cubietruck.
I started with this image: http://share.korepwx.com/cubian-desk...-a20-ct.img.7z
And then followed Building and installing on Cubieboard 2 with HW acceleration | Official OpenCPN Homepage

I do not know what you mean with Seans plugins? Is it glshim and glues?

In the weekend I can create an SD image with my work so anyone interested can use that.

Thanks

regards
Peter
__________________

__________________
it-slav is offline   Reply With Quote
Old 12-06-2014, 02:05   #242
Registered User
 
boat_alexandra's Avatar

Join Date: Aug 2009
Location: chesapeake bay
Boat: bristol 27
Posts: 2,816
Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by it-slav View Post
I do not know what you mean with Seans plugins? Is it glshim and glues?
No. the plugins for opencpn, like weather routing and climatology.
__________________

__________________
boat_alexandra is online now   Reply With Quote
Old 12-06-2014, 02:20   #243
Registered User
 
jonasaberg's Avatar

Join Date: Jul 2008
Location: Kristiansand, Norway
Boat: Wasa 410
Posts: 305
Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by it-slav View Post
VICTORY!!
I got OpenGL accelerated OpenCPN running on my cubietruck.
regards
Peter,
Congrats! Great news!

Would you be willing to make a new try to get it running on the RaspberryPi?
Will the last work on the Cubie help?

/J
__________________
jonasaberg is offline   Reply With Quote
Old 12-06-2014, 02:41   #244
Registered User
 
it-slav's Avatar

Join Date: May 2014
Posts: 46
Smile Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by jonasaberg View Post
Peter,
Congrats! Great news!

Would you be willing to make a new try to get it running on the RaspberryPi?
Will the last work on the Cubie help?

/J
I want to focus on the cubietruck now, but maybe I will give the raspberry a new try later.
Now I have to the get autologin, start opencpn automaticaly, get the bluetooth keyboard running and package everything in a waterproof case. You now the last 10% that takes 90% of the time

Regards
Peter
__________________
it-slav is offline   Reply With Quote
Old 12-06-2014, 02:51   #245
MAd
Registered User

Join Date: May 2014
Location: Germany
Boat: Vindoe 50SL, 35feet
Posts: 18
Re: OpenCPN Runs on Embedded ARM

Peter,
have you done anything different from owlhead's instructions? As posted, I followed the instructions but failed with CB2
Martin
__________________
MAd is offline   Reply With Quote
Old 12-06-2014, 03:15   #246
Registered User
 
it-slav's Avatar

Join Date: May 2014
Posts: 46
Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by MAd View Post
Peter,
have you done anything different from owlhead's instructions? As posted, I followed the instructions but failed with CB2
Martin
I followed the instructions and did nothing extra.
The instructions had some minor issues, like wrong path when running cd or cp.

Where did you get stucked?

/Peter
__________________
it-slav is offline   Reply With Quote
Old 12-06-2014, 03:21   #247
MAd
Registered User

Join Date: May 2014
Location: Germany
Boat: Vindoe 50SL, 35feet
Posts: 18
Re: OpenCPN Runs on Embedded ARM

I did eveything as described w/o errors but GLXgears states low fps (see posts #237 - #240), so I don't have a clue what's wrong...
Martin
__________________
MAd is offline   Reply With Quote
Old 12-06-2014, 10:06   #248
MAd
Registered User

Join Date: May 2014
Location: Germany
Boat: Vindoe 50SL, 35feet
Posts: 18
Re: OpenCPN Runs on Embedded ARM

I've now focused on glxgears, if I understand correctly, I need to make sure it's using the right libraries, so I renamed the original libGL.so.1 and libGLU.so.1 in /usr/lib. glxgears doesn't start anymore (missing libGL) so I tried "LD_LIBRARY_PATH=/usr/local/lib glxgears" (I've copied the newly compiled libGL.so.1. and libGLU.so.1 to /usr/local/lib before), glxgears now starts but fps is still <50. Any ideas?
Martin
__________________
MAd is offline   Reply With Quote
Old 12-06-2014, 21:46   #249
Registered User
 
boat_alexandra's Avatar

Join Date: Aug 2009
Location: chesapeake bay
Boat: bristol 27
Posts: 2,816
Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by MAd View Post
I've now focused on glxgears, if I understand correctly, I need to make sure it's using the right libraries, so I renamed the original libGL.so.1 and libGLU.so.1 in /usr/lib. glxgears doesn't start anymore (missing libGL) so I tried "LD_LIBRARY_PATH=/usr/local/lib glxgears" (I've copied the newly compiled libGL.so.1. and libGLU.so.1 to /usr/local/lib before), glxgears now starts but fps is still <50. Any ideas?
Martin
Make sure it can find libGL.so not libGL.so.1, so either a symlink, or copy to the new filename.
__________________
boat_alexandra is online now   Reply With Quote
Old 13-06-2014, 02:13   #250
MAd
Registered User

Join Date: May 2014
Location: Germany
Boat: Vindoe 50SL, 35feet
Posts: 18
Re: OpenCPN Runs on Embedded ARM

Doesn't help - still 50fps
What I did:
1) renamed libGL.* and libGLU.* in /usr/lib/arm-linux-gnueabihf (found with $ locate libGL)
2) added two symlinks in that directory (libGL.so => /usr/local/lib/libGL.so.1 and libGLU.so => /usr/local/lib/libGLU.so.1), the so.1 libs are compiled from glshim and glues as described in instructions from owlhead
3) glxgears didn't start, error message was, that libGL.so.1 can not be found, so I've added two more symlinks in that directory (libGL.so.1 => /usr/local/lib/libGL.so.1 and libGLU.so.1 => /usr/local/lib/libGLU.so.1)

Now glxgears works, but still 50fps
What is the magic, that for some the instructions above from owlhead work, but not for me
Martin
__________________
MAd is offline   Reply With Quote
Old 13-06-2014, 05:26   #251
MAd
Registered User

Join Date: May 2014
Location: Germany
Boat: Vindoe 50SL, 35feet
Posts: 18
Re: OpenCPN Runs on Embedded ARM

Well, glxgears still states <50fps, but OpenCPN works fine I've just added two maps and built the texture cache, it's now pretty fast! So I will now add all my maps for the southern baltic sea, hope this also works as expected.
Martin
__________________
MAd is offline   Reply With Quote
Old 17-06-2014, 03:18   #252
Registered User
 
boat_alexandra's Avatar

Join Date: Aug 2009
Location: chesapeake bay
Boat: bristol 27
Posts: 2,816
Re: OpenCPN Runs on Embedded ARM

Quote:
Originally Posted by MAd View Post
Well, glxgears still states <50fps, but OpenCPN works fine I've just added two maps and built the texture cache, it's now pretty fast! So I will now add all my maps for the southern baltic sea, hope this also works as expected.
Martin
It's possible on some setups that glxgears is limited to vertical refresh rates make it not always the best program to test with. In any case, if you notice a significant improvement over non-opengl mode then it's working.. it should be smooth for zooming panning and rotation etc... One way to tell is to look at the opencpn.log file and see which compression format it is using s3tc dxt1 is used on desktop gl, and would be possible only with software rendering where as etc1 should be used on gles systems.
__________________
boat_alexandra is online now   Reply With Quote
Old 18-06-2014, 16:05   #253
Registered User
 
it-slav's Avatar

Join Date: May 2014
Posts: 46
Re: OpenCPN Runs on Embedded ARM

I'm sorry. I was a little bit optimistic when it comes to my success.

When using vectorcharts I can enable "extend light sector" and get it working. I thought that it was only possible when opengl was enabled and using hw acceleration.

When runing cmake I get:
Code:
-- Found X11: /usr/lib/arm-linux-gnueabihf/libX11.so
-- Found OpenGL: /usr/lib/arm-linux-gnueabihf/libGL.so  
-- Found OpenGL...
--     Lib: /usr/lib/arm-linux-gnueabihf/libGLU.so/usr/lib/arm-linux-gnueabihf/libGL.so/usr/lib/arm-linux-gnueabihf/libSM.so/usr/lib/arm-linux-gnueabihf/libICE.so/usr/lib/arm-linux-gnueabihf/libX11.so/usr/lib/arm-linux-gnueabihf/libXext.so
--     Include: /usr/include
-- Found OpenGLESv1
-- Found wxWidgets: TRUE  
-- Found wxWidgets...
-- -L/usr/lib/arm-linux-gnueabihf;-pthread;;;-L/usr/lib/arm-linux-gnueabihf;;;-lwx_baseu-2.8;-lwx_gtk2u_core-2.8;-lwx_baseu_net-2.8;-lwx_baseu_xml-2.8;-lwx_gtk2u_html-2.8;-lwx_gtk2u_adv-2.8;-lwx_gtk2u_aui-2.8;-lwx_gtk2u_gl-2.8
It seems like it is not using the newly compiled libGL.so.1 and libGLU.so.1

If I run
Code:
cmake ../
make 
sudo make install
Start opencpn
Code:
export LD_LIBRARY_PATH=/usr/local/lib/
opencpn
Push enable opengl, it crashes.

Code:
ldd /usr/local/bin/opencpn 
...
	libGLU.so.1 => /usr/local/lib/libGLU.so.1 (0xb6489000)
	libGL.so.1 => /usr/local/lib/libGL.so.1 (0xb6458000)
...
Regards
Peter
__________________
it-slav is offline   Reply With Quote
Old 19-06-2014, 09:15   #254
Registered User
 
it-slav's Avatar

Join Date: May 2014
Posts: 46
Re: OpenCPN Runs on Embedded ARM

And some more information.
After enabling opengl, opencpn crashes. Below is the output on the console:
Code:
cubie@Cubian:~$ export LD_LIBRARY_PATH=/usr/local/lib/
cubie@Cubian:~$ /usr/local/bin/opencpn -fullscreen
(opencpn:8761): Gdk-CRITICAL **: IA__gdk_colormap_new: assertion `GDK_IS_VISUAL (visual)' failed
(opencpn:8761): Gtk-CRITICAL **: IA__gtk_widget_set_colormap: assertion `GDK_IS_COLORMAP (colormap)' failed
(opencpn:8761): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
libGL: built on Jun 11 2014 18:08:53
Unable to initialize EGL display.
ERROR: EGL Error detected: EGL_NOT_INITIALIZED (0x3001)
ERROR: EGL Error detected: EGL_NOT_INITIALIZED (0x3001)
Aborted
cubie@Cubian:~$
As far as I understand opencpn uses the correct libraries:
Code:
cubie@Cubian:~$ ldd /usr/local/bin/opencpn 
	libwx_baseu-2.8.so.0 => /usr/lib/arm-linux-gnueabihf/libwx_baseu-2.8.so.0 (0xb6e07000)
	libwx_gtk2u_core-2.8.so.0 => /usr/lib/arm-linux-gnueabihf/libwx_gtk2u_core-2.8.so.0 (0xb6b9b000)
	libwx_baseu_net-2.8.so.0 => /usr/lib/arm-linux-gnueabihf/libwx_baseu_net-2.8.so.0 (0xb6b74000)
	libwx_baseu_xml-2.8.so.0 => /usr/lib/arm-linux-gnueabihf/libwx_baseu_xml-2.8.so.0 (0xb6b66000)
	libwx_gtk2u_html-2.8.so.0 => /usr/lib/arm-linux-gnueabihf/libwx_gtk2u_html-2.8.so.0 (0xb6af3000)
	libwx_gtk2u_adv-2.8.so.0 => /usr/lib/arm-linux-gnueabihf/libwx_gtk2u_adv-2.8.so.0 (0xb6a65000)
	libwx_gtk2u_aui-2.8.so.0 => /usr/lib/arm-linux-gnueabihf/libwx_gtk2u_aui-2.8.so.0 (0xb6a1a000)
	libwx_gtk2u_gl-2.8.so.0 => /usr/lib/arm-linux-gnueabihf/libwx_gtk2u_gl-2.8.so.0 (0xb6a11000)
	libfreetype.so.6 => /usr/lib/arm-linux-gnueabihf/libfreetype.so.6 (0xb69b5000)
	libglib-2.0.so.0 => /lib/arm-linux-gnueabihf/libglib-2.0.so.0 (0xb68f6000)
	libgobject-2.0.so.0 => /usr/lib/arm-linux-gnueabihf/libgobject-2.0.so.0 (0xb68b7000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib/arm-linux-gnueabihf/libgdk_pixbuf-2.0.so.0 (0xb6898000)
	libgdk-x11-2.0.so.0 => /usr/lib/arm-linux-gnueabihf/libgdk-x11-2.0.so.0 (0xb681c000)
	libgtk-x11-2.0.so.0 => /usr/lib/arm-linux-gnueabihf/libgtk-x11-2.0.so.0 (0xb654a000)
	libcairo.so.2 => /usr/lib/arm-linux-gnueabihf/libcairo.so.2 (0xb64ab000)
	libpango-1.0.so.0 => /usr/lib/arm-linux-gnueabihf/libpango-1.0.so.0 (0xb646c000)
	libatk-1.0.so.0 => /usr/lib/arm-linux-gnueabihf/libatk-1.0.so.0 (0xb644c000)
	libportaudio.so.2 => /usr/lib/arm-linux-gnueabihf/libportaudio.so.2 (0xb6423000)
	libGLU.so.1 => /usr/local/lib/libGLU.so.1 (0xb63fe000)
	libGL.so.1 => /usr/local/lib/libGL.so.1 (0xb63cd000)
	libSM.so.6 => /usr/lib/arm-linux-gnueabihf/libSM.so.6 (0xb63c0000)
	libICE.so.6 => /usr/lib/arm-linux-gnueabihf/libICE.so.6 (0xb63a7000)
	libX11.so.6 => /usr/lib/arm-linux-gnueabihf/libX11.so.6 (0xb62be000)
	libXext.so.6 => /usr/lib/arm-linux-gnueabihf/libXext.so.6 (0xb62ac000)
	libbz2.so.1.0 => /lib/arm-linux-gnueabihf/libbz2.so.1.0 (0xb6297000)
	libz.so.1 => /lib/arm-linux-gnueabihf/libz.so.1 (0xb627e000)
	libtinyxml.so.2.6.2 => /usr/lib/libtinyxml.so.2.6.2 (0xb6262000)
	libdl.so.2 => /lib/arm-linux-gnueabihf/libdl.so.2 (0xb6257000)
	libstdc++.so.6 => /usr/lib/arm-linux-gnueabihf/libstdc++.so.6 (0xb61ac000)
	libm.so.6 => /lib/arm-linux-gnueabihf/libm.so.6 (0xb6141000)
	libgcc_s.so.1 => /lib/arm-linux-gnueabihf/libgcc_s.so.1 (0xb611d000)
	libpthread.so.0 => /lib/arm-linux-gnueabihf/libpthread.so.0 (0xb6101000)
	libc.so.6 => /lib/arm-linux-gnueabihf/libc.so.6 (0xb601c000)
	libgio-2.0.so.0 => /usr/lib/arm-linux-gnueabihf/libgio-2.0.so.0 (0xb5f41000)
	libpangoft2-1.0.so.0 => /usr/lib/arm-linux-gnueabihf/libpangoft2-1.0.so.0 (0xb5f1e000)
	libfontconfig.so.1 => /usr/lib/arm-linux-gnueabihf/libfontconfig.so.1 (0xb5ef2000)
	libgthread-2.0.so.0 => /usr/lib/arm-linux-gnueabihf/libgthread-2.0.so.0 (0xb5ee7000)
	librt.so.1 => /lib/arm-linux-gnueabihf/librt.so.1 (0xb5ed9000)
	libXinerama.so.1 => /usr/lib/arm-linux-gnueabihf/libXinerama.so.1 (0xb5ed0000)
	libpng12.so.0 => /lib/arm-linux-gnueabihf/libpng12.so.0 (0xb5eaf000)
	libjpeg.so.8 => /usr/lib/arm-linux-gnueabihf/libjpeg.so.8 (0xb5e81000)
	libtiff.so.4 => /usr/lib/arm-linux-gnueabihf/libtiff.so.4 (0xb5e2f000)
	libexpat.so.1 => /lib/arm-linux-gnueabihf/libexpat.so.1 (0xb5e0e000)
	/lib/ld-linux-armhf.so.3 (0xb6f01000)
	libpcre.so.3 => /lib/arm-linux-gnueabihf/libpcre.so.3 (0xb5dd5000)
	libffi.so.5 => /usr/lib/arm-linux-gnueabihf/libffi.so.5 (0xb5dc3000)
	libgmodule-2.0.so.0 => /usr/lib/arm-linux-gnueabihf/libgmodule-2.0.so.0 (0xb5db8000)
	libpangocairo-1.0.so.0 => /usr/lib/arm-linux-gnueabihf/libpangocairo-1.0.so.0 (0xb5da7000)
	libXrender.so.1 => /usr/lib/arm-linux-gnueabihf/libXrender.so.1 (0xb5d99000)
	libXi.so.6 => /usr/lib/arm-linux-gnueabihf/libXi.so.6 (0xb5d88000)
	libXrandr.so.2 => /usr/lib/arm-linux-gnueabihf/libXrandr.so.2 (0xb5d7a000)
	libXcursor.so.1 => /usr/lib/arm-linux-gnueabihf/libXcursor.so.1 (0xb5d6c000)
	libXcomposite.so.1 => /usr/lib/arm-linux-gnueabihf/libXcomposite.so.1 (0xb5d62000)
	libXdamage.so.1 => /usr/lib/arm-linux-gnueabihf/libXdamage.so.1 (0xb5d58000)
	libXfixes.so.3 => /usr/lib/arm-linux-gnueabihf/libXfixes.so.3 (0xb5d4c000)
	libpixman-1.so.0 => /usr/lib/arm-linux-gnueabihf/libpixman-1.so.0 (0xb5cde000)
	libxcb-shm.so.0 => /usr/lib/arm-linux-gnueabihf/libxcb-shm.so.0 (0xb5cd4000)
	libxcb-render.so.0 => /usr/lib/arm-linux-gnueabihf/libxcb-render.so.0 (0xb5cc6000)
	libxcb.so.1 => /usr/lib/arm-linux-gnueabihf/libxcb.so.1 (0xb5cab000)
	libasound.so.2 => /usr/lib/arm-linux-gnueabihf/libasound.so.2 (0xb5c0d000)
	libjack.so.0 => /usr/lib/arm-linux-gnueabihf/libjack.so.0 (0xb5bec000)
	libEGL.so => /usr/lib/libEGL.so (0xb5b2f000)
	libuuid.so.1 => /lib/arm-linux-gnueabihf/libuuid.so.1 (0xb5b23000)
	libselinux.so.1 => /lib/arm-linux-gnueabihf/libselinux.so.1 (0xb5b06000)
	libresolv.so.2 => /lib/arm-linux-gnueabihf/libresolv.so.2 (0xb5aed000)
	libjbig.so.0 => /usr/lib/arm-linux-gnueabihf/libjbig.so.0 (0xb5adb000)
	libXau.so.6 => /usr/lib/arm-linux-gnueabihf/libXau.so.6 (0xb5ad1000)
	libXdmcp.so.6 => /usr/lib/arm-linux-gnueabihf/libXdmcp.so.6 (0xb5ac6000)
	libUMP.so => /usr/lib/libUMP.so (0xb5ab8000)
	libdri2.so.1 => /usr/lib/arm-linux-gnueabihf/libdri2.so.1 (0xb5aae000)
	libdrm.so.2 => /usr/lib/arm-linux-gnueabihf/libdrm.so.2 (0xb5a9e000)
Maybe interesting because it complains about EGL
Code:
cubie@Cubian:~$ dlocate /usr/lib/libEGL.so
libsunxi-mali-x11: /usr/lib/libEGL.so.1
libsunxi-mali-x11: /usr/lib/libEGL.so
libsunxi-mali-x11: /usr/lib/libEGL.so.1.4

Regards
Peter
__________________
it-slav is offline   Reply With Quote
Old 19-06-2014, 20:25   #255
Registered User
 
boat_alexandra's Avatar

Join Date: Aug 2009
Location: chesapeake bay
Boat: bristol 27
Posts: 2,816
Re: OpenCPN Runs on Embedded ARM

Are you sure you are using my fork of glshim? I got this error with the mainstream. Otherwise, you will have to debug glshim and find why it cannot initialize the EGL display.

Does glxgears work?
__________________

__________________
boat_alexandra is online now   Reply With Quote
Reply

Tags
opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Open CPN and Google Earth bgrimwade OpenCPN 19 09-12-2011 16:32
OpenCPN Version 2.5 Release bdbcat OpenCPN 86 02-09-2011 19:14
OpenCPN Stops Running BobLarkin OpenCPN 2 31-08-2011 00:38
Route Properties, Missing Functions James Baines OpenCPN 13 13-07-2011 05:31



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 22:12.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.