Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 26-01-2016, 19:09   #136
Registered User
 
transmitterdan's Avatar

Join Date: Oct 2011
Boat: Valiant 42
Posts: 4,018
Re: OpenCPN RC(2) 4.1.1317 Release

Quote:
Originally Posted by Littlechay View Post
Here you go. text file zipped and extension changed to pdf for uploading here.

Chris
Chris,

Have tested with this nmea stream file but no evidence of 999 wind speeds. They look normal and in the 3-5 knot speed range. If you play this nmea file do you see 999 speeds?

Dan
__________________

__________________
transmitterdan is offline   Reply With Quote
Old 27-01-2016, 02:58   #137
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,294
Re: OpenCPN RC(2) 4.1.1317 Release

Dave hello, hello Jongough,

Lenovo, U41, iCore 5-5200U, CPU @ 2.20Ghz, RAM 4 Gb, Graphic card : Intel HD Graphics 5500, W8.1

A small problem with keyboard shortcuts.
"Ctrl + b" hides the charts bar but does not reappear. by cons, after hiding the charts bar, the second use of "Ctrl + b" opens the OCPN Draw icons bar.

And then, impossible to display bar charts.

A second problem , probably specific this graphic card :
"Ctrl + g" or "Crtl + G" do not change from daylight to green and, see screen copy, a second window, black, appear but it is impossible to display this second window.
The only way is to shutdown O and re-run O to return normal situation.
Attached Thumbnails
Click image for larger version

Name:	2016-01-27-Shortcut_Ctrl-G.jpg
Views:	77
Size:	84.0 KB
ID:	117732  
__________________

__________________
Gilletarom is offline   Reply With Quote
Old 27-01-2016, 03:08   #138
Registered User

Join Date: Jan 2011
Location: North Yorkshire, UK
Posts: 32
Re: OpenCPN RC(2) 4.1.1317 Release

Quote:
Originally Posted by Gilletarom View Post
I need to know how you guarantee the quality of the "charts" of OpenSeaMap.

How can we be certain that the charts are both:
- Exact with respect to the accuracy of the points
- Complete regarding all objects must be available on the electronic chart to navigate safely.
The exact answer is that no guarantee can ever be given as to the accuracy, completeness or currency of any data in the OSM database. A crowd sourced database relies on voluntary input from individual mappers and data can be added, edited or deleted by any OSM member. Therefore any nautical chart derived from the OSM database will be similarly limited in its quality.
__________________
malcolmh is offline   Reply With Quote
Old 27-01-2016, 03:13   #139
Registered User

Join Date: Jan 2016
Posts: 8
Re: OpenCPN RC(2) 4.1.1317 Release

Hi Dave,

(#122)
I have an additional question: 'The most recent (by date)'. Does that mean, the file with the most recent file-date (if so creation or modification?). Or do you use the tags in the bsb file or in the header, again in this case which one (CED/SE, CED/RE, CED/ED or else?). What if it is an older edition with a newer release and date?

The reason behind this question: do we need to preserve the file dates while copying and downloading?

Alexej
__________________
alexej-osm is offline   Reply With Quote
Old 27-01-2016, 03:26   #140
Registered User

Join Date: Oct 2014
Posts: 177
Re: OpenCPN RC(2) 4.1.1317 Release

Quote:
Originally Posted by transmitterdan View Post
Chris,

Have tested with this nmea stream file but no evidence of 999 wind speeds. They look normal and in the 3-5 knot speed range. If you play this nmea file do you see 999 speeds?

Dan
Dan,

The apparent wind speed looks okay. The problem is in the calculated True wind speed. See the bottom left corner of this screenshot:

Click image for larger version

Name:	TrueWindSpeed.png
Views:	113
Size:	184.1 KB
ID:	117731

This was made on Win10 with a build from a "git pull" yesterday morning (Jan 26 15:50 UTC).


Paul
__________________
.Paul. is offline   Reply With Quote
Old 27-01-2016, 03:30   #141
Registered User
 
transmitterdan's Avatar

Join Date: Oct 2011
Boat: Valiant 42
Posts: 4,018
Re: OpenCPN RC(2) 4.1.1317 Release

Quote:
Originally Posted by .Paul. View Post
Dan,

The apparent wind speed looks okay. The problem is in the calculated True wind speed. See the bottom left corner of this screenshot:

Attachment 117731

This was made on Win10 with a build from a "git pull" yesterday morning (Jan 26 15:50 UTC).


Paul
Paul,

Thanks, I'll have a look to see what's happening.
__________________
transmitterdan is offline   Reply With Quote
Old 27-01-2016, 03:39   #142
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,294
Re: OpenCPN RC(2) 4.1.1317 Release

Hello Dave,

Third with sortcuts:
"Ctrl + z" undo action, this Ok. "Ctrl + y" redo action Ok,
But
"Ctrl + Z" redo action and "Ctrl + Y" redo action.

So, Perhaps, "Ctrl + Z" not make what is expected ?

4°)
"Ctrl + ," : Not open Options. But this is said in O 4.1 manual. What is good ?
__________________
Gilletarom is offline   Reply With Quote
Old 27-01-2016, 03:45   #143
Registered User

Join Date: May 2011
Posts: 847
Re: OpenCPN RC(2) 4.1.1317 Release

Quote:
Originally Posted by transmitterdan View Post
Chris,



Have tested with this nmea stream file but no evidence of 999 wind speeds. They look normal and in the 3-5 knot speed range. If you play this nmea file do you see 999 speeds?



Dan

It's just one instrument Dan, the combined true wind direction and speed graphic - everything else seems ok.

Chris


SY Morgane
http://tweedsworld.com
__________________
Littlechay is offline   Reply With Quote
Old 27-01-2016, 04:33   #144
Registered User
 
transmitterdan's Avatar

Join Date: Oct 2011
Boat: Valiant 42
Posts: 4,018
Re: OpenCPN RC(2) 4.1.1317 Release

Quote:
Originally Posted by Littlechay View Post
Here you go. text file zipped and extension changed to pdf for uploading here.

Chris
Chris,

Here is the reason this is happening. The "True Wind Dir. & Speed" instrument uses the MWD sentence and the N (knots) field for speed. In the particular case here the speed fields (kts and m/s) are blank. The plugin uses 999 as a flag that the data was blank. This is an example of one sentence in the NMEA log for reference:

"$WIMWD,348.89,T,,M,,N,,M*4A\r\n"

If you can tell your wind instrument to populate the kts field (I believe it is the empty slot before the "N") of this sentence then the dashboard instrument should work ok.
__________________
transmitterdan is offline   Reply With Quote
Old 27-01-2016, 04:41   #145
Registered User

Join Date: May 2011
Posts: 847
Re: OpenCPN RC(2) 4.1.1317 Release

Quote:
Originally Posted by transmitterdan View Post
Chris,



Here is the reason this is happening. The "True Wind Dir. & Speed" instrument uses the MWD sentence and the N (knots) field for speed. In the particular case here the speed fields (kts and m/s) are blank. The plugin uses 999 as a flag that the data was blank. This is an example of one sentence in the NMEA log for reference:



"$WIMWD,348.89,T,,M,,N,,M*4A\r\n"



If you can tell your wind instrument to populate the kts field (I believe it is the empty slot before the "N") of this sentence then the dashboard instrument should work ok.

Hmmm can the speed part of the instrument not get speed from wherever the TWS text instrument gets it?

I can't do much about the data. The instrument is N2k and the data is converted by an actisense NGW .

Ok no big deal for me I can use the text display, just wanted to let you know it wasn't working in my setup.

Chris


SY Morgane
http://tweedsworld.com
__________________
Littlechay is offline   Reply With Quote
Old 27-01-2016, 05:50   #146
Registered User

Join Date: Nov 2014
Location: Netherlands
Posts: 179
Re: OpenCPN RC(2) 4.1.1317 Release

Quote:
Originally Posted by transmitterdan View Post
Chris,

Here is the reason this is happening. The "True Wind Dir. & Speed" instrument uses the MWD sentence and the N (knots) field for speed. In the particular case here the speed fields (kts and m/s) are blank. The plugin uses 999 as a flag that the data was blank. This is an example of one sentence in the NMEA log for reference:

"$WIMWD,348.89,T,,M,,N,,M*4A\r\n"

If you can tell your wind instrument to populate the kts field (I believe it is the empty slot before the "N") of this sentence then the dashboard instrument should work ok.
Dan,

You supplied a fix for this 22 days ago in files wind.cpp and wind_history.cpp.
The wind_history part works, but if I set a breakpoint on the wind.cpp part it never fires.
If however I set a breakpoint on the dial.cpp line 101 it fires there.
If I add the check "&& data < 200.0" like in the wind.cpp file I don't see the 999.0 indication anymore.

Peter
__________________
ptulp is offline   Reply With Quote
Old 27-01-2016, 06:20   #147
Registered User
 
transmitterdan's Avatar

Join Date: Oct 2011
Boat: Valiant 42
Posts: 4,018
Re: OpenCPN RC(2) 4.1.1317 Release

Quote:
Originally Posted by ptulp View Post
Dan,

You supplied a fix for this 22 days ago in files wind.cpp and wind_history.cpp.
The wind_history part works, but if I set a breakpoint on the wind.cpp part it never fires.
If however I set a breakpoint on the dial.cpp line 101 it fires there.
If I add the check "&& data < 200.0" like in the wind.cpp file I don't see the 999.0 indication anymore.

Peter
Peter,

See my previous message. I am unsure of the historical reason but this particular instrument uses the speed value from MWD sentence. The MWD sentence has no speed value. This is why the instrument displays 999.
__________________
transmitterdan is offline   Reply With Quote
Old 27-01-2016, 06:26   #148
Registered User
 
transmitterdan's Avatar

Join Date: Oct 2011
Boat: Valiant 42
Posts: 4,018
Re: OpenCPN RC(2) 4.1.1317 Release

Quote:
Originally Posted by ptulp View Post
Dan,

You supplied a fix for this 22 days ago in files wind.cpp and wind_history.cpp.
The wind_history part works, but if I set a breakpoint on the wind.cpp part it never fires.
If however I set a breakpoint on the dial.cpp line 101 it fires there.
If I add the check "&& data < 200.0" like in the wind.cpp file I don't see the 999.0 indication anymore.

Peter
Peter,

If we want to use the other source of TWS in the wind compass we can change in line 2326 of dashboard.cpp the option word OCPN_DBP_STC_TWS2 to OCPN_DBP_STC_TWS. Then the compass wind instrument will display true wind speed from the "first" true wind source. But the original author of dashboard did not intend that for some reason.
__________________
transmitterdan is offline   Reply With Quote
Old 27-01-2016, 07:05   #149
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,247
Re: OpenCPN RC(2) 4.1.1317 Release

Quote:
Originally Posted by bdbcat View Post
Thomas...

I think you have somehow a bad source file. We saw this bug earlier, and I fixed it. Or at least found a way to avoid a crash.

Please check src/georef.cpp. It should look like this at line 913:

Code:
void MolodenskyTransform (double lat, double lon, double *to_lat, double *to_lon, int from_datum_index, int to_datum_index)
{
    double dlat = 0;
    double dlon = 0;
    
    if( from_datum_index < nDatums){
      const double from_lat = lat * DEGREE;
      const double from_lon = lon * DEGREE;
      const double from_f = 1.0 / gEllipsoid[gDatum[from_datum_index].ellipsoid].invf;    // flattening
      const double from_esq = 2 * from_f - from_f * from_f;                               // eccentricity^2
      const double from_a = gEllipsoid[gDatum[from_datum_index].ellipsoid].a;             // semimajor axis
      const double dx = gDatum[from_datum_index].dx;
      const double dy = gDatum[from_datum_index].dy;
In your crashdump image, the line numbers don't match.

Dave
That was a Git trick I didn't know about!! Your line 913 was my line 900 but the file size was the same! I did not bother to investigate further. Copying the correct georef.cpp from the git site solved the problem.

Also, with the latest git my earlier problems with the svg icons in the grib plugin is fixed.

Thanks!

Thomas
__________________
cagney is offline   Reply With Quote
Old 27-01-2016, 07:28   #150
Registered User

Join Date: Nov 2014
Location: Netherlands
Posts: 179
Re: OpenCPN RC(2) 4.1.1317 Release

Quote:
Originally Posted by transmitterdan View Post
Peter,

If we want to use the other source of TWS in the wind compass we can change in line 2326 of dashboard.cpp the option word OCPN_DBP_STC_TWS2 to OCPN_DBP_STC_TWS. Then the compass wind instrument will display true wind speed from the "first" true wind source. But the original author of dashboard did not intend that for some reason.
Dan,

I see this problem not only in the ID_DBP_D_TWD case but also in ID_DBP_D_AWA_TWA and ID_DBP_I_TWS cases.
There the 999 value is only seen very shortly as it is overwritten with the data from other instruments.
So basically speed value is filled also with 999 in the MWD case.
So I think that we should check on line 785 and 787 in dashboard.cpp if the value is 999 and if so don't send the sentence.

Peter
__________________

__________________
ptulp is offline   Reply With Quote
Reply

Tags
enc, lease, opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCPN Version 2.3.1 Release cagney OpenCPN 14 02-04-2011 11:52
OpenCPN Version 2.3.0 Release bdbcat OpenCPN 74 31-12-2010 02:09
OpenCPN Version 1.3.6 Release bdbcat OpenCPN 32 30-01-2010 06:07



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 14:58.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.