Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-10-2019, 15:05   #1
Registered User

Join Date: Oct 2019
Posts: 10
Opencpn not seeing serial AIS/GPS data

We have a NAIS-500 Class B AIS transceiver, and have connected it via USB to a Windows 10 computer. The manufacture software (NAIS System Configurator) can see the com port correctly, and we are able to connect to the transceiver and see GPS and AIS data. The com port is an AIS Virtual Com, assigned as COM4 by Windows. With Opencpn, we are able to set up a connection to the com port, however, we are not seeing any nmea data in the debug window. In device manager, the com port properties indicates that the device is working properly and the installed driver is the latest one. Has anyone had a similar situation, and what can be done to get it to work?
__________________

Tracy Andacht is offline   Reply With Quote
Old 05-10-2019, 15:53   #2
Registered User

Join Date: Oct 2014
Posts: 235
Re: Opencpn not seeing serial AIS/GPS data

Windows only allows one program at a time to access a COM port.

If the NAIS System Configurator and OpenCPN both try to use the same COM port, Windows will give the first program (probably NAIS System Configurator) access to the port, and the second program cannot access the port.

The solution for this is to run the NAIS System Configurator to configure the AIS. Then exit or stop the NAIS System Configurator program. After the configuration program is stopped, and Windows knows that the NAIS System Configurator is finished with the COM port, then OpenCPN can access the COM port.

Paul
__________________

.Paul. is offline   Reply With Quote
Old 05-10-2019, 16:19   #3
Registered User
 
Dsanduril's Avatar

Join Date: Aug 2011
Location: Petersburg, AK
Boat: Outremer 50S
Posts: 2,017
Re: Opencpn not seeing serial AIS/GPS data

Do you have the correct baud rate for the OpenCPN connection? The default is 4800 but the USB connection for AIS data should be set at 38,400.

Quote:
Once installed the AIS unit can be connected to the PC. The USB
device will be automatically detected and will appear as a new COM
port device. Select this COM port and a baud rate of 38,400 in PC
based navigation software to make use of the AIS data.
[Edit] - this is the setting in OpenCPN, next to the com port dropdown, not the Win10 or other places you might set baud rate.[/edit]
Dsanduril is offline   Reply With Quote
Old 07-10-2019, 09:28   #4
Registered User

Join Date: Oct 2019
Posts: 10
Re: Opencpn not seeing serial AIS/GPS data

I have disconnected the com port in the NAIS software, and closed the program before opening up Opencpn, with the same issue. I have set the correct baud rate for nmea data (38400) both in Windows and Opencpn, but still have the same issue. I have also rebooted the computer after closing the NAIS software and before opening up Opencpn, with the same issue. Opencpn appears to recognize the the port is available, as I can select the port in the drop down menu, but I do not see the nmea data coming in to Opencpn. Any other suggestions?
Tracy Andacht is offline   Reply With Quote
Old 07-10-2019, 09:33   #5
Registered User
 
Dsanduril's Avatar

Join Date: Aug 2011
Location: Petersburg, AK
Boat: Outremer 50S
Posts: 2,017
Re: Opencpn not seeing serial AIS/GPS data

Hmm, here's a couple of long shots:

1. Turn off "Control Checksum" in the OpenCPN connection setup. Remote chance the NAIS is not sending a (proper) checksum.

2. Change the "Input Filtering" to "Ignore Sentences" and leave the filter box blank. It defaults to "Accept Only" but I thought a blank box allowed all - don't have a unit at the moment to test.
Dsanduril is offline   Reply With Quote
Old 07-10-2019, 10:01   #6
Registered User

Join Date: Oct 2019
Posts: 10
Re: Opencpn not seeing serial AIS/GPS data

I tried both suggestions individually and together, with still the same issue. I have been successful getting gps data from an old handheld Garmin GPS via serial. The difference I see between the two is that the Garmin port is assigned a fixed port, called Garmin GPS, and is not a virtual port, but the NAIS port is assigned as a virtual port. No matter which USB port I use, Windows assigns it as Com4. Could this have any bearing on the issue? I am running the latest release of Opencpn, v 5.0.0+9065270.
Tracy Andacht is offline   Reply With Quote
Old 07-10-2019, 10:17   #7
Registered User
 
Dsanduril's Avatar

Join Date: Aug 2011
Location: Petersburg, AK
Boat: Outremer 50S
Posts: 2,017
Re: Opencpn not seeing serial AIS/GPS data

Sorry, don't have a system with a USB connection in front of me (away from the boat) so hard to test any further. Windows 10 removed a lot of nice testing stuff, depending on how comfortable you are with computers and downloads from the internet, I would follow this blog post and install HyperTerminal. That will allow you to connect directly to the com port. If you see all of the NMEA data going by in a HyperTerminal window then you know it is getting to the computer.

There are several programs out there for this type of testing, I use RealTerm a lot as I find it very useful, but HyperTerminal is probably a bit easier.

That may be a waste of time since you know it works with NAIS software, but using a terminal program allows you to remove a lot of the layers that get hidden by OpenCPN.

If you don't see anything in HyperTerminal I would try changing the baud rate. The NAIS manual says 38400, but many USB serial ports run at 115200, so they may have written one thing but implemented something else.

Sorry, not much help, but those are the next few things I would try.
Dsanduril is offline   Reply With Quote
Old 07-10-2019, 10:23   #8
Registered User

Join Date: Mar 2013
Location: west coast of Thailand
Boat: Mason 44
Posts: 207
Re: Opencpn not seeing serial AIS/GPS data

Quote:
Originally Posted by Tracy Andacht View Post
We have a NAIS-500 Class B AIS transceiver, and have connected it via USB to a Windows 10 computer.
I am no IT expert. Try a different machine with Windows 7 or XP.

Eric
ericoh88 is offline   Reply With Quote
Old 07-10-2019, 10:50   #9
Registered User

Join Date: Nov 2015
Boat: Fountaine Pajot Marqueses 56
Posts: 33
Re: Opencpn not seeing serial AIS/GPS data

The manual has a warning which may be applicable.

Warning: If the USB connection is removed from the PC or Mac during use, you must reset the connection before further use. To reset the connection: disconnect, then re-apply power to the AIS before closing and re-launching any PC or Mac applications using the USB connection. Finally, re-connect the USB cable between the PC or Mac and the AIS transceiver.
Frode is offline   Reply With Quote
Old 07-10-2019, 11:20   #10
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 3,542
Re: Opencpn not seeing serial AIS/GPS data

For example worn out USB connectors can trigger a very short disconnect you will not notice.
Now the communication is "in the air" - one side waits and the other waits as well, but for a new connection...
bcn is offline   Reply With Quote
Old 07-10-2019, 12:26   #11
Registered User

Join Date: Oct 2019
Posts: 10
Re: Opencpn not seeing serial AIS/GPS data

I double checked with Hyperterminal, and as with the NAIS software, I am seeing nmea data. So the computer is seeing the data, but Opencpn is not. I tried changing the baud rate within Opencpn, and the issue is not resolved. I followed the advice in the NAIS manual to reset communication between the unit and computer, and still have the same issue. I will try another version of Windows next and will let you know how it goes.
Tracy Andacht is offline   Reply With Quote
Old 07-10-2019, 13:21   #12
Moo
Registered User

Join Date: Mar 2017
Posts: 474
Re: Opencpn not seeing serial AIS/GPS data

Let's see your com configuration in OCPN?

Let's see your com port configuration in the NASA configurator.

Are you using the NMEA debug window?

Are you sure about the baud rate? USB connections may be running much faster.
Quote:
Originally Posted by Tracy Andacht View Post
I double checked with Hyperterminal, and as with the NAIS software, I am seeing nmea data. So the computer is seeing the data, but Opencpn is not. I tried changing the baud rate within Opencpn, and the issue is not resolved. I followed the advice in the NAIS manual to reset communication between the unit and computer, and still have the same issue. I will try another version of Windows next and will let you know how it goes.
Moo is offline   Reply With Quote
Old 07-10-2019, 13:52   #13
Registered User
 
Dsanduril's Avatar

Join Date: Aug 2011
Location: Petersburg, AK
Boat: Outremer 50S
Posts: 2,017
Re: Opencpn not seeing serial AIS/GPS data

It's not helpful to you at all (no solution posted), but here is someone else with an NAIS-400->USB->Mac->OpenCPN that describes the exact same problem - works fine in other software but not OpenCPN.

Can you post some of the NMEA sentences received in the HyperTerminal window? Would be interesting to see if they look correct.
Dsanduril is offline   Reply With Quote
Old 07-10-2019, 18:43   #14
Registered User

Join Date: Oct 2019
Posts: 10
Re: Opencpn not seeing serial AIS/GPS data

I tried Opencpn v.5.0.0xxx on a Windows XP computer, with the same result. The USB port is also assigned as a virtual com port in Windows (com 9).
Tracy Andacht is offline   Reply With Quote
Old 07-10-2019, 19:32   #15
Registered User
 
Reefmagnet's Avatar

Join Date: May 2008
Location: puɐןsuǝǝnb 'ʎɐʞɔɐɯ
Boat: Nantucket Island 33
Posts: 3,626
Re: Opencpn not seeing serial AIS/GPS data

The "Com 9" could be an issue. Can you delete other unused comports and get the number to <=8? Windows has a habit of incrementing Com Port numbers at the drop of a hat.


And FWIW, I had an identical issue on the weekend just moving the plug to another port on the PC. Nothing changed yet OpenCPN didn't pick up the data. Fixed it in my case just by unplugging the device, shutting down the computer and restarting, then plugging the AIS USB lead back in fixed things in my case.


One word of caution is don't fiddle with too many settings and leave them set if things don't work. The critical number is the 38400 baud rate, but there are other settings associated with serial communication like stop bits, parity and # data bits. Fiddle with these and things will never work again if you don't get them back right. Sometimes it's best to delete the existing connection in OpenCPN and run with the default serial config (changed to 38400 bps in this case).
__________________

Reefmagnet is offline   Reply With Quote
Reply

Tags
ais, enc, gps, opencpn, serial

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Seeing my own AIS transmission on Raymarine plotter masonc Marine Electronics 21 18-06-2019 12:00
OpenCPN not seeing dAISy output Lomax OpenCPN 46 14-12-2016 22:23
opencpn not getting gps/ais data kcj OpenCPN 25 11-12-2016 11:31
AIS to OpenCPN serial pin #s svjoyeux OpenCPN 1 22-09-2012 17:16

Advertise Here


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 16:17.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×

ShowCase vBulletin Plugins by Drive Thru Online, Inc.