Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 16-10-2014, 12:52   #1
Registered User

Join Date: Oct 2014
Posts: 3
OpenCPN lost connection with the AIS Oceansat Class B

OpenCPN 3.2.2 lost connection with the AIS Oceansat Class B after running a few minutes or after some hours. I cannot find something in the loggings. Who can help me? Below all the necessary information.

Configuration details
Asus Netbook EEE PC 10001PXD, Windows 7 Starter
Oceansat AIS Class B (internal GPS) connect to Netbook by usb (Virtual Com Port)
Power management configured :pc cannot switch off
In Virusscanner (AVG 2014) exclusions for OpenCPN,CM93, Virt com port
Connections are configured as written in the OpenCPN manual

Info about Virtual com port software (USB to COM)
******************* (C) COPYRIGHT 2010 STMicroelectronics ********************
* File Name : version.txt
* Author : MCD Application Team
* Version : V1.3.1
* Date : 07/23/2010
* Description : Version file for Virtual COM Port driver
************************************************** ******************************
* THE PRESENT SOFTWARE WHICH IS FOR GUIDANCE ONLY AIMS AT PROVIDING CUSTOMERS
* WITH CODING INFORMATION REGARDING THEIR PRODUCTS IN ORDER FOR THEM TO SAVE TIME.
* AS A RESULT, STMICROELECTRONICS SHALL NOT BE HELD LIABLE FOR ANY DIRECT,
* INDIRECT OR CONSEQUENTIAL DAMAGES WITH RESPECT TO ANY CLAIMS ARISING FROM THE
* CONTENT OF SUCH SOFTWARE AND/OR THE USE MADE BY CUSTOMERS OF THE CODING
* INFORMATION CONTAINED HEREIN IN CONNECTION WITH THEIR PRODUCTS.
************************************************** *****************************/
* V1.3.1 - 07/23/2010
=====================
New Features
************
+ WHQL Certified with and published at WindowsUpdateweb site :
- Microsoft Windows 2000 family,
- Microsoft Windows XP family, x86
- Microsoft Windows XP family, x64
- Microsoft Windows Vista family, x86
- Microsoft Windows Vista family, x64
- Microsoft Windows 7

* V1.2.0 - 07/21/2009
=====================
+ Solving msports.dll copy issue when this file is already used by the operating system

* V1.1.0 - 06/13/2008
=====================
+ Remove the Firmware License Agreement file
+ resolved issues
1) Creation of "WINNT" and "Windows" directories in different disck partitions
2) Creation of multiple uninstall entries in "Add/Remove programs" service

* V1.0.0 - 05/08/2008
====================
Created.
****************** (C) COPYRIGHT 2010 STMicroelectronics *****END OF FILE******

Application log Open CPN3.2.2

19:14:37: 2014-10-15
19:14:37: ------- Starting OpenCPN -------
19:14:37: Version 3.2.2 Build 2013-05-08
19:14:37: wxWidgets version: wxWidgets 2.8.12
19:14:37: MemoryStatus: mem_total: 2038 mb,mem_initial: 7 mb
19:14:37: SData_Locn is C:\Program Files\OpenCPN\
19:14:37: Using existing Config_File: C:\ProgramData\opencpn\opencpn.ini
19:14:37: Styles loading from C:\Program Files\OpenCPN\uidata\styles.xml
19:14:37: No styles found at: C:\ProgramData\opencpn\
19:14:37: No styles found at: C:\ProgramData\opencpn\.opencpn\
19:14:37: Setting Viewpoint Lat/Lon 52.5315, 5.4398
19:14:37: Setting Ownship Lat/Lon 52.5315, 5.4398
19:14:37: System default Language: nl_NL
19:14:37: Opencpn language set to: nl_NL
19:14:38: ChartSymbols loaded from C:\Program Files\OpenCPN\s57data\chartsymbols.xml
19:14:38: Using s57data in C:\Program Files\OpenCPN\s57data
19:14:38: Setting Viewpoint Lat/Lon 52.5315, 5.4398
19:14:38: Setting Ownship Lat/Lon 52.5315, 5.4398
19:14:38: Opening NMEA Datastream Serial:COM3
19:14:39: PlugInManager searching for PlugIns in location C:\Program Files\OpenCPN\plugins
19:14:39: PlugInManager: Loading PlugIn: C:\Program Files\OpenCPN\plugins/dashboard_pi.dll
19:14:39: C:\Program Files\OpenCPN\plugins/dashboard_pi.dll Version detected: 106
19:14:39: PlugInManager: Loading PlugIn: C:\Program Files\OpenCPN\plugins/grib_pi.dll
19:14:39: C:\Program Files\OpenCPN\plugins/grib_pi.dll Version detected: 107
19:14:39: Changing NMEA Datasource for AIVDO to Serial:COM3 (Priority: 1)
19:14:39: Changing NMEA Datasource for GPRMC to Serial:COM3 (Priority: 1)
19:14:39: ChartDB Cache policy: Application target is 1019 MBytes
19:14:39: Loading chart db version: V017
19:14:39: Chartdb: Chart directory list follows
19:14:39: Chart directory #0: C:\CM93 hernoemd
19:14:39: GPS Watchdog Timeout is: 6 sec.
19:14:40: Initializing Chart C:\CM93 hernoemd\
19:14:40: CM93Composite Chart Root is C:\CM93 hernoemd\\
19:14:40: Loaded CM93 Dictionary from C:\CM93 hernoemd\\
19:14:40: Loading CM93 cell C:\CM93 hernoemd\\03900000/D/04260015.D
19:15:19: Changing NMEA Datasource for AITXT to Serial:COM3 (Priority: 1)
19:15:38: LOGBOOK: 2014-10-15 17:15:38 UTCGPS Lat52.53148 Lon5.43979 COG200.60000 SOG0.01
19:17:59: EnumerateSerialPorts() Found Garmin USB Driver.
19:19:19: Closing NMEA Datastream Serial:COM3
19:19:19: Stopping Secondary Thread
19:19:20: Stopped in 1 sec.
19:19:20: Opening NMEA Datastream Serial:COM3
19:19:23: EnumerateSerialPorts() Found Garmin USB Driver.
19:19:31: Closing NMEA Datastream Serial:COM3
19:19:31: Stopping Secondary Thread
19:19:32: Stopped in 1 sec.
19:19:32: Opening NMEA Datastream Serial:COM3
19:30:00: LOGBOOK: 2014-10-15 17:30:00 UTCGPS Lat52.53151 Lon5.43979 COG ----- SOG0.04

Last part of DEBUG VIEW in OpenCPN
There was no datatransmission No other messages

Eventvwr
In system-and application log no events.




*
__________________

__________________
Machiel H is offline   Reply With Quote
Old 16-10-2014, 13:04   #2
Registered User
 
rooiedirk's Avatar

Join Date: Aug 2010
Location: Netherlands
Boat: Oneoff
Posts: 304
Re: OpenCPN lost connection with the AIS Oceansat Class B

This is very likely a windows usb problem( sorry microsoft future ). check
Opncpn AIS with Raymarine AIS 650 is bugging me
__________________

__________________
rooiedirk is offline   Reply With Quote
Old 16-10-2014, 13:13   #3
Registered User

Join Date: Oct 2014
Posts: 3
Re: OpenCPN lost connection with the AIS Oceansat Class B

It isn't an usb problem, because when I am starting up ProAIS (the management software for the AIS) shows that COM3 (the virtual ) is still in use. So my conclusion is that it must be somewhere in OpenCPN
__________________
Machiel H is offline   Reply With Quote
Old 16-10-2014, 13:28   #4
Registered User
 
rooiedirk's Avatar

Join Date: Aug 2010
Location: Netherlands
Boat: Oneoff
Posts: 304
Re: OpenCPN lost connection with the AIS Oceansat Class B

Just to be sure, you did close OpenCPN before starting ProAIS??
__________________
rooiedirk is offline   Reply With Quote
Old 16-10-2014, 13:40   #5
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,769
Re: OpenCPN lost connection with the AIS Oceansat Class B

Quote:
Originally Posted by Machiel H View Post
It isn't an usb problem, because when I am starting up ProAIS (the management software for the AIS) shows that COM3 (the virtual ) is still in use. So my conclusion is that it must be somewhere in OpenCPN
Can be well an USB problem - USB goes to sleep, OpenCPN looses the COM, but it is not released and ProAIS can't catch it.
Close OpenCPN, Close ProAIS, unplug the device and plug it in again.
It might be even necessary to power cycle the AIS and then after connect to Windows.
ProAIS indicates that this is a device from CRT - same family as Raymarine or em-trak. There are updates for drivers and most probably for the firmware of the AIS as well to deal with this type of USB stalls.
__________________
bcn is offline   Reply With Quote
Old 17-10-2014, 07:42   #6
Registered User

Join Date: Feb 2011
Location: uk
Posts: 75
Re: OpenCPN lost connection with the AIS Oceansat Class B

I didnt think the management soft ware needs to run, when open cpn is running.

pro ais is used to configure the class b bits and show the ais is working on first installation.

also a com port cant be shared without some extra software

so

1 turn on computer.

2 when fully booted

3 if the usb connection is a rs232, plug it in , let its drivers load then connect the ais to it
4 If usb connection is just a wire to the ais, turn on ais and connect usb.

then in settings check the correct com port is configured.

hope that has been a help.

david
__________________
yachtman is offline   Reply With Quote
Old 31-05-2015, 10:58   #7
Registered User

Join Date: Oct 2014
Posts: 3
Re: OpenCPN lost connection with the AIS Oceansat Class B

Oceansat gaves the solution (and is now also part of the website):

The USB connection is only for configuration purposes and not for navigating!!

I bought a special usb adapter and connected the other wires of the AIS with this adapter. After that everything is working fine.

Everybody THX

Machiel
__________________

__________________
Machiel H is offline   Reply With Quote
Reply

Tags
ais, enc, lost, opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Icom MA-500TR Class B AIS - Anyone Used it Yet ? beetle Marine Electronics 20 Today 14:29
AIS Class B Can Be Filtered Out by Big Ship Radars goboatingnow Marine Electronics 28 30-01-2012 03:10
Simrad Class B AIS via Simnet to NX40 Connector ? SvenG Marine Electronics 11 13-03-2011 15:59
Class B AIS ozboatie Marine Electronics 4 27-06-2010 09:40
Class B AIS finally approved AnchorageGuy Navigation 12 22-09-2008 10:19



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 20:33.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.