Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 27-07-2015, 04:40   #16
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,382
Re: OpenCPN - incorrect bearings from ship

I mean to say your GPS!

Sent from my SCH-I545 using Cruisers Sailing Forum mobile app
__________________

__________________
rgleason is offline   Reply With Quote
Old 27-07-2015, 16:20   #17
Registered User

Join Date: Sep 2012
Location: Tiverton, RI
Boat: Pacific Seacraft 40
Posts: 21
Re: OpenCPN - incorrect bearings from ship

All:
I am finally able to receive internet access now that we are anchored in Linekin Bay. Thanks for your suggestions.

Hubert: When I click on the red dot for VDR/ Record, I get a window that lists 3 files - Dashboard, Grig and VDR. If I click on VDRpii, I can select Save. This yields only the choice to replay when I click Play. It does not show anything because I have not recorded anything.
What is the mistake that I am making?

rgleason: Are you saying that under Options, Display,units you have nothing (0) entered under assumed variation? If so that suggests that it is made to adjust for magnetic variation internally and that something has gone wrong with my device.
__________________

__________________
rschaedel is offline   Reply With Quote
Old 27-07-2015, 16:41   #18
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,016
Re: OpenCPN - incorrect bearings from ship

rschaedel...
When you click on the Record icon, it simply asks you to specify some name for a NEW file to save the recording to. Fill in something like "mynmeastream.txt" to the only field where you can write and click the Save button. The plugin will start recording the nmea stream on the background, until you click the same icon again.
Then give us the created file.

Pavel
__________________
nohal is offline   Reply With Quote
Old 28-07-2015, 04:53   #19
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,382
Re: OpenCPN - incorrect bearings from ship

Yes (0). Yes perhaps somethong is wrong with your device. Do as pavel suggests. He needs your VDR file to help.

Sent from my SCH-I545 using Cruisers Sailing Forum mobile app
__________________
rgleason is offline   Reply With Quote
Old 28-07-2015, 05:50   #20
Registered User

Join Date: Sep 2012
Location: Tiverton, RI
Boat: Pacific Seacraft 40
Posts: 21
Re: OpenCPN - incorrect bearings from ship

Pavel;
Thanks for the advice but where do I save the .txt file? When I click on Save, a message comes up - "you cannot save to this location, do you want to save to your documents?"
Bob
__________________
rschaedel is offline   Reply With Quote
Old 28-07-2015, 06:19   #21
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,759
Re: OpenCPN - incorrect bearings from ship

Select for instance the desktop folder or "your documents"
__________________
bcn is offline   Reply With Quote
Old 28-07-2015, 06:53   #22
Registered User

Join Date: Sep 2012
Location: Tiverton, RI
Boat: Pacific Seacraft 40
Posts: 21
Re: OpenCPN - incorrect bearings from ship

Thanks, I am making progress (slowly). I have now downloaded the file and have it on my desktop. When I tried to upload it as an attachment for you to read, I got the message that it exceeds the maximum number of bytes permitted.
Bob
__________________
rschaedel is offline   Reply With Quote
Old 28-07-2015, 06:55   #23
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,759
Re: OpenCPN - incorrect bearings from ship

Perfect - now change the file type to .doc and you will be able to upload it...
__________________
bcn is offline   Reply With Quote
Old 28-07-2015, 07:13   #24
Registered User

Join Date: Sep 2012
Location: Tiverton, RI
Boat: Pacific Seacraft 40
Posts: 21
Re: OpenCPN - incorrect bearings from ship

I am not sure whether this .doc file has been properly attached. Let me know.
Bob
[ATTACH]106222[/ATTAC
Attached Files
File Type: doc LinekinBayfile.doc (13.3 KB, 30 views)
__________________
rschaedel is offline   Reply With Quote
Old 28-07-2015, 11:19   #25
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,759
Re: OpenCPN - incorrect bearings from ship

The first part of the stream
Code:
$GPRMC,113609.000,A,4350.6461,N,06936.8935,W,0.00,183.26,280715,,,A*7D
$GPGGA,113610.000,4350.6461,N,06936.8936,W,1,10,0.8,11.5,M,-32.0,M,,0000*53
$GPGSA,M,3,26,16,31,23,03,29,32,27,09,14,,,1.4,0.8,1.1*33
$GPRMC,113610.000,A,4350.6461,N,06936.8936,W,0.00,183.26,280715,,,A*76
$GPGGA,113611.000,4350.6461,N,06936.8936,W,1,09,0.9,11.5,M,-32.0,M,,0000*5B
$GPGSA,M,3,26,16,31,23,03,29,27,09,14,,,,1.4,0.9,1.1*33
$GPGSV,3,1,12,26,83,050,36,16,63,228,31,31,48,080,37,23,45,303,36*78
$GPGSV,3,2,12,03,23,253,29,29,21,045,25,27,14,175,26,09,12,316,24*77
$GPGSV,3,3,12,14,01,143,23,08,09,179,24,32,15,213,10,40,00,000,*71
$GPRMC,113611.000,A,4350.6461,N,06936.8936,W,0.00,183.26,280715,,,A*77
$GPGGA,113612.000,4350.6461,N,06936.8936,W,1,09,0.9,11.5,M,-32.0,M,,0000*58
$GPGSA,M,3,26,16,31,23,03,29,27,09,14,,,,1.4,0.9,1.1*33
$GPRMC,113612.000,A,4350.6461,N,06936.8936,W,0.00,183.26,280715,,,A*74
!AIVDM,1,1,,B,152Kcf@P00K1AhDI5bHGjOvJ00Rd,0*64
$GPGGA,113613.000,4350.6461,N,06936.8936,W,1,09,0.9,11.5,M,-32.0,M,,0000*59
$GPGSA,M,3,26,16,31,23,03,29,27,09,14,,,,1.4,0.9,1.1*33
$GPRMC,113613.000,A,4350.6461,N,06936.8936,W,0.00,183.26,280715,,,A*75
$GPGGA,113614.000,4350.6461,N,06936.8936,W,1,09,0.9,11.5,M,-32.0,M,,0000*5E
$GPGSA,M,3,26,16,31,23,03,29,27,09,14,,,,1.4,0.9,1.1*33
$GPRMC,113614.000,A,4350.6461,N,06936.8936,W,0.00,183.26,280715,,,A*72
$GPGGA,113615.000,4350.6461,N,06936.8936,W,1,09,0.9,11.5,M,-32.0,M,,0000*5F
$GPGSA,M,3,26,16,31,23,03,29,27,09,14,,,,1.4,0.9,1.1*33
The RMC sentence has a field for variation but this is empty in your case:
$GPRMC,113614.000,A,4350.6461,N,06936.8936,W,0.00, 183.26,280715,,,A*7

So this doesn't help, I fear.
The VDR streaming file has a lot of blank lines - something I have not seen before.

The other option is to use the NMEA debug window taking a screen shot.
Gets enabled at Options|Connections

It would be interesting to see your settings for the serial port(s) as well.

Another idea: Please check under Options|Display|units your settings for bearings. (First thing to do perhaps)

Hubert
__________________
bcn is offline   Reply With Quote
Old 28-07-2015, 15:28   #26
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
Re: OpenCPN - incorrect bearings from ship

Folks...

I think I see what's going on here.

1. There is a bug in OCPN v4.0 in the caption for the settings entry relating to user variation.

In O4 it reads: "deg (+W, -E)"

Corrected, it should read: "deg (-W, +E)"

This error was corrected in Feb, 2015, for the OCPN 4.1 Beta series.
"Change label for setting variation from (+W, -E) to (-W, +E). FS#1694"


So, this explains why manually entering the "wrong" value seems to work properly, and entering the "right" value" doubles the correction in the wrong direction.

2. The BU353 trace attached above shows that there is no variation data coming form the receiver. So we will need to manually enter a value (reversing the polarity for the bug in O4), or....

3. I highly recommend that you install the WMM PlugIn, activate it, and allow the system to calculate the theoretical variation at your position.

Good Luck
Dave
__________________
bdbcat is offline   Reply With Quote
Old 30-07-2015, 15:58   #27
Registered User

Join Date: Sep 2012
Location: Tiverton, RI
Boat: Pacific Seacraft 40
Posts: 21
Re: OpenCPN - incorrect bearings from ship

Dave and Hubert:
I am sorry not to have replied sooner but am now in Rockland where we once again have internet service.

I have downloaded the WMM plugin to my desk top. How do I get it to function with OpenCPN?
Bob
__________________
rschaedel is offline   Reply With Quote
Old 30-07-2015, 16:31   #28
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,382
Re: OpenCPN - incorrect bearings from ship

I don't mean to be a pain, but shouldn't this be fixed in Version 4.0? with a small letter update or something? It is sort of important and that is the most recent "Stable" version. Or should people be using v4.1?


I guess the reason I have not noticed this is we have (0) and the wmm_pi installed.
__________________
rgleason is offline   Reply With Quote
Old 30-07-2015, 18:49   #29
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
Re: OpenCPN - incorrect bearings from ship

Rick...

There are lots of things fixed in 4.1 that have not been backported into 4.0.

This one is small potatoes, since there is a workaround. Use Wmm, or simply reverse the sign of user-entered variation in the settings dialog.

There are worse troubles, like the Mac keyboard character bug in Waypoint properties that Gerhard mentions regularly.....

We could do a Service Release of 4.0. But we probably won't. It is just a matter of managing limited Dev resources. I would not oppose a Service Release if some new developer comes along with the time and energy....

Thanks
Dave
__________________
bdbcat is offline   Reply With Quote
Old 30-07-2015, 19:39   #30
Registered User

Join Date: Sep 2012
Location: Tiverton, RI
Boat: Pacific Seacraft 40
Posts: 21
Re: OpenCPN - incorrect bearings from ship

Dave and Rick:
One thing I do not understand with my problem is why does OpenCPN show the correct magnetic bearings when it receives GPS input from my Raymarine chartplotter? When using the Raymarine input I never had any need to enter a number for assumed variation. It was presumably 0 since I never had even looked at Options, Display, Units.
Are we sure that my problem does not originate in my BU353-S4?

Or could it be that the Raymarine chartplotter calculates the correct variation and it overwrites any errors generated by OpenCPN?

Am I the first person who has posted this problem?
Bob
__________________

__________________
rschaedel is offline   Reply With Quote
Reply

Tags
enc, opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Protecting the Alternator Regulator from Incorrect Shutdown MarkSF Electrical: Batteries, Generators & Solar 30 01-03-2016 16:00
Incorrect Displayed on Quilted Screen fgd3 OpenCPN 10 23-12-2013 12:19
Incorrect Tide & Currents Shown davidjade OpenCPN 11 30-08-2013 18:46
Incorrect Part Number in Manual MV-Romnya Construction, Maintenance & Refit 5 06-11-2012 12:42
Members List - Incorrect Data Wotname Forum Tech Support & Site Help 17 20-03-2011 06:15



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 18:35.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.