Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 29-12-2010, 10:00   #1
Registered User

Join Date: Dec 2010
Location: Panamá
Boat: Bollard 116 47ft
Posts: 15
OpenCPN Fails to Start

I'm trying to run Open-CPN on two lap tops both running quite different versions of XP-SP3 (one fat and bloated one slim and light). On both machines I get back the error message:

This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.
(It doesn't of course)

Versions 2.3.0 and 2.2.1007 both fail in the same way, but 2.1.0 works perfectly. Any suggestions/ideas???
__________________

Samarang is offline   Reply With Quote
Old 29-12-2010, 10:11   #2
Registered User

Join Date: Dec 2005
Location: Helsingborg
Boat: Dufour 35
Posts: 3,569
Quote:
Originally Posted by Samarang View Post
I'm trying to run Open-CPN on two lap tops both running quite different versions of XP-SP3 (one fat and bloated one slim and light). On both machines I get back the error message:

This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.
(It doesn't of course)

Versions 2.3.0 and 2.2.1007 both fail in the same way, but 2.1.0 works perfectly. Any suggestions/ideas???
The documentation Installing OpenCPN | Official OpenCPN Homepage suggest that you download Download details: Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) .

Give it a try!

Thomas
__________________

cagney is offline   Reply With Quote
Old 29-12-2010, 10:30   #3
Registered User

Join Date: Dec 2010
Location: Panamá
Boat: Bollard 116 47ft
Posts: 15
Thanks

Yep that fixed it. Looks like a distinct lack of RTFM at this end.

Thanks very much

BarryB
Samarang is offline   Reply With Quote
Old 01-01-2011, 08:21   #4
Registered User

Join Date: Oct 2006
Location: Norfolk UK
Boat: Hunter 34
Posts: 14
Thumbs up

Thanks. Worked for me too.
__________________
Richard
s/v Green Dragon
HunterWanderer is offline   Reply With Quote
Old 11-02-2011, 20:49   #5
Registered User
 
Arch Stanton's Avatar

Join Date: Mar 2008
Location: Olympia, WA
Boat: San Juan 28
Posts: 214
Had the same problem, googled it, found this thread. Thanks, that fixed it!
Arch Stanton is offline   Reply With Quote
Old 16-02-2011, 12:04   #6
Registered User

Join Date: Apr 2010
Posts: 21
W7

Hi
My updated version 2.3.1 refuses to start. It says that there is an "APP CRASH". I had no problems with the earlier version. I'm using W 7 home 64 bit version.
Any ideas?
Joshua1 is offline   Reply With Quote
Old 24-03-2011, 05:50   #7
Registered User

Join Date: Mar 2011
Posts: 3
Re: OpenCPN Fails to Start

Similar Problem: OpenCpn 2.3.2 on Win7-32.
Install goes well. Program begins to open and I get the brief "Welcome to OpenCpn.." note. Program window opens but then an operating system message that says the program has stopped working. The following are the details associated with the message. Note that v1.3.6 works fine. And, note that I have installed the MS C++ 2008 redist (other versions of C++ were already installed).

Any suggestions on how to get it to run?



Problem signature:
Problem Event Name: BEX
Application Name: opencpn.exe
Application Version: 2.3.1.0
Application Timestamp: 4d1c67be
Fault Module Name: opencpn.exe
Fault Module Version: 2.3.1.0
Fault Module Timestamp: 4d1c67be
Exception Offset: 001041fe
Exception Code: c0000409
Exception Data: 00000000
OS Version: 6.1.7600.2.0.0.768.3
Locale ID: 1033
Additional Information 1: 439f
Additional Information 2: 439faaa3617196640e4695b8a54b1cb7
Additional Information 3: 801b
Additional Information 4: 801baf691f08bc08039146b4f539ab7f
Dragonfly1 is offline   Reply With Quote
Old 24-03-2011, 06:27   #8
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 5,226
Re: OpenCPN Fails to Start

Dragonfly1,
The following applies if you were using older versions of OpenCPN before on the same machine.

Short version: Try to delete the config files.

Long version if you don't know how to do it: Go to OpenCPN General
and read my discussion with Joshua1 leading him to do it...

Pavel
nohal is offline   Reply With Quote
Old 24-03-2011, 06:47   #9
Registered User

Join Date: Mar 2011
Posts: 3
Re: OpenCPN Fails to Start

Thanks for the follow up. Yes, I had followed that thread. Renamed the .ini file. No difference. I was actually surprised to find it there because I thought that I had checked the box to delete it when installing v2. I have gone back and forth a number of times, so perhaps I didn't check that box this last re-install. Do the details of the failure give you any info. Or is there any additional info I can supply?
Dragonfly1 is offline   Reply With Quote
Old 24-03-2011, 06:56   #10
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 5,226
Re: OpenCPN Fails to Start

The installer is not always as smart as we would like it to be... If you did rename just the ini file, try to get rid of all the content in the config folder. That the crash follows the first dialog probably means, that the problem is somewhere there, being it reading or upgrading the chart database or something similar. A look at the end of the logfile could also give you some more info.

Pavel
nohal is offline   Reply With Quote
Old 24-03-2011, 07:05   #11
Registered User

Join Date: Mar 2011
Posts: 3
Re: OpenCPN Fails to Start

Fixed it. I renamed the CHRTLIST.DAT file. The log was the key. Apparently the program was trying to open a corrupt chart.

Here is the log file, in case it can help you with other problems.


09:37:41: 2011-03-24
09:37:41: -------Starting opencpn-------
09:37:41: Version 2.3.1 Build 2010-12-28
09:37:41: SData_Locn is C:\Program Files\OpenCPN\
09:37:41: Creating new Config_File: C:\ProgramData\opencpn\opencpn.ini
09:37:41: Setting Viewpoint Lat/Lon 33.358, -79.282
09:37:41: Setting Ownship Lat/Lon 33.358, -79.282
09:37:41: System default Language: en_US
9:37:41 AM: Opencpn language set to: en_US
9:37:41 AM: looking for catalog 'opencpn' in path 'C:\Program Files\OpenCPN\share/locale\en_US.WINDOWS-1252\LC_MESSAGES;C:\Program Files\OpenCPN\share/locale\;C:\Program Files\OpenCPN\share/locale\en_US.WINDOWS-1252;C:\Program Files\OpenCPN\en_US.WINDOWS-1252;C:\Program Files\OpenCPN\share/locale\en_US\LC_MESSAGES;C:\Program Files\OpenCPN\share/locale\;C:\Program Files\OpenCPN\share/locale\en_US;C:\Program Files\OpenCPN\en_US;C:\Program Files\OpenCPN\share/locale\en\LC_MESSAGES;C:\Program Files\OpenCPN\share/locale\;C:\Program Files\OpenCPN\share/locale\en;C:\Program Files\OpenCPN\en'.
9:37:41 AM: catalog file for domain 'opencpn' not found.
9:37:43 AM: Using s57data in C:\Program Files\OpenCPN\s57data
9:37:43 AM: Using Tide/Current data from: C:\Program Files\OpenCPN\tcdata\
9:37:43 AM: Setting Viewpoint Lat/Lon 33.358, -79.282
9:37:43 AM: Setting Ownship Lat/Lon 33.358, -79.282
9:37:43 AM: NMEA Data Source is....AIS Port (Shared)
9:37:43 AM: AIS Data Source is....NONE
9:37:43 AM: Using WVSChart datafile: C:\Program Files\OpenCPN\wvsdata\wvs43.dat
9:37:43 AM: NMEA AutoPilot Port is....NONE
9:37:43 AM: PlugInManager searching for PlugIns in location C:\Program Files\OpenCPN\plugins
9:37:43 AM: PlugInManager: Loading PlugIn: C:\Program Files\OpenCPN\plugins/dashboard_pi.dll
9:37:43 AM: PlugInManager: Loading PlugIn: C:\Program Files\OpenCPN\plugins/grib_pi.dll
9:37:43 AM: Warning: found incorrect chart db version: V015
9:37:43 AM: Scheduling db upgrade to current db version on Toolbox->Charts page visit...
9:37:43 AM: Chartdb: Chart directory list follows
9:37:43 AM: Chart directory #0: E:\Charts\Charts East Coast, North GOM
9:37:43 AM: Chart directory #1: E:\Charts\Recent Downloaded cm93 Charts\CM93_ed2_May_2009\CM93ed2_2008
Dragonfly1 is offline   Reply With Quote
Old 24-03-2011, 08:44   #12
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 5,635
Re: OpenCPN Fails to Start

Hello...

I note that this relates to FS#370, which was reported on Mac builds.
We fail on a scheduled update from chart database version V015.

Evidently this is a more pervasive problem, and will be escalated.

Thanks
Dave
bdbcat is offline   Reply With Quote
Old 17-04-2011, 04:57   #13
Registered User
 
SariTimur's Avatar

Join Date: Oct 2008
Location: Seward, Alaska
Boat: William Garden Ketch
Posts: 172
Re: OpenCPN Fails to Start

I am having similar problems. I downloaded 2.3.1 to a windows 7, 32 bit machine. It seemed to load everything ok but will not start. I downloaded the xcredist_x86 file and ran it but still no luck. I am sure this is finger trouble on my side as it is a band new machine and I am learning W7 as I go.

So some idiot checks for me would be nice. Also I seem to remember reading somewhere I need to load a dongle. I have not done this or found out how to. Could this be my problem?

Cheers

Mark
SariTimur is offline   Reply With Quote
Old 17-04-2011, 05:02   #14
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 5,226
Re: OpenCPN Fails to Start

Mark,
no "dongle" is needed, whatever it is Do you get some error message when trying to start the program?

Pavel
nohal is offline   Reply With Quote
Old 17-04-2011, 05:58   #15
Registered User

Join Date: Dec 2005
Location: Helsingborg
Boat: Dufour 35
Posts: 3,569
Re: OpenCPN Fails to Start

Quote:
Originally Posted by SariTimur View Post
I am having similar problems. I downloaded 2.3.1 to a windows 7, 32 bit machine. It seemed to load everything ok but will not start. I downloaded the xcredist_x86 file and ran it but still no luck. I am sure this is finger trouble on my side as it is a band new machine and I am learning W7 as I go.

So some idiot checks for me would be nice. Also I seem to remember reading somewhere I need to load a dongle. I have not done this or found out how to. Could this be my problem?

Cheers

Mark
Mark
Your logfile would be interesting, if there is one. It is a hidden file, but if you paste this
Quote:
C:\ProgramData\opencpn
into the file browsers location bar, you should be right. If the file opencpn.log
exists, please post it here.

Thomas
__________________

cagney is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Challenge: Depth Sounder Fails, but Only when Engine Is Running Cat-a-tonic Challenges 8 25-07-2011 11:32
Where to Start . . . ? jenanddave Off Topic Forum 9 16-07-2010 08:18
Where to Start ? barry2010 Meets & Greets 6 27-06-2010 00:04
Start from Zero qalinx Dollars & Cents 16 16-06-2010 20:43
Where Do I Start? Rick Iverson Meets & Greets 16 08-02-2010 15:27



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 07:15.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.