Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 22-02-2014, 00:21   #1
Registered User
 
GREENGHOST's Avatar

Join Date: Feb 2014
Location: Canucks in Africa, crossing Atlantic for Carib
Boat: Vancouver 42
Posts: 4
OpenCPN does not see STM32 virtual port in MAC OSX

Hello All,

I am running a MacBook Pro with windows 7 and Mac OSX.

I have OpenCPN installed in each operating system.

I have a SiTex AIS Transceiver with built in GPS and a USB output for the NMEA strings.

The SiTex AIS comes bundled with ProAIS software used to connect to the AIS for setup and to check you GPS satellites and AIS targets.

ProAIS works fine on MAC OSX and I can connect to the AIS when i plug in the USB output. It recognises and sees the STM32 virtual com port.

I have also successfully connected OpenCPN on the windows OS to the AIS/GPS and use it for navigation and AIS plotting.

However, on the MAC OSX, OpenCPN does not see the STM32 VirtualCom port. OpenCPN sees the STM32 virtual port in windows but not in Mac. So this leads me to believe there is a bug or some issue with how MAC OSX and OpenCPN work together to recognise the STM32 virtual port.

ProAIS running on the Mac OSX sees the STM32 Virtual com port just fine so I know USB connection works and is transferring all the pertinent NMEA strings.

Has anyone else come across this and figured out a way to fix it?

I have tried rebooting the AIS,
I have plugged the AIS in before starting OpenCPN
I have plugged the AIS in after starting OpenCPN
Nothing triggers OpenCPN to see the stm32 virtual port.
I have ensured that I do a software disconnect on Pro AIS so that there is no chance that the resource is being used by ProAIS and is not available to Open CPN.
I have also checked in Network Utilities and the STM32 port is listed but interestingly it never registers as being connected - even when connected to PROAIS.

I am using OpenCPN version 3.2.2

I look forward to hearing words of wisdom to help me solve this issue.

Thanks from Nik in South Africa about to head to the Caribbean.
__________________

__________________
GREENGHOST is offline   Reply With Quote
Old 22-02-2014, 03:36   #2
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,777
Re: OpenCPN does not see STM32 virtual port in MAC OSX

How do you use Win7 and OS X on your MacBook?
Either Boot Camp or Parallels or VMware Fusion are possible.
Boot Camp only allows to run one OS at a time while Parallels or Fusion can run several OS at the same time.

It might be possible to configure the OS that an external device will always connect to one OS only (either Win7 or OS X). Another way of configuration is that you will be asked which OS to connect the external device once its connector is attached.

Gerhard
__________________

__________________
CarCode is online now   Reply With Quote
Old 22-02-2014, 08:04   #3
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN does not see STM32 virtual port in MAC OSX

Nik...

We have never seen this environment/device before. (STM32 on OSx)

May we see the OpenCPN logfile? Anything at all in there about the STM32 port/driver?

Thanks
Dave
__________________
bdbcat is offline   Reply With Quote
Old 22-02-2014, 08:25   #4
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,777
Re: OpenCPN does not see STM32 virtual port in MAC OSX

To see which ports are available for OS X open the terminal and type in this command:
Code:
ls /dev/cu*
If your driver is on the list you can configure it as serial port in OpenCPN connection settings.

Gerhard
__________________
CarCode is online now   Reply With Quote
Old 23-02-2014, 13:16   #5
Registered User
 
GREENGHOST's Avatar

Join Date: Feb 2014
Location: Canucks in Africa, crossing Atlantic for Carib
Boat: Vancouver 42
Posts: 4
Re: OpenCPN does not see STM32 virtual port in MAC OSX

Hello Gerhard,
Thank you for getting back to me.

I use Parallels to run MAC OSX and Windows at the same time. When I do, I have no problems connecting the AIS into OPEN CPN running on the windows OS. Windows recognises the STM32 virtual com port and off I go.

Now, I am NOT running windows and only the running MAC OSX however here OPEN CPN does NOT see the STM 32 virtual com port.

Also - that was good advice on looking in terminal here are the results of that suggestion:

Last login: Sun Feb 23 21:56:50 on ttys000
Macintosh:~ admin$ ls /dev/cu*
/dev/cu.Bluetooth-Modem /dev/cu.Bluetooth-Serial-2
/dev/cu.Bluetooth-PDA-Sync /dev/cu.usbmodemfd131
/dev/cu.Bluetooth-Serial-1
Macintosh:~ admin$

So the device is not listed in this search.

Ive attached two screen captures showing you what I see in Open CPN and what I see when I look at USB devices in the system information report

However, the strange this is that the software that is bundled with the SiTEX AIS has no problem seeing and connecting to the STM32 virtual port.

I am really delving into the unknown here. I have no idea.

Let me know if you have any ideas. I will reply to Dave and attach the OPEN CPN Log file. We'll see it that sees the port.

Thanks in advance,

Nik.
Attached Thumbnails
Click image for larger version

Name:	OPEN CPN Options for connection ports.png
Views:	181
Size:	41.0 KB
ID:	76624   Click image for larger version

Name:	System Info Report with USB Devices.png
Views:	222
Size:	81.3 KB
ID:	76625  

__________________
GREENGHOST is offline   Reply With Quote
Old 23-02-2014, 13:30   #6
Registered User
 
GREENGHOST's Avatar

Join Date: Feb 2014
Location: Canucks in Africa, crossing Atlantic for Carib
Boat: Vancouver 42
Posts: 4
Re: OpenCPN does not see STM32 virtual port in MAC OSX

Hi Dave,

Thanks for the suggestion

Here is the opencpn log file:

I might go at look at the config ini file ( will first have to make the library visible) because the nice people at Apple did want to let people see under the hood. But I suspect there won't be anything I see that I can tinker with in there.

Let me know if there is anything you see the log that is of interest.

I have a feeling that somehow, the way OPEN CPN scan ports and the way this STM 32 port works doesn't allow them to see each other. Works in windows just fine.

Thanks in advance.


Nik.





________

21:43:10 SAST: 2014-02-23
21:43:10 SAST: ------- Starting OpenCPN -------
21:43:10 SAST: Version 3.2.2 Build 2013-05-08
21:43:10 SAST: wxWidgets version: wxWidgets 2.8.12
21:43:10 SAST: MemoryStatus: mem_total: 0 mb, mem_initial: 0 mb
21:43:10 SAST: SData_Locn is /Applications/OpenCPN.app/Contents/SharedSupport/
21:43:10 SAST: Using existing Config_File: /Users/admin/Library/Preferences/opencpn.ini
21:43:10 SAST: Styles loading from /Applications/OpenCPN.app/Contents/SharedSupport/uidata/styles.xml
21:43:10 SAST: No styles found at: /Users/admin/Library/Preferences/opencpn/
21:43:10 SAST: No styles found at: /Users/admin/Library/Preferences/opencpn/.opencpn/
21:43:10 SAST: Setting Viewpoint Lat/Lon -33.9038, 18.4443
21:43:10 SAST: Setting Ownship Lat/Lon 0, 0
21:43:10 SAST: System default Language: en_US
21:43:10 SAST: Opencpn language set to: en_US
21:43:11 SAST: ChartSymbols loaded from /Applications/OpenCPN.app/Contents/SharedSupport/s57data/chartsymbols.xml
21:43:11 SAST: Using s57data in /Applications/OpenCPN.app/Contents/SharedSupport/s57data
21:43:11 SAST: Setting Viewpoint Lat/Lon -33.9038, 18.4443
21:43:11 SAST: Setting Ownship Lat/Lon 0, 0
21:43:11 SAST: Opening NMEA Datastream Serial:STM32 Virtual COM Port
21:43:12 SAST: PlugInManager searching for PlugIns in location /Applications/OpenCPN.app/Contents/PlugIns
21:43:12 SAST: PlugInManager: Loading PlugIn: /Applications/OpenCPN.app/Contents/PlugIns/libdashboard_pi.dylib
21:43:12 SAST: /Applications/OpenCPN.app/Contents/PlugIns/libdashboard_pi.dylib Version detected: 106
21:43:12 SAST: PlugInManager: Loading PlugIn: /Applications/OpenCPN.app/Contents/PlugIns/libgrib_pi.dylib
21:43:12 SAST: /Applications/OpenCPN.app/Contents/PlugIns/libgrib_pi.dylib Version detected: 107
21:43:12 SAST: OpenGL-> Renderer String: NVIDIA GeForce GT 330M OpenGL Engine
21:43:12 SAST: OpenGL-> Framebuffer Objects unavailable
21:43:12 SAST: OpenGL-> Using Stencil buffer clipping
21:43:12 SAST: OpenGL-> Estimated Max Resident Textures: 98
21:43:12 SAST: ChartDB Cache policy: Max open chart limit is 20.
21:43:12 SAST: Loading chart db version: V017
21:43:12 SAST: Chartdb: Chart directory list follows
21:43:12 SAST: Chart directory #0: /Users/admin/Documents/CM93 2010
21:43:12 SAST: GPS Watchdog Timeout is: 6 sec.
21:43:12 SAST: Initializing Chart /Users/admin/Documents/CM93 2010
21:43:12 SAST: CM93Composite Chart Root is /Users/admin/Documents/CM93 2010/
21:43:12 SAST: Loaded CM93 Dictionary from /Users/admin/Documents/CM93 2010/
21:43:12 SAST: Loading CM93 cell /Users/admin/Documents/CM93 2010/01500000/D/01680054.D
21:48:01 SAST: PlugInManager: Deactivating PlugIn: /Applications/OpenCPN.app/Contents/PlugIns/libdashboard_pi.dylib
21:48:01 SAST: opencpn::MyFrame exiting cleanly.
21:48:01 SAST: Closing NMEA Datastream Serial:STM32 Virtual COM Port
21:48:01 SAST: Chart cache purge
21:48:01 SAST: PlugInManager: UnLoading PlugIn: /Applications/OpenCPN.app/Contents/PlugIns/libdashboard_pi.dylib
21:48:01 SAST: PlugInManager: UnLoading PlugIn: /Applications/OpenCPN.app/Contents/PlugIns/libgrib_pi.dylib
21:48:01 SAST: Chart cache purge
21:48:08 SAST:

________

21:48:08 SAST: 2014-02-23
21:48:08 SAST: ------- Starting OpenCPN -------
21:48:08 SAST: Version 3.2.2 Build 2013-05-08
21:48:08 SAST: wxWidgets version: wxWidgets 2.8.12
21:48:08 SAST: MemoryStatus: mem_total: 0 mb, mem_initial: 0 mb
21:48:08 SAST: SData_Locn is /Applications/OpenCPN.app/Contents/SharedSupport/
21:48:08 SAST: Using existing Config_File: /Users/admin/Library/Preferences/opencpn.ini
21:48:08 SAST: Styles loading from /Applications/OpenCPN.app/Contents/SharedSupport/uidata/styles.xml
21:48:08 SAST: No styles found at: /Users/admin/Library/Preferences/opencpn/
21:48:08 SAST: No styles found at: /Users/admin/Library/Preferences/opencpn/.opencpn/
21:48:08 SAST: Setting Viewpoint Lat/Lon -33.9038, 18.4443
21:48:08 SAST: Setting Ownship Lat/Lon 0, 0
21:48:08 SAST: System default Language: en_US
21:48:08 SAST: Opencpn language set to: en_US
21:48:08 SAST: ChartSymbols loaded from /Applications/OpenCPN.app/Contents/SharedSupport/s57data/chartsymbols.xml
21:48:08 SAST: Using s57data in /Applications/OpenCPN.app/Contents/SharedSupport/s57data
21:48:08 SAST: Setting Viewpoint Lat/Lon -33.9038, 18.4443
21:48:08 SAST: Setting Ownship Lat/Lon 0, 0
21:48:09 SAST: PlugInManager searching for PlugIns in location /Applications/OpenCPN.app/Contents/PlugIns
21:48:09 SAST: PlugInManager: Loading PlugIn: /Applications/OpenCPN.app/Contents/PlugIns/libdashboard_pi.dylib
21:48:09 SAST: /Applications/OpenCPN.app/Contents/PlugIns/libdashboard_pi.dylib Version detected: 106
21:48:09 SAST: PlugInManager: Loading PlugIn: /Applications/OpenCPN.app/Contents/PlugIns/libgrib_pi.dylib
21:48:09 SAST: /Applications/OpenCPN.app/Contents/PlugIns/libgrib_pi.dylib Version detected: 107
21:48:09 SAST: OpenGL-> Renderer String: NVIDIA GeForce GT 330M OpenGL Engine
21:48:09 SAST: OpenGL-> Framebuffer Objects unavailable
21:48:09 SAST: OpenGL-> Using Stencil buffer clipping
21:48:09 SAST: OpenGL-> Estimated Max Resident Textures: 98
21:48:09 SAST: ChartDB Cache policy: Max open chart limit is 20.
21:48:09 SAST: Loading chart db version: V017
21:48:09 SAST: Chartdb: Chart directory list follows
21:48:09 SAST: Chart directory #0: /Users/admin/Documents/CM93 2010
21:48:09 SAST: GPS Watchdog Timeout is: 6 sec.
21:48:09 SAST: Initializing Chart /Users/admin/Documents/CM93 2010
21:48:09 SAST: CM93Composite Chart Root is /Users/admin/Documents/CM93 2010/
21:48:09 SAST: Loaded CM93 Dictionary from /Users/admin/Documents/CM93 2010/
21:48:09 SAST: Loading CM93 cell /Users/admin/Documents/CM93 2010/01500000/D/01680054.D
21:48:51 SAST: PlugInManager: Deactivating PlugIn: /Applications/OpenCPN.app/Contents/PlugIns/libdashboard_pi.dylib
21:48:51 SAST: opencpn::MyFrame exiting cleanly.
21:48:51 SAST: Chart cache purge
21:48:51 SAST: PlugInManager: UnLoading PlugIn: /Applications/OpenCPN.app/Contents/PlugIns/libdashboard_pi.dylib
21:48:51 SAST: PlugInManager: UnLoading PlugIn: /Applications/OpenCPN.app/Contents/PlugIns/libgrib_pi.dylib
21:48:51 SAST: Chart cache purge
21:48:51 SAST: LOGBOOK: 2014-02-23 19:48:51 UTC OFF: Lat 0.00000 Lon 0.00000
21:48:51 SAST: opencpn::MyApp exiting cleanly...

21:55:44 SAST:

________

21:55:44 SAST: 2014-02-23
21:55:44 SAST: ------- Starting OpenCPN -------
21:55:44 SAST: Version 3.2.2 Build 2013-05-08
21:55:44 SAST: wxWidgets version: wxWidgets 2.8.12
21:55:44 SAST: MemoryStatus: mem_total: 0 mb, mem_initial: 0 mb
21:55:44 SAST: SData_Locn is /Applications/OpenCPN.app/Contents/SharedSupport/
21:55:44 SAST: Using existing Config_File: /Users/admin/Library/Preferences/opencpn.ini
21:55:44 SAST: Styles loading from /Applications/OpenCPN.app/Contents/SharedSupport/uidata/styles.xml
21:55:44 SAST: No styles found at: /Users/admin/Library/Preferences/opencpn/
21:55:44 SAST: No styles found at: /Users/admin/Library/Preferences/opencpn/.opencpn/
21:55:44 SAST: Setting Viewpoint Lat/Lon -33.9038, 18.4443
21:55:44 SAST: Setting Ownship Lat/Lon 0, 0
21:55:44 SAST: System default Language: en_US
21:55:44 SAST: Opencpn language set to: en_US
21:55:44 SAST: ChartSymbols loaded from /Applications/OpenCPN.app/Contents/SharedSupport/s57data/chartsymbols.xml
21:55:44 SAST: Using s57data in /Applications/OpenCPN.app/Contents/SharedSupport/s57data
21:55:44 SAST: Setting Viewpoint Lat/Lon -33.9038, 18.4443
21:55:44 SAST: Setting Ownship Lat/Lon 0, 0
21:55:45 SAST: PlugInManager searching for PlugIns in location /Applications/OpenCPN.app/Contents/PlugIns
21:55:45 SAST: PlugInManager: Loading PlugIn: /Applications/OpenCPN.app/Contents/PlugIns/libdashboard_pi.dylib
21:55:45 SAST: /Applications/OpenCPN.app/Contents/PlugIns/libdashboard_pi.dylib Version detected: 106
21:55:45 SAST: PlugInManager: Loading PlugIn: /Applications/OpenCPN.app/Contents/PlugIns/libgrib_pi.dylib
21:55:45 SAST: /Applications/OpenCPN.app/Contents/PlugIns/libgrib_pi.dylib Version detected: 107
21:55:45 SAST: OpenGL-> Renderer String: NVIDIA GeForce GT 330M OpenGL Engine
21:55:45 SAST: OpenGL-> Framebuffer Objects unavailable
21:55:45 SAST: OpenGL-> Using Stencil buffer clipping
21:55:45 SAST: OpenGL-> Estimated Max Resident Textures: 98
21:55:45 SAST: ChartDB Cache policy: Max open chart limit is 20.
21:55:45 SAST: Loading chart db version: V017
21:55:45 SAST: Chartdb: Chart directory list follows
21:55:45 SAST: Chart directory #0: /Users/admin/Documents/CM93 2010
21:55:45 SAST: GPS Watchdog Timeout is: 6 sec.
21:55:45 SAST: Initializing Chart /Users/admin/Documents/CM93 2010
21:55:45 SAST: CM93Composite Chart Root is /Users/admin/Documents/CM93 2010/
21:55:45 SAST: Loaded CM93 Dictionary from /Users/admin/Documents/CM93 2010/
21:55:45 SAST: Loading CM93 cell /Users/admin/Documents/CM93 2010/01500000/D/01680054.D
21:56:45 SAST: LOGBOOK: 2014-02-23 19:56:45 UTC DR Lat 0.00000 Lon 0.00000
21:57:35 SAST: Got quitflag from SIGUSR1
21:57:35 SAST: PlugInManager: Deactivating PlugIn: /Applications/OpenCPN.app/Contents/PlugIns/libdashboard_pi.dylib
21:57:35 SAST: opencpn::MyFrame exiting cleanly.
21:57:35 SAST: Chart cache purge
21:57:35 SAST: PlugInManager: UnLoading PlugIn: /Applications/OpenCPN.app/Contents/PlugIns/libdashboard_pi.dylib
21:57:35 SAST: PlugInManager: UnLoading PlugIn: /Applications/OpenCPN.app/Contents/PlugIns/libgrib_pi.dylib
21:57:35 SAST: Chart cache purge
21:57:35 SAST: LOGBOOK: 2014-02-23 19:57:35 UTC OFF: Lat 0.00000 Lon 0.00000
21:57:35 SAST: opencpn::MyApp exiting cleanly...

22:16:36 SAST:

________

22:16:36 SAST: 2014-02-23
22:16:36 SAST: ------- Starting OpenCPN -------
22:16:36 SAST: Version 3.2.2 Build 2013-05-08
22:16:36 SAST: wxWidgets version: wxWidgets 2.8.12
22:16:36 SAST: MemoryStatus: mem_total: 0 mb, mem_initial: 0 mb
22:16:36 SAST: SData_Locn is /Applications/OpenCPN.app/Contents/SharedSupport/
22:16:36 SAST: Using existing Config_File: /Users/admin/Library/Preferences/opencpn.ini
22:16:36 SAST: Styles loading from /Applications/OpenCPN.app/Contents/SharedSupport/uidata/styles.xml
22:16:36 SAST: No styles found at: /Users/admin/Library/Preferences/opencpn/
22:16:36 SAST: No styles found at: /Users/admin/Library/Preferences/opencpn/.opencpn/
22:16:36 SAST: Setting Viewpoint Lat/Lon -33.9038, 18.4443
22:16:36 SAST: Setting Ownship Lat/Lon 0, 0
22:16:36 SAST: System default Language: en_US
22:16:36 SAST: Opencpn language set to: en_US
22:16:36 SAST: ChartSymbols loaded from /Applications/OpenCPN.app/Contents/SharedSupport/s57data/chartsymbols.xml
22:16:36 SAST: Using s57data in /Applications/OpenCPN.app/Contents/SharedSupport/s57data
22:16:36 SAST: Setting Viewpoint Lat/Lon -33.9038, 18.4443
22:16:36 SAST: Setting Ownship Lat/Lon 0, 0
22:16:37 SAST: PlugInManager searching for PlugIns in location /Applications/OpenCPN.app/Contents/PlugIns
22:16:37 SAST: PlugInManager: Loading PlugIn: /Applications/OpenCPN.app/Contents/PlugIns/libdashboard_pi.dylib
22:16:37 SAST: /Applications/OpenCPN.app/Contents/PlugIns/libdashboard_pi.dylib Version detected: 106
22:16:37 SAST: PlugInManager: Loading PlugIn: /Applications/OpenCPN.app/Contents/PlugIns/libgrib_pi.dylib
22:16:37 SAST: /Applications/OpenCPN.app/Contents/PlugIns/libgrib_pi.dylib Version detected: 107
22:16:37 SAST: OpenGL-> Renderer String: NVIDIA GeForce GT 330M OpenGL Engine
22:16:37 SAST: OpenGL-> Framebuffer Objects unavailable
22:16:37 SAST: OpenGL-> Using Stencil buffer clipping
22:16:37 SAST: OpenGL-> Estimated Max Resident Textures: 98
22:16:37 SAST: ChartDB Cache policy: Max open chart limit is 20.
22:16:37 SAST: Loading chart db version: V017
22:16:37 SAST: Chartdb: Chart directory list follows
22:16:37 SAST: Chart directory #0: /Users/admin/Documents/CM93 2010
22:16:37 SAST: GPS Watchdog Timeout is: 6 sec.
22:16:37 SAST: Initializing Chart /Users/admin/Documents/CM93 2010
22:16:37 SAST: CM93Composite Chart Root is /Users/admin/Documents/CM93 2010/
22:16:37 SAST: Loaded CM93 Dictionary from /Users/admin/Documents/CM93 2010/
22:16:37 SAST: Loading CM93 cell /Users/admin/Documents/CM93 2010/01500000/D/01680054.D
__________________
GREENGHOST is offline   Reply With Quote
Old 23-02-2014, 14:37   #7
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,777
Re: OpenCPN does not see STM32 virtual port in MAC OSX

Greenghost,

I have not found a driver for your device for Mac OS X. There is only a driver for Windows at: STSW-STM32102 STM32 Virtual COM Port Driver - STMicroelectronics

The doc say:

/******************** (C) COPYRIGHT 2010 STMicroelectronics ********************
* File Name : readme.txt
* Author : MCD Application Team
* Version : V1.3.1
* Date : 07/23/2010
* Description : read me file for Virtual COM Port driver
************************************************** ******************************
* THE PRESENT SOFTWARE WHICH IS FOR GUIDANCE ONLY AIMS AT PROVIDING CUSTOMERS
* WITH CODING INFORMATION REGARDING THEIR PRODUCTS IN ORDER FOR THEM TO SAVE TIME.
* AS A RESULT, STMICROELECTRONICS SHALL NOT BE HELD LIABLE FOR ANY DIRECT,
* INDIRECT OR CONSEQUENTIAL DAMAGES WITH RESPECT TO ANY CLAIMS ARISING FROM THE
* CONTENT OF SUCH SOFTWARE AND/OR THE USE MADE BY CUSTOMERS OF THE CODING
* INFORMATION CONTAINED HEREIN IN CONNECTION WITH THEIR PRODUCTS.
************************************************** *****************************/

Last version
***************

- V1.3.1 - 07/23/2010


Supported OS
***************

+ Windows 98SE, 2000, XP, Vista, Seven (x86 & x64 Windows platforms)

How to use
***************

1- Uninstall previous versions (Start-> Settings-> Control Panel-> Add or remove programs)

2- run setup.

******************* (C) COPYRIGHT 2010 STMicroelectronics *****END OF FILE******

OpenCPN does not support direct USB but only COM Ports.
Some people on the net reports however that the STM32 virtual com port works with Mavericks (OS X 10.9) without any further driver.

Gerhard
__________________
CarCode is online now   Reply With Quote
Old 23-02-2014, 20:15   #8
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN does not see STM32 virtual port in MAC OSX

Gerhard....

So maybe on Mavericks the STM32 comes up as some accessible /dev/cu* port?

Dave
__________________
bdbcat is offline   Reply With Quote
Old 24-02-2014, 01:58   #9
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,777
Re: OpenCPN does not see STM32 virtual port in MAC OSX

Quote:
Originally Posted by bdbcat View Post
Gerhard....

So maybe on Mavericks the STM32 comes up as some accessible /dev/cu* port?

Dave
Dave,
I really don't know, I haven't searched further in the OS and only found some people saying in the net that this chip is supported by Mavericks.
Gerhard
__________________
CarCode is online now   Reply With Quote
Old 24-02-2014, 13:40   #10
Registered User
 
GREENGHOST's Avatar

Join Date: Feb 2014
Location: Canucks in Africa, crossing Atlantic for Carib
Boat: Vancouver 42
Posts: 4
Re: OpenCPN does not see STM32 virtual port in MAC OSX

Hi all,

So tried this: I just typed in the name of the STM32 Port into the drop down menu in Open CPN and it did work for about 5 seconds and then stops. So i got a ship position plotted and some AIS targets. But then it went black and no more communications would happen.

I don't understand why it would stop communicating. I've tried this a few types and I get sporadic communications and ship plots.

I wonder if the guys at OPEN CPN now about this.

I will not be upgrading to Mavericks on eve of an Atlantic Crossing. To many other potential things to go wrong if I do that.
__________________

__________________
GREENGHOST is offline   Reply With Quote
Reply

Tags
enc, opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 11:50.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.