Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-08-2015, 07:36   #1
Registered User

Join Date: Aug 2008
Location: S Devon, UK
Boat: Woods Sagitta 9m
Posts: 80
OpenCPN, com ports, autohelm - help please?

Hi,

Can someone help me get my laptop running OpenCPN to connect to my Autohelm S2000+ so that I can send a route to the Autohelm and have it run in track mode?

I have a couple of things already connected to the laptop via USB - a depth sounder and an AIS. I use a USB hub, and these things have been working fine for years. So I've tried adding a new USB connection from the hub to the Autohelm. I've cut the end of the USB cable and connected the red and black wires to a length of two-core that runs to the Autohelm deck fitting. The two core connects to sockets 5 and 6 in the Autohelm deck connection, as instructed in the Autohelm manual.

I get 5v or so across these wires.

When I first connected the Autohelm and switched on, a new com port appeared in Device Manager (com3), and right clicking on an active route in OpenCPN gave me the option of sending the route to the Autohelm. I tried that. The Autohelm display showed a 't' and the course, and then the bunch of symbols the manual tells me means 'Track data not received'.

A further attempt later crashed OpenCPN, and when checking in Device Manager for com3 I could see it only when I clicked on 'Show hidden devices'. I've tried uninstalling com3, hoping switching on the Autohelm while it was connected to the laptop would result in the recreation of the com port, but that didn't work.

Any advice would be most welcome.

Thanks,

John Pedersen
__________________

__________________
pir8ped is offline   Reply With Quote
Old 05-08-2015, 07:53   #2
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,761
Re: OpenCPN, com ports, autohelm - help please?

Your OS (Windows ?) and the version of OCPN your using?
__________________

__________________
bcn is offline   Reply With Quote
Old 05-08-2015, 07:57   #3
Registered User

Join Date: Aug 2008
Location: S Devon, UK
Boat: Woods Sagitta 9m
Posts: 80
Re: OpenCPN, com ports, autohelm - help please?

Sorry, windows 7 and opencpn 4.0.0
__________________
pir8ped is offline   Reply With Quote
Old 05-08-2015, 08:00   #4
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,761
Re: OpenCPN, com ports, autohelm - help please?

Next would be the OCPN log file. You can try with the USB attached and without to see what OCPN sees.
__________________
bcn is offline   Reply With Quote
Old 05-08-2015, 09:34   #5
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 1,967
Re: OpenCPN, com ports, autohelm - help please?

John
If you have the AP 2000 I think the advised socket connections, NMEA+/NMEA-, is not an USB connection but a (old fashioned?) serial RS232. To connect it to your PC's USB you need a "serial to USB" converter (or if you (unlikely) happens to have a serial port on the PC use that (pin 3 and 5)).
Please revert if you need more details.
Håkan
__________________
Hakan is offline   Reply With Quote
Old 05-08-2015, 09:41   #6
Registered User

Join Date: Aug 2008
Location: S Devon, UK
Boat: Woods Sagitta 9m
Posts: 80
Re: OpenCPN, com ports, autohelm - help please?

I've just left the boat, before I got your message suggesting trying with and without the USB connected.

But attached is today's log from OpenCpn. I see the program 'thinks' it is sending data to the Autohelm. I don't know if there is any handshaking or feedback involved so that openCpn 'knows' whether the data has been received.

I'll try what you asked when I get back to the boat.

Thanks,

John

(I haven't attached a file on this forum before. Just today's log file is 23 kb, and I get a message saying the limit for a txt file is 1 kb... seems a very small limit?)
__________________
pir8ped is offline   Reply With Quote
Old 05-08-2015, 09:43   #7
Registered User

Join Date: Aug 2008
Location: S Devon, UK
Boat: Woods Sagitta 9m
Posts: 80
Re: OpenCPN, com ports, autohelm - help please?

Hakan,

That sounds like a good lead. My depth sounder is attached to the laptop via a serial to USB converter. I'll take another look at that and try what you've suggested.

Thanks very much.

John
__________________
pir8ped is offline   Reply With Quote
Old 05-08-2015, 10:32   #8
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,761
Re: OpenCPN, com ports, autohelm - help please?

Rename the log to .doc before uploading. Does accept larger files then.
__________________
bcn is offline   Reply With Quote
Old 05-08-2015, 11:44   #9
Registered User

Join Date: Aug 2008
Location: S Devon, UK
Boat: Woods Sagitta 9m
Posts: 80
Re: OpenCPN, com ports, autohelm - help please?

OK, hopefully I've attached the file OK.
Attached Files
File Type: doc opencpn_today_log.doc (22.2 KB, 29 views)
__________________
pir8ped is offline   Reply With Quote
Old 20-08-2015, 03:02   #10
Registered User

Join Date: Aug 2008
Location: S Devon, UK
Boat: Woods Sagitta 9m
Posts: 80
Re: OpenCPN, com ports, autohelm - help please?

Sorry about the time lapse - I've been sailing.

I'm still unable to send a route to my AP.

I have fitted a usb to serial adapter, and connected pin 3 to the NMEA+ and pin 5 to NMEA-.

The USB to serial adapter is installed on com9, and seems to be working fine.

However, when I try to send a route from opencpn to the AP, I get a message on the AP screen saying that no data has been received.

Looking in the opencpn log, I can see that data has been sent through com9, but the NMEA sentences start with either ECWPL or ECRTE. These are the only sentences sent.

According to my Autohelm 2000 manual, these sentences are not recognised by the AP. (There is a list of the recognised sentences on page 47 of the manual).

In opencpn, in the properties section for com9, I have ticked the box marked 'output on this port (as autopilot or NMEA repeater).

Any suggestions?

Thanks.
__________________
pir8ped is offline   Reply With Quote
Old 20-08-2015, 03:30   #11
Sponsoring Vendor
 
Neptune's Gear's Avatar

Community Sponsor

Join Date: Oct 2012
Location: Gulf Harbour, New Zealand
Boat: Farr Phase 4, 12.8m
Posts: 992
Re: OpenCPN, com ports, autohelm - help please?

Serial data needs to have the baud rate, and other parameters set correctly to allow the connection to be successful. Standard NMEA0183 is 4800, 8,N,1
Check the AP manual to get the required parameters, otherwise use those above. You can set the speed - baud rate - in opencpn, but the rest should be set in windows.
__________________
Matt Paulin
Neptunes Gear Ltd
www.neptunes-gear.com
Neptune's Gear is offline   Reply With Quote
Old 20-08-2015, 06:41   #12
Registered User

Join Date: Aug 2008
Location: S Devon, UK
Boat: Woods Sagitta 9m
Posts: 80
Re: OpenCPN, com ports, autohelm - help please?

I have the baud rate set as you've suggested. I don't think this is the problem.

What about the NMEA sentences? It looks like opencpn is sending only sentences that the AP doesn't handle.

Have other people succeeded in getting opencpn working with an Autohelm ST2000?

Thanks.
__________________
pir8ped is offline   Reply With Quote
Old 20-08-2015, 09:10   #13
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 1,967
Re: OpenCPN, com ports, autohelm - help please?

pirSped...
I'm not sure the AP can handle a route. I suppose you want to follow a route made in OCPN? In that case the method is to activate the route in OCPN. Then O will start to send data for next WP to navigate to. Once received your AP will understand these NMEA messages that O will send.
When the route is activated in OCPN put your AP in automatic or manual track mode as described in your manual page 15.
Whether your AP will understand the course change after a WP is received and continue to next I don't know. Maybe you have to acknowledge the course change, as I have to do with my, WP30, AP.
Good luck/Håkan
__________________
Hakan is offline   Reply With Quote
Old 30-08-2015, 18:38   #14
Registered User

Join Date: Mar 2013
Posts: 28
Re: OpenCPN, com ports, autohelm - help please?

Quote:
Originally Posted by pir8ped View Post
Looking in the opencpn log, I can see that data has been sent through com9, but the NMEA sentences start with either ECWPL or ECRTE. These are the only sentences sent.
That won't work with an old autopilot. Usually **APB sentence works best.

/Marcus
__________________

__________________
Shipraiser is offline   Reply With Quote
Reply

Tags
autohelm, enc, helm, lease, opencpn, ports

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacing Ports with New Found Metals Ports Papa Joe Construction, Maintenance & Refit 10 04-06-2016 15:34
Sending Routes to serial ports OPENCPN moteje OpenCPN 1 26-09-2013 05:25
Want To Buy: Z075 Autohelm Navigation Interface for Autohelm 3000 Murat Akturk Classifieds Archive 1 26-10-2011 01:00
Need Help Finding Gaskets for Ports sobound2 Construction, Maintenance & Refit 1 09-10-2011 21:54
For Sale: (4) 6" x 12" Opening Ports and (2) 6" x 12" Fixed Ports captsam54 Classifieds Archive 7 03-08-2011 08:01



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 22:53.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.