Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 31-08-2014, 10:31   #136
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,020
Re: OpenCPN Beta Version 3.3.1931 Released

Dave...
Funny behavior - The exactly horizontal and vertical fine lines are not drawn in OpenGL on my aging Intel GPU:

Code:
10:55:02 CDT: OpenGL-> Renderer String: Mesa DRI Intel(R) Ironlake Mobile
10:55:02 CDT: OpenGL-> Detected Intel renderer, disabling stencil buffer
10:55:02 CDT: OpenGL-> Texture rectangle format: de1
10:55:02 CDT: OpenGL-> Using Vertexbuffer Objects
10:55:02 CDT: OpenGL-> Using Framebuffer Objects
10:55:02 CDT: OpenGL-> Using FBO Stencil buffer
10:55:02 CDT: OpenGL-> Using Depth buffer clipping
10:55:02 CDT: OpenGL-> Using s3tc dxt1 compression
10:55:02 CDT: OpenGL-> Compressed tile size: 128kb (6:1)
Do we have some better option than
Code:
diff --git a/src/ais.cpp b/src/ais.cpp
index fffce35..5362f71 100644
--- a/src/ais.cpp
+++ b/src/ais.cpp
@@ -1134,6 +1134,8 @@ static void AISDrawTarget( AIS_Target_Data *td, ocpnDC& dc )
 
             if (g_bDrawAISSize && bcan_draw_size)
             {
+                wxPen target_pen( GetGlobalColor( _T ( "UBLCK" ) ), 2 );
+                dc.SetPen( target_pen );
                 dc.SetBrush( wxBrush( GetGlobalColor( _T ( "UBLCK" ) ), wxTRANSPARENT ) );
                 dc.StrokePolygon( 6, ais_real_size, TargetPoint.x, TargetPoint.y );
             }
and alike in other affected places?

Pavel
Attached Thumbnails
Click image for larger version

Name:	Screenshot from 2014-08-31 11:02:37.png
Views:	210
Size:	11.1 KB
ID:	87471  
__________________

__________________
nohal is offline   Reply With Quote
Old 31-08-2014, 10:45   #137
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,769
Re: OpenCPN Beta Version 3.3.1931 Released

Building on ARM (7c81663..a604785) fails with

Code:
CMakeFiles/opencpn.dir/src/chart1.cpp.o: In function `MyApp::OnExit()':
/root/GitOpenCPN/OpenCPN/src/chart1.cpp:2440: undefined reference to `FontMgr::Shutdown()'
CMakeFiles/opencpn.dir/src/chartdbs.cpp.o: In function `ChartTableEntry':
/root/GitOpenCPN/OpenCPN/src/chartdbs.cpp:221: undefined reference to `DouglasPeucker(double*, int, int, double, wxArrayInt*)'
/root/GitOpenCPN/OpenCPN/src/chartdbs.cpp:312: undefined reference to `DouglasPeucker(double*, int, int, double, wxArrayInt*)'
CMakeFiles/opencpn.dir/src/chcanv.cpp.o: In function `ChartCanvas::OnPaint(wxPaintEvent&)':
/root/GitOpenCPN/OpenCPN/src/chcanv.cpp:8779: undefined reference to `OCPNRegion::GetNew_wxRegion()'
CMakeFiles/opencpn.dir/src/glChartCanvas.cpp.o: In function `glChartCanvas::FactoryCrunch(double)':
/root/GitOpenCPN/OpenCPN/src/glChartCanvas.cpp:2716: undefined reference to `glTexFactory::FreeSome(long)'
libS57ENC.a(s57chart.cpp.o): In function `S57Obj':
/root/GitOpenCPN/OpenCPN/src/s57chart.cpp:704: undefined reference to `PolyTessGeo::PolyTessGeo(unsigned char*, int, int, int)'
libS57ENC.a(s57chart.cpp.o): In function `s57chart::CreateSENCRecord(OGRFeature*, _IO_FILE*, int, S57Reader*)':
/root/GitOpenCPN/OpenCPN/src/s57chart.cpp:5673: undefined reference to `PolyTessGeo::PolyTessGeo(OGRPolygon*, bool, double, double, bool, double)'
/root/GitOpenCPN/OpenCPN/src/s57chart.cpp:5684: undefined reference to `PolyTessGeo::PolyTessGeo(OGRPolygon*, bool, double, double, bool, double)'
libS57ENC.a(s57chart.cpp.o): In function `s57chart::CreateSENCVectorEdgeTable(_IO_FILE*, S57Reader*)':
/root/GitOpenCPN/OpenCPN/src/s57chart.cpp:5833: undefined reference to `DouglasPeucker(double*, int, int, double, wxArrayInt*)'
collect2: ld returned 1 exit status
make[2]: *** [opencpn] Error 1
make[1]: *** [CMakeFiles/opencpn.dir/all] Error 2
make: *** [all] Error 2
OpenCPN make failed
Hubert
__________________

__________________
bcn is offline   Reply With Quote
Old 31-08-2014, 12:37   #138
Registered User

Join Date: Dec 2011
Boat: MC-Tec, Akilaria 950
Posts: 233
Re: OpenCPN Beta Version 3.3.1931 Released

Dave,

me again, with my OpenGL-Intel-onboard-graphics-framebuffer-black-screen-problem.
This OpenGL stuff is part of wxWidgets, right ?
I'm still running wxWidgets 2.8.12.
Do you think it makes sense to install wxWidgets 3 and try again ?

Thomas
__________________
tom_BigSpeedy is offline   Reply With Quote
Old 31-08-2014, 13:44   #139
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,421
Re: OpenCPN Beta Version 3.3.1931 Released

Found that my Dell XPS Inspiron 15 Laptop is using the Intel HD Display adapter rather than the NVIDIA Geforce 540M. (The NVIDIA card was an option and the machine comes wiith onboard Intel HD Graphics. -this uses more juice than a standard machine..) I have found more success with Opengl when I run Opencpn on the NVIDIA always. Something has changed here now, back to using Intel HD Graphics, and I do not seem to have the "Advanced" TAB which will direct the system to run Opencpn with only the NVIDIA Geforce Adapter. (..Its here somewhere, I am sure.) Anyway that is why I am now having some new troubles with Opengl I believe.

3:36:01 PM: OpenGL-> Renderer String: Intel(R) HD Graphics Family
3:36:01 PM: OpenGL-> Detected Intel renderer, disabling stencil buffer
3:36:01 PM: OpenGL-> Texture rectangle format: de1
3:36:01 PM: OpenGL-> Using Vertexbuffer Objects
3:36:01 PM: OpenGL-> Using Framebuffer Objects
3:36:01 PM: OpenGL-> Using FBO Stencil buffer
3:36:01 PM: OpenGL-> Using Depth buffer clipping
3:36:01 PM: OpenGL-> Using s3tc dxt1 compression
3:36:01 PM: OpenGL-> Compressed tile size: 128kb (6:1)
3:36:01 PM: ChartDB Cache policy: Application target is 1024 MBytes
3:36:01 PM: Loading chart db version: V018
3:36:01 PM: Chartdb: Chart directory list follows
__________________
rgleason is offline   Reply With Quote
Old 31-08-2014, 17:01   #140
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,020
Re: OpenCPN Beta Version 3.3.1931 Released

Hubert...
Weird, builds fine for me on ARM and there's nothing that could actually cause this in the last commits as far as I can tell. Try a clean build with
Code:
make clean && cmake .. && make
and of course make sure that your source tree is actually consistent.

Pavel

Quote:
Originally Posted by bcn View Post
Building on ARM (7c81663..a604785) fails with

Code:
CMakeFiles/opencpn.dir/src/chart1.cpp.o: In function `MyApp::OnExit()':
/root/GitOpenCPN/OpenCPN/src/chart1.cpp:2440: undefined reference to `FontMgr::Shutdown()'
CMakeFiles/opencpn.dir/src/chartdbs.cpp.o: In function `ChartTableEntry':
/root/GitOpenCPN/OpenCPN/src/chartdbs.cpp:221: undefined reference to `DouglasPeucker(double*, int, int, double, wxArrayInt*)'
/root/GitOpenCPN/OpenCPN/src/chartdbs.cpp:312: undefined reference to `DouglasPeucker(double*, int, int, double, wxArrayInt*)'
CMakeFiles/opencpn.dir/src/chcanv.cpp.o: In function `ChartCanvas::OnPaint(wxPaintEvent&)':
/root/GitOpenCPN/OpenCPN/src/chcanv.cpp:8779: undefined reference to `OCPNRegion::GetNew_wxRegion()'
CMakeFiles/opencpn.dir/src/glChartCanvas.cpp.o: In function `glChartCanvas::FactoryCrunch(double)':
/root/GitOpenCPN/OpenCPN/src/glChartCanvas.cpp:2716: undefined reference to `glTexFactory::FreeSome(long)'
libS57ENC.a(s57chart.cpp.o): In function `S57Obj':
/root/GitOpenCPN/OpenCPN/src/s57chart.cpp:704: undefined reference to `PolyTessGeo::PolyTessGeo(unsigned char*, int, int, int)'
libS57ENC.a(s57chart.cpp.o): In function `s57chart::CreateSENCRecord(OGRFeature*, _IO_FILE*, int, S57Reader*)':
/root/GitOpenCPN/OpenCPN/src/s57chart.cpp:5673: undefined reference to `PolyTessGeo::PolyTessGeo(OGRPolygon*, bool, double, double, bool, double)'
/root/GitOpenCPN/OpenCPN/src/s57chart.cpp:5684: undefined reference to `PolyTessGeo::PolyTessGeo(OGRPolygon*, bool, double, double, bool, double)'
libS57ENC.a(s57chart.cpp.o): In function `s57chart::CreateSENCVectorEdgeTable(_IO_FILE*, S57Reader*)':
/root/GitOpenCPN/OpenCPN/src/s57chart.cpp:5833: undefined reference to `DouglasPeucker(double*, int, int, double, wxArrayInt*)'
collect2: ld returned 1 exit status
make[2]: *** [opencpn] Error 1
make[1]: *** [CMakeFiles/opencpn.dir/all] Error 2
make: *** [all] Error 2
OpenCPN make failed
Hubert
__________________
nohal is offline   Reply With Quote
Old 31-08-2014, 17:16   #141
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,421
Re: OpenCPN Beta Version 3.3.1931 Released

Dell XPS 15 Laptop with Nvidia geforce card (active) and Intel graphic card.
====
NVIDIA System Information report
Operating System: Windows 7 Professional, 64-bit (Service Pack 1)
DirectX version: 11.0
GPU processor: GeForce GT 540M
Driver version: 306.97
DirectX support: 11.1
CUDA Cores: 96
Core clock: 672 MHz
Shader clock: 1344 MHz
Memory data rate: 1800 MHz
Memory interface: 128-bit
Total available graphics memory: 4096 MB
Dedicated video memory: 2048 MB DDR3
System video memory: 0 MB
Shared system memory: 2048 MB
Video BIOS version: 70.08.44.00.11
IRQ: 16
Bus: PCI Express x16 Gen2

In NVIDIA Control Panel > 3D Settings > Manage 3D Settings
Global Settings TAB Set to NVIDIA Processor (Not Intel HP Graphics
Program Settings TAB Add a new program and pick Opencpn.exe for version intended.
----
Now Opencpn program application is set to use NVIDIA instead of Intel HP Graphics.

However under Intel HP Graphics, Opencpn 3.3.1931 and 3.3.2028 seem to work much better with thee Opengl check turned OFF. These programs when using NVIDIA Geforce 540M Display Adapter work well with Accelerated Graphics Opengl checked and there is not nearly the same hesitation and waiting for the graphics Processor.

I note that this post from 3.3.1824 reported use with NVIDIA Geforce 540M
OpenCPN Beta Version 3.3.1824 Released



__________________
rgleason is offline   Reply With Quote
Old 31-08-2014, 17:22   #142
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,421
Re: OpenCPN Beta Version 3.3.1931 Released

PS: Under Nvidia Geforce 540M when I go into "Rebuild Texture Maps" it shows 2+ hours, and seems to be processing, just as with Intel HD Graphics, but it is a heck of a lot more graceful when you hit "Skip".

Observation: It might be good to have two progress bars, one overalll time and the other for individual charts processing to texture map.
__________________
rgleason is offline   Reply With Quote
Old 31-08-2014, 18:53   #143
Registered User
 
boat_alexandra's Avatar

Join Date: Aug 2009
Location: chesapeake bay
Boat: bristol 27
Posts: 2,824
Re: OpenCPN Beta Version 3.3.1931 Released

Quote:
Originally Posted by tom_BigSpeedy View Post
Dave,

me again, with my OpenGL-Intel-onboard-graphics-framebuffer-black-screen-problem.
This OpenGL stuff is part of wxWidgets, right ?
I'm still running wxWidgets 2.8.12.
Do you think it makes sense to install wxWidgets 3 and try again ?

Thomas
framebuffer object is an opengl extension. Has nothing to do with wxwidgets.

Maybe you can try some fbo samples to verify they work?
__________________
boat_alexandra is offline   Reply With Quote
Old 31-08-2014, 22:17   #144
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,421
Re: OpenCPN Beta Version 3.3.1931 Released

First Chart 13274 Massachusets Bay BSB has 45 degree lines through it (with Opengl on) using Nvidia card.
Second image is with Opengl off.
Attached Thumbnails
Click image for larger version

Name:	Screenshot 2014-09-01 00.08.00.jpg
Views:	68
Size:	281.6 KB
ID:	87500   Click image for larger version

Name:	Screenshot 2014-09-01 00.08.28.jpg
Views:	71
Size:	223.2 KB
ID:	87501  

__________________
rgleason is offline   Reply With Quote
Old 01-09-2014, 01:12   #145
Registered User

Join Date: Dec 2011
Boat: MC-Tec, Akilaria 950
Posts: 233
Re: OpenCPN Beta Version 3.3.1931 Released

Quote:
Originally Posted by boat_alexandra View Post
framebuffer object is an opengl extension. Has nothing to do with wxwidgets.

Maybe you can try some fbo samples to verify they work?
Yes, you're right Sean.
But O adresses the fbo opengl extension somehow.
And isn't that done by wxWidgets ?

Thomas
__________________
tom_BigSpeedy is offline   Reply With Quote
Old 01-09-2014, 03:00   #146
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,769
Re: OpenCPN Beta Version 3.3.1931 Released

Quote:
Originally Posted by nohal View Post
Hubert...
Weird, builds fine for me on ARM and there's nothing that could actually cause this in the last commits as far as I can tell. Try a clean build with
Code:
make clean && cmake .. && make
and of course make sure that your source tree is actually consistent.

Pavel
Pavel,

thanks, that did the trick.
3.3.2028 built and running (slow as there is no Mali support installed).

Hubert
__________________
bcn is offline   Reply With Quote
Old 01-09-2014, 06:54   #147
Registered User
 
boat_alexandra's Avatar

Join Date: Aug 2009
Location: chesapeake bay
Boat: bristol 27
Posts: 2,824
Re: OpenCPN Beta Version 3.3.1931 Released

Quote:
Originally Posted by tom_BigSpeedy View Post
Yes, you're right Sean.
But O adresses the fbo opengl extension somehow.
And isn't that done by wxWidgets ?

Thomas
I wish this were the case, but instead platform specific routines are invoked which are not part of wxwidgets neither.
__________________
boat_alexandra is offline   Reply With Quote
Old 01-09-2014, 07:47   #148
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN Beta Version 3.3.1931 Released

cagney...

Regarding cm93 near Herthas Flak....

I think that we are looking at two different cm93 datasets. The Windows 3.3.1606 image seems to be cm93/2010. The linux 3.3.2028 seems to be cm93/2011. Could this be so?

The cm93/2011 reclassified the wrecks on the image to "non-dangerous", depth not available. So O 3.3.2028 seems to be doing the right thing.

Still wondering about the funny raster charts shown before. Maybe I have them. What is the file name of the funny skewed image?

Thanks
Dave

ps. I am bottled up by weather in a spot with very poor WiFi. Trying to follow along, but it is difficult....
__________________
bdbcat is offline   Reply With Quote
Old 01-09-2014, 10:53   #149
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN Beta Version 3.3.1931 Released

Thomas Speedy...

Lets try this:

1. Remove the line you added:
// m_b_DisableFBO = true;

2. Enable this test, which was disabled some time ago:

#if 0 /* this test sometimes failes when the fbo still works */
if( m_b_BuiltFBO ) {
// Check framebuffer completeness at the end of initialization.
( s_glBindFramebuffer )( GL_FRAMEBUFFER_EXT, m_fb0 );
GLenum fb_status = ( s_glCheckFramebufferStatus )( GL_FRAMEBUFFER_EXT );
( s_glBindFramebuffer )( GL_FRAMEBUFFER_EXT, 0 );

if( fb_status != GL_FRAMEBUFFER_COMPLETE_EXT ) {
wxString msg;
msg.Printf( _T(" OpenGL-> Framebuffer Incomplete: %08X"), fb_status );
wxLogMessage( msg );
m_b_DisableFBO = true;
BuildFBO();
}
}
#endif

To do that, simply remove the
#ifdef 0 and the #endif lines.

$make and test.

This test should fail on your system, and thus disable FBOs, and so it works.

Let me know
Thanks
Dave
__________________
bdbcat is offline   Reply With Quote
Old 01-09-2014, 11:29   #150
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,250
Re: OpenCPN Beta Version 3.3.1931 Released

Quote:
Originally Posted by bdbcat View Post
cagney...

Regarding cm93 near Herthas Flak....

I think that we are looking at two different cm93 datasets. The Windows 3.3.1606 image seems to be cm93/2010. The linux 3.3.2028 seems to be cm93/2011. Could this be so?

The cm93/2011 reclassified the wrecks on the image to "non-dangerous", depth not available. So O 3.3.2028 seems to be doing the right thing.

Still wondering about the funny raster charts shown before. Maybe I have them. What is the file name of the funny skewed image?

Thanks
Dave

ps. I am bottled up by weather in a spot with very poor WiFi. Trying to follow along, but it is difficult....
Dave

You're right about CM93 & Herthas Flak, loading CM93 /2009 and using the same settings as in XP, I do get the same screen. Sorry for the red herring!
The point is that I'm a bit worried about the lack of soundings in many areas.

Regarding the weird raster. I sent you a mail, but it's doubtful if it's delivered.
Anyway.. you can download the chart here http://www.first-escape.com/sail/doc...anser-1999-.7z

Thanks
/Thomas
__________________

__________________
cagney is offline   Reply With Quote
Reply

Tags
enc, lease, opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCPN Beta Version 3.1.814 Released bdbcat OpenCPN 185 14-09-2012 08:43
OpenCPN Beta Version 3.1.802 Released bdbcat OpenCPN 158 14-08-2012 11:07
OpenCPN Beta Version 3.1.714 Released bdbcat OpenCPN 91 01-08-2012 18:08



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 02:46.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.