Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-11-2012, 08:02   #61
Registered User

Join Date: Jan 2010
Location: Thunder Bay, On
Boat: C&C Landfall 38
Posts: 17
Re: OpenCPN Beta Version 3.1.1105 Released

Quote:
Originally Posted by bdbcat View Post
Brian...

OK, a legitimate bug. The messages from the PlugIns, especially the magvar info from wmm, are being ignored.

Fix is pushed to git master.
Can you build from source?

Thanks
Dave
Dave

Working great from latest master, tested on XP and W7 32 bits.

Thanks for the quick response.
Brian
__________________

__________________
brianalex is offline   Reply With Quote
Old 09-11-2012, 09:35   #62
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,247
Re: OpenCPN Beta Version 3.1.1105 Released

Quote:
Originally Posted by SethDart View Post
Hi Thomas,

Unfortunately, your trace has only wxWidgets internal calls. We can't see where it's called inside OpenCPN or the dashboard plugin, can you send a screenshot with trace after #9?

BTW i have 64bits too, no hang so far... ;-)

Thanks,
Jean-Eudes
Jean-Eudes
OK, I can see your point.....
A gdb trace is attached.
bt.txt.pdf
Get rid of the ".pdf" extension.
Thomas

PS. Still funny links. Click "Size"!
__________________

__________________
cagney is offline   Reply With Quote
Old 09-11-2012, 10:53   #63
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,247
Re: OpenCPN Beta Version 3.1.1105 Released

Dave!

Warning!
I suspect a bad bug in the handling of chart groups. I lost all the help files, dictionary etc, in my CM 93 directories, when manipulating chart groups. Adding and deleting chart-groups and files-
I can now replicate the problem with CM93 previous reported.

Luckily I have backups, and can compare contents.

Thomas.
__________________
cagney is offline   Reply With Quote
Old 09-11-2012, 16:11   #64
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
Re: OpenCPN Beta Version 3.1.1105 Released

Thomas...

Let me get this right:
Are you saying that by manipulating chart groups, the contents of the cm93 root directory have been deleted? Literally?

More info on how to reproduce, if possible...
I'll start looking into it.
Dave
__________________
bdbcat is offline   Reply With Quote
Old 09-11-2012, 17:09   #65
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,356
Re: OpenCPN Beta Version 3.1.1105 Released

I too had some difficulty with charts but believe I got it going without losing anything. I believe the problem has something to do with Rebuilding the database and which chart items are selected above in the window when you rebuild. For example the last time I did it I highlighted all the charts and hit apply to rebuild. Then the directory that had not been built was highlighted and the rebuild occured. Before that it did not seem to be rebuilding. I thought it was just me screwing up somehow. Don't know if that makes it a bug but I hope that helps.
__________________
rgleason is offline   Reply With Quote
Old 09-11-2012, 17:14   #66
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,356
Re: OpenCPN Beta Version 3.1.1105 Released

OpenGL in a release build seems to be working nicely now. Much faster and no chart issues yet.
__________________
rgleason is offline   Reply With Quote
Old 10-11-2012, 02:59   #67
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,247
Re: OpenCPN Beta Version 3.1.1105 Released

Quote:
Originally Posted by bdbcat View Post
Thomas...

Let me get this right:
Are you saying that by manipulating chart groups, the contents of the cm93 root directory have been deleted? Literally?

More info on how to reproduce, if possible...
I'll start looking into it.
Dave
Dave
Unfortunately that seems to be the case. The whole content of the root directory was not deleted, only the 6 files, while the directories were left alone. Furthermore..... three other cm93 directories on the same level in the file tree as the root directory, also lost their files.
A cm93 directory one level further up was alright.
I have tried to recreate the failure but have, so far been unable to do so...

It all started when someone mentioned problems with chart groups, and I started some testing. At this point cm93 was OK and had been so, literally, for years.
In the beginning, I think there were three chart groups with one chart directory in each. I tested all kind of things, deleting groups still containing charts, deleting chart directories still used by groups, rebuilding the chart database in between, creating new grops etc., etc. At some stage I only got the background chart when switching to a group containing cm93 .....and found the problem with the cm93 root directory.
I cannot, for now, see any other explanation, than that there is some code path, that deletes the files in the cm 93 root directory.

I'll continue testing and trying to find a repeatable scenario...

See this thread as well cm93 works in V2 but not V3.

Thomas
__________________
cagney is offline   Reply With Quote
Old 10-11-2012, 03:40   #68
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,247
Re: OpenCPN Beta Version 3.1.1105 Released

When adding or deleting chart directories in the "Loaded Charts" tab, the available charts "Chart Groups" Tab are not updated when pressing "Apply". Pressing "OK" and reopening the options dialog, is required for updating the Chart Groups.

Thomas
__________________
cagney is offline   Reply With Quote
Old 10-11-2012, 05:12   #69
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,356
Re: OpenCPN Beta Version 3.1.1105 Released

I deleted a two chart groups and recreated them. Have not seen any missing charts....yet. Sorry for the conflicting report. I'm using a Windows Release build.
__________________
rgleason is offline   Reply With Quote
Old 10-11-2012, 08:29   #70
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,247
Re: OpenCPN Beta Version 3.1.1105 Released

Dave
I have discovered a more widespread file corruption on my hard disk.
The few files in the cm 93 root directories, now seems like the top of the iceberg......
I'll have to backtrack everything I said about his having anything to do with O.
Looking back, it now more seems like a coincidence.
Sorry for the "red herring".
Now it remains to see, just how good my backups are...

Thomas
__________________
cagney is offline   Reply With Quote
Old 10-11-2012, 09:21   #71
Registered User

Join Date: Mar 2010
Location: Wandering around North America
Boat: Defever 43 - Gray Hawk
Posts: 602
@Dave Tides and currents work fine on XP. Win 7 not at all.
__________________
R.J.(Bob) Evans
M/V Gray Hawk, 43 Defever Offshore Cruiser
http://www.bobandmarilyn.ca
bobofthenorth is offline   Reply With Quote
Old 10-11-2012, 09:46   #72
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: OpenCPN Beta Version 3.1.1105 Released

Quote:
Originally Posted by cagney View Post
Jean-Eudes
...etc...

PS. Still funny links. Click "Size"!
..?they only look funny if you are not logged in? That's what happens to me. It's very odd...

PS: Just starting, but on XP, OPortable working fine with groups,tides -nice new ControlPanel! Very Pretty!
__________________
HappySeagull is offline   Reply With Quote
Old 10-11-2012, 10:01   #73
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: OpenCPN Beta Version 3.1.1105 Released

Fooling with the ownship dialogue...! a bit of a math problem with the width...? or is it my icons?
Click image for larger version

Name:	narrowownship.png
Views:	73
Size:	87.3 KB
ID:	49519

...and compared to plainjane default

Click image for larger version

Name:	defaultownship.png
Views:	77
Size:	103.6 KB
ID:	49520

Very nice, by the way. oh, and the Vector option works ok.

edit: open the picture "in new tab" works better (for me) to see detail of these screengarbs

edit add : making width = length fixes it...ahso!
edit add add: but when NOT using my own icon, everything is copacetic and I wish I hadn't mentioned it. Oh well.
__________________
HappySeagull is offline   Reply With Quote
Old 10-11-2012, 13:22   #74
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,294
Re: OpenCPN Beta Version 3.1.1105 Released

Hello,

Option (Toolbox), tab "Connexions", impossible to use the button "Add".
And if I destroyed the existing connection, impossible to create a new connection for the GPS.
Attached Thumbnails
Click image for larger version

Name:	2012-11-10_Add_connection.jpg
Views:	84
Size:	106.1 KB
ID:	49532  
__________________
Gilletarom is offline   Reply With Quote
Old 10-11-2012, 14:23   #75
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: OpenCPN Beta Version 3.1.1105 Released

Gilletarom, that's odd- your "Connections" page does not look like mine. ...(on XP)
Click image for larger version

Name:	connectionswindow.jpg
Views:	75
Size:	92.5 KB
ID:	49536

... I deleted and then re-added this gps no problem by using the ports choice and then the "Apply" button, but I guess that won't work for you if you haven't got the whole Page available!
__________________

__________________
HappySeagull is offline   Reply With Quote
Reply

Tags
opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 01:03.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.