Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 29-12-2015, 14:09   #616
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,319
Re: OpenCPN Beta test 4.1.1108 Release

Again,
Nobody has a problem with current beta when
ON = Show Chart Outlines
with Opengl=ON and Texture Cache=ON?
__________________

__________________
rgleason is offline   Reply With Quote
Old 29-12-2015, 14:19   #617
Registered User

Join Date: Feb 2011
Posts: 488
Re: OpenCPN Beta test 4.1.1108 Release

Quote:
Originally Posted by rgleason View Post
Does anyone else with a SurfacePro3 have trouble with the current beta when
ON = Show Chart Outlines
with Opengl=ON and Texture Cache=ON?

Doesn't anyone else (any computer) have this problem?

@P_Dub


P_Dub, Please try the above settings. Thanks.
I tried moving all over and nothing when wrong, I hope your next version will not mess it. Good luck. In your BuildWin OpenCpn_gittest1 there is something missing!
Looking forward for a official version.
__________________

__________________
P_Dub is offline   Reply With Quote
Old 29-12-2015, 14:22   #618
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,319
Re: OpenCPN Beta test 4.1.1108 Release

I am a dog with a bone.
The Win Beta on the website from
Opencpn-2015-11-08-released


has the same problem.
ON = Show Chart Outlines
with Opengl=ON and Texture Cache=ON?

I did not compile it, I am using Pavel's compile, so nothing is missing.
Also I do not believe I have anything missing in my Buildwin!

The problem is Show Chart Outlines,
otherwise why would Opengl=ON Texture Cache=ON work when
OFF=Show Chart Outlines?

P_Dub ... I tried it too, just now, what OS are you running!

Would someone with SurfacePro3 and Windows 10 try this?
__________________
rgleason is offline   Reply With Quote
Old 29-12-2015, 14:26   #619
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 1,967
Re: OpenCPN Beta test 4.1.1108 Release

VS2010...........
I would be one of the alluded and I'm very grateful for the VS2010 "overtimed" support but is now mainly on VS2013 and happy with that.
Today's VS2010 test was more to maintain a consistency to the developers manual still referring to this.
So - if it's just me I'll say thanks to Pavel and goodbye to 2010.

XP as such to run OpenCPN will though persist for some more years I think. There are many of us using it for navigation.

Thanks
HŚkan
__________________
Hakan is offline   Reply With Quote
Old 29-12-2015, 14:28   #620
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,751
Re: OpenCPN Beta test 4.1.1108 Release

Rick,

here with .1108 no problem (From the beginning and now some of one of your later compiles). A Dell XPS13, so not that far from your system.

Hubert
__________________
bcn is online now   Reply With Quote
Old 29-12-2015, 14:30   #621
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: OpenCPN Beta test 4.1.1108 Release

I followed directions compiling on Linux Mint 17.2 Rafaela 64 bit and it worked fine... simple Pull
and I did install at first over the previous but found it better to Uninstall , then delete all Opoop I could find as root and then install again. second time,
blah blah but anyways
The toolbar does look very different so I think I did ok .and I got the welcome/disclaimer too-always a good sign where fresh is wanted.

however, I notice that I again have the "forever-caching wheel of whatever" until I do something....you ask what? examples; in the toolbox, change something, click apply or restart O sometimes fixes.

add.
I am also getting some strange effects with OpenGL off. clickndrag charts, raster or cm93. Ownship ,chart borders can be moved,, blinking ...even some black flashes, and some strange overlays where charts get cut up appearing in the wrong place.

these do not happen with opengl on.

(reminder to self-need a better way to screengrab in linux)
__________________
HappySeagull is offline   Reply With Quote
Old 29-12-2015, 14:37   #622
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,319
Re: OpenCPN Beta test 4.1.1108 Release

Hubert,

It is very reassuring to know that some of my compiles work for you too . It is really nice to know that. I found them to be very useful on both of my machines, but we are finding out that one machine likes them and the other does not, both are Windows 10 OS. - So thank you Hubert for the info and the confirmation.

I am away, and don't have my Dell Inspiron with Nvidia Geforce 540m and Windows 10. I have with me a SurfacePro3 with Windows 10, that I have installed VS2013, git and all the rest so I can compile and test. However all of the compiles I have listed above were compiled on my Dell Inspiron, and I just copied them over to this SurfacePro3.

Is it something weird with SurfacePro3? Kind of hard to believe, but every one of the compiles of mine that I tried, AND Pavel's from 2015-11-08-released DOES NOT work properly with

ON = Show Chart Outlines
with Opengl=ON and Texture Cache=ON?

on the SurfacePro3 with Win10.

I can live with it but I think it is extremely weird and would like to get it fixed or know why.
__________________
rgleason is offline   Reply With Quote
Old 29-12-2015, 14:45   #623
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,751
Re: OpenCPN Beta test 4.1.1108 Release

Rick,

so what I would recommend is to settle down a moment, waiting for the next beta and start from there. Relax..

The SVG merge from today is a big one...

Hubert
__________________
bcn is online now   Reply With Quote
Old 29-12-2015, 14:49   #624
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,319
Re: OpenCPN Beta test 4.1.1108 Release

Dear Happy SeaGull,
Thanks for your Linux note and the support -albeit a bit reversed (the guys here don't seem to believe me)

Quote:
however, I notice that I again have the "forever-caching wheel of whatever" until I do something....you ask what? examples; in the toolbox, change something, click apply or restart O sometimes fixes.

add.
I am also getting some strange effects with OpenGL off. clickndrag charts, raster or cm93. Ownship ,chart borders can be moved,, blinking ...even some black flashes, and some strange overlays where charts get cut up appearing in the wrong place.

these do not happen with opengl on.
A little information, I believe the changing wheel is a result of one of did-g's changes to show it spinning when the cache is empty. It was one of the Merged Pull Requests. I don't know why he thought that was needed, but I usually think he has good reasons.
https://github.com/OpenCPN/OpenCPN/c...aea7ec36cad832

..However maybe there is a good reason not to have it too.

I am looking for a Merge Pull Request that changed the way "Show Chart Outline" worked. Have not found it yet.
https://github.com/OpenCPN/OpenCPN/commits/master
__________________
rgleason is offline   Reply With Quote
Old 29-12-2015, 15:46   #625
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: OpenCPN Beta test 4.1.1108 Release

of course, i am getting a log full of these too...
Quote:
14:23:31 PST: Can't find SVG: /home/gormin/OpenCpnPortable4.1.11.08/uidata//zoomin.svg
Rick, I am seeing borders ok opengl on or off . I can't help with setting texture cache as I am plain avoiding it...it's Not a setting I have ever wanted to use since ram-rich and powerful machines became available even to seagulls.
Quote:
Again,
Nobody has a problem with current beta when
ON = Show Chart Outlines
with Opengl=ON and Texture Cache=ON?
Anyways I have more pressing befuddlements...slipping the newer executeable into my Portable Folder exhibits the same issues I mentioned. except that I can once again use my own icons in the portable. My installed version has some trouble with permissions..
Quote:
Error: can't open file '/home/gormin/.opencpn/UserIcons/Flag, Green.png' (error 13: Permission denied)
edit add: but yes,Rick,if you are seeing what I am? the borders move together with the ownship. sometimes a "tile" slips too, but recovers before I can get the onboard screengrab happening to prove it! I "think" this is the way O has worked for a long time (overlays? if that's acceptable jargon) but is being slowed somewhere lately.
__________________
HappySeagull is offline   Reply With Quote
Old 29-12-2015, 16:35   #626
Registered User

Join Date: Jun 2015
Posts: 198
Re: OpenCPN Beta test 4.1.1108 Release

Quote:
Originally Posted by rgleason View Post


Is it something weird with SurfacePro3? Kind of hard to believe, but every one of the compiles of mine that I tried, AND Pavel's from 2015-11-08-released DOES NOT work properly with

ON = Show Chart Outlines
with Opengl=ON and Texture Cache=ON?

on the SurfacePro3 with Win10.

I can live with it but I think it is extremely weird and would like to get it fixed or know why.
It could be your charts... or the cache. I don't know where it is on windows but in opencpn directory in a subdirectory cm93 there's something like:
<xxxxx>___coverset_sigp.A
...
<xxxxx>___coverset_sigp.G
With xxxx being the directory of your CM install.

Could you copy these files elsewhere and remove them?

Another test.
In cm93.cpp around line 6242 in following code
Code:
#if 1 // Push array (faster)
    glVertexPointer(2, GL_FLOAT, 2*sizeof(float), mcd->gl_screen_vertices);
    glDrawArrays(GL_LINES, 0, mcd->m_ngl_vertices);
#else // immediate mode (may be useful for debugging buggy gfx cards)
    glBegin(GL_LINES);
    for(int i=0; i<mcd->m_ngl_vertices; i++)
        glVertex2f(mcd->gl_screen_vertices[i].y, mcd->gl_screen_vertices[i].x);
    glEnd();
#endif
Could you replace
#if 1
with
#if 0
It's possible that your driver bug if for whatever reason mcd->m_ngl_vertices is zero.
__________________
did-g is offline   Reply With Quote
Old 29-12-2015, 16:38   #627
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,319
Re: OpenCPN Beta test 4.1.1108 Release

To compile properly I did the following:
Under my git directory for Opencpn
Renamed buildwin to buildwin-old
Unpacked the OpenCPN_buildwin-svg.7z to the Git Opencpn directory creating a new buildwin.
Tried to compile and found errors related to NSIS so I copied the NSIS directory from buildwin-old into buildwin
Tried to compile and found more errors related to crashrpt.h so I copied that and crashrpt.lang.ini and privacypolicy.txt from buildwin-old/crashrpt to the buildwin/crashrpt directory.

Then I was able to compile it completely and run cpack to make an installable. I think I have some necessary files for compiling plugins still in the buildwin-old directory.

I installed the package and started it up. It immediately hung up because I had ON=Show Chart Outline and was using Opengl=on and Texture Cache=on. I terminated the program with task manager and started O4.0 to turn off=show chart outline.

Then I started the new version of O and the SVG graphics for the toolbar Icons were great! I started panning and zooming and managed to cause a total crash with not black screen but a total Red screen, then a black screen with the cursor showing a big pointer that I could not move. I could not get out of that mode. I believe I was still in O. There was not bottom taskbar to use, screen was totally black. I finally just pushed the button and kept it down to shutdown.

Restarted. Tried the new O again, more carefully and slowly this time.
Tried pan and zoom with CM93, RNC and ENC, ran Ocpn_Draw and created several objects. Ran Launcher and VDRserver.py with Hakafjord.txt and tried the new AIS Attenuation of less critical targets and the Menubar-AIS and Toolbar-AIS, went into Options-Ships-AIS Tab and changed some things. Tried most of the new SVG icons by clicking on them. Scrolled around more and panned with several types of charts.
It seems to be working well under Windows now... but I have not tested it extensively.

For Windows users who want to see what is coming, try this, with the warning that SVG for Toolbar Icons is completely new to Opencpn (and very nice!).
Newest beta, with Pavel's SVG graphics for Windows Beta users
Opencpn Beta File Thingie rguser rgpass
In Home directory.
opencpn_4.1.1108_GIT11-ba2361a-MPR530Tdan_setup

@ Happy Seagull,
I am sorry Linux version is breaking up on the screen. I am sure that Pavel is all over it and will have a new PR soon.

Thank you Pavel!

My esoteric "Show Chart Outlines" woes are still around, but I've just turned that off for now because I like to use OpenGL and Texture Cache.
Attached Thumbnails
Click image for larger version

Name:	Toolbar-SVG.png
Views:	76
Size:	217.4 KB
ID:	115815  
__________________
rgleason is offline   Reply With Quote
Old 29-12-2015, 16:42   #628
Registered User

Join Date: Jun 2015
Posts: 198
Re: OpenCPN Beta test 4.1.1108 Release

Quote:
Originally Posted by HappySeagull View Post
however, I notice that I again have the "forever-caching wheel of whatever" until I do something....you ask what? examples; in the toolbox, change something, click apply or restart O sometimes fixes.

Are you using a compositing window manager?
__________________
did-g is offline   Reply With Quote
Old 29-12-2015, 17:16   #629
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,319
Re: OpenCPN Beta test 4.1.1108 Release

Did-g:
C:\ProgramData\opencpn\cm93
Has screwed up paths for CM93 A,B,C,D charts.
Copied all the files elsewhere and deleted them all in above dir.

Then tried it. Turning Show Chart Outlines on.
There is more blue wheel spinning and I could pan and zoom for longer, but eventually the black screen occurred and I was unable to use the menus and could not close O, so had to terminate from Task Manager.

I then was able to opencpn and access Show Chart Outlines to turn it off and shut down, to restart the program afresh. This is better than before.
__________________
rgleason is offline   Reply With Quote
Old 29-12-2015, 17:34   #630
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,319
Re: OpenCPN Beta test 4.1.1108 Release

@did-g
Quote:
Could you replace
#if 1
with
#if 0
It's possible that your driver bug if for whatever reason mcd->m_ngl_vertices is zero.
Seemed like the wheel appeared less when pan-scroll, but it too began to get black screen and menus would not cooperation.
Will change it back.

Thanks.
__________________

__________________
rgleason is offline   Reply With Quote
Reply

Tags
enc, lease, opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCPN Beta test 4.1.1022 Release bdbcat OpenCPN 122 07-11-2015 02:12
OpenCPN Beta test 4.1.925 Release bdbcat OpenCPN 177 04-11-2015 09:16
OpenCPN Beta test 4.1.602 Release bdbcat OpenCPN 193 13-10-2015 09:19
OpenCPN Version 2.2 Beta Test bdbcat OpenCPN 437 15-12-2010 20:17
OpenCPN Version 2.2 Beta Test Bugs / Discussion bdbcat OpenCPN 120 26-09-2010 03:53



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 12:42.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.