Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 27-12-2015, 21:19   #586
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,320
Re: OpenCPN Beta test 4.1.1108 Release

@did-g
I don't know enough to know if screen going black is a "regression" sorry.

Here is the most current log:
Quote:
10:48:20 PM: Using s57data in C:\Program Files (x86)\OpenCPN 4.1.1108\s57data
10:48:20 PM: Detected display size (horizontal): 254 mm
10:48:20 PM: Detected display size (horizontal): 254 mm
10:48:20 PM: OpenGL-> Renderer String: Intel(R) HD Graphics 4400
10:48:20 PM: OpenGL-> Version reported: 4.3.0 - Build 10.18.15.4256
10:48:20 PM: OpenGL-> Detected Intel renderer, disabling stencil buffer
10:48:20 PM: OpenGL-> Texture rectangle format: de1
10:48:20 PM: OpenGL-> glGenerateMipmap unavailable
10:48:20 PM: OpenGL-> Detected Windows Intel renderer, disabling Vertexbuffer Objects
10:48:20 PM: OpenGL-> Vertexbuffer Objects unavailable
10:48:20 PM: OpenGL-> Using Framebuffer Objects
10:48:20 PM: OpenGL-> Using FBO Stencil buffer
10:48:20 PM: OpenGL-> Using Depth buffer clipping
10:48:20 PM: OpenGL-> Using s3tc dxt1 compression
10:48:20 PM: OpenGL-> Compressed tile size: 128kb (6:1)
10:48:20 PM: OpenGL-> Minimum cartographic line width: 1.0
10:48:20 PM: OpenGL-> Minimum symbol line width: 1.0
10:48:20 PM: Warning: iCCP: known incorrect sRGB profile
I have also attached the full log which will have more detail. I have not noticed black screens today or yesterday, and I have pretty much the most current git fetch running, maybe missed some today.

I have not been concentrating on charts so much that last day. I will exercise this more tonight.
Attached Files
File Type: doc opencpn-beta-surfacepro3.log.doc (321.4 KB, 7 views)
__________________

__________________
rgleason is offline   Reply With Quote
Old 27-12-2015, 21:25   #587
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,320
Re: OpenCPN Beta test 4.1.1108 Release

That was pretty quick. I tried some new territory with CM93 charts and very quickly ran into issues with black screens, spinning wheels and Ocpn (not responding)then coming back after a littile while.

I think I have to turn off all plugins first though. -- a thought just now.
__________________

__________________
rgleason is offline   Reply With Quote
Old 27-12-2015, 22:00   #588
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,320
Re: OpenCPN Beta test 4.1.1108 Release

Ocpn stuttering, slow and stuck. Closed Ocpn. Opened it. Turned off plugins WD, OD, and Launcher. Closed it. Opened it.

Tried CM93 again. Black screens, slow, Closed O, Shut down machine, reboot.
Tired CM93 agian. Still having issues. Tried change to USCG01enc. Had some black screens while creating Senc files, creating senc files may be a little slower, but the cache was being built up and gradually it got better. Then after doing Ct, RI and MA, went up to Maine and loaded that, the back to Ct & RI that seemed fast, but with some black screens when loading senc.

Then switched to USCG01 RNC (New England again) started zooming in and adding Senc. then got a fault error, Ocpn froze3 up and cut out. Now my desktop icons are scrambled around and the background it black intesd of blue.

Have tried Ocpn again after reboot and it seems to get frozen now and I have to close it with Task Manager.

I think I am going to have to clean the texture cache. Did not have this problem before. Should try V4.0. This is intel graphics, I could back off on opengl teture cache but it worked before I believe.

Have not used this SurfacePro3 that much recently with O so its seems pretty new. Have O on a Dell Laptop with Nvidia graphics which work great.

Perhaps should run this as MS VS Debug?
Any way have to sleep now and travel tomorrow.
__________________
rgleason is offline   Reply With Quote
Old 27-12-2015, 22:12   #589
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,320
Re: OpenCPN Beta test 4.1.1108 Release

The Display driver says Microsoft Basic Driver. The screen res is at the max recommended. I seem to remember that I had it at a different res to increase font size, but that may not be accurate. It was awhile ago that I set up the computer.

Text looks a bit smaller to me now, but not enough to be sure,.
__________________
rgleason is offline   Reply With Quote
Old 27-12-2015, 22:16   #590
Registered User

Join Date: Jun 2015
Posts: 198
Re: OpenCPN Beta test 4.1.1108 Release

Quote:
Originally Posted by rgleason View Post
@did-g
I don't know enough to know if screen going black is a "regression" sorry.
It's easy, was it working before?
If yes, have the time and still have the old version around, it'd be great to double check it's still working (no black screen), could be an OS update.

Quote:
Here is the most current log:
I have also attached the full log which will have more detail. I have not noticed black screens today or yesterday, and I have pretty much the most current git fetch running, maybe missed some today.

I have not been concentrating on charts so much that last day. I will exercise this more tonight.
thanks.

CM93 doesn't use the raster cache so it's something more general.

With CM93 the spinning wheel is normal the first time you move, zoom in/out to an area but it should be fast.

Note:
If you click on a chart in the piano it purges all charts from the program memory so it's 'first time' again.
__________________
did-g is offline   Reply With Quote
Old 28-12-2015, 08:13   #591
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,320
Re: OpenCPN Beta test 4.1.1108 Release

Thanks did-g. Will test it further today, but first make sure computer is cleaned up and running well. Yesterday had many windows open and it was pretty busy for most of the day.

Should I try O in debug mode to, maybe catch some faults?
__________________
rgleason is offline   Reply With Quote
Old 28-12-2015, 08:16   #592
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,320
Re: OpenCPN Beta test 4.1.1108 Release

I think I have some old versions too. Also some are in Opencpn Beta File Thingie rguser rgpass under Directory Earlier PI because I generally move things there.
__________________
rgleason is offline   Reply With Quote
Old 28-12-2015, 08:17   #593
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,320
Re: OpenCPN Beta test 4.1.1108 Release

Will take awhile because I am traveling. Sorry.
__________________
rgleason is offline   Reply With Quote
Old 28-12-2015, 15:57   #594
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,320
Re: OpenCPN Beta test 4.1.1108 Release

Bdcat do you have a preliminary ChangeLog for v4.1.1108?
Can you please post it here?
Opencpn 4.1.1108 Documentation

This may give us a reasonably comprehensive list to check against the O Documentation for necessary changes.


Also, Thomas nicely left us all with this list in the Wiki Update notes for Android
http://opencpn.org/ocpn/wiki-update
2015-06-02
4.1.602
Changelog

Am I correct in assuming that these changes need to be checked against the documentation as well? That would give us the first list to check against.

Thank you
__________________
rgleason is offline   Reply With Quote
Old 28-12-2015, 16:05   #595
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,878
Re: OpenCPN Beta test 4.1.1108 Release

Rick...

Changelog for 4.1.1108 is at Post #1 of this thread, as always. If you need more, let me know.

Thanks for bird-dogging the Doc updates in advance of the 4.2 Release.

Dave
__________________
bdbcat is offline   Reply With Quote
Old 28-12-2015, 16:34   #596
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,320
Re: OpenCPN Beta test 4.1.1108 Release

Quote:
Changelog for 4.1.1108 is at Post #1 of this thread, as always
Perfect. Thank you. Did not know that.


LATER:

I note that the change.log 4.1.602 finishes with #40 and this 4.1.1108 starts with #78. I have searched for all other threads "Opencpn Beta Test 4.1" with bdbcat as author and have not found any other lists.

Can you advise?
__________________
rgleason is offline   Reply With Quote
Old 28-12-2015, 16:36   #597
Registered User

Join Date: Jun 2015
Posts: 198
Re: OpenCPN Beta test 4.1.1108 Release

Quote:
Originally Posted by rgleason View Post
Thanks did-g. Will test it further today, but first make sure computer is cleaned up and running well. Yesterday had many windows open and it was pretty busy for most of the day.

Should I try O in debug mode to, maybe catch some faults?
It's a little outside my comfort zone, I don't use windows that much, but you could try in full screen mode...

If the whole screen goes black it's a driver reset, likely after a driver bug.

If an older but not to old OCPN version works, maybe it's possible to work around these bugs.

I wouldn't spend to much time on this though, with Intel it seems hopeless. Chrome, Firefox, Qt and so on are using a translation layer OpenGL ES to Direct3D, ie they gave up and bypass Intel driver...
__________________
did-g is offline   Reply With Quote
Old 28-12-2015, 20:49   #598
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,320
Re: OpenCPN Beta test 4.1.1108 Release

Surface Pro 3, current Windows 10 drivers (November 2015) i5 usually pretty snappy with Opencpn.

This version of Opencpn_4.1.1108_GIT10-5a7d84d-PR526tdan

I also have these versions but have not tested them:
opencpn_4.1.1108_GIT9-cba9f98-PR519-Ptizef
opencpn_4.1.1108_GIT8-df06bedCorrectPersistentOptionSerialdetect
opencpn_4.1.1108_GIT7-32ee195AddMissingImagefiles

And that's it of the most recent compiles.

Using the Opencpn_Git10 above:

With Opengl checked and Texture Cache with CM93, very very slow and hung up.

With Opengl unchecked and Texture_cache disabled, with USCG01 RNC very useable, hardly any wait circles, no black screens.

with Opengl unchecked and Texture _cache disabled, with USG01 ENC similar goog results.

with Opengl unchecked and texture_cache disabled, with CM93 the charts got slower and slower, panning stopped, and I gradually could not do much. It started out being ok, I could zoom in and out, on east coast, then went across to Sweden and got hung up there with O almost at a crawl.

Then looked in Task Manager, found Opencpn CPU=9%-15% Memory=400mb Disk=0% Network=0%

When I try to zoom in by hitting the + button, the wheel spins, the menu blinks several times and nothing happens now.

I was able to shutdown after 3-4 tries...
__________________
rgleason is offline   Reply With Quote
Old 28-12-2015, 21:36   #599
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,878
Re: OpenCPN Beta test 4.1.1108 Release

Rick....

If the effect you are seeing is recently introduced, you should try to do some git-bisect loops to identify the offending commit.

The idea is to go back in time to find a github commit that builds and seems to work correctly, and then let git help you find the later commit that breaks something, which it does by a binary search. Presumably, the offending commit happened after the commit proven to work, and before the most recent HEAD, which you declare broken. You just need to find it, and then inspect the code diffs for that commit.

There are plenty of git-bisect tutorials online, and it is a good tool to have in your set when this type of thing happens. It is far better than trying to run random builds you find floating on your file system, since you may have no idea really where those builds came from.

We can help you get started...

Thanks
Dave
__________________
bdbcat is offline   Reply With Quote
Old 28-12-2015, 21:40   #600
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,320
Re: OpenCPN Beta test 4.1.1108 Release

Continued.. This kind of operation with CM93 not using opengl or texture cache, is really unacceptable!

But there is at least a definite work around. For some reason I turned off
  • Show Chart outlines
  • Show Skewed raster charts as north up
I then tested USCG01-RNC and USCG01-ENC which worked fine, without Opengl or texture cache.


Then turned on CM93 and it started out fine scroll in and out and panning.
Pretty soon the Memory=500mb and CPU ran between 1%-30%. I thought it would start to fail, and continue zooming and panning to the West coast, zoomed in and out, panned to Sweden, Memory=800mb, then zoomed in and out, panned to the baltic, went to St Petersburg, Memory at 1100mb, CPU=15% Pausing CPU= 3%, Pausing more and the CPU=0% and Memory=0%
======


Ok now, Turn on Opengl, with NO texture cache. Using CM93 charts.
Oh is this nice. Fast zooms, pans, smooth really sweet. I can live with this! Who needs Texture Cache with this? CPU=1%-30% Memory=540 after lots of panning and zooming. Panned over to Sweden and Norway. Was able to pan from Trompso, to Lofoten and down to Bergen without a single pause with Vector Chart Display - Display Category "All". Now Cpu=0 Mem=350mb.


I can live with this. Turn off Show Chart Outline and turn off show skewed raster charts with north up [This very well might not be the problem].


==================


Ok now, Keep OpenGL on and turn on Texture Settings with Caching. Well in the beginning there were blue wheels and one black screen, but pretty soon the cache started working well. Zooming in was not as responsive, with the blue wheel showing just a bit. Then I noticed things getting a little faster, so I panned up to Trompso, and zoomed in, then panned continuous down to Lofoten, at which point I was liking the action.

Then I got a memory notice from Windows, running out of memory, close Opencpn.
Looked at Task Manager Ocpn CPU=29% Mem=840mb, and System was up at 825mb,

I did not close Opencpn. I wrote this and waited. Ocpn CPU=0% and Mem=5.1 mb.

So it seems to me that the Texture Cache is working with perhaps a few issues, and I don't know if it has a memory problem over the long haul, but it seems to work,

...particularly with these two settings off!
  • Show Chart outlines
  • Show Skewed raster charts as north up
Now I am going to bed. -The plane did not leave and we did not get home.
__________________

__________________
rgleason is offline   Reply With Quote
Reply

Tags
enc, lease, opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCPN Beta test 4.1.1022 Release bdbcat OpenCPN 122 07-11-2015 02:12
OpenCPN Beta test 4.1.925 Release bdbcat OpenCPN 177 04-11-2015 09:16
OpenCPN Beta test 4.1.602 Release bdbcat OpenCPN 193 13-10-2015 09:19
OpenCPN Version 2.2 Beta Test bdbcat OpenCPN 437 15-12-2010 20:17
OpenCPN Version 2.2 Beta Test Bugs / Discussion bdbcat OpenCPN 120 26-09-2010 03:53



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 23:45.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.