Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 16-12-2011, 12:29   #16
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: OpenCPN Beta Build 2.6.1215

Yes.I restarted O.The cm93 loads at 7.5x .I turned off OpenGL.Everything WOULD be fine IF I didn't "+"in-I Did,and now I'm stuck,same place at 15x...
__________________

__________________
HappySeagull is offline   Reply With Quote
Old 16-12-2011, 12:36   #17
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: OpenCPN Beta Build 2.6.1215

..by the way,DoctorDave,I can still drag the chart (or charts)around and if I have kaps loaded in the bar,as I said,I could change to them.But no zoom-/+ ...it's just stuck with Overzoom showing.
__________________

__________________
HappySeagull is offline   Reply With Quote
Old 16-12-2011, 12:56   #18
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: OpenCPN Beta Build 2.6.1215

but the IBM has 2.5 and 2.6.1215PORTABLE and neither sticks in the same location-EVEN with openGL on-which the IBM is not so good at...
Funny thing-the IBM DID lock first with 2.6.1210 so I changed the ini.Then I went for a short cruise,but I" need" overzoom so I put it back on .Now it's ok...a ghost in my machines?
__________________
HappySeagull is offline   Reply With Quote
Old 16-12-2011, 13:15   #19
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: OpenCPN Beta Build 2.6.1215

I'm STUCKin Florida (TrueScale 400 100%)after a stop at Cape Hatteras where she wouldn't stick because she wouldn't zoom so far at that place-but Wait.I found a spot in the Chesapeake where her gumboots sunk in...100%.That's the clue,I guess.Something to do with the CM93 cells?allowing 100%?
Nope.take it back.Twas "15x" in SanDiego.
__________________
HappySeagull is offline   Reply With Quote
Old 16-12-2011, 14:09   #20
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: OpenCPN Beta Build 2.6.1215

Tried a crispy new install.everything uninstalled.Totally default settings.(but No internet connection,if that's important...)
First off,just load cm93 and I thought aha bug is gone!she zooms to infinity (0)and recovers.But back in San Diego or the Cheapeake.I'm stuck again...

soo,disabled overzoom in "ini file..."
But still
Stuck at 400 in SanDiego...
__________________
HappySeagull is offline   Reply With Quote
Old 16-12-2011, 17:11   #21
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: OpenCPN Beta Build 2.6.1215

..The 2.6.1125 Ubuntu build I'm using on Puppy Linux accessing the same cm93 chart folder...is fine (also on the Dell D420 on its own partition).It reaches all the same zoom levels but doesn't get stuck.
__________________
HappySeagull is offline   Reply With Quote
Old 16-12-2011, 18:25   #22
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN Beta Build 2.6.1215

Happy....

OK, I found a point that gets stuck on Windows XP, no Opengl, cm93 only.

SanDiego

32 42 N
117 14 W

Same location works just fine on linux...

I'll be looking into this now.

Thanks
Dave
__________________
bdbcat is online now   Reply With Quote
Old 18-12-2011, 08:37   #23
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,018
Re: OpenCPN Beta Build 2.6.1215

Dave...
Some OpenGL observations on my Win7 workstation:
  • The chart info window still disappears right after it's rendered - first it's rendered, then the border disappears instantly (screenshot), then even the rest disappears after another split second.
  • While panning the charts around, I get the behavior shown on the big screenshot at the edge between raster and CM93 coverage.
  • I've also had artifacts at the bottom of the chart canvas as seen on the 200% screenshot, but can't reproduce it anymore.
Code:
1:59:47 PM: OpenGL-> Renderer String: Intel(R) HD Graphics
1:59:47 PM: OpenGL-> Framebuffer Objects unavailable
1:59:47 PM: OpenGL-> Using Stencil buffer clipping
1:59:47 PM: OpenGL-> Estimated Max Resident Textures: 98


Pavel
Attached Thumbnails
Click image for larger version

Name:	261215-chartinfo.png
Views:	77
Size:	6.5 KB
ID:	34858   Click image for larger version

Name:	261215-wrong_rendering.png
Views:	85
Size:	101.8 KB
ID:	34859  

Click image for larger version

Name:	261215-artifacts.png
Views:	78
Size:	5.0 KB
ID:	34860  
__________________
nohal is offline   Reply With Quote
Old 18-12-2011, 11:13   #24
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: OpenCPN Beta Build 2.6.1215

I had the disappearing Chart Info too on this Dell420
OpenCPN Beta Build 2.6.1215
No OpenGL then ,I said.But it isn't disappearing today,whicheverGL or not. though I can still get stuck)There are no thumbnails however.

But on a T42,OPCN ~1215-as-portable,everything is fine.
__________________
HappySeagull is offline   Reply With Quote
Old 18-12-2011, 14:21   #25
Registered User
 
SvLetitgo's Avatar

Join Date: Dec 2009
Boat: Lagoon 380 Letitgo
Posts: 110
Re: OpenCPN Beta Build 2.6.1215

we used to be able to display the grib on Open the latest version doesn't seem to let me

Any know problem

Thanks
__________________
svletitgo.com

From Dreamer to doer
SvLetitgo is offline   Reply With Quote
Old 18-12-2011, 15:29   #26
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN Beta Build 2.6.1215

Pavel, and other Intel integrated Graphics OpenGL testers........

As an experiment.....
If you could, please hack chcanv.cpp at line 11810 to disable the stencil buffer. I think there is some problem with Intel's OpenGL driver set and stencils....

Code:
 
         g_b_useStencil = false;
//          if( !bad_stencil_code && stencil && (sb == 8))
//                g_b_useStencil = true;
build and retest under similar conditions....

Thanks
Dave
__________________
bdbcat is online now   Reply With Quote
Old 18-12-2011, 16:07   #27
Registered User
 
Rik-lu's Avatar

Join Date: May 2010
Location: Luxembourg
Boat: HR40
Posts: 196
Images: 2
Re: OpenCPN Beta Build 2.6.1215

I scrolled up to 80 degrees north (twice) with opengl switched on and had this result:




after that I just saw the blue map on black background.

had to reinstall opencpn.

win7-64 with intel hd graphic.

try to go up or down to the end of the chart..... at 80 degrees.



and later without opengl this result:

__________________
Hi from Rik
Rik-lu is offline   Reply With Quote
Old 18-12-2011, 16:13   #28
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN Beta Build 2.6.1215

Rik...

Thanks for the report.

Should very very rarely need to reload OCPN.
Just delete the config file, and start normally.

Config file location is shown in Toolbox->Help .

Thanks
Dave
__________________
bdbcat is online now   Reply With Quote
Old 19-12-2011, 01:49   #29
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,018
Re: OpenCPN Beta Build 2.6.1215

Quote:
Originally Posted by bdbcat View Post
If you could, please hack chcanv.cpp at line 11810 to disable the stencil buffer. I think there is some problem with Intel's OpenGL driver set and stencils....
Dave...
I would say the behavior is exactly the same with the stencil buffer disabled.
Ah. And if it's worth something, the behavior of the wrong rendering above 80N is "animated" - two bitmaps are switched periodically about once a second.

Pavel
__________________
nohal is offline   Reply With Quote
Old 19-12-2011, 11:46   #30
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN Beta Build 2.6.1215

Pavel...

Thanks for the test.

Leaving aside lat> 80.0 for a moment....This is a Mercator failure, and anyway, polar bears can't type...

And not trying to dodge the issue completely....

Is it possible there are updated drivers available for your Graphics system? I Google the problem, and get lots of hits regarding old Intel drivers, Vista/W7 compatibility, etc., etc.

But I cannot reproduce, since it is so hardware dependent.
Intel graphics works fine for me on (tiny)XP.

I hesitate to suggest that testing your system with some 3D action games may flush out some more OpenGL issues unrelated to OCPN. Just sayin'....

Stumped
Dave
__________________

__________________
bdbcat is online now   Reply With Quote
Reply

Tags
opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCPN Beta Build 2.6.1210 bdbcat OpenCPN 45 15-12-2011 18:00
Open CPN and Google Earth bgrimwade OpenCPN 19 09-12-2011 16:32
OpenCPN Version 2.4 Beta Build 628 bdbcat OpenCPN 63 15-07-2011 19:17
Route Properties, Missing Functions James Baines OpenCPN 13 13-07-2011 05:31
OpenCPN Version 2.4 Beta Build 708 bdbcat OpenCPN 34 12-07-2011 14:20



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 09:56.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.