Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-11-2014, 04:46   #1
Registered User

Join Date: Dec 2013
Location: The Netherlands
Boat: Hallberg Rassy 40c
Posts: 9
opencpn baudrate

On my hdu I have installed opencpn with ubuntu - navigatrix.
ttyS0 must be on 4800 baud, ttyS1 on 57600 baud. But when I startup both are on 4800baud, when I change the baudrate in connections, nothing changes.
When I do : sudo stty -F /dev/ttyS1 57600 the baud rate is changed, but everytime when I resart I have to type that again.
How can I get this changes permanent ?
__________________

__________________
reinM is offline   Reply With Quote
Old 06-11-2014, 06:57   #2
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,018
Re: opencpn baudrate

reinM...
The best you can do is debug around https://github.com/OpenCPN/OpenCPN/b...hread.cpp#L834 and find out what the real problem is.
If you can't do it, please file a bug in the tracker (more info, like if the port is a real RS-232 port or an USB converter welcome) and write a launcher script calling stty for you.

Pavel
__________________

__________________
nohal is offline   Reply With Quote
Old 06-11-2014, 08:51   #3
Registered User

Join Date: Dec 2013
Location: The Netherlands
Boat: Hallberg Rassy 40c
Posts: 9
Re: opencpn baudrate

Hello Pavel,
I am not familiar with linux programming.
The computer I use is based on a D2500H board with Intel Atom D410 processor and 2 serial com poorts.
When I do the same under windows everything works fine !

Rein
__________________
reinM is offline   Reply With Quote
Old 06-11-2014, 10:33   #4
Marine Service Provider

Join Date: May 2013
Location: Norway
Posts: 571
Re: opencpn baudrate

Hi ! Has just tested under linux ( Xinutop) running 3.3.2302 and setting up two comports at 4800 and 57600 baud works just fine as excepted even after restarting opencpn and also fine after reeboot.
__________________
petter5 is offline   Reply With Quote
Old 07-11-2014, 07:29   #5
Registered User

Join Date: Dec 2013
Location: The Netherlands
Boat: Hallberg Rassy 40c
Posts: 9
Re: opencpn baudrate

Hi,

I installed xinutop-nav-13.05.img but I still have the same problem.
Changing baudrate in opencpn to 57600bd does not change, stays on 4800bd.
Typing : sudo stty -F /dev/ttyS1 57600, changes the baud rate to 57600 and it works.
My input is coming from a miniplex mux !
__________________
reinM is offline   Reply With Quote
Old 07-11-2014, 07:37   #6
Marine Service Provider

Join Date: May 2013
Location: Norway
Posts: 571
Re: opencpn baudrate

Witch version OpenCpn are you running in Xinutop ?? I'm using 3.3.2302
__________________
petter5 is offline   Reply With Quote
Old 08-11-2014, 04:06   #7
Registered User

Join Date: Dec 2013
Location: The Netherlands
Boat: Hallberg Rassy 40c
Posts: 9
Re: opencpn baudrate

On xunutop I use opencpn 3.2.0 date 2013-02-26 and on navigatrix 3.2.2 from 2013-05-08.
__________________
reinM is offline   Reply With Quote
Old 08-11-2014, 09:06   #8
Marine Service Provider

Join Date: May 2013
Location: Norway
Posts: 571
Re: opencpn baudrate

Maybee try to update your xinitop ??

Make your /etc/apt/sources.list file look like:

# ubuntu
deb Index of /ubuntu precise main multiverse restricted universe
deb Index of /ubuntu precise-updates main restricted universe
deb Index of /ubuntu precise-backports main multiverse restricted universe
deb Index of /ubuntu precise-security main multiverse restricted universe

deb Index of /nohal/opencpn/ubuntu precise main
deb-src Index of /nohal/opencpn/ubuntu precise main

# ubuntu partners
deb Index of /ubuntu precise partner

# special applications
#deb http://packages.medibuntu.org/ precise free non-free
deb http://archive.getdeb.net/ubuntu/ precise-getdeb apps
deb Index of /opencpn/opencpn/ubuntu precise main
deb Index of /alexx2000/doublecmd/ubuntu precise main
deb http://doc.hausser.ch/debpackages ubuntu-dha precise

# linutop
# deb Index of /linutop 5-0-3 main
# deb Index of /linutop 5-0-3-updates main

# form localhost
#deb http://127.0.0.1/mirror/archive.ubuntu.com/ubuntu/

then:
sudo apt-get update && apt-get upgrade

Then reebot and try to see if your settings is correct ??
__________________
petter5 is offline   Reply With Quote
Old 11-11-2014, 12:17   #9
Registered User

Join Date: Dec 2013
Location: The Netherlands
Boat: Hallberg Rassy 40c
Posts: 9
Re: opencpn baudrate

To update xinutop is a bit to complicated for me as linux starter.

I also tested on Linux Mint 17 -Mate and Cinnamon and it is not working.
Is it possible to make a batch file with the command `sudo stty -F /dev/tty S1 57600` before we start opencpn ?
__________________
reinM is offline   Reply With Quote
Old 11-11-2014, 14:09   #10
Marine Service Provider

Join Date: May 2013
Location: Norway
Posts: 571
Re: opencpn baudrate

Quote:
Originally Posted by reinM View Post
To update xinutop is a bit to complicated for me as linux starter.

I also tested on Linux Mint 17 -Mate and Cinnamon and it is not working.
Is it possible to make a batch file with the command `sudo stty -F /dev/tty S1 57600` before we start opencpn ?
No, it is not so complicated for a Linux starter.
  1. In the menu left lower corner at the Xinutop desktop, open the menu and start Terminal Emulator from the menu.
  2. With the cursor inside the black terminal window, type ( Copy&Paste:
    Code:
    sudo mousepad /etc/apt/sources.list
    and then press enter.
  3. In the text editor thart opens, look for the line:
    Code:
    deb http://ppa.launchpad.net/nohal/opencpn/ubuntu precise main
    Is this line there ?? If Yes, everything is ok. If not, copy the line above and paste into a new line in the editor, then press save.
  4. press exit from the mousepad text editor.
  5. Now, go th the black terminal window, copy this code:
    Code:
    sudo apt-get update && apt-get upgrade
    and paste into the terminal window, ( be sure the computer is connected to internet) press enter and wait for the conmputer to update. If you are asked co confirm, press Y and enter. Upgrade process will start. When finished, reeboot your computer and all is done.
__________________
petter5 is offline   Reply With Quote
Old 12-11-2014, 06:45   #11
Registered User

Join Date: Dec 2013
Location: The Netherlands
Boat: Hallberg Rassy 40c
Posts: 9
Re: opencpn baudrate

I have done all the instructions, the update stopped at :

get : 75 http ......
100% (68 Transaction ....
Then nothing more happened.

I did a restart and : one of the last things I saw was Xubuntu and starting ..
and the I had a black screen.

I build a new usb stick and the same happened.
__________________

__________________
reinM is offline   Reply With Quote
Reply

Tags
enc, opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual OpenCPN - 'OpenCPN on a Stick' r.fairman OpenCPN 23 16-10-2011 20:51
OpenCPN bdbcat OpenCPN 1343 19-09-2009 16:59
OpenCPN with BSB v4 selkie Navigation 4 03-08-2009 12:32



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 20:43.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.