Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 15-07-2019, 08:51   #1
Registered User

Join Date: Sep 2016
Location: Germany
Boat: Vega 499
Posts: 23
OpenCPN Android App 1.0.26 incorrect display

Hello, everyone,
since version 1.0.26 I have problems with the display.
I only use official maps from BSH Germany.
Sometimes whole tiles are missing or they are grayed out.
The resolution is sometimes more than miserable. But sometimes it gets better or worse when zooming.
I use OpenCPN on a Cat S61 and also on a Sony Tablet Z2.
The same problems on both devices.
Can anyone confirm these problems or has any idea how to fix them?
Some screenshots can be found in the appendix.
Greetings Jürgen

edit:
On my PC Win 10. everything runs as planned.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20190715-173653.jpg
Views:	30
Size:	199.3 KB
ID:	195993   Click image for larger version

Name:	Screenshot_20190715-173639.jpg
Views:	29
Size:	197.6 KB
ID:	195994  

Click image for larger version

Name:	Screenshot_20190715-173622.jpg
Views:	29
Size:	165.6 KB
ID:	195995   Click image for larger version

Name:	Screenshot_20190715-170252.jpg
Views:	28
Size:	175.7 KB
ID:	195996  

Click image for larger version

Name:	2019-07-15_LI.jpg
Views:	27
Size:	188.5 KB
ID:	195999  
__________________

Luckbert is offline   Reply With Quote
Old 15-07-2019, 09:12   #2
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 3,470
Re: OpenCPN Android App 1.0.26 incorrect display

These are InlandENCs, hence S-57 format. Anyhow, this should not happen.
__________________

bcn is offline   Reply With Quote
Old 15-07-2019, 09:15   #3
Registered User

Join Date: Dec 2005
Location: Helsingborg
Boat: Dufour 35
Posts: 3,554
Re: OpenCPN Android App 1.0.26 incorrect display

The Android App is handled in a separate forum, which is the right place to ask your question.
https://bigdumboat.com/aocpn/cpnapp.html
https://bigdumboat.com/aocpn/forum/f...play.php?fid=4
cagney is offline   Reply With Quote
Old 15-07-2019, 14:10   #4
Registered User

Join Date: Sep 2016
Location: Germany
Boat: Vega 499
Posts: 23
Re: OpenCPN Android App 1.0.26 incorrect display

Thank you for pointing that out,
I described the problem there.
Greetings Jürgen
Luckbert is offline   Reply With Quote
Old 15-08-2019, 01:19   #5
Registered User

Join Date: Sep 2016
Location: Germany
Boat: Vega 499
Posts: 23
Re: OpenCPN Android App 1.0.26 incorrect display !!!Now also on RPI!!!!

Hello, everybody,
I now have the problem described above also on an RPI.
Tiles are missing. In contrast to Android they are not shown in grey but missing from the beginning. They are the same tiles that cause problems under Android.

I installed openplotter V. 2.0.6 beta.
It is a RPI 3b+ with buster.

In the appendix 2 pictures.
Greetings Jürgen
Attached Thumbnails
Click image for larger version

Name:	OpenCPN_RPI.JPG
Views:	22
Size:	21.5 KB
ID:	197896   Click image for larger version

Name:	OpenCPN_Win10.JPG
Views:	20
Size:	32.5 KB
ID:	197897  

Luckbert is offline   Reply With Quote
Old 15-08-2019, 11:21   #6
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 2,515
Re: OpenCPN Android App 1.0.26 incorrect display

Jurgen..
Win10: What happens if you zoom in and click on a chart bar?
Hakan is offline   Reply With Quote
Old 15-08-2019, 11:27   #7
Registered User

Join Date: Sep 2016
Location: Germany
Boat: Vega 499
Posts: 23
Re: OpenCPN Android App 1.0.26 incorrect display

Hello, Hakan,
With WIN10 everything works fine and as it should.
In the app and with the RPI the tiles are not displayed.
If you compare the two pictures you can see it.
It doesn't matter if you zoom with the keys, "+", "-" or with the mouse wheel.
Greetings Jürgen
Luckbert is offline   Reply With Quote
Old 15-08-2019, 12:01   #8
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 5,632
Re: OpenCPN Android App 1.0.26 incorrect display

Luckbert...


Looks like simply missing cells.
On Win10, find the NAME of the "missing" cells, by using "single chart mode", and clicking the chart (piano) bar to choose individual charts. You will find the target .S57 files somewhere on your hard drive.



Then, go to RPI, and try to find those same cells (.S57 files) in that file system. Easier on RPI than on Android...


Can you find the S57 files (cells) that are not displayed correctly?


Thanks
Dave
bdbcat is offline   Reply With Quote
Old 15-08-2019, 14:32   #9
Registered User

Join Date: Sep 2016
Location: Germany
Boat: Vega 499
Posts: 23
Re: OpenCPN Android App 1.0.26 incorrect display

Hello, Dave,
You were right. The tiles are not available.
If I manually add the tiles then everything will work as expected.
Why the tiles are missing makes no sense to me. I used the "Chart downloader" on both systems.
I cannot tell yet where the error lies exactly.
I'm still looking for something.

If someone wants to participate in the search.
It is about the German ENC cards. The errors occur only with the following waterways. "Küstenkanal, "untere Havelwasserstrasse"

Greetings Jürgen
Luckbert is offline   Reply With Quote
Old 15-08-2019, 14:59   #10
Registered User

Join Date: Sep 2016
Location: Germany
Boat: Vega 499
Posts: 23
Re: OpenCPN Android App 1.0.26 incorrect display

Hello
It seems to be the downloader.
With the same procedure it works perfectly with WIN10.
With Android the tiles are missing.
With RPI the same tiles are missing as in Android.
Greetings Jürgen
Luckbert is offline   Reply With Quote
Old 15-08-2019, 19:02   #11
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 5,632
Re: OpenCPN Android App 1.0.26 incorrect display

Luckbert...


The chart list for DE that chart downloader uses is downloaded first, and is here:


https://raw.githubusercontent.com/ch...NC_Catalog.xml


Maybe check that out?


Dave
bdbcat is offline   Reply With Quote
Old 15-08-2019, 22:10   #12
Registered User

Join Date: Sep 2016
Location: Germany
Boat: Vega 499
Posts: 23
Re: OpenCPN Android App 1.0.26 incorrect display

Good morning,
I noticed something. All waters that cause problems have letters or signs in the word that are not international. ( "ẞ" "ü" "()" ) this could be the reason
Here are the examples.

Küstenkanal
Untere Havel-Wasserstraße (Plaue - Elbe)
Elbe-Lübeck-Kanal

Greetings Jürgen
Luckbert is offline   Reply With Quote
Old 16-08-2019, 05:28   #13
Registered User

Join Date: Aug 2009
Posts: 186
Re: OpenCPN Android App 1.0.26 incorrect display

Hello,


I have tried to register on Bigboat forum as Cagney told. But I didn't received any activation mail. I cannot register again, my login is used (by me... ) and there is nothing to do on the page to get any help.

If I login, I am recognized, but it asks me to activate my account... And I have no access.
I need help, please
__________________
Jean-Pierre
jpiebrig is offline   Reply With Quote
Old 16-08-2019, 05:39   #14
Registered User

Join Date: Sep 2016
Location: Germany
Boat: Vega 499
Posts: 23
Re: OpenCPN Android App 1.0.26 incorrect display

Did the mail end up in the spam folder?
Greetings Jürgen
Luckbert is offline   Reply With Quote
Old 16-08-2019, 05:57   #15
Registered User

Join Date: Aug 2009
Posts: 186
Re: OpenCPN Android App 1.0.26 incorrect display

Hi,


No, it doesn't ! I have had a look before.
__________________

__________________
Jean-Pierre
jpiebrig is offline   Reply With Quote
Reply

Tags
opencpn, enc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCPN on Android vs Navionics boating app? GTom Navigation 2 10-07-2019 16:11
OpenCPN User Manual now available as Android App bdbcat OpenCPN 8 20-06-2019 20:15
OpenCPN - incorrect bearings from ship rschaedel OpenCPN 33 31-07-2015 05:43
Android ´extGPS´app for OpenCPN sinbad7 OpenCPN 5 06-11-2014 03:35
Members List - Incorrect Data Wotname Forum Tech Support & Site Help 17 20-03-2011 05:15



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 21:47.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.