Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 13-04-2016, 09:42   #1
Registered User

Join Date: Nov 2009
Location: Cyprus
Boat: Amel Super Maramu 2000 53'
Posts: 30
OpenCPN 4.2 Plugins

Hi,

I just upgraded to OCPN 4.2. Thank you developers. More great work.

When I ran the new version it warned me that my Celestial and Weatherfax plugins were not compatible with 4.2.

I downloaded the new versions of these plugins said to be compatible with 4.2, (Celestial pi-2.0 and Weatherfax pi-1.5001), and they installed fine on Windows 7 64 bit.

However when I start OCPN I still get the same message that they are incompatible.

Other plugins such as Dogwatch and OCPN-draw work fine. As a single hander, the latter two plugins have solved my biggest wish for OCPN. Namely to draw a boundary line and set an alarm if the line is crossed or approached.

Any thoughts please on why Celestial and Weatherfax do not work?
__________________

__________________
Biggles is offline   Reply With Quote
Old 13-04-2016, 10:08   #2
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,018
Re: OpenCPN 4.2 Plugins

Biggles...
All the plugins on the download page are compatible with 4.2. My wild guess is that you still have some old DLLs in your plugin folder. You will sure find more information in the logfile.
FWIW celestial navigation 2.0 is currently unusable on Windows and causes a hang when entering a second sight, there is no fix available yet.

Pavel
__________________

__________________
nohal is online now   Reply With Quote
Old 13-04-2016, 10:11   #3
Marine Service Provider

Join Date: May 2013
Location: Norway
Posts: 571
Re: OpenCPN 4.2 Plugins

Quote:
Originally Posted by Biggles View Post
Hi,

I just upgraded to OCPN 4.2. Thank you developers. More great work.

When I ran the new version it warned me that my Celestial and Weatherfax plugins were not compatible with 4.2.

I downloaded the new versions of these plugins said to be compatible with 4.2, (Celestial pi-2.0 and Weatherfax pi-1.5001), and they installed fine on Windows 7 64 bit.

However when I start OCPN I still get the same message that they are incompatible.

Other plugins such as Dogwatch and OCPN-draw work fine. As a single hander, the latter two plugins have solved my biggest wish for OCPN. Namely to draw a boundary line and set an alarm if the line is crossed or approached.

Any thoughts please on why Celestial and Weatherfax do not work?
You will have to uninstall / remove the old version of the plugin - it seems that the old plugin remains in parallel with the new ? and is still present after installing the new version - thereby the error message.
__________________
petter5 is offline   Reply With Quote
Old 13-04-2016, 10:50   #4
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,389
Re: OpenCPN 4.2 Plugins

Go to your plugins directory and remove those two dll for the problem plugins. Then reinstall tacking careful note which version of ocpn you are installing into. Get the right path. Also you could look at the ini file for those plugins messages.
__________________
rgleason is online now   Reply With Quote
Old 14-04-2016, 09:22   #5
Registered User

Join Date: Nov 2009
Location: Cyprus
Boat: Amel Super Maramu 2000 53'
Posts: 30
Re: OpenCPN 4.2 Plugins

Quote:
Originally Posted by nohal View Post
Biggles...
All the plugins on the download page are compatible with 4.2. My wild guess is that you still have some old DLLs in your plugin folder. You will sure find more information in the logfile.
FWIW celestial navigation 2.0 is currently unusable on Windows and causes a hang when entering a second sight, there is no fix available yet.

Pavel
Hello Pavel. Thanks for your reply. I have found the problem. Firstly I did an upgrade to 4.2 on my Chuwi tablet running Windows 10. I installed the problematic plugins using the default folders and they both worked fine.

So I went back to my Windows 7 laptop where I had modified the install folder as a sub folder of the suggested default. When I reinstalled Weatherfax and Celestial, both were seen as compatible. So it would seem that there is a small problem in the program not recognising a non standard installation folder. No big deal.

Thanks for the heads up on the Celestial bug. I will have a play and see if I can reproduce it.

Cheers
__________________
Biggles is offline   Reply With Quote
Reply

Tags
enc, opencpn, plug

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCPN Beta Windows Plugins rgleason OpenCPN 155 26-08-2016 10:22
OpenCPN 3.3.xxxx and plugins : NMEA sentences list ? Gilletarom OpenCPN 17 01-05-2014 07:02
PreBuild for OpenCPN Beta and Head with plugins (OpenSUSE) dominig OpenCPN 3 03-07-2013 06:04
Installateur de plugins, Install software for plugins. Gilletarom OpenCPN 3 30-04-2013 06:57
Plugins for OpenCPN: How to Install ? amadeus Navigation 3 27-01-2011 09:13



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 09:35.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.