Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 16-10-2015, 17:15   #1
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,294
Unhappy OpenCPN 4.0 do not run correctly with PC Lenovo U41, under W 8.1

Hello Dave,

Since my PC ASUS 1001 is definitely off, I bought another PC.
U41 Lenovo, Intel Core i5 5200U CPU @ 2.20 GHz, 4.O Gb RAM, Intel HD Graphics 5500 with Windows 8.1. It is a 64-bit machine.

I installed 4.0 OpenCPN and two types of charts: The CM93 and raster charts of Brazil.
- Quilting ON mode, and OpenGL ON: Can not move the chart with the touchpad, if it is a raster charts or CM93.
- Quilting OFF mode, and OpenGL ON: Can not move the chart with the touchpad, if it is a raster charts or CM93.
- Quilting ON mode, and OpenGL OFF: You can move without difficulty, chart with the touchpad, whatever the type of charts.
- Quilting OFF mode, and OpenGL OFF: You can move without difficulty, chart with the touchpad, whatever the type of charts.

Note also that it is impossible to test the NV-Verlag charts with my dongle because it is impossible to install the charts. I alerted NV-Verlag about it and I expect their answer.

Best regards. Gilletarom.
__________________

__________________
Gilletarom is offline   Reply With Quote
Old 16-10-2015, 17:34   #2
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
Re: OpenCPN 4.0 do not run correctly with PC Lenovo U41, under W 8.1

Gilletarom...

re Lenovo U41...

Clearly this is a problem related to OpenGL.

1. Is the display of charts OK in OpenGL? Do they look right?

2. As a test, can you move around charts using the keyboard arrow keys (left, right, etc.)?

Thanks
Dave
__________________

__________________
bdbcat is offline   Reply With Quote
Old 16-10-2015, 18:04   #3
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,294
Re: OpenCPN 4.0 do not run correctly with PC Lenovo U41, under W 8.1

Quote:
Originally Posted by bdbcat View Post
Gilletarom...

re Lenovo U41...

1. Is the display of charts OK in OpenGL? Do they look right?
Yes, the chart are displayed correctly.
I can change chart using the charts bar.

Quote:
2. As a test, can you move around charts using the keyboard arrow keys (left, right, etc.)?
Nothing occur, if openGL ON, when I try to use left, right, page down or page up.
Also, it is impossible to center the chart at a point by clicking once in a point of chart.

It is also impossible to use "T" and "S" with CM93.
__________________
Gilletarom is offline   Reply With Quote
Old 16-10-2015, 21:05   #4
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
Re: OpenCPN 4.0 do not run correctly with PC Lenovo U41, under W 8.1

Gilletarom....

May we see your OCPN logfile, the section about OpenGL setup, something like this:

Code:
14:08:23 EDT: OpenGL-> Renderer String: Mesa DRI Intel(R) Q35 x86/MMX/SSE2
14:08:23 EDT: OpenGL-> Version reported:  1.4 Mesa 8.0.4
14:08:23 EDT: OpenGL-> Detected Intel renderer, disabling stencil buffer
14:08:23 EDT: OpenGL-> Texture rectangle format: de1
14:08:23 EDT: OpenGL-> Using Vertexbuffer Objects
14:08:23 EDT: OpenGL-> Using Framebuffer Objects
14:08:23 EDT: OpenGL-> Using FBO Stencil buffer
14:08:23 EDT: OpenGL-> Using Depth buffer clipping
14:08:23 EDT: OpenGL-> Using s3tc dxt1 compression
14:08:23 EDT: OpenGL-> Compressed tile size: 128kb (6:1)
14:08:23 EDT: OpenGL-> Minimum cartographic line width:  1.0
14:08:23 EDT: OpenGL-> Minimum symbol line width:  1.5
Thanks
Dave
__________________
bdbcat is offline   Reply With Quote
Old 17-10-2015, 02:37   #5
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,294
Re: OpenCPN 4.0 do not run correctly with PC Lenovo U41, under W 8.1

Quote:
Originally Posted by bdbcat View Post
Gilletarom....

May we see your OCPN logfile, the section about OpenGL setup, something like this:
.....
Dave
Here join my logfile
Attached Files
File Type: doc opencpn.log.doc (72.9 KB, 21 views)
__________________
Gilletarom is offline   Reply With Quote
Old 17-10-2015, 02:48   #6
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,759
Re: OpenCPN 4.0 do not run correctly with PC Lenovo U41, under W 8.1

Gilletarom...

you might want to look for an update of the Graphic driver (in case you did not already). Intel did publish some updates in the last weeks.

Hubert
__________________
bcn is online now   Reply With Quote
Old 17-10-2015, 03:06   #7
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,759
Re: OpenCPN 4.0 do not run correctly with PC Lenovo U41, under W 8.1

That's what I get (Dell XPS13 with i7-5500U) OCPN 4.0.0, OpenGL ON

Code:
11:01:36 AM: OpenGL-> Renderer String: Intel(R) HD Graphics 5500
11:01:36 AM: OpenGL-> Version reported:  4.3.0 - Build 10.18.10.3960
11:01:36 AM: OpenGL-> Detected Intel renderer, disabling stencil buffer
11:01:36 AM: OpenGL-> Texture rectangle format: de1
11:01:36 AM: OpenGL-> glGenerateMipmap unavailable
11:01:36 AM: OpenGL-> Detected Windows Intel renderer, disabling Vertexbuffer Objects
11:01:36 AM: OpenGL-> Vertexbuffer Objects unavailable
11:01:37 AM: OpenGL-> Using Framebuffer Objects
11:01:37 AM: OpenGL-> Using FBO Stencil buffer
11:01:37 AM: OpenGL-> Using Depth buffer clipping
11:01:37 AM: OpenGL-> Using s3tc dxt1 compression
11:01:37 AM: OpenGL-> Compressed tile size: 128kb (6:1)
11:01:37 AM: OpenGL-> Minimum cartographic line width:  1.0
11:01:37 AM: OpenGL-> Minimum symbol line width:  1.0
11:01:37 AM: ChartDB Cache policy:  Application target is 1024 MBytes
11:01:37 AM: Loading chart db version: V018
11:01:37 AM: Chartdb: Chart directory list follows
__________________
bcn is online now   Reply With Quote
Old 17-10-2015, 04:17   #8
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,294
Re: OpenCPN 4.0 do not run correctly with PC Lenovo U41, under W 8.1

Dave,

I try to update the graphic driver. The driver in this PC is the last driver (15/12/2014). So no possible to update it.
__________________
Gilletarom is offline   Reply With Quote
Old 17-10-2015, 06:45   #9
Registered User
 
boat_alexandra's Avatar

Join Date: Aug 2009
Location: Masachusetts
Boat: bristol 27
Posts: 2,803
Re: OpenCPN 4.0 do not run correctly with PC Lenovo U41, under W 8.1

maybe the framebuffer object is buggy on that platform. If you can edit glChartCanvas.cpp and hack in to make m_b_DisableFBO = true instead of false then try it might help.
__________________
boat_alexandra is offline   Reply With Quote
Old 17-10-2015, 06:46   #10
Registered User
 
boat_alexandra's Avatar

Join Date: Aug 2009
Location: Masachusetts
Boat: bristol 27
Posts: 2,803
Re: OpenCPN 4.0 do not run correctly with PC Lenovo U41, under W 8.1

if you enable glexpert mode you can disable accelerated panning, but this doesn't exactly do the same thing as disabling the fbo
__________________
boat_alexandra is offline   Reply With Quote
Old 17-10-2015, 07:11   #11
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
Re: OpenCPN 4.0 do not run correctly with PC Lenovo U41, under W 8.1

Gilletarom...

Have you tried 4.1.925, possibly as a parallel install?

Dave
__________________
bdbcat is offline   Reply With Quote
Old 17-10-2015, 07:28   #12
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,294
Re: OpenCPN 4.0 do not run correctly with PC Lenovo U41, under W 8.1

Quote:
Originally Posted by bdbcat View Post
Gilletarom...

Have you tried 4.1.925, possibly as a parallel install?

Dave
I just got this new machine and I have to rebuild my whole environment. For the part concerning OpenCPN, I was just running O4.0. I will install O 4.1.025 to see.
__________________
Gilletarom is offline   Reply With Quote
Old 17-10-2015, 08:00   #13
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,294
Re: OpenCPN 4.0 do not run correctly with PC Lenovo U41, under W 8.1

Dave,

Installed the 4.1.925 release in parallel.

I note two things:
- Same problem with O4.0. OpenGL mode ON, you can not move the map.
- The texts are small and the icon bar is not very great. See the screenshots.

To understand :
My tablet was bi dOS: W 8.1 and android. I can not run the android but still running 8.1 W (I upgraded W 10).
On this tablet under 8.1 W, the parallel use of O4.0 and O41925 is impossible. Indeed, the text with O41925 were ridiculously small. I changed all the text sizes. But now with text 04.0 are enormous. So on the tablet, O4.0 became unusable.

So on the Lenovo:
If I change the font sizes in 4.1.925, to enlarge them, they will automatically be far too great in O4.0. Pfuuuu.
Attached Thumbnails
Click image for larger version

Name:	2015-10-17_Window_options_with_O40.jpg
Views:	37
Size:	99.0 KB
ID:	111126   Click image for larger version

Name:	2015-10-17_Screen_with_O40.jpg
Views:	43
Size:	344.6 KB
ID:	111127  

Click image for larger version

Name:	2015-10-17_Screen_with_O41925.jpg
Views:	45
Size:	371.3 KB
ID:	111128   Click image for larger version

Name:	2015-10-17_Window_options_with_O41925.jpg
Views:	37
Size:	58.4 KB
ID:	111129  

__________________
Gilletarom is offline   Reply With Quote
Old 17-10-2015, 09:24   #14
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
Re: OpenCPN 4.0 do not run correctly with PC Lenovo U41, under W 8.1

Gilletarom...

Of course we can address the issues of icon and text size when migrating from O4 to the next official release. Just not done yet.

I am more concerned with OpenGL W8.1 on the HD5500 GPU. This GPU core may become more common as the newer intel CPU generations reach the market.

I will need to build some test versions for your specific machine, and ask you to download and report results. Probably we will need some special case conditions in the code to accommodate this chipset. Sigh....

Please stand by.
Dave
__________________
bdbcat is offline   Reply With Quote
Old 17-10-2015, 22:31   #15
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
Re: OpenCPN 4.0 do not run correctly with PC Lenovo U41, under W 8.1

Gilletarom....

Here is a link to a custom build 4.1.1017 for Windows.
https://www.dropbox.com/s/f2kzuooqh0...setup.exe?dl=0

This is built specifically to test OpenGL on the Lenovo Win 8.1 HD5500 GPU system. It may have other problems, but we just want to check chart panning/zooming on the HD5500 systems. This Test uses the simplest possible OpenGL configuration.

If possible, please download, test, and report results. Again, we would like to see the logfile.

Good Luck
Dave
__________________

__________________
bdbcat is offline   Reply With Quote
Reply

Tags
enc, opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Solar not Working Correctly? simonpickard Electrical: Batteries, Generators & Solar 78 11-09-2014 10:29
Is My Shore Power Earthed Correctly ? Shanaly Electrical: Batteries, Generators & Solar 5 14-08-2012 06:15
Mosquito Screens - How to Insert Correctly ? sec906 Health, Safety & Related Gear 2 18-07-2010 18:43
Navionics Chart Pricing: Am I Interpreting this Correctly ? teneicm Navigation 3 26-06-2010 15:05
Two Battery Banks Correctly Charged? bryan and wendy Electrical: Batteries, Generators & Solar 20 14-01-2010 09:42



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 12:08.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.