Cruisers Forum
 


Join CruisersForum Today

Closed Thread
 
Thread Tools Rating: Thread Rating: 4 votes, 4.75 average. Display Modes
Old 02-09-2009, 10:27   #991
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Dave..

I don't want to confuse the issue now that you are busy stabilizing OpenCPN,BUT, on my wish list:

1. I notice an .xml file is being created in the same area as the opencpn.ini file.
My question is: would it be possible,as an option to create an .xml file of the ship locations and info based on the map display? See example below:

<markers>
<marker lat='36.109' lon='-5.417' name='GREEN MAGNIFIC' dx='0' dy='0' type='79' ais='311029000!9011492!C6VY3!ALGECIRAS!Aug25 10:00!0.1!235.4!1!136!16!5.7!2009-08-28 00:33:21UTC!de!A'/>
<marker lat='36.093' lon='-5.365' name='YAMAMAH' dx='-0.005' dy='0.008' type='89' ais='257840000!7431210!LAFM2!!!5.9!328.5!0!170!25! 11.4!2009-08-28 00:33:21UTC!de!A'/>
<marker lat='35.965' lon='-5.604' name='ANICIA' dx='-0.016' dy='-0.001' type='70' ais='258762000!8115552!LAJY6!!!10.3!266.1!0!106!18 !5.2!2009-08-28 00:33:22UTC!de!A'/>
<marker lat='36.144' lon='-5.435' name='EDITH MAERSK' dx='0' dy='0' type='71' ais='220501000!9321548!OXOR2!!!0!181.9!5!398!56!15 .5!2009-08-28 00:33:25UTC!de!A'/>
<marker lat='36.141' lon='-5.314' name='ELECTRON' dx='0' dy='0' type='70' ais='244265000!9186390!PBBQ!FOR ORDERS!Aug14 22:00!0!37!1!118!18!5.2!2009-08-28 00:31:46UTC!de!A'/>
</markers>
__________________

__________________
sinbad7 is offline  
Old 02-09-2009, 11:09   #992
Registered User
 
LeaseOnLife's Avatar

Join Date: Apr 2008
Location: out cruising again
Boat: Sailboat
Posts: 1,046
Heading debug

Dave, it only seems to capture the first sec of NMEA data. I sent you the log file as email.

Dirk
__________________

__________________
LeaseOnLife is online now  
Old 02-09-2009, 13:57   #993
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Seems most problems occur when accessing the right mouse click menu. Could there be a problem with the selection box itself somehow?
__________________
sinbad7 is offline  
Old 02-09-2009, 14:40   #994
Senior Cruiser
 
idpnd's Avatar

Cruisers Forum Supporter

Join Date: Sep 2007
Location: Almerķa, ES
Boat: Chiquita 46 - Libertalia
Posts: 1,551
Quote:
Originally Posted by bdbcat View Post
Never tried on Gnome....

Could it be that the boxes are not being erased between clicks of Leg/Route box?
It does this without any clicking out of the box, see KDE screenshot as well.
__________________
idpnd is offline  
Old 02-09-2009, 15:01   #995
Registered User
 
LeaseOnLife's Avatar

Join Date: Apr 2008
Location: out cruising again
Boat: Sailboat
Posts: 1,046
Confirm bug fixed: Suppress AIS Alerts for anchored vessels

Dave

Good news.

I haven't had a false alarm, all day, with several anchored class a and class b AIS vessels around me. But I do get valid alarms from vessels coming into the harbor.

Great! Thanks!

Dirk
__________________
LeaseOnLife is online now  
Old 02-09-2009, 18:59   #996
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Extreme propagation in Costa Verde today.. Note also good display of ship name..

http://yachtmarine.com/httpdocs/Goodrange.jpg
__________________
sinbad7 is offline  
Old 02-09-2009, 22:32   #997
Registered User

Join Date: Aug 2009
Posts: 183
Dave,

Thank's for your good work.

I have two problems :
* with V1.3.3 build 901 when I open a big scale chart like a World chart, it doesn't open immediatly, only after 8 or 10 seconds, then if I try anything with the cursor (and sometimes without doing anything), Opencpn becomes gray for 15/30 seconds (it freezes) then the colors come back for 5 or 10 seconds and then gray again, colors again and so on. If the colors stay, it is very difficult to do anything, quite impossible to center the chart, move it, open Toolbox, etc. Sometimes it stays gray and I have to kill Opencpn. Sometimes, when the colors are there, I succeed to change the chart for a detail one and then all become normal.
During that problem the processor is always half occuped which is a lot.
Never happend with detail charts, neither with cm93.

* Other small problem : sometimes the picture of the boat and the black line before the boat keep the orientation of the previous COG when the boat turn. Just look at the picture it will be more easy to understand, the boat is following the route :

__________________
jpiebrig is offline  
Old 02-09-2009, 22:39   #998
Registered User

Join Date: Aug 2009
Posts: 183
Oups ! I forget my picture's URL :

http://www.cijoint.fr/cjlink.php?file=cj200909/cijRDuhREx.png
__________________
jpiebrig is offline  
Old 03-09-2009, 02:53   #999
Registered User
 
phiggins's Avatar

Join Date: Nov 2004
Location: Toronto, Canada
Posts: 1,288
Send a message via Skype™ to phiggins
Dave,

I found the problem trying to build openCPN with Visual Studio 2008. I had to recompile all the wxWidgets with /MTd. Thanks for all your help.
__________________
Paul,
" One moment you are running along, the next you are no more." Dean Spanley
phiggins is offline  
Old 03-09-2009, 06:42   #1000
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Quote:
I don't want to confuse the issue now that you are busy stabilizing OpenCPN,BUT, on my wish list:

1. I notice an .xml file is being created in the same area as the opencpn.ini file.
My question is: would it be possible,as an option to create an .xml file of the ship locations and info based on the map display? See example below:

<markers>
<marker lat='36.109' lon='-5.417' name='GREEN MAGNIFIC' dx='0' dy='0' type='79' ais='311029000!9011492!C6VY3!ALGECIRAS!Aug25 10:00!0.1!235.4!1!136!16!5.7!2009-08-28 00:33:21UTC!de!A'/>
</markers>
Being able to create .xml files from the displayed chart would be great for the display of boat positions etc. in regattas which could be published over the internet using the google map interface. Many boats now have access to internet via wireless connection and could view all the positions of the regatta participants well outside their own AIS range.

Food for thought?
__________________
sinbad7 is offline  
Old 03-09-2009, 11:20   #1001
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,248
Dave

Some inconsistency in the display of CM93 chart-outlines in Build 901.
If I start OpenCpn in West Indies I can't see any outlines of CM93 charts. Moving East, looking at the Med a full display of charts starts at the Greenwich Meridian. Moving further east the CM93 charts show up fine in the whole Eastern Hemisphere, but as soon as the middle of my screen passes the dateline, all CM93 chart outlines disappears.
Bsb- and ENC- chart outlines works just fine, only a cm93 problem.
Her we go again.......another mole to whack!!!

Thomas
__________________
cagney is offline  
Old 03-09-2009, 12:17   #1002
Registered User

Join Date: Jul 2009
Location: The Netherlands
Boat: Koopmans, 33 ft cutter
Posts: 170
Quote:
Originally Posted by cagney View Post
Dave

Some inconsistency in the display of CM93 chart-outlines in Build 901.
If I start OpenCpn in West Indies I can't see any outlines of CM93 charts. Moving East, looking at the Med a full display of charts starts at the Greenwich Meridian. Moving further east the CM93 charts show up fine in the whole Eastern Hemisphere, but as soon as the middle of my screen passes the dateline, all CM93 chart outlines disappears.
Bsb- and ENC- chart outlines works just fine, only a cm93 problem.
Her we go again.......another mole to whack!!!

Thomas
Thomas,

I have tried to duplicate your observations, but I do not have the problem you describe. The West-Indies show up fine and nothing strange happens when I pass from East to West.
I'm on Vista and use the 2009 update of cm93 (and nothing else) with openCPN.

Klaas
__________________
Zoef is offline  
Old 03-09-2009, 12:22   #1003
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Thomas..

Same here,all outlines are visible cm93 v. 2006 - Vista...

/Tore
__________________
sinbad7 is offline  
Old 03-09-2009, 12:32   #1004
Registered User

Join Date: Aug 2009
Posts: 211
OK here too, running Vista and OpenCPN with CM93 2002. No other charts installed.

(Not wishing to start any thread drift but is there anywhere online I can get hold of CM93 2009 update?)
__________________
ColdFusion is offline  
Old 03-09-2009, 13:59   #1005
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,248
Strangest thing......
Turning OpenCPN off and then starting again....
Sometimes I can repeat the CM93 "bug" above, but on occasion the program starts with all the outlines working ???
No obvious pattern, or apparent cause to this,....yet.

Thomas
__________________

__________________
cagney is offline  
Closed Thread

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 05:22.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.