Cruisers Forum
 


Join CruisersForum Today

Closed Thread
 
Thread Tools Rating: Thread Rating: 4 votes, 4.75 average. Display Modes
Old 20-07-2009, 16:47   #451
Registered User

Join Date: Jul 2009
Location: Miami, fl
Boat: Hobie 16 & Hatteras 53
Posts: 5
first post here, let me start with a BIG thank you for your work and your support !!

i'm running 1.32 on a Vista 64 HP Tablet Touchsmart with a globalsat BT368 bluetooth GPS configured on com7. Available options in the toolbox are COM3, 5 and 6 so GPS isnt't recognized and I can't change the port nr in windows bluetooth settings.

I saw the post about opencpn.ini file which i can't find on my system.. Also about xport but i dont' know if that will run on v64 and i like to keep things simple.

is there a way to configure a com7 GPS?

So far, I find OpenCPN to be a nice alternative to SeaClear, especially the tide data integration. Scroll wheel works fine on V64.


__________________

__________________
pascalG is offline  
Old 20-07-2009, 17:11   #452
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
pascalG....

Welcome aboard.

Does your COM7 GPS appear in the system Device Manager as a COM port?
If it does, it should appear in the pulldown list for NMEA Data Source.

If it does not, this is the problem.
Are there any other references to COM7 in the Device Manager?

You could also try editing the .INI file found in

Documents and Settings\{user}\Application Data\opencpn\opencpn.ini

Good luck, and let us know the results....

Dave
__________________

__________________
bdbcat is offline  
Old 20-07-2009, 17:15   #453
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
Linux users....

Has anyone compiled Build 716 from CVS source?
If so, what are the available choices for NMEA data source?

It is reported that
/dev/ttyUSB0
/dev/ttyUSB1
have disappeared from Build 716.

I can't reproduce this on Kubuntu 7.10....Mysterious....

Thanks
Dave
__________________
bdbcat is offline  
Old 20-07-2009, 17:42   #454
Registered User

Join Date: Jul 2009
Location: Miami, fl
Boat: Hobie 16 & Hatteras 53
Posts: 5
i was coming back to edit my post since i found the ini file, edited it to COM7 and it worked! don't i feel like an idiot... I should have known Vista would "hide" the ini file somewhere else

COM7 appears in Device Manager as "Standard Serial over bluetooth link (com7)
same for COM8. yet COM7 doesn't appear in the Toolbox, until i manaually edit the ini file.

There is still a glitch i need to solve but it seems to be a Bluetooth SPP issue... with XP and a usb delorme GPS, i was able to use 2 GPS apps at the same time. Now, in Vista 64 and Bluetooth, i can't run two apps. I typically run OpenCPN and Goops (a small utility which uploads position in Google Earth KML file...)
__________________
pascalG is offline  
Old 20-07-2009, 18:17   #455
Registered User

Join Date: Oct 2008
Location: San Diego, CA
Boat: Beneteau Oceanis 38.1
Posts: 244
Dave,

Once again, thanks so much for openCPN - it's really a great piece of software. We used 1.3.2 for our delivery to Newport and race around Catalina last weekend and it worked great. Tons of AIS targets on-screen at once, bouncing back and forth between BSB and ENC charts, and frequently putting the laptop to sleep with everything plugged in and it all worked wonderfully.

I have two feature requests to add to the wish-list:

1) Tracks. I'd love to be able to record tracks for later analysis. It could be something as simple as a Turn Tracking On/Off button, a simple way to delete them (just a button to clear all tracks, or perhaps a pop-up menu with a delete option when you right-click on a track), and when you select GPX Out save all tracks along with the routes.

2) A ruler to measure distances. Yeah, I know this violates the "it's an underway tool, not a planning tool" axiom, but IMO that's all you'd need to make openCPN a great planning tool.

Thanks again!
__________________
gjorgensen is offline  
Old 20-07-2009, 18:20   #456
Registered User
 
phiggins's Avatar

Join Date: Nov 2004
Location: Toronto, Canada
Posts: 1,288
Send a message via Skype™ to phiggins
I'll second both of those suggestions by gjorgensen. I was going to ask for the track enhancement next.
__________________
Paul,
" One moment you are running along, the next you are no more." Dean Spanley
phiggins is offline  
Old 21-07-2009, 17:37   #457
Registered User

Join Date: Jul 2009
Location: Miami, fl
Boat: Hobie 16 & Hatteras 53
Posts: 5
I solved the sharing issue mentioned above by installing Franson GPSGate. The $12 express version allows 2 programs to share 1 GPS. works well, stable, easy to configure. actually, it seems to make the bluetooth connection more stable.

another question though... I see that routes are saved in teh Ini file, which is ok except that they were lost when i upgraded 1.3 to 1.32.

I did notice that with a number of wyapoints already in (two routes, 100+ wp altogether) it is taking much longer to update a route when a WP is inserted, moved or modified. 3 to 4 seconds delay now during which vista flags the window as non responding, which is borderline acceptable.
__________________
pascalG is offline  
Old 21-07-2009, 18:25   #458
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
pascalG...

Regarding your points:
1. Next version for Windows will have a setup option to retain old configuration files.

2. Do you mean that you have routes with an average of 50 waypoints in each route, or that there are many isolated waypoints in addition to a moderate number of waypoints in each route? I never tested with 50 waypoints in a route.....
I'll have a look at the code and see what this means.

Thanks
Dave
__________________
bdbcat is offline  
Old 21-07-2009, 19:02   #459
Obsfucator, Second Class
 
dacust's Avatar

Cruisers Forum Supporter

Join Date: Feb 2008
Location: Southeast USA.
Boat: 1982 Sea Ray SRV360
Posts: 1,743
Quote:
Originally Posted by pascalG View Post
... I did notice that with a number of wyapoints already in (two routes, 100+ wp altogether) it is taking much longer to update a route when a WP is inserted, moved or modified. 3 to 4 seconds delay now ...
Quote:
Originally Posted by bdbcat View Post
...I never tested with 50 waypoints in a route.....
That could be interesting. I have at least one route with over 3000 waypoints. Charleston to Chattanooga. I built it when I had Nobeltec, but my GPS was a Garmin 182. No marine maps, just blank space where there was water. So, with no depth or markers on the screen, I had the route with every little turn. I've gotten in the habit and still do it to that detail so if I loose the laptop, I still have a detailed route in the little GPS.

-dan
__________________
dacust is offline  
Old 22-07-2009, 04:50   #460
Senior Cruiser
 
idpnd's Avatar

Cruisers Forum Supporter

Join Date: Sep 2007
Location: Almerķa, ES
Boat: Chiquita 46 - Libertalia
Posts: 1,551
Quote:
Originally Posted by gjorgensen View Post
I have two feature requests to add to the wish-list:

1) Tracks. I'd love to be able to record tracks for later analysis. It could be something as simple as a Turn Tracking On/Off button, a simple way to delete them (just a button to clear all tracks, or perhaps a pop-up menu with a delete option when you right-click on a track), and when you select GPX Out save all tracks along with the routes.

2) A ruler to measure distances. Yeah, I know this violates the "it's an underway tool, not a planning tool" axiom, but IMO that's all you'd need to make openCPN a great planning tool.
I have taken the liberty of adding these two to the feature requests on sourceforge.
__________________
idpnd is offline  
Old 22-07-2009, 05:48   #461
Registered User

Join Date: Jun 2009
Location: Morbihan Brittany France
Boat: Hallberg Rassy 37
Posts: 64
Quote:
Originally Posted by bdbcat View Post
Linux users....

Has anyone compiled Build 716 from CVS source?
If so, what are the available choices for NMEA data source?

It is reported that
/dev/ttyUSB0
/dev/ttyUSB1
have disappeared from Build 716.
I can't reproduce this on Kubuntu 7.10....Mysterious....

Dave
I tried last CVS on Ubuntu-9.04 and it works as before, your helper copy files from /proc/tty/driver/*serial to /var/tmp/*serial to discover which serial devices [USB or not] is active even when not running as root.

Note that if you have an existing $HOME/.opencpn then you extract devices from the existing list. People may want to delete .opencpn for a fresh try.

Finally I would add that scanning /dev/ttyS*|ttyUSB* and checking which one can be open would be as efficient and would not imply using a helper with superuser stickybit. It would also allow to handle device alias as generate by UDEV to support device hotplug when sleeping on ram.
__________________
fulup is offline  
Old 22-07-2009, 14:20   #462
Registered User

Join Date: Jul 2009
Location: Miami, fl
Boat: Hobie 16 & Hatteras 53
Posts: 5
Dave

yes, i have two routes in right now, one has 99 WP (my seasonal trip north) and the other one has 26 WP (an upcoming week long trip in the north east).

it seems that the delay in saving route/wp updates builds up over time as routes/wp are edited. There is no delay for the first few updates but after 10 or 15 the delay build up to well over 5 seconds. exiting the program and restarting, allows to edit with no delay until it builds up again.
__________________
pascalG is offline  
Old 22-07-2009, 17:46   #463
Registered User
 
phiggins's Avatar

Join Date: Nov 2004
Location: Toronto, Canada
Posts: 1,288
Send a message via Skype™ to phiggins
Dave,

Thanks for the instructions that you emailed me on how to get the latest CVS release and compile it on my XO. Its up and running now and will check your new features.
__________________
Paul,
" One moment you are running along, the next you are no more." Dean Spanley
phiggins is offline  
Old 22-07-2009, 18:23   #464
Registered User
 
phiggins's Avatar

Join Date: Nov 2004
Location: Toronto, Canada
Posts: 1,288
Send a message via Skype™ to phiggins
Dave,

Ran the AIS simulator againt openCPN V1.3.3 build 716 on the XO and the way you show the CPA graphic is much easier too see now.

Also re your question about /dev/ttyUSB0/1 they are both there on the XO running linux Ubuntu Intrepid. The /dev/ttys0/1 are also there.
__________________
Paul,
" One moment you are running along, the next you are no more." Dean Spanley
phiggins is offline  
Old 22-07-2009, 20:07   #465
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
pascalG...

Now I am confused. I don't see any unreasonable delay editing a route of 50 waypoints under VirtualBox XP. 1 or 2 seconds, not increasing.....
It is much faster under native Ubuntu.

Where exactly is the delay happening for you, and increasing?

1. Right-click ->Insert Waypoint->Redraw?
2. Waypoint Drag->Redraw?
3. Right-Click -> Waypoint Properties->OK->Redraw?
4. Right Click ->Route Properties->OK->Redraw?
5. Other?

Thanks
Dave
__________________

__________________
bdbcat is offline  
Closed Thread

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 19:57.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.