Cruisers Forum
 


Join CruisersForum Today

Closed Thread
 
Thread Tools Rating: Thread Rating: 4 votes, 4.75 average. Display Modes
Old 17-07-2009, 18:01   #421
Registered User
 
phiggins's Avatar

Join Date: Nov 2004
Location: Toronto, Canada
Posts: 1,288
Send a message via Skype™ to phiggins
Oops spoke too soon. Running my AIS simulator on the beta version I got:

Unhandled exception at 0x0050a4fc in opencpn.exe: 0xC0000005: Access violation reading location 0xffffffff.
__________________

__________________
Paul,
" One moment you are running along, the next you are no more." Dean Spanley
phiggins is offline  
Old 17-07-2009, 18:27   #422
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
phiggins...

Sourceforge CVS files are up-to-date, if you feel up to downloading and compiling....

I can give CVS download/compile tips if you need them.

Dave
__________________

__________________
bdbcat is offline  
Old 17-07-2009, 18:35   #423
Registered User
 
phiggins's Avatar

Join Date: Nov 2004
Location: Toronto, Canada
Posts: 1,288
Send a message via Skype™ to phiggins
Dave,

Don't think I have a compiler on the XO so I'll have to get the.deb

The exception happens when I run the simulator on Vista for about 5 minutes. When I ran it and watched it it didn't happen. Seems to only happen when openCPN is not the active window.
__________________
Paul,
" One moment you are running along, the next you are no more." Dean Spanley
phiggins is offline  
Old 17-07-2009, 18:49   #424
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
phiggins...

OK, how do I run the simulator on XP/Vista?
I have Python 2.6.2 on XP.

Dave
__________________
bdbcat is offline  
Old 17-07-2009, 18:59   #425
Registered User
 
phiggins's Avatar

Join Date: Nov 2004
Location: Toronto, Canada
Posts: 1,288
Send a message via Skype™ to phiggins
I resent the instructions that I sent you originally. Besides python you need a virtual port program like ComEmulDrv3 to send openCpn data. See the instructions for the link.

I'm retrying on XP to see if itfails.
__________________
Paul,
" One moment you are running along, the next you are no more." Dean Spanley
phiggins is offline  
Old 17-07-2009, 19:42   #426
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
XP/Vista users with Opencpn 1.3.3 Build 716....

Question: When you enable Wheel-Zoom-To-Cursor, and zoom in, does the cursor jump to mid-screen after the zoom? Or does it stay where it was, relative to the screen, and thus in the wrong place relative to the new zoomed chart?

Works on linux, no works on XP VirtualBox. Wondering....

Thanks
Dave
__________________
bdbcat is offline  
Old 17-07-2009, 19:51   #427
Registered User
 
phiggins's Avatar

Join Date: Nov 2004
Location: Toronto, Canada
Posts: 1,288
Send a message via Skype™ to phiggins
Dave,

I can't reproduce it on XP but it happens on Vista even after I reboot and only run the simulator and openCPN. I attached a snapshot of the Visual Studio debug screen.
Attached Thumbnails
Click image for larger version

Name:	Unhandled.Exception.jpg
Views:	107
Size:	151.7 KB
ID:	8988  
__________________
Paul,
" One moment you are running along, the next you are no more." Dean Spanley
phiggins is offline  
Old 17-07-2009, 19:59   #428
Registered User
 
phiggins's Avatar

Join Date: Nov 2004
Location: Toronto, Canada
Posts: 1,288
Send a message via Skype™ to phiggins
Re your Zoom question: the cursor and the place on the chart that cursor is, jump to the middle of the screen, thus cursor is still over place it was before the zoom. Seems correct to me.
__________________
Paul,
" One moment you are running along, the next you are no more." Dean Spanley
phiggins is offline  
Old 17-07-2009, 20:14   #429
Registered User
 
Viking Sailor's Avatar

Join Date: Nov 2006
Location: San Francisco Bay
Boat: Fantasia 35 - s/v Feeling Good
Posts: 1,074
Dave,

Zoom to cursor works correctly on my XP box. Place cursor any place on chart feature, roll the wheel, and the feature and cursor jump to the center.

Thanks,

Paul
__________________
Viking Sailor is offline  
Old 17-07-2009, 20:18   #430
Registered User
 
Tia Bu's Avatar

Join Date: Jul 2009
Location: South Carolina
Boat: 40' Jeanneau
Posts: 454
Cagney and Sinbad7, thanks for your help with my CM 93 chart loading problems. I have downloaded different files from another source and am getting the same results. Maybe I'm just doing something a little bit wrong? No trouble at all loading NOAA ENC's or RNC's. Any ideas? I still get the brief appearance of a brown bar on the lower horizontal bar, and then that disappears. (Thanks to Blubaju also for his suggestion.)
__________________
Tia Bu is offline  
Old 17-07-2009, 20:30   #431
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Tia Bu.. A silly question,BUT, you DO select the DIRECTORY cm93 and not the files?
Have you tried putting the cm93 files in a different directory? What about the directory itself? are you using the correct upper/lower case?
__________________
sinbad7 is offline  
Old 17-07-2009, 20:30   #432
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
Tia Bu....

Lets look at your log file.

\Documents and Settings\{user}\Application Data\opencpn\opencpn.log

Post the last runtime session log here, if you please.

Thanks
Dave
__________________
bdbcat is offline  
Old 17-07-2009, 21:21   #433
Registered User
 
Tia Bu's Avatar

Join Date: Jul 2009
Location: South Carolina
Boat: 40' Jeanneau
Posts: 454
Dave:

My most recent attempts have been on the Ubuntu machine. Where would these runtime session files be on that system?
__________________
Tia Bu is offline  
Old 18-07-2009, 01:23   #434
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,247
Tia Bu the log file is in your home directory and is called opencpn.log
A quick way would be to write this on a command line: "tail -50 ~/opencpn.log". That gives you the 50 last lines of the log file. Adjust the number to make sure you catch the last session ( check the time stamp on each line).
Thomas
__________________
cagney is offline  
Old 18-07-2009, 07:17   #435
Registered User
 
Tia Bu's Avatar

Join Date: Jul 2009
Location: South Carolina
Boat: 40' Jeanneau
Posts: 454
Thanks, Cagney. I believe these might be the relevant lines from the last time I tried to load. This is with a new set of files from a different source than the first one I had problems with. And Sinbad7, your suggestions aren't silly at all. I've got to think it's something like you're suggesting. One question: Is there some limit to how far down in a tree of subdirectories OpenCPM will look for chart files? The current operation is much more user-friendly than SeaClear (also a great program), in which all the chart files have to be on the same level in the directory.

10:00:00 PM:


10:00:00 PM: 2009-07-17 -------Starting opencpn-------
10:00:00 PM: Using existing Config_File: /home/marshall/.opencpn/opencpn.conf
10:00:00 PM: Setting Viewpoint Lat/Lon 41.4286, -70.9202
10:00:00 PM: Using s57data in /usr/local/share/opencpn/s57data
10:00:00 PM: Using Tide/Current data from: /usr/local/share/opencpn/tcdata/
10:00:00 PM: Setting Viewpoint Lat/Lon 41.4286, -70.9202
10:00:00 PM: NMEA Data Source is....None
10:00:00 PM: AIS Data Source is....None
10:00:00 PM: Using WVSChart datafile: /usr/local/share/opencpn/wvsdata/wvs43.dat
10:00:00 PM: NMEA AutoPilot Port is....None
10:00:00 PM: MemoryStatus: mem_total: 1479676 kb, mem_initial: 374172 kb
10:00:01 PM: Initializing Chart /home/marshall/CM93/00300000/A/00300000.A
10:00:01 PM: CM93Composite Chart Init cannot locate CM93 dictionary.
10:00:01 PM: OpenChartFromStack...Error opening chart /home/marshall/CM93/00300000/A/00300000.A at index 0, return code 2
10:00:01 PM: Initializing Chart /home/marshall/CG Dist 1 RNC's/13229/13229_8.KAP
10:00:47 PM: searching for .geo
10:00:47 PM: searching for .KAP
10:00:47 PM: searching for .000
10:00:47 PM: searching for .S57
10:00:47 PM: searching for .CM93
10:00:47 PM: Create ChartTable Entry for /home/marshall/CM93/00300000/A/00300000.A
10:00:48 PM: Initializing Chart /home/marshall/CM93/00300000/A/00300000.A
10:00:48 PM: CM93Composite Chart Init cannot locate CM93 dictionary.
10:00:48 PM: OpenChartFromStack...Error opening chart /home/marshall/CM93/00300000/A/00300000.A at index 0, return code 2
10:14:19 PM: opencpn::MyFrame exiting cleanly...
10:14:19 PM: opencpn::MyApp exiting cleanly...
__________________

__________________
Tia Bu is offline  
Closed Thread

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 10:31.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.