Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 25-03-2019, 14:57   #1
Registered User

Join Date: Mar 2019
Location: Sweden
Boat: Dufour 385 GL
Posts: 5
Question oeSENC loader version 5 error

Hi,
Today I upgraded to OpenCPN version 5. I then went to O-Charts and purchased oeSENC Charts over Poland. When I try to retreive the charts in the Chart loader I get an error message saying that the program can't find MSVCP120.dll. I then tried to download a new oeSENC plug in for version 5 but got error while opening file for writing C: program files/(x86) OpenCPN/plugins/oesenc_pi.dll. Please find logfile enclosed.

Can some help me?

Thanks
Jan
Attached Files
File Type: pdf LogFileOpenCPN 190325.pdf (690.9 KB, 7 views)
__________________

Puddle_Sailor is offline   Reply With Quote
Old 25-03-2019, 15:08   #2
Registered User
 
transmitterdan's Avatar

Join Date: Oct 2011
Boat: Valiant 42
Posts: 5,084
Re: oeSENC loader version 5 error

Are you using Windows XP?
__________________

transmitterdan is offline   Reply With Quote
Old 25-03-2019, 15:13   #3
Registered User

Join Date: Mar 2019
Location: Sweden
Boat: Dufour 385 GL
Posts: 5
Re: oeSENC loader version 5 error

I'm using Windows 10
Puddle_Sailor is offline   Reply With Quote
Old 25-03-2019, 15:58   #4
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 5,066
Re: oeSENC loader version 5 error

Do you have the correct latest version of the plugin for OpenCPN 5.0? If so, go to https://www.microsoft.com/en-us/down....aspx?id=40784 and download and install the x86 version of the MSVC 2013 redistributable package that contains the DLL missing on your system.

Pavel
nohal is offline   Reply With Quote
Old 25-03-2019, 23:53   #5
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 2,398
Re: oeSENC loader version 5 error

Quote:
Originally Posted by Puddle_Sailor View Post
Hi,
Today I upgraded to OpenCPN version 5. I then went to O-Charts and purchased oeSENC Charts over Poland. When I try to retreive the charts in the Chart loader I get an error message saying that the program can't find MSVCP120.dll. I then tried to download a new oeSENC plug in for version 5 but got error while opening file for writing C: program files/(x86) OpenCPN/plugins/oesenc_pi.dll. Please find logfile enclosed.

Can some help me?

Thanks
Jan
Jan..
1. If oesenc search for MSVCP120.dll it may be very old? So update was good.

2.This "C: program files/(x86) OpenCPN/plugins/oesenc_pi.dll" error could be OpenCPN was opened while the new oeSENC plugin was installed?

Please try to restart Win10 (The MS first step for every trouble??).
Install the latest oeSENC_pi plugin before starting OCPN.
Start OCPN and go to Options->Plugins and activate oeSENC plugin.
Then go to Options->Charts->oeSENC Charts->Refresh (Uppdatera) charts list.
When asked enter your username and password for O-Charts.org and create a new System name. (3-15 characters without capitals so far.) And proceed to download the chart set.
Hakan is offline   Reply With Quote
Old 26-03-2019, 01:44   #6
Registered User

Join Date: Jul 2009
Location: GIRONDE FRANCE
Boat: HALLBERG RASSY 352
Posts: 11
Re: oeSENC loader version 5 error

Hello Jan, I fell in the same thread yesterday using the new plugin OESENC for OpenCpn V5 and I solve this in installing the runtime visual C++ found at microsoft :
https://www.microsoft.com/en-US/down....aspx?id=40784
MY OS is winxp sp3 32 bits so I choose the vcredist_x86.exe.
after installing this the msg MSVP120CP.dll not found disapear and OESENC works fine.
Don't know why the former version works without this stuf! we may ask to the programmer of the OESENC plugin. for now I don't ask this question to myself, as I deal with it.
cheers!
Caprarebird is offline   Reply With Quote
Old 26-03-2019, 12:49   #7
Registered User

Join Date: Mar 2019
Location: Sweden
Boat: Dufour 385 GL
Posts: 5
Re: oeSENC loader version 5 error

Quote:
Originally Posted by Hakan View Post
Jan..
1. If oesenc search for MSVCP120.dll it may be very old? So update was good.

2.This "C: program files/(x86) OpenCPN/plugins/oesenc_pi.dll" error could be OpenCPN was opened while the new oeSENC plugin was installed?

Please try to restart Win10 (The MS first step for every trouble??).
Install the latest oeSENC_pi plugin before starting OCPN.
Start OCPN and go to Options->Plugins and activate oeSENC plugin.
Then go to Options->Charts->oeSENC Charts->Refresh (Uppdatera) charts list.
When asked enter your username and password for O-Charts.org and create a new System name. (3-15 characters without capitals so far.) And proceed to download the chart set.


Håkan,
That didn't work.
When starting open CPN after installing version 5 of oeSENC plugin again I get: "Kodkörrningen kan inte fortsätta eftersom det inte går att hitta MSVCP120.dll. Prova att installera om programmet."
Puddle_Sailor is offline   Reply With Quote
Old 26-03-2019, 12:51   #8
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 5,066
Re: oeSENC loader version 5 error

Again, you must install the x86 (32bit) version of the MSVC 2013 redistributable from https://www.microsoft.com/en-us/down....aspx?id=40784 that contains the DLL library you are missing.
nohal is offline   Reply With Quote
Old 26-03-2019, 13:22   #9
Registered User

Join Date: Mar 2019
Location: Sweden
Boat: Dufour 385 GL
Posts: 5
Re: oeSENC loader version 5 error

I followed the link from Caprarebird, but took a chance on down loading the version that had x86 in it.
I have also down loaded and installed the the latest oeSENC_pi plugin again. Now I don't have any MSVP120CP.dll issues anymore.

However when running oeSENC plug in (version 2.9 1524) and I go to Refresh charts list I get promted to enter username and password then this gives me:
"o-Chart API error code {4}. Check your configuration and try again.


What's wrong now?
Puddle_Sailor is offline   Reply With Quote
Old 26-03-2019, 13:25   #10
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 2,398
Re: oeSENC loader version 5 error

But, Pavel, this is strange if where talking Win10 and the latest oeSENC_pi? where msvcp140.dll should be used and not msvcp120.dll. I thought the latter was used when we built: cmake -T v120_xp ..?
I've home built oeSENC using cmake -T v140_xp .. and so msvcp140.dll is needed and not msvcp120.dll
How is the oeSENC_pi Puddle... and Caprar.. are using built?


And BTW: I'm pretty sure you'll have a msvcp120.dll in your C:\Windows\System32\. Copy that file to your C:\Program Files (x86)\OpenCPN\ and test.
Or use the one attached here. Copy and delete .pdf in the end.
Håkan
Attached Files
File Type: pdf msvcp120.dll.pdf (644.7 KB, 4 views)
Hakan is offline   Reply With Quote
Old 26-03-2019, 13:26   #11
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 3,272
Re: oeSENC loader version 5 error

o-Chart API error code {4} is "wrong password"

You might want to reset your credentials from Plug-ins|oeSENC and try again.
bcn is offline   Reply With Quote
Old 26-03-2019, 13:35   #12
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 2,398
Re: oeSENC loader version 5 error

Quote:
Originally Posted by Puddle_Sailor View Post
I followed the link from Caprarebird, but took a chance on down loading the version that had x86 in it.
I have also down loaded and installed the the latest oeSENC_pi plugin again. Now I don't have any MSVP120CP.dll issues anymore.

However when running oeSENC plug in (version 2.9 1524) and I go to Refresh charts list I get promted to enter username and password then this gives me:
"o-Chart API error code {4}. Check your configuration and try again.
What's wrong now?
Puddle...
The message "o-Chart API error code" says O-Charts.org server is not happy with either of your User name, Password or system name. Since I suppose this is the first visit for you this way it would be the log in credentials. Did you used the same login as when you visited o-charts.org?
Håkan
Hakan is offline   Reply With Quote
Old 26-03-2019, 13:48   #13
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 2,398
Re: oeSENC loader version 5 error

Quote:
Originally Posted by bcn View Post
o-Chart API error code {4} is "wrong password"
@bdbcat
With that info from Hubert we could add that to explicate the message?

ochartShop.cpp: ~667 ?

switch(dresult){
case 3:
+ case 4:
msg += _("Invalid user/email name or password.");
break;

Håkan
Hakan is offline   Reply With Quote
Old 26-03-2019, 18:23   #14
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 5,497
Re: oeSENC loader version 5 error

Hakan...


Good catch.


A slightly extended implementation is in oesenc_pi github now.


Thanks
Dave
bdbcat is offline   Reply With Quote
Old 28-03-2019, 12:51   #15
Registered User

Join Date: Mar 2019
Location: Sweden
Boat: Dufour 385 GL
Posts: 5
Re: oeSENC loader version 5 error

Håkan,
It is the first time I'm getting charts from O-Charts. I have received an order confirmation, so the e-mail adress i obviously right. I do beleive to have the password too, (but I can of course be wrong. )

I have restarted Open CPN multiple times. The first time after restart I hit the green jig saw icon for plugins I get the message:"Plugin ofc_pi.dll är inte kompatibel med den här versionen av OpenCPN, vänligen använd en uppdaterad version."


What do I need to do to retrieve my charts?
Regards
Jan
__________________

Puddle_Sailor is offline   Reply With Quote
Reply

Tags
enc, loa

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bug? oesenc-pi crashes on start-up with "Bus error" Sea Patroller OpenCPN 12 30-03-2019 04:29
oeSENC Plugin Version 2.0 Released bdbcat OpenCPN 3 23-04-2018 05:01
oeSENC plug-in: New Version 1.6 bcn OpenCPN 21 08-03-2018 23:11
oeSENC vector charts for OCPN - new plug-in version 1.2 bcn OpenCPN 12 18-06-2017 10:53
oeSENC: Error on Fingerprint file creation Tanagra OpenCPN 17 29-05-2017 03:04



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 03:22.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.