Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 16-03-2013, 06:35   #1
Registered User

Join Date: Aug 2011
Location: On board
Boat: Rival 41C
Posts: 73
Send a message via Skype™ to RobbieW
OCPN 3.2.0 install on Ubuntu 12.04 - dependencies

Just tried this and, initially, it failed. The failure was shown as a missing dependency, libgl1-mesa-glx. My system is showing as having libgl1-mesa-glx-lts-quantal installed which I figured is the same function set packaged with a modified name. So edited the .deb dependencies for OCPN to reflect the installed package and the install went ok, so far the function looks good too.

The question is should that missing dependency have shown up? Is there something I could/should have done on the system first.

A bit of background, this is a newly installed system and I've added Cinnamon on top of Ubuntu as I prefer the interface. In the dim past I passed the tests as an AIX 3/4 admin but havent touched any Unix for at least 10 years.
__________________

__________________
RobbieW is offline   Reply With Quote
Old 16-03-2013, 09:31   #2
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,018
Re: OCPN 3.2.0 install on Ubuntu 12.04 - dependencies

Robbie...
Definitely not. It looks like your setup is a bit screwed - if it really is 12.04, there should not be any "quantal" packages on it (quantal = 12.11) Might be because of Cinnanmon, if you installed 1.6 targeting Mint's Nadia release (but there's a backport to 12.04 based Maya, which should not pull any quantal packages into the system, at least it did not for me).
Also, which DEB did you use? The one directly from opencpn.org or from the Launchpad PPA?
Anyway, this looks like a situation very specific for your machine and hardly resolvable during packaging.

Pavel
__________________

__________________
nohal is offline   Reply With Quote
Old 16-03-2013, 10:03   #3
Registered User

Join Date: Aug 2011
Location: On board
Boat: Rival 41C
Posts: 73
Send a message via Skype™ to RobbieW
Re: OCPN 3.2.0 install on Ubuntu 12.04 - dependencies

Thanks Pavel,
The OCPN package I used is the one linked from the OCPN Downloads page for Ubuntu 12.04. I just checked the Ubuntu install image used which says its 12.04, the Cinnamon install came from here ... Cinnamon 1.6.7 has been Released for Ubuntu 12.10/12.04/13.04/Linux Mint 14/13 ~ Noobs on Ubuntu and Windows, HD Wallpapers, Tutorials

I think I tried installing OCPN before putting Cinnamon on and got the dependency failure but I didnt check what libraries were installed at that point. The Ubuntu install was done with the install updates during installation box checked, the system then found another 75 odd updates to do, so the first OCPN try would have been at that point. What I think I'll do is re-install the Ubuntu image and see what gets pulled in at various points along the way.
__________________
RobbieW is offline   Reply With Quote
Old 16-03-2013, 10:23   #4
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,018
Re: OCPN 3.2.0 install on Ubuntu 12.04 - dependencies

Robbie...
My base system is a bit different - based on Mint 13, so my Cinnamon 1.6.7 comes from Repository - Linux Mint
Anyway using
Code:
deb http://ppa.launchpad.net/gwendal-lebihan-dev/cinnamon-stable/ubuntu precise main
should IMHO not pull any quantal packages into the system

Pavel
__________________
nohal is offline   Reply With Quote
Old 17-03-2013, 06:05   #5
Registered User

Join Date: Aug 2011
Location: On board
Boat: Rival 41C
Posts: 73
Send a message via Skype™ to RobbieW
Re: OCPN 3.2.0 install on Ubuntu 12.04 - dependencies

Pavel,
Just had a look at the version of libgl1 on the install image by booting it from the stick. This is ubuntu-12.04.2-desktop-i386.iso downloaded straight from the Ubuntu site. Thats showing the libgl1-mesa-glx-lts-quantal as installed when doing get-selections and grepping for libgl1.

Cheers ... Robbie
__________________
RobbieW is offline   Reply With Quote
Old 17-03-2013, 06:24   #6
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,249
Re: OCPN 3.2.0 install on Ubuntu 12.04 - dependencies

The "libgl1-mesa-glx-lts-quantal" is listed in "precise update" but not in "precise". This is unusual, it looks more like a "backport" than an "update". The first thing I would try, is to create a link "libgl1-mesa-glx" pointing to "libgl1-mesa-glx-lts-quantal".

Thomas
__________________
cagney is offline   Reply With Quote
Old 17-03-2013, 07:43   #7
Registered User

Join Date: Aug 2011
Location: On board
Boat: Rival 41C
Posts: 73
Send a message via Skype™ to RobbieW
Re: OCPN 3.2.0 install on Ubuntu 12.04 - dependencies

Hi Thomas,
So far I've found I dont need a pseudonym for the libgl1 libraries, OCPN seems to run fine without. Changing the install dependency to reflect the libraries actually found allowed the installation to complete.

For anyone else tripping over this, I found Linux Mint Forums • View topic - How To: Change .deb Package Dependencies a useful guide to editing the dependencies for a package.

Robbie
__________________

__________________
RobbieW is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 19:28.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.