Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-02-2016, 09:25   #1
Registered User

Join Date: Jul 2012
Location: Raritan Bay
Boat: Canadian Sailcraft 33
Posts: 20
Object Search not working

Forgive me if I am bringing up a topic thats been rehashed in the past. I am new to OpenCPN and recently installed it on Win10 machine at home. On top I also installed Object Search plugin which is not working. I cannot find anything on the chart using that search. It said I have to visit that chart at least once which I did not it is still not working. Are there any tricks to get this to work?

Also, I tried to build the DB by specifying coordinates (from and to). This also doesnt work. No matter what I do it puts me in middle of the ocean but still not search.

Thanks

Val
__________________

__________________
vechnyak is offline   Reply With Quote
Old 10-02-2016, 10:39   #2
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,398
Re: Object Search not working

Object search only works with vector charts (ENC) not BSB.
What charts are you trying it on?
__________________

__________________
rgleason is offline   Reply With Quote
Old 10-02-2016, 10:40   #3
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,398
Re: Object Search not working

ps: iF you are talking about building the chart db. just check and let it run til complete.
__________________
rgleason is offline   Reply With Quote
Old 10-02-2016, 10:51   #4
Registered User

Join Date: Jul 2012
Location: Raritan Bay
Boat: Canadian Sailcraft 33
Posts: 20
Re: Object Search not working

Quote:
Originally Posted by rgleason View Post
Object search only works with vector charts (ENC) not BSB.
What charts are you trying it on?
Sorry I didnt mention. Yes, I am using ENC charts.
__________________
vechnyak is offline   Reply With Quote
Old 10-02-2016, 10:54   #5
Registered User

Join Date: Jul 2012
Location: Raritan Bay
Boat: Canadian Sailcraft 33
Posts: 20
Re: Object Search not working

Quote:
Originally Posted by rgleason View Post
ps: iF you are talking about building the chart db. just check and let it run til complete.
Maybe I am doing something wrong but its not working. In the "populate database" if I click OK. nothing happens except it puts me on the chart in the middle of the ocean
__________________
vechnyak is offline   Reply With Quote
Old 10-02-2016, 11:55   #6
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,777
Re: Object Search not working

Quote:
Originally Posted by vechnyak View Post
Maybe I am doing something wrong but its not working. In the "populate database" if I click OK. nothing happens except it puts me on the chart in the middle of the ocean
Maybe you show us some screenshots of what you are doing. Without knowing your settings nobody can help you.

Gerhard
__________________
CarCode is offline   Reply With Quote
Old 10-02-2016, 14:49   #7
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,398
Re: Object Search not working

vechnyak

Please refer to the Opencpn manual. I think it will help you a lot.
The areas I suggest you read and review are as follows:
Chart Installation | Official OpenCPN Homepage
Charts | Official OpenCPN Homepage
Chart Files Tab | Official OpenCPN Homepage
Chart Groups Tab | Official OpenCPN Homepage
Chart Download Tab | Official OpenCPN Homepage

I believe these will help you understand how to use the tools at hand.
If you have questions after reading and reviewing these, please come back and ask.

vechnvak, I am not trying to put you off, just suggesting that the User Manual may be a very big help, then if you have questions, please put them forth!
__________________
rgleason is offline   Reply With Quote
Old 10-02-2016, 17:06   #8
Registered User

Join Date: Jul 2012
Location: Raritan Bay
Boat: Canadian Sailcraft 33
Posts: 20
Re: Object Search not working

Quote:
Originally Posted by CarCode View Post
Maybe you show us some screenshots of what you are doing. Without knowing your settings nobody can help you.

Gerhard

Here is the screenshot of window. If I click on with or without entering From/To it the dialog box goes away and it puts the middle of the screen in the ocean off of africa
Attached Thumbnails
Click image for larger version

Name:	ObjectSearch01.JPG
Views:	69
Size:	87.1 KB
ID:	118732  
__________________
vechnyak is offline   Reply With Quote
Old 10-02-2016, 17:09   #9
Registered User

Join Date: Jul 2012
Location: Raritan Bay
Boat: Canadian Sailcraft 33
Posts: 20
Re: Object Search not working

Quote:
Originally Posted by rgleason View Post
vechnyak

Please refer to the Opencpn manual. I think it will help you a lot.
The areas I suggest you read and review are as follows:
Chart Installation | Official OpenCPN Homepage
Charts | Official OpenCPN Homepage
Chart Files Tab | Official OpenCPN Homepage
Chart Groups Tab | Official OpenCPN Homepage
Chart Download Tab | Official OpenCPN Homepage

I believe these will help you understand how to use the tools at hand.
If you have questions after reading and reviewing these, please come back and ask.

vechnvak, I am not trying to put you off, just suggesting that the User Manual may be a very big help, then if you have questions, please put them forth!
The charts are installed and working fine. Its the search thats not working. Are you saying chart installation instructions have something to do with how the search works?
__________________
vechnyak is offline   Reply With Quote
Old 10-02-2016, 19:49   #10
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,398
Re: Object Search not working

vechnyak

I understood you were having trouble with the chart database. That is what happens when people speak in shorthand, and then don't answer a question.

I have tested the objectsearch_pi and confirm that it does not work.
git fetched, and built new with opencpn.lib v4.2

It will have to be fixed.
File a bug report for pi-objectsearch in Tracker.
__________________
rgleason is offline   Reply With Quote
Old 11-02-2016, 03:28   #11
Marine Service Provider

Join Date: May 2013
Location: Norway
Posts: 571
Re: Object Search not working

Quote:
Originally Posted by rgleason View Post
vechnyak

I understood you were having trouble with the chart database. That is what happens when people speak in shorthand, and then don't answer a question.

I have tested the objectsearch_pi and confirm that it does not work.
git fetched, and built new with opencpn.lib v4.2

It will have to be fixed.
File a bug report for pi-objectsearch in Tracker.
It would be great to be able to mark the area to be included in the search database with the mouse cursor to fill in the values the same way done for selecting area in Zygrib. The current method of entering the area in numerical format in the menu is not so handsome.
__________________
petter5 is offline   Reply With Quote
Old 11-02-2016, 05:17   #12
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,777
Re: Object Search not working

Quote:
Originally Posted by rgleason View Post
vechnyak

I understood you were having trouble with the chart database. That is what happens when people speak in shorthand, and then don't answer a question.

I have tested the objectsearch_pi and confirm that it does not work.
git fetched, and built new with opencpn.lib v4.2

It will have to be fixed.
File a bug report for pi-objectsearch in Tracker.
I still don't know what you are doing. It works here for Mac OS X with all OCPN versions. So I tested it now for Windows also using Windows 10, OpenCPN 4.2 and http://opencpn.navnux.org/plugins/ob...-0.6-win32.exe from the official OCPN download site.
Installing this plugin and using CM93 charts I tested an area of 50/0 to 10/20 and got a database called objsearch_pi.db with 918 kilobytes at C:\Programdata\opencpn. Then going to make a search I got the screenshot attached here.
If someone however make a database with coordinates 0/0 to 0/0 as shown in posting #8 above the database will be for sure empty.

So there is nothing to have been fixed although the comment from petter5 is a good hint to make this plugin easier to use.

Gerhard
Attached Thumbnails
Click image for larger version

Name:	objsearch.png
Views:	61
Size:	205.8 KB
ID:	118752  
__________________
CarCode is offline   Reply With Quote
Old 11-02-2016, 05:36   #13
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,398
Re: Object Search not working

Gerhard,
Yes, indeed ObjectSearch does work with CM93 charts!
but isn't an ENC chart a Vector Chart? -- I was using ENC!

So, the plugin does work as intended.
Sorry about the confusion.

Is there a way to extend it to ENC charts sometime perhaps?
Also the windows version probably uses the extent of display to set the search area, so we don't have Lat/Long showing, but I like ptulp's suggestion too.

Thanks for persisting.

ObjectSearch_pi works only for CM93 Charts currently.

I've uploaded it to OpenCPN Beta File thingie.
__________________
rgleason is offline   Reply With Quote
Old 11-02-2016, 06:22   #14
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,777
Re: Object Search not working

Rick,

one word to you: You are writing very much in this forum. This might lead sometimes to errors. Write a little bit less please.
I admit OpenCPN and its plugins are very bad software because the average user doesn't know how to use it. This software is mostly not intuitive and obviously huge manuals are needed which nobody read. Sometimes even only the developer knows how to use something. Too much functions are not self explaining. This is the dead for any software.
For making more irritations you provide your own compiled software pieces to the public. I think this is a bad idea. You have too less knowledge to be sure your versions are better than the officially ones from opencpn.org
It might make you happy to be able to compile something. But please keep it for yourself.

Gerhard
__________________
CarCode is offline   Reply With Quote
Old 11-02-2016, 16:27   #15
Registered User

Join Date: Jul 2012
Location: Raritan Bay
Boat: Canadian Sailcraft 33
Posts: 20
Re: Object Search not working



I thought S-57 is supported also? Are you now saying only CM93 is supported? I am not aware of any NOAA charts in CM93 format..

__________________

__________________
vechnyak is offline   Reply With Quote
Reply

Tags
arc

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hitting an Object While Motoring sonnysoh Monohull Sailboats 38 02-03-2016 20:12
Chart Object Search plug-in nohal OpenCPN 41 10-11-2014 03:50
Google Custom Search Feature Not Working + One Other Issue teneicm Forum Tech Support & Site Help 4 29-07-2010 07:06
If money was no object... Llamster Construction, Maintenance & Refit 14 25-03-2009 13:30
cost no object... neither to buy or maintain - what mono would you have any why? Sterling Monohull Sailboats 36 25-10-2008 08:19



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 00:01.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.