Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 17-02-2016, 03:03   #31
Marine Service Provider

Join Date: May 2013
Location: Norway
Posts: 571
Re: Object Search not working

Quote:
Originally Posted by CarCode View Post
Of course you will see nothing because 40/70 to 39/71 is somewhere in Russia and a land area. Do you really have no knowledge about Latitude and Longitude? How you have been sailing then?

Gerhard
************************************************** ***************
The selection of are is not easy to get in correct format. No need to make sarcastic comments of people struggling and searing for help on the forum.
************************************************** ***************

On the other hand, the search tool would improve greatly with a graphical area selection tool as done in zygrib. - in fact, the first times I used the search tool, I used Zygrib to get the correct input format for the Search tool dialogue.
__________________

__________________
petter5 is offline   Reply With Quote
Old 17-02-2016, 03:53   #32
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,778
Re: Object Search not working

Correct, but he asked for several days now and still understand nothing although several people tried to help.
On the other hand OpenCPN and its plugins seems to need large manuals to be operable for the average user. Almost nothing is self-explaining and intuitive to use. Mostly only the developers knows how something works. This is a very bad software style and developers should not see this software as a playground for themselfes but usable for the average user. Nobody reads many, many pages of manuals or even understand them.
Your suggestion for a graphical selection is the right step and there are many other items which can make software more intuitive. The developers should be forced to either make their software more intuitive to use or to pull back their software.

Gerhard
__________________

__________________
CarCode is offline   Reply With Quote
Old 17-02-2016, 04:20   #33
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,020
Object Search not working

Quote:
Originally Posted by CarCode View Post
Correct, but he asked for several days now and still understand nothing although several people tried to help.
On the other hand OpenCPN and its plugins seems to need large manuals to be operable for the average user. Almost nothing is self-explaining and intuitive to use. Mostly only the developers knows how something works. This is a very bad software style and developers should not see this software as a playground for themselfes but usable for the average user. Nobody reads many, many pages of manuals or even understand them.
Your suggestion for a graphical selection is the right step and there are many other items which can make software more intuitive. The developers should be forced to either make their software more intuitive to use or to pull back their software.

Gerhard

Gerhard...
You are not forced to use that total crap we produced. I'm really sorry if it is not clear to you and will try to emphasize it in a much shorter manual you will be able to read.

Pavel


Sent from my iPhone using Cruisers Sailing Forum
__________________
nohal is offline   Reply With Quote
Old 17-02-2016, 05:26   #34
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,778
Re: Object Search not working

Quote:
Originally Posted by nohal View Post
Gerhard...
You are not forced to use that total crap we produced. I'm really sorry if it is not clear to you and will try to emphasize it in a much shorter manual you will be able to read.

Pavel


Sent from my iPhone using Cruisers Sailing Forum
Obiously you have not understand also.
It's not me who is unable to use the software but for other people it seems to be a nightmare when I read all the postings in this forum.
Please come down from your high horse...
Gerhard
__________________
CarCode is offline   Reply With Quote
Old 17-02-2016, 05:32   #35
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,020
Re: Object Search not working

Quote:
Originally Posted by CarCode View Post
Obiously you have not understand also.
It's not me who is unable to use the software but for other people it seems to be a nightmare when I read all the postings in this forum.
Please come down from your high horse...
Gerhard
Gerhard...

We of course listen to the feature requests. We also listen to you, but unfortunately hear not much of useful stuff compared to the endless waterfall of insults. And if you want to force us to do stuff, I suggest you move to North Korea or similar place - people deciding what they want to do for themselves will not bother you there.

Pavel
__________________
nohal is offline   Reply With Quote
Old 17-02-2016, 05:46   #36
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,778
Re: Object Search not working

Quote:
Originally Posted by nohal View Post
Gerhard...

We of course listen to the feature requests. We also listen to you, but unfortunately hear not much of useful stuff compared to the endless waterfall of insults. And if you want to force us to do stuff, I suggest you move to North Korea or similar place - people deciding what they want to do for themselves will not bother you there.

Pavel
Be aware that you don't get hurt when stepping down from your high horse...
Gerhard
__________________
CarCode is offline   Reply With Quote
Old 17-02-2016, 06:18   #37
Registered User

Join Date: Jul 2012
Location: Raritan Bay
Boat: Canadian Sailcraft 33
Posts: 20
Re: Object Search not working

It would be great if people would stop themselves from personal attacks! Insulting one another does not fix the plugin

I would greatly appreciate if anyone can give me a suggestion on how to make Object Search work.

I learned about my mistake and corrected it. Now I am using minus (-) for the longitude. So the search is now 41/-74 until 40/-71. Unfortunately this didnt help build the database.


p.s. I am very grateful to any software developer who takes the time to write free software. If the documentation is there I would be happy to read it, no matter how long. If the documentation is not available its still OK because the person who took the time to write software does not owe me anything.

Thank you

Val
__________________
vechnyak is offline   Reply With Quote
Old 17-02-2016, 07:13   #38
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,421
Re: Object Search not working

In the Windows version the box of lat/long is defined by the screen extents, which I find to be intuitive and simple to use. Is there some reason the linux version does not impliment this approach?
__________________
rgleason is online now   Reply With Quote
Old 18-02-2016, 12:41   #39
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,778
Re: Object Search not working

Quote:
Originally Posted by vechnyak View Post
It would be great if people would stop themselves from personal attacks! Insulting one another does not fix the plugin

I would greatly appreciate if anyone can give me a suggestion on how to make Object Search work.

I learned about my mistake and corrected it. Now I am using minus (-) for the longitude. So the search is now 41/-74 until 40/-71. Unfortunately this didnt help build the database.


p.s. I am very grateful to any software developer who takes the time to write free software. If the documentation is there I would be happy to read it, no matter how long. If the documentation is not available its still OK because the person who took the time to write software does not owe me anything.

Thank you

Val
I really don't know what you are doing. Taking your coordinates 41/-74 to 40/-71 I get the area attached here and the database file "objsearch_pi.db" (delete the extension .pdf if you want to use this attachment).

Gerhard
Attached Thumbnails
Click image for larger version

Name:	41-74to40-71.png
Views:	41
Size:	240.0 KB
ID:	119226  
Attached Files
File Type: pdf objsearch_pi.db.pdf (527.0 KB, 9 views)
__________________
CarCode is offline   Reply With Quote
Old 18-02-2016, 13:28   #40
Registered User

Join Date: Jul 2012
Location: Raritan Bay
Boat: Canadian Sailcraft 33
Posts: 20
Re: Object Search not working

Quote:
Originally Posted by CarCode View Post
I really don't know what you are doing. Taking your coordinates 41/-74 to 40/-71 I get the area attached here and the database file "objsearch_pi.db" (delete the extension .pdf if you want to use this attachment).

Gerhard
Thank you. This worked. I saved the file and removed the .PDF extension. Then i moved the file over to C:\ProgramData\opencpn\objsearch_pi.db and replaced the file that was already there (old file was only about 5kb). Then started OCPN.

Now I can search Long Island Sound.

Val
__________________
vechnyak is offline   Reply With Quote
Old 18-02-2016, 13:34   #41
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,769
Re: Object Search not working

Leaves us with the question what has been wrong before...
We want to learn.

Val, if you rename/remove the .db and start again, what happens?
__________________
bcn is offline   Reply With Quote
Old 18-02-2016, 14:01   #42
Registered User

Join Date: Jul 2012
Location: Raritan Bay
Boat: Canadian Sailcraft 33
Posts: 20
Re: Object Search not working

Quote:
Originally Posted by bcn View Post
Leaves us with the question what has been wrong before...
We want to learn.

Val, if you rename/remove the .db and start again, what happens?
If I rename the file, the new .db gets created but is not populated after I do the "Scan Chart". I wish I could turn on some internal debugging. I did try to use procmon and debugview from sysinternals but it doesnt show me any errors.

EDIT: In the log I also noticed extra (\) in the path. I know this is not a problem but I just wanted to let everyone know that this is how it shows in my log.

Line 445: 4:08:18 PM: OBJSEARCH_PI: Database file to be used: C:\ProgramData\opencpn\\objsearch_pi.db
__________________

__________________
vechnyak is offline   Reply With Quote
Reply

Tags
arc

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hitting an Object While Motoring sonnysoh Monohull Sailboats 38 02-03-2016 20:12
Chart Object Search plug-in nohal OpenCPN 41 10-11-2014 03:50
Google Custom Search Feature Not Working + One Other Issue teneicm Forum Tech Support & Site Help 4 29-07-2010 07:06
If money was no object... Llamster Construction, Maintenance & Refit 14 25-03-2009 13:30
cost no object... neither to buy or maintain - what mono would you have any why? Sterling Monohull Sailboats 36 25-10-2008 08:19



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 18:42.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.