Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 19-03-2010, 22:07   #31
Registered User

Join Date: Mar 2010
Posts: 4
I'm not much of a programmer, so if you could email me, I could try it out next week. I'll send you a message with my email.
__________________

__________________
SailorJed is offline   Reply With Quote
Old 21-03-2010, 06:31   #32
Registered User

Join Date: Feb 2010
Posts: 619
Probably I am also not much of a programmer...
I emailed you an opencpn.exe built under Vista, but I have just got hold of an XP machine and it does not start here: The message reads that "application configuration is incorrect. Reinstalling may fix the problem." Well, I have still a lot to learn... I fixed the PE Header (RequiredOperatingSystem=4), but this is not enough.
Next week maybe I will have an XP box for a longer time, so I can experiment.
So please be patient or try on Vista.
Piotr
__________________

__________________
PjotrC is offline   Reply With Quote
Old 21-03-2010, 17:24   #33
Registered User

Join Date: Dec 2006
Posts: 80
No waypoint visible

I have the same problem; here is a section of my OpenCPN.ini file:

[Marks]
[Marks/MarkDefn1]
RoutePoint=-38.557999,145.080002
RoutePointName=
RoutePointIcon=circle
RoutePointGUID=385579-1450800-1269159487
RoutePointProp=A,0,0,0,0
RoutePointNameLocationOffset=-10,8

I think it may have something to do with the RoutrPointIccon? I'm happy to manually edit the OpenCPN.ini file if someone could tell me what is missing (maybe the circle icon?).

BTW, I used VPP2 to create the route and exported it as a CSV file. I reorganized the data (had to swap lon/lat) and dropped it into:

Edit Garmin POI files, TomTom POI files or Navman POI files - Online POI Manager

which created a GPX file for me.

I dropped this into Google Earth and it worked; all of my waypoints along the route had a visible icon. When I imported the GPX file into CPN the only place it was visible was in my ini file.
Thanx, Jim
__________________
jimthom is offline   Reply With Quote
Old 21-03-2010, 22:12   #34
Registered User

Join Date: Dec 2006
Posts: 80
Fixed!

I edited the ini file to change the string from "A,0,0,0,0" to "A,0,0,0,1". This works much better when openCPN is not running.

Jim
__________________
jimthom is offline   Reply With Quote
Old 22-03-2010, 04:07   #35
Registered User

Join Date: Feb 2010
Posts: 619
SailorJed...

I downloaded from Microsoft and installed the file vcredist_x86.exe (redistributable run time for Visual C++ 2008) on the XP and the opencpn.exe (as you have it) runs fine now. Hope this helps.

P.
__________________
PjotrC is offline   Reply With Quote
Old 22-03-2010, 10:18   #36
Registered User

Join Date: Mar 2010
Location: Den Helder, the Netherlands
Boat: Drascombe Coaster (22ft) "Seanymph"
Posts: 107
Ozi-waypoints need a "description"

I found out that by default OziExplorer Waypoints lack a "description". Maybe this can be of some help to anyone who is having trouble with OziExplorer-waypoints in OpenCPN.....

(see the attached WORD-document).

Roel
Attached Files
File Type: doc OziWaypoints.doc (151.5 KB, 44 views)
__________________
Roel Smidt is offline   Reply With Quote
Old 28-03-2010, 14:49   #37
Registered User

Join Date: Mar 2010
Posts: 4
Patch

I ws able to use the exe you emailed me. The imported waypoints appear, but not the name text. It appears that each waypoint would need the show name box checked. Quite a project if there are a lot of them. perhaps a waypoint tab in the tools menu. I'm going to try editing the ini file and see what I get.
__________________
SailorJed is offline   Reply With Quote
Old 29-03-2010, 01:45   #38
Registered User

Join Date: Feb 2010
Posts: 619
SailorJed...

Thanks for trying! I will have a look at the names. If you want to edit the .ini or .gpx, here is the meaning of the four "A" attributes:

A,x1,x2,x3,x4 : x1 - dynamic name, x2 - show name, x3 - keep route, x4 - is visible

to show names set x2 to 1

P.
__________________

__________________
PjotrC is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for GPX Files for Testing Netsurfer OpenCPN 3 10-02-2010 04:18
Converting MaxSea .wpt Routes to GPX jimbim OpenCPN 2 08-02-2010 23:38
Why Waypoints? rigormortis Navigation 26 14-01-2009 00:45
Images/photos not visible undrsol Forum Tech Support & Site Help 3 31-08-2007 12:38
Exumas Waypoints GordMay Atlantic & the Caribbean 3 22-11-2006 03:40



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 19:17.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.