Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 25-10-2016, 09:50   #1
Marine Service Provider
 
LifePart2's Avatar

Join Date: Sep 2010
Location: ex Canada - now on the boat
Boat: Leopard 42 catamaran
Posts: 155
NMEA Received, but no ship-follow - HELP!

I am having a problem getting OpenCPN to show the GPS as active and to show my ship's position. Platform is Windows 10 Anniversary Update

I am connecting to a ShipModul 2USB/BT

Currently I am connecting by USB while I figure this out.

I have configured the USB to COM 10 baud 38400.

The NMEW debug window shows NMEA coming in.

I also have the VDR plugin. If I press record for a few seconds, this is what I get:

$SDDBT,17.7,f,5.3,M,2.9,F*3A
$GPRMC,163727.00,A,2851.393,N,01348.941,W,000.0,00 0.0,251016,4.3,W*5D
$VWVHW,,,105.5,M,0.00,N,0.00,K*2F
$WIMTW,24.5,C*0E
$HCHDG,105.5,,,4,W*20
!AIVDO,1,1,,,B4eH7:000?h<7=48<8Jvswg5sP06,0*25
$GPGGA,163728.00,2851.393,N,01348.941,W,1,09,00.8, 005.2,M,,M,0.0,0000*74
$GPGBS,163730.00,1.9,2.1,3.9,,,,*40
$HCHDG,105.5,,,4,W*20
$WIMWV,65.5,R,19.3,N,A*2E
$GPGLL,2851.393,N,01348.941,W,163728.00,A*1A
$GPXTE,A,A,,,*72
$SDDBT,17.1,f,5.2,M,2.8,F*3C
$VWVHW,,,105.5,M,0.00,N,0.00,K*2F
$GPRMC,163728.00,A,2851.393,N,01348.941,W,000.0,00 0.0,251016,4.3,W*52
$WIMTW,24.5,C*0E
$HCHDG,105.5,,,4,W*20
!AIVDM,1,1,,B,4028jOAv2dhUNO0qdH@S2jw000S:,0*5B
!AIVDO,1,1,,,B4eH7:000?h<7=48<8JwCwgUsP06,0*74
$WIMWV,75.5,R,18.9,N,A*24
$GPGGA,163729.00,2851.393,N,01348.941,W,1,08,01.2, 005.2,M,,M,0.0,0000*7F
$GPGBS,163731.00,1.9,2.1,3.9,,,,*41
$HCHDG,105.5,,,4,W*20
$GPGLL,2851.393,N,01348.941,W,163729.00,A*1B
$SDDBT,17.5,f,5.3,M,2.9,F*38
$GPXTE,A,A,,,*72
!AIVDO,1,1,,B,B4eH7:000?h<7=48<8JwCwgUkP06,0*2E
$VWVHW,,,105.5,M,0.00,N,0.00,K*2F
$GPRMC,163729.00,A,2851.393,N,01348.941,W,000.0,00 0.0,251016,4.3,W*53
!AIVDM,1,1,,A,B3mqkOP007h<<0T8<>2i7wgUoP06,0*2E
$WIMTW,24.5,C*0E
$HCHDG,105.5,,,4,W*20
$WIMWV,73.0,R,17.8,N,A*29
$HCHDG,104.5,,,4,W*21
$GPGBS,163732.00,1.9,2.1,3.9,,,,*42
$GPGGA,163730.00,2851.393,N,01348.941,W,1,08,01.2, 005.1,M,,M,0.0,0000*74

In the NMEA debug window it prefaces all the above lines with:
(Serial:COM10)\s:MX26-2*47\

eg: (Serial:COM10)\s:MX26-2*47\$GPGBS,163732.00,1.9,2.1,3.9,,,,*42

I am seeing other AIS targets. My Dashboard is showing all the relevant data - position, depth, speed, wind etc.

But my own ship is still black, and the little GPS indicator top right is still red instead of green.

Tearing my hair out here. What am I missing? Why is it receiving all the correct data, yet not following my ship?

Any suggestions?

Thanks!

Noel
__________________

__________________
Noel Swanson

Life is too short to live in ugly places.
LifePart2 is offline   Reply With Quote
Old 25-10-2016, 10:26   #2
Marine Service Provider
 
LifePart2's Avatar

Join Date: Sep 2010
Location: ex Canada - now on the boat
Boat: Leopard 42 catamaran
Posts: 155
Re: NMEA Received, but no ship-follow - HELP!

Update:

I did a debug from the ini file, and this is what is in the log file:



6:22:23 PM: MEH.NMEA Sentence received...\s:MX26-4*41\$HCHDG,106.0,0,E,4,W*53

6:22:24 PM: MEH.NMEA Sentence received...\s:MX26-4*41\$HCHDG,106.0,0,E,4,W*53

6:22:24 PM: MEH.NMEA Sentence received...\s:MX26-1*44\$GPGGA,172222.00,2851.394,N,01348.941,W,2,08, 01.0,015.0,M,,M,0.0,0000*74

6:22:24 PM: MEH.NMEA Sentence received...\s:MX26-1*44\$GPGLL,2851.394,N,01348.941,W,172222.00,A*12

6:22:24 PM: MEH.NMEA Sentence received...\s:MX26-1*44\$GPXTE,A,A,,,*72

6:22:24 PM: MEH.NMEA Sentence received...\s:MX26-4*41\$SDDBT,17.5,f,5.3,M,2.9,F*38

6:22:24 PM: MEH.NMEA Sentence received...\s:MX26-1*44\$GPRMC,172222.00,A,2851.394,N,01348.941,W,000 .0,000.0,251016,4.3,W*5A

6:22:24 PM: MEH.NMEA Sentence received...\s:MX26-4*41\$WIMWV,82.5,R,16.0,N,A*2B

6:22:24 PM: MEH.NMEA Sentence received...\s:MX26-4*41\$VWVHW,,,106.0,M,0.00,N,0.00,K*29

6:22:24 PM: MEH.NMEA Sentence received...\s:MX26-4*41\$WIMTW,24.5,C*0E

6:22:24 PM: MEH.NMEA Sentence received...\s:MX26-4*41\$HCHDG,105.5,0,E,4,W*55

So is that prefix from the shipModul the problem? How do I go about filtering that out?

Incidentally, I am using OpenCPN 4.4.0

Thanks

Noel
__________________

__________________
Noel Swanson

Life is too short to live in ugly places.
LifePart2 is offline   Reply With Quote
Old 25-10-2016, 10:33   #3
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 5,226
Re: NMEA Received, but no ship-follow - HELP!

Turn off the "TAG blocks" in your ShipModul multiplexer configuration (Don't have it to tell you exactly where you find the setting, but it is there.) If it still won't work, let us know and we may investigate further.

Pavel
nohal is offline   Reply With Quote
Old 25-10-2016, 11:51   #4
Marine Service Provider
 
LifePart2's Avatar

Join Date: Sep 2010
Location: ex Canada - now on the boat
Boat: Leopard 42 catamaran
Posts: 155
Re: NMEA Received, but no ship-follow - HELP!

Awesome, Pavel!

That did the job instantly. It is in the Options tab on the config program.

So grateful.

Noel
__________________
Noel Swanson

Life is too short to live in ugly places.
LifePart2 is offline   Reply With Quote
Reply

Tags
nmea

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NMEA debug window : changing NMEA datasource pegase22003 OpenCPN 6 29-02-2016 10:44
For Sale: Comar NMEA-2-WIFI NMEA 0183 Converter $230 4arch Classifieds Archive 1 02-11-2015 03:02
Ship tracks and auto follow Settler OpenCPN 2 20-06-2015 16:58
Multiplexing NMEA on a router (NMEA over WiFi redux) Mollymawk Marine Electronics 16 21-10-2014 05:18
Receiving NMEA stream but not finding "My Ship" ChannelIslander OpenCPN 13 21-12-2011 21:55

Advertise Here


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 16:06.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×

ShowCase vBulletin Plugins by Drive Thru Online, Inc.