Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 28-06-2010, 05:21   #16
Registered User

Join Date: Mar 2010
Location: Normandy, France
Boat: Flush Poker, 8.25m (Point Barre)
Posts: 335
Quote:
Originally Posted by tebsin View Post
Hey you guys are speaking a different language, where do i find this file ? you have got to understand I am not from your parts, I am from a time past by
Go to System > Administration > Synaptic package manager
or Applications > Ubuntu software center
search libwxgtk2.8-0 and install it
__________________

__________________
SethDart is offline   Reply With Quote
Old 28-06-2010, 11:07   #17
Registered User

Join Date: May 2010
Location: Cairns Nth Qld, Australia
Posts: 34
Thank You, Thank You

Thank You so much, did not realise it was that easy, suppose the next problem i will face is to get drivers for my GPS and Brookhouse multiplexer.
Thanks again
__________________

__________________
tebsin is offline   Reply With Quote
Old 28-06-2010, 16:26   #18
Registered User

Join Date: May 2010
Location: Cairns Nth Qld, Australia
Posts: 34
Can not get GPS or AIS to work in Ubuntu !!!!!!

Maybe I am out of my depth and should not be mucking around with something I know little about, but if I cant get the GPS or AIS working in Opencpn on Ubuntu, I will have to revert back to Windows XP (god forbid), its a shame because I really like the simplicity of the Ubuntu layout.
I followed the steps in configuring the Gps mouse in Wiki, initially it sort of half worked until I loaded a couple of commands as described, now it is just wont happen, at a loose end. What I need is someone who has the patience to walk me through, step by step, to help me solve this problem, please
__________________
tebsin is offline   Reply With Quote
Old 28-06-2010, 20:02   #19
Registered User

Join Date: Sep 2007
Location: FL
Boat: Pacific Seacraft 31 - Cielo Azul
Posts: 359
Images: 3
Quote:
Originally Posted by SethDart View Post
Please install libwxgtk2.8-0 it's required
as I mention in another thread, we need to add the prereqs to the
package file, the installers will automatically take care of installing prereqs.
Tom
__________________
teejayevans is offline   Reply With Quote
Old 28-06-2010, 23:34   #20
Registered User

Join Date: Mar 2010
Location: Göteborg, Sweden
Boat: Seamaster 700
Posts: 96
Send a message via Skype™ to balp
Quote:
Originally Posted by teejayevans View Post
as I mention in another thread, we need to add the prereqs to the
package file, the installers will automatically take care of installing prereqs.
Tom
Code:
balp@silvara:~/src/opencpn/git-opencpn$ dpkg -I /home/balp/src/opencpn/git-opencpn/build/opencpn-2.1.624.deb
 nytt debianpaket, version 2.0.
 storlek 15739172 byte: kontrollarkiv= 5723 byte.
     393 byte,     10 rader      control              
   15101 byte,    181 rader      md5sums              
 Package: opencpn
 Version: 2.1.624
 Section: Miscellaneous
 Priority: optional
 Architecture: i386
 Depends: wx-common (>= 2.8.0) | libwxbase2.8-0 (>= 2.8.7.1), wx-common (>= 2.8.0) | libwxgtk2.8-0 (>= 2.8.7.1), libglu1-mesa (>= 7.0.0), libgl1-mesa-glx (>= 7.0.0), zlib1g, bzip2
 Installed-Size: 27685
 Maintainer: Dave Register <bdbcat@.....>
 Description: An OpenSource Chart Plotter/Navigator
I think the CMakePackage stuff addes that already.. lastest 2.1....
__________________
balp is offline   Reply With Quote
Old 30-06-2010, 04:31   #21
Registered User

Join Date: Jan 2010
Posts: 32
Debian package dependancies on Ubuntu 10.04

I've just done a clean install test on a new Ubuntu Lucid installation, and there's definitely a dependency link missing somewhere in the chain.

libwxgtk2.8-0 is not being pre-installed and opencpn fails to launch until it is manually added.

I recall seeing this problem installing on the last ubuntu release as well...

Regards,

Mike
__________________
bluearcus is offline   Reply With Quote
Old 30-06-2010, 05:14   #22
Registered User

Join Date: Mar 2010
Location: Göteborg, Sweden
Boat: Seamaster 700
Posts: 96
Send a message via Skype™ to balp
Quote:
Originally Posted by bluearcus View Post
libwxgtk2.8-0 is not being pre-installed and opencpn fails to launch until it is manually added.
I'm no deb expert but i think i understands it now.

Depends: wx-common (>= 2.8.0) | libwxbase2.8-0 (>= 2.8.7.1), wx-common (>= 2.8.0) | libwxgtk2.8-0 (>= 2.8.7.1), libglu1-mesa (>= 7.0.0), libgl1-mesa-glx (>= 7.0.0), zlib1g, bzip22

the first "wx-common (>= 2.8.0) | libwxbase2.8-0 (>= 2.8.7.1), wx-common (>= 2.8.0) | libwxgtk2.8-0 (>= 2.8.7.1)" is an or dependence and can leave you without the needed libs.

Testing a small change
__________________
balp is offline   Reply With Quote
Old 30-06-2010, 06:10   #23
Registered User

Join Date: Mar 2010
Location: Göteborg, Sweden
Boat: Seamaster 700
Posts: 96
Send a message via Skype™ to balp
Try:

http://www.acc.umu.se/~balp/OpenCPN/...24a-1_i386.deb

I can't easy remove the libwxbase2.8-0 to test at the moment.
__________________
balp is offline   Reply With Quote
Old 01-07-2010, 02:12   #24
Registered User

Join Date: Jan 2010
Posts: 32
Works great now.

That seems fixed. Installation on a fresh Ubuntu 10.04 now produces a runnable binary.

:-)

Mike
__________________
bluearcus is offline   Reply With Quote
Old 01-07-2010, 23:12   #25
Registered User

Join Date: Mar 2010
Location: Göteborg, Sweden
Boat: Seamaster 700
Posts: 96
Send a message via Skype™ to balp
Quote:
Originally Posted by bluearcus View Post
That seems fixed. Installation on a fresh Ubuntu 10.04 now produces a runnable binary.

:-)

Mike
Great i have sent the patch to Dave.
__________________

__________________
balp is offline   Reply With Quote
Reply

Tags
linux

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Improved GNUAIS (AISMON for Linux) hackoon OpenCPN 24 14-07-2013 09:34
Linux Grib Viewer cagney Navigation 13 20-05-2010 18:51
Printing Charts on Linux captsparky OpenCPN 1 24-04-2010 04:15
Anyone know of any boat Design Software for Linux ? steveh000 Construction, Maintenance & Refit 1 27-11-2007 07:56
linux or xp uncle_fred Navigation 7 21-08-2006 18:03



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 01:49.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.