Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-08-2012, 09:23   #1
Registered User

Join Date: Aug 2012
Posts: 4
Need help getting OpenCPN running with Ubunutu 12.04

Hello all,

This is my first post here, nice to meet you ! I'm trying to get OpenCPN up and working on a fairly recent ubuntu version (12.04), but up to now I didn't succeed. I've tried many things : downloading the deb package from the web site, a package from a fresh git clone or make install from the same sources.

None of these tries has been successfull to date. With more or less the same symptoms : when launching opencpn I get a splash dialog to which I must agree to go further. When I disagree, the program quits normally as expected, when I agree, it unexpectedly quits with the following message :
Code:
The program 'opencpn' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 1368 error_code 1 request_code 136 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
This is from the as-of-today git cloned sources.

Can anyone help me or point me to somewhere where I could get help getting the SW in place ?

Sincerely

Sébastien
__________________

__________________
mseb is offline   Reply With Quote
Old 11-08-2012, 09:32   #2
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,016
Re: Nedd help getting OpenCPN running with Ubunutu 12.04

Seb...
Could you elaborate a little bit about your hardware, especially video subsystem? Also post the contents of opencpn.log in your home directory.

Pavel
__________________

__________________
nohal is offline   Reply With Quote
Old 11-08-2012, 09:42   #3
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,248
Re: Nedd help getting OpenCPN running with Ubunutu 12.04

Sébastien

I have seen that error message before. The problem is probably with your video-card driver. Make sure you have the latest version.
That said, there has also been cases where a new update has been bad.
Go to the manufacturers home page and download the latest.
Alternatively, there may be an entry in your system menu called "Additional Drivers", that sometimes is helpful.

Thomas
__________________
cagney is offline   Reply With Quote
Old 11-08-2012, 10:08   #4
Registered User

Join Date: Aug 2012
Posts: 4
Re: Nedd help getting OpenCPN running with Ubunutu 12.04

Thanks for dealing with my issue so fast !

Let's first say that I've reached the exact same issue with the launchpad repo version (3.02) since I posted.

Regarding the hardware, indeed, I'm running an not so young Dell Latitude C610. The video chipset seems to be a Radeon Mobility (RV100). If you need more on this, please tell me how to get the information.

The ubuntu version is up-to-date, I'm a little bit at a loss with this interface, but it seems there are no better available drivers for this HW (even in the "proprietary drivers" section).

Just for the record, I'm trying to help friends of mine who feel that running OpenCPN on a laptop is their best option when sailing. The know next to nothing of computers (but quite something of sailing). They asked me to update their computer from a 9.04 ubuntu running some kind of 1.x OpenCPN. It used to be functional, before I started...

Regarding the opencpn.log, here it is :
Code:
13:36:35 CEST: 


13:36:35 CEST: 2012-08-11
13:36:35 CEST:  -------Starting opencpn-------
13:36:35 CEST: Version 3.0.2 Build 2012-07-07
13:36:35 CEST: MemoryStatus:  mem_total: 495 mb,  mem_initial: 53 mb
13:36:36 CEST: SData_Locn is /usr/local/share/opencpn/
13:36:36 CEST: Creating new Config_File: /home/loul/.opencpn/opencpn.conf
13:36:36 CEST: Setting Viewpoint Lat/Lon 33.358, -79.282
13:36:36 CEST: Setting Ownship Lat/Lon 33.358, -79.282
13:36:36 CEST: System default Language:  fr_FR
13:36:36 CEST: Opencpn language set to:  en_US
13:36:46 CEST: ChartSymbols loaded from /usr/local/share/opencpn/s57data/chartsymbols.xml
13:36:47 CEST: Using s57data in /usr/local/share/opencpn/s57data
13:36:47 CEST: Setting Viewpoint Lat/Lon 33.358, -79.282
13:36:47 CEST: Setting Ownship Lat/Lon 33.358, -79.282
13:36:47 CEST: NMEA Data Source is....NONE
13:36:47 CEST: AIS Data Source is....NONE
13:59:58 CEST: 


13:59:58 CEST: 2012-08-11
13:59:58 CEST:  -------Starting opencpn-------
13:59:58 CEST: Version 3.1.802 Build 2012-08-02
13:59:58 CEST: MemoryStatus:  mem_total: 495 mb,  mem_initial: 54 mb
13:59:58 CEST: SData_Locn is /usr/local/share/opencpn/
13:59:58 CEST: Creating new Config_File: /home/loul/.opencpn/opencpn.conf
13:59:58 CEST: Styles loading from /usr/local/share/opencpn/uidata/styles.xml
13:59:58 CEST: No styles found at: /home/loul/
13:59:58 CEST: No styles found at: /home/loul/.opencpn/
13:59:59 CEST: Setting Viewpoint Lat/Lon 33.358, -79.282
13:59:59 CEST: Setting Ownship Lat/Lon 33.358, -79.282
13:59:59 CEST: System default Language:  fr_FR
13:59:59 CEST: Opencpn language set to:  en_US
14:00:06 CEST: ChartSymbols loaded from /usr/local/share/opencpn/s57data/chartsymbols.xml
14:00:07 CEST: Using s57data in /usr/local/share/opencpn/s57data
14:00:07 CEST: Setting Viewpoint Lat/Lon 33.358, -79.282
14:00:07 CEST: Setting Ownship Lat/Lon 33.358, -79.282
14:00:08 CEST: NMEA Data Source is....NONE
14:00:08 CEST: AIS Data Source is....NONE
17:08:31 CEST: 


17:08:31 CEST: 2012-08-11
17:08:31 CEST:  -------Starting opencpn-------
17:08:31 CEST: Version 3.1.802 Build 2012-08-02
17:08:31 CEST: MemoryStatus:  mem_total: 495 mb,  mem_initial: 54 mb
17:08:31 CEST: SData_Locn is /usr/local/share/opencpn/
17:08:31 CEST: Creating new Config_File: /home/loul/.opencpn/opencpn.conf
17:08:31 CEST: Styles loading from /usr/local/share/opencpn/uidata/styles.xml
17:08:32 CEST: No styles found at: /home/loul/
17:08:32 CEST: No styles found at: /home/loul/.opencpn/
17:08:33 CEST: Setting Viewpoint Lat/Lon 33.358, -79.282
17:08:33 CEST: Setting Ownship Lat/Lon 33.358, -79.282
17:08:33 CEST: System default Language:  fr_FR
17:08:33 CEST: Opencpn language set to:  en_US
17:08:41 CEST: ChartSymbols loaded from /usr/local/share/opencpn/s57data/chartsymbols.xml
17:08:42 CEST: Using s57data in /usr/local/share/opencpn/s57data
17:08:42 CEST: Setting Viewpoint Lat/Lon 33.358, -79.282
17:08:42 CEST: Setting Ownship Lat/Lon 33.358, -79.282
17:08:43 CEST: NMEA Data Source is....NONE
17:08:43 CEST: AIS Data Source is....NONE
17:16:41 CEST: 


17:16:41 CEST: 2012-08-11
17:16:41 CEST:  -------Starting opencpn-------
17:16:41 CEST: Version 3.1.802 Build 2012-08-02
17:16:41 CEST: MemoryStatus:  mem_total: 495 mb,  mem_initial: 54 mb
17:16:41 CEST: SData_Locn is /usr/local/share/opencpn/
17:16:41 CEST: Creating new Config_File: /home/loul/.opencpn/opencpn.conf
17:16:41 CEST: Styles loading from /usr/local/share/opencpn/uidata/styles.xml
17:16:42 CEST: No styles found at: /home/loul/
17:16:42 CEST: No styles found at: /home/loul/.opencpn/
17:16:42 CEST: Setting Viewpoint Lat/Lon 33.358, -79.282
17:16:42 CEST: Setting Ownship Lat/Lon 33.358, -79.282
17:16:42 CEST: System default Language:  fr_FR
17:16:42 CEST: Opencpn language set to:  en_US
17:16:55 CEST: ChartSymbols loaded from /usr/local/share/opencpn/s57data/chartsymbols.xml
17:16:56 CEST: Using s57data in /usr/local/share/opencpn/s57data
17:16:56 CEST: Setting Viewpoint Lat/Lon 33.358, -79.282
17:16:56 CEST: Setting Ownship Lat/Lon 33.358, -79.282
17:16:56 CEST: NMEA Data Source is....NONE
17:16:56 CEST: AIS Data Source is....NONE
17:17:48 CEST: 


17:17:48 CEST: 2012-08-11
17:17:48 CEST:  -------Starting opencpn-------
17:17:48 CEST: Version 3.1.802 Build 2012-08-02
17:17:48 CEST: MemoryStatus:  mem_total: 495 mb,  mem_initial: 54 mb
17:17:48 CEST: SData_Locn is /usr/local/share/opencpn/
17:17:48 CEST: Creating new Config_File: /home/loul/.opencpn/opencpn.conf
17:17:48 CEST: Styles loading from /usr/local/share/opencpn/uidata/styles.xml
17:17:48 CEST: No styles found at: /home/loul/
17:17:48 CEST: No styles found at: /home/loul/.opencpn/
17:17:48 CEST: Setting Viewpoint Lat/Lon 33.358, -79.282
17:17:48 CEST: Setting Ownship Lat/Lon 33.358, -79.282
17:17:48 CEST: System default Language:  fr_FR
17:17:48 CEST: Opencpn language set to:  en_US
17:18:02 CEST: 


17:18:02 CEST: 2012-08-11
17:18:02 CEST:  -------Starting opencpn-------
17:18:02 CEST: Version 3.1.802 Build 2012-08-02
17:18:02 CEST: MemoryStatus:  mem_total: 495 mb,  mem_initial: 54 mb
17:18:02 CEST: SData_Locn is /usr/local/share/opencpn/
17:18:02 CEST: Creating new Config_File: /home/loul/.opencpn/opencpn.conf
17:18:02 CEST: Styles loading from /usr/local/share/opencpn/uidata/styles.xml
17:18:02 CEST: No styles found at: /home/loul/
17:18:02 CEST: No styles found at: /home/loul/.opencpn/
17:18:02 CEST: Setting Viewpoint Lat/Lon 33.358, -79.282
17:18:02 CEST: Setting Ownship Lat/Lon 33.358, -79.282
17:18:02 CEST: System default Language:  fr_FR
17:18:02 CEST: Opencpn language set to:  en_US
17:51:42 CEST: 


17:51:42 CEST: 2012-08-11
17:51:42 CEST:  -------Starting opencpn-------
17:51:42 CEST: Version 3.0.2 Build 2012-07-07
17:51:42 CEST: MemoryStatus:  mem_total: 495 mb,  mem_initial: 53 mb
17:51:42 CEST: SData_Locn is /usr/share/opencpn/
17:51:42 CEST: Creating new Config_File: /home/loul/.opencpn/opencpn.conf
17:51:42 CEST: Setting Viewpoint Lat/Lon 33.358, -79.282
17:51:42 CEST: Setting Ownship Lat/Lon 33.358, -79.282
17:51:42 CEST: System default Language:  fr_FR
17:51:42 CEST: Opencpn language set to:  en_US
17:51:49 CEST: ChartSymbols loaded from /usr/share/opencpn/s57data/chartsymbols.xml
17:51:50 CEST: Using s57data in /usr/share/opencpn/s57data
17:51:50 CEST: Setting Viewpoint Lat/Lon 33.358, -79.282
17:51:50 CEST: Setting Ownship Lat/Lon 33.358, -79.282
17:51:51 CEST: NMEA Data Source is....NONE
17:51:51 CEST: AIS Data Source is....NONE
__________________
mseb is offline   Reply With Quote
Old 11-08-2012, 10:40   #5
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,016
Re: Nedd help getting OpenCPN running with Ubunutu 12.04

Seb...
It looks like the video drivers are the likely cause. Try switching between the proprietary (fglrx) and opensource (radeon) drivers - both are in Ubuntu's SW repository. You can also try to install the latest (or older) Catalyst drivers manually - a lot of info at https://help.ubuntu.com/community/BinaryDriverHowto/ATI
My own Ubuntu 12.04 machine has a Mobility Radeon X1400 and runs well with the opensource driver.

Good luck

Pavel
__________________
nohal is offline   Reply With Quote
Old 11-08-2012, 11:24   #6
Registered User

Join Date: Aug 2012
Posts: 4
Re: Nedd help getting OpenCPN running with Ubunutu 12.04

Well, from what I can tell, the machine uses the open source drivers : I'm with the stock ubuntu install, nothing happens in ubuntu's "proprietary drivers" panel and I found a mention of "radeon" in the X log.

However, I must admit I'm a little at a loss with this part. I, for example don't know how to tell which drivers are loaded. A simple lsmod didn't show anything obviously related to graphics HW I'm with a 3.2.0-20-generic-pae kernel. As for the X server, if the config file is still /etc/X11/xorg.conf, it's mostly empty and I don't know of any tool which could help here.

Anyway, your graphics drivers idea seems more and more plausible, I'll have a look at what I can do and post the results here.

Thank you for your time.
__________________
mseb is offline   Reply With Quote
Old 11-08-2012, 14:14   #7
Registered User

Join Date: Dec 2008
Boat: Journeyman
Posts: 705
Re: Nedd help getting OpenCPN running with Ubunutu 12.04

Quote:
Originally Posted by mseb View Post
However, I must admit I'm a little at a loss with this part. I, for example don't know how to tell which drivers are loaded.
Try these:

$ jockey-text -l
$ sudo lshw -c video

...read up on them if you want to know more ;-)
__________________
JesperWe is offline   Reply With Quote
Old 12-08-2012, 03:01   #8
Registered User

Join Date: Aug 2012
Posts: 4
Re: Nedd help getting OpenCPN running with Ubunutu 12.04

Code:
$ jockey-text -l
gives no output, at least on stout
Code:
$ sudo lshw -c video
shows that I'm with a radeon Mobility 7000 (RV100)

So I'm with the latest opensource driver that's in ubuntu 12.04.

In the while, I've manually installed the OpenCPN 2.5 version from the website. It works like a charm ! I'm thus more or less happy with the current situation.

However, I'd gladly help fix this issue if I can. What can I do ? BTW, the error message explicitly states that it's an application error.
__________________
mseb is offline   Reply With Quote
Old 12-08-2012, 03:38   #9
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,016
Re: Nedd help getting OpenCPN running with Ubunutu 12.04

Seb...
OpenCPN 3.0 is way more demanding on the graphical subsystem than the previous versions were as OpenGL display was introduced and different kinds of new graphic intensive stuff implemented...
You may run the source in a debugger and try to catch the exact spot where the problem appears so we can see whether we have any chance to do something about it.
If you are not familiar with debugging apps on Linux using gdb, the simplest probably would be to install CodeBlocks IDE, which has ubuntu packages, integrates the debugger in it's GUI and generating it's project files is directly supported by cmake with
Code:
cmake -G "CodeBlocks - Unix Makefiles" ..
From the log we know that you get at least past the AIS init (chart1.cpp:2170) in the MyFrame constructor called from chart1.cpp, line 1557, so that's the place where to start tracing...

Pavel
__________________
nohal is offline   Reply With Quote
Old 14-09-2012, 22:19   #10
Registered User

Join Date: Sep 2012
Location: Malaysia
Boat: maracuja 12m
Posts: 6
Send a message via Skype™ to corinactis
Question Re: Nedd help getting OpenCPN running with Ubunutu 12.04

Hello,
I have a big problem, after installing Ubuntu 12.O4 and openCPN with BU 353 gps to get the data from gps. It doesn't work after hours of research.
I have problem with internet connection all the time.
Thank you if you can help me
Yannick
__________________
corinactis is offline   Reply With Quote
Old 14-09-2012, 23:44   #11
Registered User

Join Date: Dec 2008
Boat: Journeyman
Posts: 705
Re: Nedd help getting OpenCPN running with Ubunutu 12.04

Quote:
Originally Posted by corinactis View Post
Hello,
I have a big problem, after installing Ubuntu 12.O4 and openCPN with BU 353 gps to get the data from gps. It doesn't work after hours of research.
I have problem with internet connection all the time.
Thank you if you can help me
Yannick
Have you followed the instructions provided in Setting Up GPS | Official OpenCPN Homepage ?
__________________
JesperWe is offline   Reply With Quote
Old 15-09-2012, 02:51   #12
Registered User

Join Date: Sep 2012
Location: Malaysia
Boat: maracuja 12m
Posts: 6
Send a message via Skype™ to corinactis
Re: Nedd help getting OpenCPN running with Ubunutu 12.04

Yes, I tried everything on openCPN help as your propose me, but a lot of command they propose (for linux), are invalid command for ubuntu 12.04.
I spend already 4 days to try , it's really difficult to find somebody to help me. My problem is the link between gps BU 353 and opencpn.
I hope for a solution
Thank you
Yannick
__________________
corinactis is offline   Reply With Quote
Old 15-09-2012, 03:08   #13
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,248
Re: Need help getting OpenCPN running with Ubunutu 12.04

It's impossible to help you unless you describe exactly what you are doing. It would help to see your logfile for example.
You could try this:
1 un-install gpsd if it is installed
2 restart the computer
3 NMEA data source should be /dev/ttyUSB0
4 plug in the gps

I have also Ubuntu 12.04 & BU 353 !

Thomas
__________________
cagney is offline   Reply With Quote
Old 15-09-2012, 06:47   #14
Registered User

Join Date: Sep 2012
Location: Malaysia
Boat: maracuja 12m
Posts: 6
Send a message via Skype™ to corinactis
Re: Need help getting OpenCPN running with Ubunutu 12.04

Hello Thomas,
Thank you for your answer. gpsd ans gpsd-clients are uninstalled. On openCPN , after 4 days of research, I already try every choice they give for gps réception.. I know that normally is /dev/ttyUSB0. But nothing arrive.
I get gtkterm, it says "no port open" and on a black page: cannot open/dev/ttyS0: no permission accorded (sorry for my english I'am french)
Other thing, I have an other computer, from a friend which works on Ubuntu 12.04 with opencpcn with my BU 353 ! No special configuration !!!! I can't keep this one !
Then I don't know what to do
Thank you for your next help ?
Yannick
__________________
corinactis is offline   Reply With Quote
Old 15-09-2012, 10:46   #15
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,248
Re: Need help getting OpenCPN running with Ubunutu 12.04

Quote:
Originally Posted by corinactis View Post
Hello Thomas,
Thank you for your answer. gpsd ans gpsd-clients are uninstalled. On openCPN , after 4 days of research, I already try every choice they give for gps réception.. I know that normally is /dev/ttyUSB0. But nothing arrive.
I get gtkterm, it says "no port open" and on a black page: cannot open/dev/ttyS0: no permission accorded (sorry for my english I'am french)
Other thing, I have an other computer, from a friend which works on Ubuntu 12.04 with opencpcn with my BU 353 ! No special configuration !!!! I can't keep this one !
Then I don't know what to do
Thank you for your next help ?
Yannick
Permissions....
Do you belong to the group "dialout" ?

To check write "groups" on the command line and then press enter.
Check that "dialout" appears in the output.
If not execute:
Quote:
sudo usermod -a -G dialout $USER
Then try your gps again.

Thomas
__________________

__________________
cagney is offline   Reply With Quote
Reply

Tags
opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCPN running but not visible spiv OpenCPN 12 03-05-2012 15:56
Open CPN and Google Earth bgrimwade OpenCPN 19 09-12-2011 16:32
OpenCPN Version 2.5 Release bdbcat OpenCPN 86 02-09-2011 19:14
OpenCPN Stops Running BobLarkin OpenCPN 2 31-08-2011 00:38
Route Properties, Missing Functions James Baines OpenCPN 13 13-07-2011 05:31



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 20:19.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.