Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 25-08-2016, 06:45   #46
Marine Service Provider

Join Date: May 2013
Location: Norway
Posts: 506
Re: Navico radar plugin v2.0 released

First of all, I just installed the pluging without a radar in " Emulate" mode just to look at the plugin. V2.0 installed and worked fine, V2.1 crashes when pressing "enable" in the plugins window.
__________________

__________________
petter5 is offline   Reply With Quote
Old 25-08-2016, 07:00   #47
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Westerly Pentland
Posts: 1,571
Re: Navico radar plugin v2.0 released

V2.1 doesn't crash for Mac OS X but I have to tick 3 times onto the radar menue to switch from standby mode to emulator mode. Perhaps merrimac should have a look for this.

Gerhard
Attached Images
 
__________________

__________________
CarCode is offline   Reply With Quote
Old 25-08-2016, 15:47   #48
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 1,685
Re: Navico radar plugin v2.0 released

Petter5
Strange - I've now also tested 2.1 on a Win-XP and it works as fine as on Win10. I've also tested to disable and enable the plugin without problem.

Håkan
__________________
Hakan is offline   Reply With Quote
Old 25-08-2016, 16:23   #49
Marine Service Provider

Join Date: May 2013
Location: Norway
Posts: 506
Re: Navico radar plugin v2.0 released

Quote:
Originally Posted by Hakan View Post
Petter5
Strange - I've now also tested 2.1 on a Win-XP and it works as fine as on Win10. I've also tested to disable and enable the plugin without problem.

Håkan
Not critical for me, the old WIN pc is only for testing and works fine except for this issue. Will try to rename the ini file, restart and try to enable plugin to see is if any success,,, tomorrow or later when I'm close to that pc.
__________________
petter5 is offline   Reply With Quote
Old 26-08-2016, 00:45   #50
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 1,685
Re: Navico radar plugin v2.0 released

Petter
BTW what's the OCPN version on the "old" one? Should be 4.4 or newer. I'm on 4.5
__________________
Hakan is offline   Reply With Quote
Old 26-08-2016, 01:46   #51
Marine Service Provider

Join Date: May 2013
Location: Norway
Posts: 506
Re: Navico radar plugin v2.0 released

Quote:
Originally Posted by Hakan View Post
Petter
BTW what's the OCPN version on the "old" one? Should be 4.4 or newer. I'm on 4.5
4.4 downloaded from the opencpn site.
__________________
petter5 is offline   Reply With Quote
Old 26-08-2016, 09:12   #52
Registered User

Join Date: Jan 2010
Location: Harlingen, NL
Boat: KMY Stadtship 56
Posts: 166
Re: Navico radar plugin v2.0 released

Gerhard,

Try waiting a little longer.


Sent from my iPhone using Cruisers Sailing Forum
__________________
merrimac is offline   Reply With Quote
Old 26-08-2016, 10:28   #53
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Westerly Pentland
Posts: 1,571
Re: Navico radar plugin v2.0 released

Sorry, I was too lazy to look for myself.

Gerhard
__________________
CarCode is offline   Reply With Quote
Old 28-08-2016, 08:04   #54
Registered User

Join Date: Jan 2010
Location: Harlingen, NL
Boat: KMY Stadtship 56
Posts: 166
Re: Navico radar plugin v2.0 released

The PPA version has been updated to 2.1 by Pavel yesterday, thanks!

From here on we're going to go back to slow development on the master branch, and the next big step is to make the code share-able with the Garmin guys.
__________________
merrimac is offline   Reply With Quote
Old 28-08-2016, 11:10   #55
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Westerly Pentland
Posts: 1,571
Re: Navico radar plugin v2.0 released

Just compiled with the commits of today now. Very nice, no 3 time clicks needed anymore to switch between standby and emulation. Congratulations.
Best plugin I have ever seen.

Gerhard
__________________
CarCode is offline   Reply With Quote
Old 31-08-2016, 13:59   #56
Registered User

Join Date: Jan 2012
Posts: 22
No radar present

Hi,

I'd be very grateful for guidance on what I am doing wrong, since I cannot get Open CPN to recognise the presence of the new B & G 3G scanner that I've just taken delivery of.

I have CPN 4.4. installed. And plug in 2.0 installed and enabled.

I've connected the scanner to power and verified that 12.5V is present at pins 1 & 2 of plug into scanner.

I've connected the 20M supplied scanner cable directly into the ethernet port on my laptop.

I have not connected to Heading or Position sources as yet, since I am not on the boat.

A BR24 button shows up on the button bar, though there is no light showing in the bottom right hand corner of the button as the manual suggest there should be.

The Radar Control dialogue box comes up and shows :
>No lights at all in the top section.
>"Cannot switch radar on as it is not connected or off."
>Accelerated graphics box is ticked.
>No tick in Radar Present box.
> There is no Zero Config line as the manual suggests there should be but in place of that it says"Ethernet Card" followed by two alternating sets of numbers - presumably IP addresses.

I have tried with the yellow "switch" wire both connected and disconnected to the +ve power supply as suggested in B & G manual, but it appears to make no difference.

This may not be relevant, but in the Ethernet tab of the laptop's Network Connections nothing shows up despite the radars ethernet cable being plugged in. By contrast if I take a wired connection from my wireless router that shows up immediately.

All suggestions gratefully received.

Regards,

Graham
__________________
GrahamW is offline   Reply With Quote
Old 31-08-2016, 14:16   #57
Registered User

Join Date: Jan 2010
Location: Harlingen, NL
Boat: KMY Stadtship 56
Posts: 166
Re: Navico radar plugin v2.0 released

Graham,

The recommended practice is to use the supplied RI10 box. The only downside is you need a Navico yellow to RJ45 conversion cable. Navico has a complete one now, see http://store.navico.com/Products/000-10438-001 . You can also get a yellow to yellow one that you need to cut in half and crimp a RJ 45 on. See http://yachtelectronics.blogspot.nl/...t-cabling.html

This will allow addition of a plotter later on with use of MARPA. It also means you're not wondering what's one the other four pins in your Radar cable.

I also recommend using a switch, this isolates any electrical issues to one device only. With your setup, plug the radar into the wireless router, and keep it there. Do you see the appropriate LEDs for 100 Mbit Ethernet?

Did you disable the Windows firewall for testing?


Sent from my iPad using Cruisers Sailing Forum
__________________
merrimac is offline   Reply With Quote
Old 01-09-2016, 04:16   #58
Registered User

Join Date: Jan 2012
Posts: 22
No radar present

Merrimac,

Thanks for such a quick and helpful reply.

Apologies, I had not disabled the Firewall! Despite having read through all previous forum posts 10 days or so ago and noted that needed to be done, I clean forgot in the excitement of the scanner arriving....

I'm still plugging the scanner cable direct, since it will take me a few days to sort out the connection via the RI 10.

But plugging direct into the router did activate the LED.

And with the firewall off the Radar present box is ticked and followed by an IP address.

But there is no tick in the Radar sending data box and it does not switch to the controls dialog.

I have switched to Emulator mode but still do not get a picture.

I have changed the VerboseLog in the ini file to 2, but still no picture.

Not sure if it is relevant, but extract from logfile below.

Is my issue likely to be resolved once I connect via the RI 10, or is there something else I need to try?

Thanks.

Graham

10:50:50 AM: BR24radar_pi: RenderGLOverlay
10:50:50 AM: BR24radar_pi: Radar busy encountered, overlay_refreshes_queued=1
10:50:50 AM: BR24radar_pi: Radar busy encountered, overlay_refreshes_queued=1
10:50:50 AM: BR24radar_pi: Radar busy encountered, overlay_refreshes_queued=1
10:50:50 AM: BR24radar_pi: Radar busy encountered, overlay_refreshes_queued=1
10:50:50 AM: BR24radar_pi: Radar busy encountered, overlay_refreshes_queued=1
10:50:50 AM: BR24radar_pi: Radar busy encountered, overlay_refreshes_queued=1
10:50:50 AM: BR24radar_pi: Radar busy encountered, overlay_refreshes_queued=1
10:50:51 AM: BR24radar_pi: messagebox decision: show=1 overlay=0 auto_hide=1 opengl=1 radarOn=1 navOn=0
10:50:51 AM: BR24radar_pi: messagebox overlay needs not met: SHOW
10:50:51 AM: BR24radar_pi: no change
10:50:51 AM: BR24radar_pi: Radar busy encountered, overlay_refreshes_queued=1
10:50:51 AM: BR24radar_pi: Radar busy encountered, overlay_refreshes_queued=1
10:50:51 AM: BR24radar_pi: Radar busy encountered, overlay_refreshes_queued=1
10:50:51 AM: BR24radar_pi: Radar busy encountered, overlay_refreshes_queued=1
10:50:51 AM: BR24radar_pi: RenderGLOverlay
10:50:51 AM: BR24radar_pi: Radar busy encountered, overlay_refreshes_queued=1
10:50:51 AM: BR24radar_pi: Radar busy encountered, overlay_refreshes_queued=1
__________________
GrahamW is offline   Reply With Quote
Old 01-09-2016, 04:37   #59
Registered User

Join Date: Jan 2010
Location: Harlingen, NL
Boat: KMY Stadtship 56
Posts: 166
Re: No radar present

Quote:
Originally Posted by GrahamW View Post
Merrimac,
And with the firewall off the Radar present box is ticked and followed by an IP address.

But there is no tick in the Radar sending data box and it does not switch to the controls dialog.

I have switched to Emulator mode but still do not get a picture.

I have changed the VerboseLog in the ini file to 2, but still no picture.

Not sure if it is relevant, but extract from logfile below.

Is my issue likely to be resolved once I connect via the RI 10, or is there something else I need to try?
...

10:50:51 AM: BR24radar_pi: messagebox decision: show=1 overlay=0 auto_hide=1 opengl=1 radarOn=1 navOn=0
10:50:51 AM: BR24radar_pi: messagebox overlay needs not met: SHOW
First make sure your display options are OK.
  1. Disconnect the radar
  2. Enable emulator mode
  3. Open the radar PPI window (black window with range rings)
  4. Press Menu and select Transmit. Wait 2 seconds.
  5. You should now see a "blocky" pattern at various ranges.

If not, go back to the preferences > plugin > options and choose a different drawing method (flip between vertex and shader).

Once this works, you can try the real radar:
  1. Disable emulator mode
  2. Connect the radar
  3. Open the radar PPI window (black window with range rings)
  4. This should show "Radar standby". If it says anything else it should have opened the "Info" dialog for you showing what is insufficient.
  5. Now you can access the menu and press "Standby/Transmit".
  6. If this does not switch on the radar make sure outgoing connections are allowed by the firewall.

Only once this works can you go to the next step which is getting heading in order to allow overlay over chart.
__________________
merrimac is offline   Reply With Quote
Old 01-09-2016, 05:39   #60
Registered User

Join Date: Jan 2012
Posts: 22
Re: Navico radar plugin v2.0 released

Merrimac,

Thanks - this is what happened so far :

Disconnect the radar
>Done
Enable emulator mode
> Done
Open the radar PPI window (black window with range rings)
> I assume by this you mean the BR24Radar button on the button bar, though initially it is white with range rings? When pressed, it does turn black, but only the Radar Open CPN options dialog box comes up, with Open GL, Radar present and Variation boxes ticked, nothing else. I do not see any Menu.

Graham
__________________

__________________
GrahamW is offline   Reply With Quote
Reply

Tags
lease, navico, plug, radar

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
BR24 radar plugin Beta 2.515 released merrimac OpenCPN 14 08-08-2016 16:43
Navico Radar Plugin + heading problem Jonna OpenCPN 9 06-07-2016 14:10
Navico radar plugin hardware connection mikereed100 OpenCPN 8 07-12-2015 10:44
Navico RADAR Plugin Optimization NahanniV OpenCPN 67 19-10-2015 23:46
Garmin Radar PlugIn Version 1.4 Released bdbcat OpenCPN 8 20-06-2014 18:03


Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 03:11.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.