Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-01-2011, 10:19   #16
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Thomas..

I've re-checked my PATH settings in the System Variables panel and can not find anything wrong. Have a look.

Quote:
D:\PROGRAM FILES\MC2BSBH;\D:\PROGRAM FILES\IMAGEMAGIC\ImageMagick-6.6.3-Q16;%SystemRoot%\system32;%SystemRoot%;%SystemRoot %\System32\Wbem;C:\Programfiler\Common Files\Ulead Systems\MPEG;C:\kap;C:\%SYSTEMROOT%\System32\Windo wsPowerShell\v1.0\;C:\Windows\QTSystem\;D:\PROGRAM FILES\RUBY\ruby-1.9.2-p136\;D:\PROGRAM FILES\LIBBSB;D:\PROGRAM FILES\MAP2KAP
Trying to start Chartconverter from it's own directory aborts Windows operation. The second message in Norwegian says "Stopped functioning" and "Windows is looking for a solution" then I aborted..

Tore
Attached Thumbnails
Click image for larger version

Name:	Screenshot_01 Jan. 04 15.17.jpg
Views:	121
Size:	14.7 KB
ID:	22535   Click image for larger version

Name:	Screenshot_02 Jan. 04 15.17.jpg
Views:	111
Size:	15.3 KB
ID:	22536  

__________________

__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline   Reply With Quote
Old 04-01-2011, 10:43   #17
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,250
Quote:
Originally Posted by cagney View Post
Tore, if you have downloaded ruby you probably have to associate the ".rb" ending with ruby manually. Again Google is your friend.
Rightclick map2kap, press properties. What does "Type of file" say?
I should read: "Ruby Program".
Please read CarCode's post again!

Thomas
__________________

__________________
cagney is offline   Reply With Quote
Old 04-01-2011, 11:08   #18
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Thomas.. Done that... have a look....

I even downloaded a fresh Chartconvert.exe and installed,but still not accepted as Windows 32 program and aborts Windows. I even ran it from within the Chartconverts own directory.

Same with your program,will not run in the Ruby directory.
Error messages says "Not a valid Win 32bit program"

HappySeagull's suggestions does not work here either.

Tore
Attached Thumbnails
Click image for larger version

Name:	Screenshot_02 Jan. 04 16.16.jpg
Views:	120
Size:	57.2 KB
ID:	22537  
__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline   Reply With Quote
Old 04-01-2011, 11:36   #19
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,250
Quote:
Originally Posted by sinbad7 View Post
Thomas.. Done that... have a look....

I even downloaded a fresh Chartconvert.exe and installed,but still not accepted as Windows 32 program and aborts Windows. I even ran it from within the Chartconverts own directory.

Same with your program,will not run in the Ruby directory.
Error messages says "Not a valid Win 32bit program"

HappySeagull's suggestions does not work here either.

Tore
No you have not!
Right-click on the ruby-file icon in explorer, not in the dos window. Actually, your output shows that ruby is not correctly installed and associated with the "rb" extension. I get the same response on a XP if I try a non existing extension.

Another simple test. In any dos terminal write: ruby -v , and hit enter. It should tell you the version of ruby you have installed, if indeed installed correctly.
Do not mess around in the directories where ruby is installed or in "Program Files"! Leave them alone.
If your path is set up correctly things will work from your normal home folder, "My Documents" or whatever you normally use.
Change back your path to the original settings. You don't even know if it was wrong to start with, as ruby never worked.


Thomas
__________________
cagney is offline   Reply With Quote
Old 04-01-2011, 12:35   #20
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Thomas..

Actually,I DID list the setup and it shows ok I think.
Perhaps my mistake was moving some programs to drive D: to have them in the same area and then editing the PATH section in the control box.

I have since tried to re-install these progs from scratch to drive D: but still having problems. I think the PATH alterations are causing all the problems but unfortunately I did not take a backup of the original settings and a re-set to a few days ago does not work. Sorry to bother you with all these problems.

The only area I edited was PATH as seen in the attachment,and the present contents is as follows:

Quote:
D:\PROGRAM FILES\IMAGEMAGIC\ImageMagick-6.6.3-Q16;D:\PROGRAM FILES\MC2BSBH;\D:\PROGRAM FILES\IMAGEMAGIC\ImageMagick-6.6.3-Q16;%SystemRoot%\system32;%SystemRoot%;%SystemRoot %\System32\Wbem;C:\Programfiler\Common Files\Ulead Systems\MPEG;C:\kap;C:\%SYSTEMROOT%\System32\Windo wsPowerShell\v1.0\;C:\Windows\QTSystem\;D:\PROGRAM FILES\RUBY\ruby-1.9.2-p136\;D:\PROGRAM FILES\LIBBSB;D:\PROGRAM FILES\Chartconvert;D:\PROGRAM FILES\MAP2KAP;D:\PROGRAM FILES\ooRexx
Tore
Attached Thumbnails
Click image for larger version

Name:	Screenshot_01 Jan. 04 16.01.jpg
Views:	133
Size:	44.2 KB
ID:	22538   Click image for larger version

Name:	Screenshot_05 Jan. 04 17.43.jpg
Views:	140
Size:	56.3 KB
ID:	22539  

__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline   Reply With Quote
Old 04-01-2011, 14:47   #21
Obsfucator, Second Class
 
dacust's Avatar

Cruisers Forum Supporter

Join Date: Feb 2008
Location: Southeast USA.
Boat: 1982 Sea Ray SRV360
Posts: 1,743
Quote:
Originally Posted by sinbad7 View Post
Thomas..

Actually,I DID list the setup and it shows ok I think.
Perhaps my mistake was moving some programs to drive D: to have them in the same area and then editing the PATH section in the control box.

I have since tried to re-install these progs from scratch to drive D: but still having problems. I think the PATH alterations are causing all the problems but unfortunately I did not take a backup of the original settings and a re-set to a few days ago does not work. Sorry to bother you with all these problems.

The only area I edited was PATH as seen in the attachment,and the present contents is as follows:



Tore
Here is what I see wrong in your path:

Code:
D:\PROGRAM FILES\IMAGEMAGIC\ImageMagick-6.6.3-Q16;
D:\PROGRAM FILES\MC2BSBH;
\D:\PROGRAM FILES\IMAGEMAGIC\ImageMagick-6.6.3-Q16;   Should not have first \.  
                                                      No matter though, it is a duplicate.
                                                      So just remove it.
%SystemRoot%\system32;
%SystemRoot%;
%SystemRoot %\System32\Wbem;                          Remove space after %SystemRoot
C:\Programfiler\Common Files\Ulead Systems\MPEG;
C:\kap;
C:\%SYSTEMROOT%\System32\Windo wsPowerShell\v1.0\;
C:\Windows\QTSystem\;
D:\PROGRAM FILES\RUBY\ruby-1.9.2-p136\;
D:\PROGRAM FILES\LIBBSB;
D:\PROGRAM FILES\Chartconvert;
D:\PROGRAM FILES\MAP2KAP;
D:\PROGRAM FILES\ooRexx
Here it is edited.

Code:
D:\PROGRAM FILES\IMAGEMAGIC\ImageMagick-6.6.3-Q16;D:\PROGRAM FILES\MC2BSBH;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Programfiler\Common Files\Ulead Systems\MPEG;C:\kap;C:\%SYSTEMROOT%\System32\Windo wsPowerShell\v1.0\;C:\Windows\QTSystem\;D:\PROGRAM FILES\RUBY\ruby-1.9.2-p136\;D:\PROGRAM FILES\LIBBSB;D:\PROGRAM FILES\Chartconvert;D:\PROGRAM FILES\MAP2KAP;D:\PROGRAM FILES\ooRexx
This does NOT ensure you have everything in there you need, or that there are no typos in there. It only corrects 2 syntax errors.

WARNING!!! Before changing your path to what I posted, make sure at least two other people in here proofread what I posted and say they don't find any errors I may have introduced.

-dan
dacust is offline   Reply With Quote
Old 04-01-2011, 15:08   #22
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Dan..

I have now made these last two corrections and re-booted the system.

Quote:
D:\PROGRAM FILES\MC2BSBH;\D:\PROGRAM FILES\IMAGEMAGIC\ImageMagick-6.6.3-Q16;%SystemRoot%\system32;%SystemRoot%;%SystemRoot %\System32\Wbem;C:\Programfiler\Common Files\Ulead Systems\MPEG;C:\kap;C:\%SYSTEMROOT%\System32\Windo wsPowerShell\v1.0;C:\Windows\QTSystem\;D:\PROGRAM FILES\RUBY\ruby-1.9.2-p136;D:\PROGRAM FILES\LIBBSB\libbsb-0.0.7;D:\PROGRAM FILES\Chartconvert;D:\PROGRAM FILES\MAP2KAP;D:\PROGRAM FILES\ooRexx
Is there anything else to be corrected in this area?

Thanks

Tore
__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline   Reply With Quote
Old 04-01-2011, 15:19   #23
Registered User

Join Date: Sep 2009
Location: Rome
Posts: 320
Tore,

what is this?

C:\%SYSTEMROOT%\System32\Windo wsPowerShell\v1.0\;

I guess it should be

%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;

ciao, Marco
__________________
GPS-Marco is offline   Reply With Quote
Old 04-01-2011, 15:30   #24
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Marco..

Strange but the space does not exist in the real Path,only when printed out here in the box.

Thanks for checking.

Tore

P.S. I'm in real trouble since this morning as none of my 'special' map conversion programs are working. Ruby based prog. does not work and others like Imagemagic and tif2bsb.exe in libbsb-0.0.7 can not be found..
__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline   Reply With Quote
Old 04-01-2011, 15:54   #25
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
For example... I am trying to start GE2KAP but have to show the program where 'ooRexx' is located and then get the message that both 'ImageMagic convert' as well as 'tif2bsb' is not installed and can not be found respectively.

Must be something very wrong with the system path setup as none of the programs can find the required directories and components.

Tore
Attached Thumbnails
Click image for larger version

Name:	Screenshot_02 Jan. 04 20.42.jpg
Views:	125
Size:	78.8 KB
ID:	22541  
__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline   Reply With Quote
Old 05-01-2011, 02:24   #26
Registered User

Join Date: Sep 2009
Location: Rome
Posts: 320
Quote:
Originally Posted by GPS-Marco View Post
Tore,

what is this?

C:\%SYSTEMROOT%\System32\Windo wsPowerShell\v1.0\;

I guess it should be

%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;

ciao, Marco
Tore, even if spaces are not there, please try to remove C:\ in front of %SYSTEMROOT%

Ciao, Marco.
__________________
GPS-Marco is offline   Reply With Quote
Old 05-01-2011, 04:25   #27
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Hi Marco..

There are two instances of '%SYSTEMROOT%' ,the first one does not show the drive and the second one shows C:\ Which one is right? Trying your suggestion.

Regds
Tore
__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline   Reply With Quote
Old 05-01-2011, 05:52   #28
Registered User

Join Date: Sep 2009
Location: Rome
Posts: 320
Quote:
Originally Posted by sinbad7 View Post
Hi Marco..

There are two instances of '%SYSTEMROOT%' ,the first one does not show the drive and the second one shows C:\ Which one is right? Trying your suggestion.

Regds
Tore
Tore, on a cmd shell try to type:

echo %systemroot%

you will see that %systemroot% variable already contains the drive letter. So you shoud not put the drive letter again in front of %systemroot%

Ciao, Marco.
__________________
GPS-Marco is offline   Reply With Quote
Old 05-01-2011, 07:25   #29
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Thanks Marco..

Now at least my Chartconvert is working again.

The other two programs based on 'rex' and 'rb' (Ruby) are still not working.
The programs when executed finds no operating language.

Should the Windows system not be adviced of the various languages used so it will be recognised when executed? Is there a listing in the kontrol panel (Path etc) where the rex and rb suffixes should be entered?

These type of programs are not using the Windows installer but instead enter the building "via the back stairs without the janitor knowing about it". When unzipped,they are just placed in a new directory and "who tells the janitor?"

We live and learn!

Tore
__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline   Reply With Quote
Old 05-01-2011, 10:02   #30
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,250
Quote:
Originally Posted by sinbad7 View Post

.........
These type of programs are not using the Windows installer but instead enter the building "via the back stairs without the janitor knowing about it". When unzipped,they are just placed in a new directory and "who tells the janitor?"

.....

Tore
Good that you have managed to sort out the worst issues!

The quote above is not correct. Both the link I gave to Ruby in #8 and "phiggins" link to ooRex leads to full installers, that register properly with win, and takes care of "path" etc. I suggest that you try to download this Ruby package and reinstall. Also .. reinstall ooRex and you ought to be OK .

Thomas
__________________

__________________
cagney is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Portable OpenCPN zemaria OpenCPN 12 05-07-2010 05:34
I Have a Few Questions Regarding OpenCPN Skua OpenCPN 1 03-06-2010 23:24
OpenCPN bdbcat OpenCPN 1343 19-09-2009 16:59
OziExplorer phiggins Navigation 2 27-06-2009 14:43



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 04:07.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.