Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 20-09-2019, 13:25   #1
Registered User

Join Date: Jul 2019
Posts: 6
Lost feature after updating OpenCPN

Hello,


I updated openCPN from version 4.8 to 5.0. After updating the data shown in Active Route Console disapeart. The NMEA sentences i got before from the openCPN are also missing. I would like to controll the autopilot with this data. What could be the possible reason and how can I solwe the issue?



My sistem:
Raspberry Pi 3B+
openplotter 1.2 alpha
openCPN 5.0
__________________

robertsail is offline   Reply With Quote
Old 20-09-2019, 14:32   #2
Moo
Registered User

Join Date: Mar 2017
Posts: 474
Re: Lost feature after updating OpenCPN

Quote:
Originally Posted by robertsail View Post
Hello,


I updated openCPN from version 4.8 to 5.0. After updating the data shown in Active Route Console disapeart. The NMEA sentences i got before from the openCPN are also missing. I would like to controll the autopilot with this data. What could be the possible reason and how can I solwe the issue?



My sistem:
Raspberry Pi 3B+
openplotter 1.2 alpha
openCPN 5.0
Do you mean the track info as shown in the attached screenshot?

As for the NMEA output. Have you set up an output under connections?
Attached Thumbnails
Click image for larger version

Name:	goto.PNG
Views:	24
Size:	39.2 KB
ID:	200244  
__________________

Moo is offline   Reply With Quote
Old 20-09-2019, 14:48   #3
Registered User

Join Date: Jul 2019
Posts: 6
Re: Lost feature after updating OpenCPN

Hello,


Yes, the track like on your screenshot is empty. The windows of the active leg is shown but empty, no data.


Under the connections I hawe a serial connection to the USB port I use for connection to the Autopilot. Is this correct?
robertsail is offline   Reply With Quote
Old 20-09-2019, 15:00   #4
Moo
Registered User

Join Date: Mar 2017
Posts: 474
Re: Lost feature after updating OpenCPN

Quote:
Originally Posted by robertsail View Post
Hello,


Yes, the track like on your screenshot is empty. The windows of the active leg is shown but empty, no data.


Under the connections I hawe a serial connection to the USB port I use for connection to the Autopilot. Is this correct?
Do you have valid GPS position coming in? Check the NMEA diagnostics window.

You will need to configure input (from the GPS) and output (to the autopilot)

Can you send screenshots of your settings or attach your config file here (rename it by changing the extension if necessary) You can find the location of your configuration file if you click the help icon, it is shown in the pop-up window.
Moo is offline   Reply With Quote
Old 20-09-2019, 15:10   #5
Registered User

Join Date: Jul 2019
Posts: 6
Re: Lost feature after updating OpenCPN

Yes, I assume, that the GPS position is OK because I get the correct position. If I switch on tracking the track line is correct. I can get the RMC NMEA sentence in the diagnostic window but no other sentence. I will send the config file as soon I can.
robertsail is offline   Reply With Quote
Old 21-09-2019, 13:58   #6
Registered User

Join Date: Jul 2019
Posts: 6
Re: Lost feature after updating OpenCPN

Hello, hier are the screenshots from my openplotter and openCPN.


In openplotter defined USB for Autopilot is the ttyUSB0. The Autopilot I use is a Raymarine ST2000+ and I set all NMEA sentences accordingly to autopilots manual.


I also set a connection in openCPN.
Attached Thumbnails
Click image for larger version

Name:	openplotter_1.jpg
Views:	26
Size:	107.6 KB
ID:	200316   Click image for larger version

Name:	openplotter_2.jpg
Views:	27
Size:	112.7 KB
ID:	200317  

Click image for larger version

Name:	openCPN1.jpg
Views:	27
Size:	325.9 KB
ID:	200318  
robertsail is offline   Reply With Quote
Old 21-09-2019, 14:06   #7
Registered User

Join Date: Jul 2019
Posts: 6
Re: Lost feature after updating OpenCPN

Hier is the config file.
Attached Files
File Type: doc opencpnconf.doc (18.5 KB, 5 views)
robertsail is offline   Reply With Quote
Old 21-09-2019, 14:11   #8
Moo
Registered User

Join Date: Mar 2017
Posts: 474
Re: Lost feature after updating OpenCPN

Ah... You're using openplotter! That changes things.

You don't mess with the settings in OCPN but configure the external connections on openplotter.

I think you need to change the connection to openplotter (in OCPN) to in/out.

The direct connection that you have set up in OCPN won't work IIRC.

I don't have a current version of openplotter running to fiddle with. If you are running Openplotter you are better of asking for support on their support forums... Scroll down to the bottom of the openplotter website and select support... (nope no idea why the menu is at the bottom page!).
Moo is offline   Reply With Quote
Old 22-09-2019, 13:35   #9
Registered User

Join Date: Jul 2019
Posts: 6
Re: Lost feature after updating OpenCPN

Thank you for your advice, it was a connection problem. The data in the Active Route Console disapeart because the font color changed to black at the update.



Why the screen flicker to white for a second from time to time? Is this a problem of limitations of the Raspberry Pi? Is it possible to optimize the resources to prevent this flickering?
__________________

robertsail is offline   Reply With Quote
Reply

Tags
enc, lost, opencpn

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues with updating NOAA charts in OpenCPN Android version Mitch K OpenCPN 2 18-02-2019 10:17
Couple of Practical OpenCPN Questions or Possibly Feature Requests Dockhead OpenCPN 45 05-09-2017 11:28
OpenCPN.org - Feature Requests Netsurfer OpenCPN 8 14-05-2017 00:15
Tracker 9: Lost Feature Route Properties rgleason OpenCPN 1 13-05-2016 03:02
OpenCPN Bug Report / Feature Request Tracker bdbcat OpenCPN 37 09-10-2011 02:15

Advertise Here


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 13:06.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×

ShowCase vBulletin Plugins by Drive Thru Online, Inc.