Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 22-12-2017, 08:27   #1
Registered User

Join Date: Dec 2013
Location: The Netherlands
Boat: Hallberg Rassy 40c
Posts: 14
Instruction to install OpenCPN on RPI3 does not work!

I tried to install opencpn on my rpi3 following the instructions in the manual.
Made a new Raspbian installation on a 16gb sd card. Following the instructions gives an error dirmngr does not exist.!
What is wrong ? Who has a solution ?
__________________

reinM is offline   Reply With Quote
Old 22-12-2017, 08:32   #2
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 3,540
Re: Instruction to install OpenCPN on RPI3 does not work!

Go for OpenPlotter, everything packaged and prepared for rasPi...
Sailing with free hardware | Sailoog

Complete SD card image with very good support and a lot of other goodies for sailing
__________________

bcn is offline   Reply With Quote
Old 22-12-2017, 08:42   #3
Registered User

Join Date: Dec 2013
Location: The Netherlands
Boat: Hallberg Rassy 40c
Posts: 14
Re: Instruction to install OpenCPN on RPI3 does not work!

Quote:
Originally Posted by bcn View Post
Go for OpenPlotter, everything packaged and prepared for rasPi...

Sailing with free hardware | Sailoog



Complete SD card image with very good support and a lot of other goodies for sailing


I know and I have OpenPlotter working, but I want to test if there is a difference in performance. Sometimes I don’t need the extra things from OP.
reinM is offline   Reply With Quote
Old 22-12-2017, 09:05   #4
Registered User

Join Date: Aug 2016
Posts: 77
Re: Instruction to install OpenCPN on RPI3 does not work!

Quote:
Originally Posted by reinM View Post
I tried to install opencpn on my rpi3 following the instructions in the manual.
Made a new Raspbian installation on a 16gb sd card. Following the instructions gives an error dirmngr does not exist.!
What is wrong ? Who has a solution ?
Don't know what's wrong, but solution is easy
Code:
sudo aptitude install dirmngr
BlackSea is offline   Reply With Quote
Old 23-12-2017, 01:09   #5
Registered User

Join Date: Oct 2014
Location: Netherlands
Boat: Halmatic 30
Posts: 588
Re: Instruction to install OpenCPN on RPI3 does not work!

Quote:
Originally Posted by reinM View Post
I know and I have OpenPlotter working, but I want to test if there is a difference in performance. Sometimes I don’t need the extra things from OP.
Beste Rein,

the best result you get from OpenPlotter is an update to Linux Stretch and then switch on the VC4 driver. Then you get an excellent performance of OpenCPN on the Raspberry Pi3.

OpenPlotter is working on a Linux Stretch version (Debian 9).

But you can do it also yourselves. The instructions to do the upgrade is very simple.

Groet,

Bram
verkerkbr is offline   Reply With Quote
Old 23-12-2017, 04:08   #6
Registered User

Join Date: Nov 2007
Location: Probably in an anchorage or a boatyard..
Boat: Ebbtide 33' steel cutter
Posts: 4,680
Re: Instruction to install OpenCPN on RPI3 does not work!

Quote:
Originally Posted by reinM View Post
I know and I have OpenPlotter working, but I want to test if there is a difference in performance. Sometimes I don’t need the extra things from OP.
Tried loading htop? "Sudo apt-get install htop" , the just "htop" to start the program which will show what resources each process is using. You can kill processes one by one to see what changes. Openplotter processes are typically well below 10%.
conachair is online now   Reply With Quote
Old 24-12-2017, 05:24   #7
Registered User

Join Date: Dec 2013
Location: The Netherlands
Boat: Hallberg Rassy 40c
Posts: 14
Re: Instruction to install OpenCPN on RPI3 does not work!

I still tried on a new loaded sd card to get openCPN without Openplotter, I did :

sudo aptitude install dirmngr

Followed the instructions on OpenCPN Raspbian 2/3

after

sudo apt-get install opencpn

I get as result :

Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd
De statusinformatie wordt gelezen... Klaar
Sommige pakketten konden niet geļnstalleerd worden. Dit kan betekenen
dat u om een onmogelijke situatie gevraagd heeft, of, indien u
de distributie 'unstable' gebruikt, dat sommige benodigde pakketten nog gemaakt moeten worden of uit 'Incoming' verwijderd werden.
De volgende informatie kan misschien helpen de situatie op te lossen:

De volgende pakketten hebben niet-voldane vereisten:
opencpn : Vereisten: libtinyxml2.6.2 maar het is niet installeerbaar
Vereisten: libwxbase3.0-0 (>= 3.0.0) maar het is niet installeerbaar
Vereisten: libwxgtk3.0-0 (>= 3.0.0) maar het is niet installeerbaar
Aanbevelingen: xcalib maar het zal niet geļnstalleerd worden
Aanbevelingen: opencpn-doc maar het zal niet geļnstalleerd worden
Aanbevelingen: opencpn-gshhs-intermediate maar het zal niet geļnstalleerd worden
Aanbevelingen: opencpn-gshhs-high maar het zal niet geļnstalleerd worden
Aanbevelingen: opencpn-gshhs-full maar het zal niet geļnstalleerd worden
E: Kan problemen niet verhelpen, u houdt defecte pakketten vast.

Anyway, Merry Christmas.

Rein
reinM is offline   Reply With Quote
Old 24-12-2017, 06:15   #8
Registered User

Join Date: Oct 2014
Location: Netherlands
Boat: Halmatic 30
Posts: 588
Re: Instruction to install OpenCPN on RPI3 does not work!

Beste Rein,

you must have the correct server settings to install OpenCPN.

What is wrong with OpenPlotter ? You can switched off the items you don't like.

My recommandation is: OpenPlotter 0.10 with the latest updates. Linux and the latest updates sudo apt update en sudo apt upgrade. Latest kernel update sudo rpi-update. Now 4.9.70.

And then changing the server settings from jessie to stretch.

sudo apt update en sudo apt upgrade. It is a very large update, but simple to do.

Then remove all the unused files with sudo apt autoremove.

To speed things up: sudo raspi-config en switch vc4 driver to on.

Groet,

Bram
Have a nice weekend.
verkerkbr is offline   Reply With Quote
Old 24-12-2017, 09:46   #9
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 5,226
Re: Instruction to install OpenCPN on RPI3 does not work!

Rein...
Would it be possible to do us a favour and run the commands with english locale while intending to post their output here? Like in
Code:
LANG=C apt-get install opencpn
Anyway, your Raspbian repositories do not contain packages able to satisfy OpenCPN's dependencies. libtinyxml seems to be renamed to libtinyxml2.6.2v5 and all the wxWidgets packages have -0v5 suffix added to the name in Debian Stretch, on which your Raspbian probaby is based.
This means only one thing, you can't use the packages for Ubuntu Trusty on Stretch based Raspbian anymore. But looking at the Ubuntu repositories, you might have luck using Xenial instead.

I really doubt you can get any measurable performance advantage over OpenPlotter doing this, but you are of course free to try.

Pavel
__________________

nohal is offline   Reply With Quote
Reply

Tags
enc, opencpn

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RPi3 Touch screen not working with openCPN B25Matt OpenCPN 1 10-09-2019 02:42
rPI3 + openplotter -> is it a viable solution? svsputnik OpenCPN 40 24-03-2017 07:15
Sending WPL and RTE sentence(s) TO OpenCpn does not work... m1ch3al OpenCPN 3 21-12-2016 09:37
OpenCPN on RPi3 Latest Raspbian NahanniV OpenCPN 30 05-11-2016 11:13
No ENC text on RPI3 henklor OpenCPN 11 13-06-2016 17:44

Advertise Here


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 23:09.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×

ShowCase vBulletin Plugins by Drive Thru Online, Inc.