Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 19-04-2010, 07:22   #16
Senior Cruiser
 
idpnd's Avatar

Cruisers Forum Supporter

Join Date: Sep 2007
Location: Almería, ES
Boat: Chiquita 46 - Libertalia
Posts: 1,551
Hello Hamish, I think the repositories are disabled (see his terminal output above), plus I don't think we've banged head enough to be able to process your instructions.

Please take a look at my ones, I hope they're accessible to a relative novice (and correct as to just get it going for the time being).
__________________

__________________
sv Libertalia
idpnd is offline   Reply With Quote
Old 19-04-2010, 08:32   #17
Registered User
 
HamishB's Avatar

Join Date: Jan 2010
Location: New Zealand
Posts: 286
Quote:
Originally Posted by idpnd View Post
Hello Hamish, I think the repositories are disabled (see his terminal output above),
I concur.

Quote:
plus I don't think we've banged head enough to be able to process your instructions.
just open a terminal, become root (`sudo su`), and cut and paste the commands I put in the comment box of post # 6 above. the DEPS line contains the rest of the needed dependency packages.


regards,
__________________

__________________
HamishB is offline   Reply With Quote
Old 20-04-2010, 21:47   #18
Marine Service Provider

Join Date: Apr 2005
Location: Salish Sea
Boat: Tayana 37
Posts: 243
More happened, but I have a feeling that I forced it to abort a process it needed to do at the end. I repeated it a few times, changing the way I answered "y" -- caps or whole word -- but the result was always the same.


ubuntu@ubuntu:~$ sudo apt-get update
Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/main Translation-en_US
Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/restricted Translation-en_US
Hit Index of / karmic Release.gpg
Ign Index of / karmic/main Translation-en_US
Get:1 Ubuntu Security Notices | Ubuntu karmic-security Release.gpg [189B]
Ign Ubuntu Security Notices | Ubuntu karmic-security/main Translation-en_US
Ign Index of / karmic/restricted Translation-en_US
Ign Index of / karmic/universe Translation-en_US
Ign Index of / karmic/multiverse Translation-en_US
Get:2 Index of / karmic-updates Release.gpg [189B]
Ign Index of / karmic-updates/main Translation-en_US
Ign Index of / karmic-updates/restricted Translation-en_US
Ign Index of / karmic-updates/universe Translation-en_US
Ign Index of / karmic-updates/multiverse Translation-en_US
Ign Ubuntu Security Notices | Ubuntu karmic-security/restricted Translation-en_US
Ign Ubuntu Security Notices | Ubuntu karmic-security/universe Translation-en_US
Ign Ubuntu Security Notices | Ubuntu karmic-security/multiverse Translation-en_US
Get:3 Ubuntu Security Notices | Ubuntu karmic-security Release [44.1kB]
Hit Index of / karmic Release
Get:4 Index of / karmic-updates Release [44.1kB]
Hit Index of / karmic/main Packages
Hit Index of / karmic/restricted Packages
Get:5 Index of / karmic/universe Packages [5,133kB]
Get:6 Ubuntu Security Notices | Ubuntu karmic-security/main Packages [95.0kB]
Get:7 Ubuntu Security Notices | Ubuntu karmic-security/restricted Packages [14B]
Get:8 Ubuntu Security Notices | Ubuntu karmic-security/universe Packages [50.7kB]
Get:9 Ubuntu Security Notices | Ubuntu karmic-security/multiverse Packages [1,666B]
Get:10 Ubuntu Security Notices | Ubuntu karmic-security/main Sources [28.2kB]
Get:11 Ubuntu Security Notices | Ubuntu karmic-security/restricted Sources [14B]
Get:12 Ubuntu Security Notices | Ubuntu karmic-security/universe Sources [8,743B]
Get:13 Ubuntu Security Notices | Ubuntu karmic-security/multiverse Sources [577B]
Get:14 Index of / karmic/multiverse Packages [190kB]
Hit Index of / karmic/main Sources
Hit Index of / karmic/restricted Sources
Get:15 Index of / karmic/universe Sources [2,795kB]
Get:16 Index of / karmic/multiverse Sources [116kB]
Get:17 Index of / karmic-updates/main Packages [201kB]
Get:18 Index of / karmic-updates/restricted Packages [14B]
Get:19 Index of / karmic-updates/universe Packages [125kB]
Get:20 Index of / karmic-updates/multiverse Packages [7,354B]
Get:21 Index of / karmic-updates/main Sources [60.0kB]
Get:22 Index of / karmic-updates/restricted Sources [14B]
Get:23 Index of / karmic-updates/universe Sources [29.8kB]
Get:24 Index of / karmic-updates/multiverse Sources [4,036B]
Fetched 8,934kB in 44s (199kB/s)
Reading package lists... Done
ubuntu@ubuntu:~$
ubuntu@ubuntu:~$ sudo apt-get install gpsd gpsd-clients python-gps libgl1-mesa-glx libglu1-mesa libglib2.0-0 libgtk2.0-0 libstdc++6 libwxbase2.8-0 libwxgtk2.8-0 zlib1g
Reading package lists... Done
Building dependency tree
Reading state information... Done
libgl1-mesa-glx is already the newest version.
libglu1-mesa is already the newest version.
zlib1g is already the newest version.
The following extra packages will be installed:
cpp-4.4 gcc-4.4 gcc-4.4-base gtk2-engines-pixbuf lesstif2 libgail-common
libgail18 libgcc1 libgomp1 libgps18
Suggested packages:
gcc-4.4-locales gcc-4.4-multilib libmudflap0-4.4-dev gcc-4.4-doc libgcc1-dbg
libgomp1-dbg libmudflap0-dbg libcloog-ppl0 libppl-c2 libppl7
libgnomeprintui2.2-0
The following NEW packages will be installed:
gpsd gpsd-clients lesstif2 libgps18 libwxbase2.8-0 libwxgtk2.8-0 python-gps
The following packages will be upgraded:
cpp-4.4 gcc-4.4 gcc-4.4-base gtk2-engines-pixbuf libgail-common libgail18
libgcc1 libglib2.0-0 libgomp1 libgtk2.0-0 libstdc++6
11 upgraded, 7 newly installed, 0 to remove and 247 not upgraded.
Need to get 16.6MB of archives.
After this operation, 14.2MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Abort.


I will retry Hamish's short script now.
__________________
jimbim is offline   Reply With Quote
Old 20-04-2010, 22:02   #19
Registered User
 
HamishB's Avatar

Join Date: Jan 2010
Location: New Zealand
Posts: 286
Quote:
Do you want to continue [Y/n]? y
Abort.
that is very weird. try just hitting enter. (the uppercased letter is the default)

or using --assume-yes on the command line options as in my example, which just answers yes to that question for you.


Hamish
__________________
HamishB is offline   Reply With Quote
Old 20-04-2010, 22:10   #20
Marine Service Provider

Join Date: Apr 2005
Location: Salish Sea
Boat: Tayana 37
Posts: 243
With Hamish's short script, this is what I got....


ubuntu@ubuntu:~$ sudo wget -c --progress=dot:mega \
> "http://downloads.sourceforge.net/project/opencpn/opencpn/1.3.6/opencpn_1.3.6_i386.deb"
--2010-04-21 03:58:02-- Download OpenCPN from SourceForge.net
Resolving downloads.sourceforge.net... 216.34.181.59
Connecting to downloads.sourceforge.net|216.34.181.59|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://nchc.dl.sourceforge.net/proje...1.3.6_i386.deb [following]
--2010-04-21 03:58:03-- http://nchc.dl.sourceforge.net/proje...1.3.6_i386.deb
Resolving nchc.dl.sourceforge.net... 211.79.60.17, 2001:e10:ffff:1f02::17
Connecting to nchc.dl.sourceforge.net|211.79.60.17|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 7712890 (7.4M) [application/octet-stream]
Saving to: `opencpn_1.3.6_i386.deb'

0K ........ ........ ........ ........ ........ ........ 40% 231K 19s
3072K ........ ........ ........ ........ ........ ........ 81% 248K 6s
6144K ........ ........ ..... 100% 247K=31s

2010-04-21 03:58:36 (241 KB/s) - `opencpn_1.3.6_i386.deb' saved [7712890/7712890]

ubuntu@ubuntu:~$
ubuntu@ubuntu:~$ # recommended:
ubuntu@ubuntu:~$ apt-get --assume-yes install gpsd gpsd-clients python-gps
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
ubuntu@ubuntu:~$
ubuntu@ubuntu:~$ # ...
ubuntu@ubuntu:~$
ubuntu@ubuntu:~$ sudo DEPS="libgl1-mesa-glx libglu1-mesa \
> libglib2.0-0 libgtk2.0-0 libstdc++6 \
> libwxbase2.8-0 libwxgtk2.8-0 zlib1g"
usage: sudo [-n] -h | -K | -k | -L | -V | -v
usage: sudo -l[l] [-AnS] [-g groupname|#gid] [-U username] [-u username|#uid]
[-g groupname|#gid] [command]
usage: sudo [-AbEHnPS] [-C fd] [-g groupname|#gid] [-p prompt] [-u
username|#uid] [-g groupname|#gid] [VAR=value] [-i|-s] [<command>]
usage: sudo -e [-AnS] [-C fd] [-g groupname|#gid] [-p prompt] [-u
username|#uid] file ...
ubuntu@ubuntu:~$
ubuntu@ubuntu:~$ sudo apt-get --assume-yes install $DEPS
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 258 not upgraded.
ubuntu@ubuntu:~$
ubuntu@ubuntu:~$ sudo dpkg -i "opencpn_1.3.6_i386.deb"
Selecting previously deselected package opencpn.
(Reading database ... 120319 files and directories currently installed.)
Unpacking opencpn (from opencpn_1.3.6_i386.deb) ...
dpkg: dependency problems prevent configuration of opencpn:
opencpn depends on libwxbase2.8-0 (>= 2.8.7.1); however:
Package libwxbase2.8-0 is not installed.
opencpn depends on libwxgtk2.8-0 (>= 2.8.7.1); however:
Package libwxgtk2.8-0 is not installed.
dpkg: error processing opencpn (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
opencpn
ubuntu@ubuntu:~$


I don't know why it keeps asking me if I am root. I thought "sudo" made me the boss.

Thanks for all the help. I'll keep working on this. We are sailing for Japan (Ishigaki-jima) in a few days, so will soon be out of touch, but would appreciate any ideas anyone has.

cheers, jim
__________________
jimbim is offline   Reply With Quote
Old 20-04-2010, 22:25   #21
Marine Service Provider

Join Date: Apr 2005
Location: Salish Sea
Boat: Tayana 37
Posts: 243
Now I am confused. I planned to do as Hamish suggested, but re-running idpnd's short script now gives my a different response, at least not one that ends in y/n question.


ubuntu@ubuntu:~$ sudo apt-get update
Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/main Translation-en_US
Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/restricted Translation-en_US
Hit Ubuntu Security Notices | Ubuntu karmic-security Release.gpg
Ign Ubuntu Security Notices | Ubuntu karmic-security/main Translation-en_US
Hit Index of / karmic Release.gpg
Ign Index of / karmic/main Translation-en_US
Ign Ubuntu Security Notices | Ubuntu karmic-security/restricted Translation-en_US
Ign Ubuntu Security Notices | Ubuntu karmic-security/universe Translation-en_US
Ign Ubuntu Security Notices | Ubuntu karmic-security/multiverse Translation-en_US
Hit Ubuntu Security Notices | Ubuntu karmic-security Release
Ign Index of / karmic/restricted Translation-en_US
Ign Index of / karmic/universe Translation-en_US
Ign Index of / karmic/multiverse Translation-en_US
Hit Index of / karmic-updates Release.gpg
Ign Index of / karmic-updates/main Translation-en_US
Ign Index of / karmic-updates/restricted Translation-en_US
Ign Index of / karmic-updates/universe Translation-en_US
Ign Index of / karmic-updates/multiverse Translation-en_US
Hit Index of / karmic Release
Hit Ubuntu Security Notices | Ubuntu karmic-security/main Packages
Hit Index of / karmic-updates Release
Hit Ubuntu Security Notices | Ubuntu karmic-security/restricted Packages
Hit Ubuntu Security Notices | Ubuntu karmic-security/universe Packages
Hit Ubuntu Security Notices | Ubuntu karmic-security/multiverse Packages
Hit Ubuntu Security Notices | Ubuntu karmic-security/main Sources
Hit Index of / karmic/main Packages
Hit Index of / karmic/restricted Packages
Hit Index of / karmic/universe Packages
Hit Index of / karmic/multiverse Packages
Hit Index of / karmic/main Sources
Hit Ubuntu Security Notices | Ubuntu karmic-security/restricted Sources
Hit Ubuntu Security Notices | Ubuntu karmic-security/universe Sources
Hit Ubuntu Security Notices | Ubuntu karmic-security/multiverse Sources
Hit Index of / karmic/restricted Sources
Hit Index of / karmic/universe Sources
Hit Index of / karmic/multiverse Sources
Hit Index of / karmic-updates/main Packages
Hit Index of / karmic-updates/restricted Packages
Hit Index of / karmic-updates/universe Packages
Hit Index of / karmic-updates/multiverse Packages
Hit Index of / karmic-updates/main Sources
Hit Index of / karmic-updates/restricted Sources
Hit Index of / karmic-updates/universe Sources
Hit Index of / karmic-updates/multiverse Sources
Reading package lists... Done
ubuntu@ubuntu:~$
ubuntu@ubuntu:~$ sudo apt-get install gpsd gpsd-clients python-gps libgl1-mesa-glx libglu1-mesa libglib2.0-0 libgtk2.0-0 libstdc++6 libwxbase2.8-0 libwxgtk2.8-0 zlib1g
Reading package lists... Done
Building dependency tree
Reading state information... Done
libgl1-mesa-glx is already the newest version.
libglu1-mesa is already the newest version.
zlib1g is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
gpsd: Depends: libgps18 (>= 2.39) but it is not going to be installed
gpsd-clients: Depends: lesstif2 (>= 1:0.94.4) but it is not going to be installed
Depends: libgps18 (>= 2.39) but it is not going to be installed
gtk2-engines-pixbuf: Depends: libgtk2.0-0 (= 2.18.3-1) but 2.18.3-1ubuntu2.2 is to be installed
libgail18: Depends: libgtk2.0-0 (= 2.18.3-1) but 2.18.3-1ubuntu2.2 is to be installed
libstdc++6: Depends: gcc-4.4-base (= 4.4.1-4ubuntu9) but 4.4.1-4ubuntu8 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
ubuntu@ubuntu:~$
ubuntu@ubuntu:~$ dpkg -i "opencpn_1.3.6_i386.deb"
dpkg: requested operation requires superuser privilege
ubuntu@ubuntu:~$
__________________
jimbim is offline   Reply With Quote
Old 20-04-2010, 22:27   #22
Registered User
 
HamishB's Avatar

Join Date: Jan 2010
Location: New Zealand
Posts: 286
Quote:
I don't know why it keeps asking me if I am root. I thought "sudo" made me the boss.
sudo only works for the current command. so you (re)download the .deb package as root, but nothing else.

to become root and stay root at a terminal ('#' prompt instead of '$' prompt) try: sudo su

and remember to exit when you are done :-)


Hamish
__________________
HamishB is offline   Reply With Quote
Old 20-04-2010, 23:36   #23
Marine Service Provider

Join Date: Apr 2005
Location: Salish Sea
Boat: Tayana 37
Posts: 243
Trying with sudo su, gives me this:

ubuntu@ubuntu:~$ sudo su apt-get update
Unknown id: apt-get
ubuntu@ubuntu:~$
ubuntu@ubuntu:~$ sudo su apt-get install gpsd gpsd-clients python-gps libgl1-mesa-glx libglu1-mesa libglib2.0-0 libgtk2.0-0 libstdc++6 libwxbase2.8-0 libwxgtk2.8-0 zlib1g
Unknown id: apt-get
ubuntu@ubuntu:~$
ubuntu@ubuntu:~$ dpkg -i "opencpn_1.3.6_i386.deb"
dpkg: requested operation requires superuser privilege
ubuntu@ubuntu:~$
__________________
jimbim is offline   Reply With Quote
Old 21-04-2010, 00:31   #24
Registered User
 
HamishB's Avatar

Join Date: Jan 2010
Location: New Zealand
Posts: 286
just "sudo su" by itself. the prompt should change from $ to #
__________________
HamishB is offline   Reply With Quote
Old 21-04-2010, 00:36   #25
Registered User
 
HamishB's Avatar

Join Date: Jan 2010
Location: New Zealand
Posts: 286
(and you've probably 'apt-get update'd enough today to be well in sync, so can skip that step for another week or so :-)

"su" by itself becomes the superuser. "su username" becomes that user. So "su apt-get ..." was trying to become the apt-get user, which doesn't exist.


you are so close....

Hamish
__________________
HamishB is offline   Reply With Quote
Old 21-04-2010, 01:02   #26
Senior Cruiser
 
idpnd's Avatar

Cruisers Forum Supporter

Join Date: Sep 2007
Location: Almería, ES
Boat: Chiquita 46 - Libertalia
Posts: 1,551
Quote:
Need to get 16.6MB of archives.
After this operation, 14.2MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Abort.
Bit dumbfounded, you're basically there, this is deeply mysterious..

Have a good trip anyway..
__________________
sv Libertalia
idpnd is offline   Reply With Quote
Old 22-04-2010, 09:17   #27
Marine Service Provider

Join Date: Apr 2005
Location: Salish Sea
Boat: Tayana 37
Posts: 243
Well I have managed to install it -- I know this because when I install it I am told it is already installed... and there are a heap of files at usr/local/share/opencpn.

However, the help file in usr/local/share/opencpn/doc tells me the file to launch the program is found at usr/bin/opencpn. No such file has been found there or anywhere else I have looked. I am sure I am missing something, but can't for the life of me figure out what
__________________
jimbim is offline   Reply With Quote
Old 22-04-2010, 09:43   #28
Registered User
 
HamishB's Avatar

Join Date: Jan 2010
Location: New Zealand
Posts: 286
it is installed, but is it set up? what does "dpkg -l opencpn" say? does it start with "ii"? ("i" for installled). sometimes if it is waiting for dependencies it can be waiting partially installed. check also for /usr/local/bin/opencpn. usually you just type "opencpn" at the the terminal prompt though, or look for it in the menus/make a new launcher (shortcut) for it there.
__________________
HamishB is offline   Reply With Quote
Old 22-04-2010, 10:05   #29
Senior Cruiser
 
idpnd's Avatar

Cruisers Forum Supporter

Join Date: Sep 2007
Location: Almería, ES
Boat: Chiquita 46 - Libertalia
Posts: 1,551
Can't you just type in "opencpn" in a terminal to launch it? Then you can make up a desktop shortcut by rightclicking on desktop, create launcher, etc
__________________
sv Libertalia
idpnd is offline   Reply With Quote
Old 23-04-2010, 00:31   #30
Marine Service Provider

Join Date: Apr 2005
Location: Salish Sea
Boat: Tayana 37
Posts: 243
Good question. I have no idea why I can't do that. I did do it and I think I am up and running... more details when I manage to update my charts...
__________________

__________________
jimbim is offline   Reply With Quote
Reply

Tags
linux

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCPN Linux / Ubuntu Issues and Questions yachtmanforfun OpenCPN 52 19-02-2016 18:54
Linux Grib Viewer cagney Navigation 13 20-05-2010 18:51
The Green Flash imagine2frolic Cruising News & Events 39 26-09-2009 21:34
Green Flash Trim50 Off Topic Forum 27 19-05-2009 16:11
linux or xp uncle_fred Navigation 7 21-08-2006 18:03



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 22:28.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.