Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 15-03-2011, 10:30   #31
Registered User

Join Date: Jun 2009
Boat: Elan 37,Racing version
Posts: 42
Re: How to Transmit to Autopilot on COM40 ?

Quote:
Originally Posted by haydudeTake4 View Post
Well in the case of OpenCPN I am afraid I cannot even receive the NMEA stream from serial Bluetooth, let alone sending it.
Thanks. Cheers.
__________________

__________________
ON3CHD is offline   Reply With Quote
Old 15-03-2011, 11:43   #32
֍֎֍֎֍֎֍֎֍֎

Cruisers Forum Supporter

Join Date: Apr 2006
Posts: 13,056
Re: How to Transmit to Autopilot on COM40 ?

Quote:
Originally Posted by bdbcat View Post
Windows algorithm for discovery of available COM ports is very slow legacy code, and MS has never provided any improved API for simply getting an array of COM ports.
That's surprising. Windows3.x and Windows9.x have their own limits, but all the versions of NT since...NT4 I think? have supported 255 COM ports, and all the NT OSes (which include 2000, XP, Vista and Win7) are very quick to use additional COM ports.

If it goes beyond COM8 (the old MS-DOS limit)...the code should support all 255 of them these days.
__________________

__________________
hellosailor is offline   Reply With Quote
Old 16-03-2011, 12:36   #33
Registered User

Join Date: Aug 2009
Posts: 24
Re: How to Transmit to Autopilot on COM40 ?

p { margin-bottom: 0.08in; } I was doing similar setup with my toys and faced similar symptoms. The problem was that serial- bluetooth adapter itself had to be setup to baud rate speed to match connecting parties. Its usually done via set of AT commands.
__________________
125Miles is offline   Reply With Quote
Old 16-03-2011, 12:45   #34
Registered User

Join Date: Jan 2011
Posts: 571
Re: How to Transmit to Autopilot on COM40 ?

Quote:
Originally Posted by 125Miles View Post
I was doing similar setup with my toys and faced similar symptoms. The problem was that serial- bluetooth adapter itself had to be setup to baud rate speed to match connecting parties. Its usually done via set of AT commands.
Yes, that is exactly what I am thinking. Like yours, my Bluetooth adapter defaults can be configured via AT commands. I had meant to do that, but discovered that the GPS signals came in fine without configuring. It wasn't until later that I realized that the Autopilot output was not working.

I think that OpenCPN's baud setting setting of 4800 for the incoming GPS info overrides the default baud setting of the adapter (which I think is set to 9600 by the factory). But OpenCPN has no baud setting for the outgoing Autopilot info, so I have a hunch that the adapter itself has to configured to 4800 or it won't work.

I'll test this out in the next few days and let everyone know. Meanwhile my time is limited - scraping and sanding my bottom paint is a higher priority while the weather is nice here in the northeast US. Oh, and I also have to work during the days.
__________________
RhythmDoctor is offline   Reply With Quote
Old 16-03-2011, 13:31   #35
Registered User

Join Date: Jun 2009
Boat: Elan 37,Racing version
Posts: 42
Re: How to Transmit to Autopilot on COM40 ?

Quote:
Originally Posted by RhythmDoctor View Post
...

I think that OpenCPN's baud setting setting of 4800 for the incoming GPS info overrides the default baud setting of the adapter (which I think is set to 9600 by the factory). But OpenCPN has no baud setting for the outgoing Autopilot info, so I have a hunch that the adapter itself has to configured to 4800 or it won't work.
Hi ,
I probably will have to reinstall OCPN to follow all your comments but...in the meantime...

- You probably can ? your adapter using AT commands to know all the parameters used including the BDS rate as per factory setup (I can do it with my cheap -15 euros - Chinese one and I have now a few spare one due to static electricity problem one might encounter... )
- Unless mistaken you can modify in OCPN the BDS rate of the AUTOPILOT output by just typing the number you wish in the appropriate BDS rate selection scrolling.

Cheers,
__________________
ON3CHD is offline   Reply With Quote
Old 18-03-2011, 14:42   #36
Registered User

Join Date: Jun 2010
Location: Europe
Boat: Finn Express 83 - Lorelei (27')
Posts: 6
Send a message via Skype™ to topi
Re: How to Transmit to Autopilot on COM40 ?

Quote:
Originally Posted by RhythmDoctor View Post

I think that OpenCPN's baud setting setting of 4800 for the incoming GPS info overrides the default baud setting of the adapter (which I think is set to 9600 by the factory). But OpenCPN has no baud setting for the outgoing Autopilot info, so I have a hunch that the adapter itself has to configured to 4800 or it won't work.
That is very true. If you look at the source code, the serial device for Autopilot is opened with a hardcoded speed of 4800. This is a valid assumption for most autopilots, which expect NMEA messages at 4800 bps, but when using a MUX device operating duplex communications at 38400 or other baud rates, it's not really sensible to force the baud rate to 4800.

The Autopilot output port (or the choice of ports) needs to have the same choices as the NMEA port has (e.g. the choice of using AIS port(shared)).
__________________
topi is offline   Reply With Quote
Old 18-03-2011, 17:35   #37
Registered User

Join Date: Jan 2011
Posts: 571
Re: How to Transmit to Autopilot on COM40 ?

Quote:
Originally Posted by RhythmDoctor View Post
Yes, that is exactly what I am thinking. Like yours, my Bluetooth adapter defaults can be configured via AT commands. I had meant to do that, but discovered that the GPS signals came in fine without configuring. It wasn't until later that I realized that the Autopilot output was not working.

I think that OpenCPN's baud setting setting of 4800 for the incoming GPS info overrides the default baud setting of the adapter (which I think is set to 9600 by the factory). But OpenCPN has no baud setting for the outgoing Autopilot info, so I have a hunch that the adapter itself has to configured to 4800 or it won't work.

I'll test this out in the next few days and let everyone know. Meanwhile my time is limited - scraping and sanding my bottom paint is a higher priority while the weather is nice here in the northeast US. Oh, and I also have to work during the days.
Well, my recollection was wrong. I had already configured my Bluetooth adapter for 4800 baud. My GPS signal has been coming in COM41 with no problem, but output to Autopilot is still not working. (FYI, AIS is also coming in successfully on COM40 at 38400 baud via a second Bluetooth adaptor.)

After testing today, I was able to confirm that the exact same hardware setup running SeaClear II does successfully send information to the Autopilot through Bluetooth. So the problem here definitely seems to be with OpenCPN's routines for sending Autopilot data out through COM41. (Note that I had previously succeeded at having OpenCPN send Autopilot data out COM3 using a hardwire connection.)
__________________
RhythmDoctor is offline   Reply With Quote
Old 22-03-2011, 19:16   #38
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: How to Transmit to Autopilot on COM40 ?

RhythmDoctor....

I am very confused by all the twists and turns of this thread, but your last post caught my attention.

I see this setup:
a.Bluetooth adapter on COM41, set at 4800 baud.
b.GPS input thru COM41 works fine.
c. Autopilot output at COM41 does not work.
d. Same setup for wardwire thru COM3 works OK.

Do we know if there is any data at all appearing on the autopilot output port? Do we have any way of monitoring the physical port at the autopilot?

Maybe we are sending an incompatible NMEA sentence. We send $ECRMB. Is this compatible with your autopilot? I guess it is, since you got it working with COM3 hardwire earlier.

And again, logfile entries relating to COM port activity (open/close. etc) will be instructive.

You will see things like this....
Code:
....
NMEA Data Source is....Serial:COM3
6:11:20 PM: AIS Data Source is....Serial:COM1
6:11:20 PM: OpenPD: 272, new_count = 1 for COM3
6:11:20 PM: NMEA AutoPilot Port is....Serial:COM3
6:11:20 PM: Re-OpenPD: 272, new_count = 2 for COM3
6:11:26 PM: opencpn::MyFrame exiting cleanly.
6:11:26 PM: ClosePD: 272, count_after_close = 1 for COM3
6:11:28 PM: ClosePD: 272, count_after_close = 0 for COM3
6:11:29 PM:   and so CloseComPortPhysical
....
I cannot replicate any problem here. It all works fine with simple hardwire I/O for me.

There are many other issues relating to external muxes, speeds, and port sharing which are to be addressed separately. Lets get the simple case running first.

Thanks
Dave
__________________
bdbcat is offline   Reply With Quote
Old 22-03-2011, 20:42   #39
Registered User

Join Date: Jan 2011
Posts: 571
Re: How to Transmit to Autopilot on COM40 ?

Please let me know where I can find the logfiles, or how I can activate that feature (edit an .ini file, maybe?). Once I have that information I will be happy to provide the log files.

You are correct, my successful connection via hardwire seems to indicate that the sentences that OpenCPN is sending are compatible with the AutoPilot (Raymarine ST4000+).

Also, as I mentioned, SeaClear II does succeed in sending sentences to the AutoPilot through Bluetooth, so the hardware and XP drivers appear to be functioning properly.
__________________
RhythmDoctor is offline   Reply With Quote
Old 23-03-2011, 13:08   #40
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,250
Re: How to Transmit to Autopilot on COM40 ?

Read the friendly manual
Thomas
__________________
cagney is offline   Reply With Quote
Old 23-03-2011, 20:51   #41
Registered User

Join Date: Jan 2011
Posts: 571
Re: How to Transmit to Autopilot on COM40 ?

OK, I got the Autopilot working with OpenCPN! Thanks for all of your patience with me. However, there is a minor glitch that the development team may want to look into.

If I launch OpenCPN with the NMEA settings pre-selected, the AutoPilot out fails. However, if I deselect it and reselect it, it works. If I quit out of OpenCPN and re-launch it, same thing happens again - I need to go back in and re-select it again each time I launch OpenCPN. I only need to do this for the AutoPilot output - the GPS and AIS inputs work immediately upon launch.

I can live with this glitch, because I plan to use this feature of OpenCPN very infrequently. As long as I know what I need to do to make it work, I am fine. But the team may want to look into the underlying causes of this issue.

Here's a representative log. I highlighted the relevant entries in red. From this, it looks like the EnumerateSerialPorts() function is needed before the AutoPilot output can be established successfully. OpenCPN does this when you manually open the port, but does NOT do it upon initially launching the program:
Quote:
21:06:08:


21:06:08: 2011-03-24
21:06:08: -------Starting opencpn-------
21:06:08: Version 2.3.1 Build 2010-12-28
21:06:08: SData_Locn is C:\Program Files\OpenCPN\
21:06:08: Using existing Config_File: C:\Documents and Settings\All Users\Application Data\opencpn\opencpn.ini
21:06:08: Setting Viewpoint Lat/Lon 39.8619, -75.307
21:06:08: Setting Ownship Lat/Lon 39.8619, -75.307
21:06:08: System default Language: en_US
9:06:08 PM: Opencpn language set to: en_US
9:06:08 PM: looking for catalog 'opencpn' in path 'C:\Program Files\OpenCPN\share/locale\en_US.WINDOWS-1252\LC_MESSAGES;C:\Program Files\OpenCPN\share/locale\;C:\Program Files\OpenCPN\share/locale\en_US.WINDOWS-1252;C:\Program Files\OpenCPN\en_US.WINDOWS-1252;C:\Program Files\OpenCPN\share/locale\en_US\LC_MESSAGES;C:\Program Files\OpenCPN\share/locale\;C:\Program Files\OpenCPN\share/locale\en_US;C:\Program Files\OpenCPN\en_US;C:\Program Files\OpenCPN\share/locale\en\LC_MESSAGES;C:\Program Files\OpenCPN\share/locale\;C:\Program Files\OpenCPN\share/locale\en;C:\Program Files\OpenCPN\en'.
9:06:08 PM: catalog file for domain 'opencpn' not found.
9:06:09 PM: Using s57data in C:\Program Files\OpenCPN\s57data
9:06:09 PM: Using Tide/Current data from: C:\Program Files\OpenCPN\tcdata\
9:06:09 PM: Setting Viewpoint Lat/Lon 39.8619, -75.307
9:06:09 PM: Setting Ownship Lat/Lon 39.8619, -75.307
9:06:09 PM: NMEA Data Source is....Serial:COM41
9:06:09 PM: AIS Data Source is....Serial:COM40
9:06:09 PM: Using WVSChart datafile: C:\Program Files\OpenCPN\wvsdata\wvs43.dat
9:06:09 PM: NMEA AutoPilot Port is....Serial:COM41
9:06:09 PM: Autopilot output device open failed: COM41
9:06:09 PM: OpenPD: 268, new_count = 1 for COM41
9:06:09 PM: PlugInManager searching for PlugIns in location C:\Program Files\OpenCPN\plugins
9:06:09 PM: PlugInManager: Loading PlugIn: C:\Program Files\OpenCPN\plugins/dashboard_pi.dll
9:06:10 PM: PlugInManager: Loading PlugIn: C:\Program Files\OpenCPN\plugins/grib_pi.dll
9:06:10 PM: Loading chart db version: V016
9:06:10 PM: Chartdb: Chart directory list follows
9:06:10 PM: Chart directory #0: C:\Documents and Settings\All Users\Documents\Sailboat\NOAA Nautical Charts\ENC\ENC_ROOT\OpenCPN
9:06:10 PM: Chart directory #1: C:\Documents and Settings\All Users\Documents\Sailboat\NOAA Nautical Charts\RNC\BSB_ROOT\OpenCPN
9:06:10 PM: GPS Watchdog Timeout is: 6 sec.
9:06:10 PM: Initializing Chart C:\Documents and Settings\All Users\Documents\Sailboat\NOAA Nautical Charts\RNC\BSB_ROOT\OpenCPN\12312\12312_1.KAP
9:07:09 PM: LOGBOOK: 2011-03-24 01:07:09 UTC GPS Lat 39.86186 Lon -75.30702 COG 0.00000 SOG 0.00
9:07:25 PM: EnumerateSerialPorts() Found Garmin USB Driver.
9:07:41 PM: NMEA AutoPilot Port is....None
9:07:45 PM: EnumerateSerialPorts() Found Garmin USB Driver.
9:07:53 PM: NMEA AutoPilot Port is....Serial:COM41
9:07:53 PM: Re-OpenPD: 268, new_count = 2 for COM41
9:09:45 PM: PlugInManager: Deactivating PlugIn: C:\Program Files\OpenCPN\plugins/dashboard_pi.dll
9:09:45 PM: PlugInManager: Deactivating PlugIn: C:\Program Files\OpenCPN\plugins/grib_pi.dll
9:09:45 PM: opencpn::MyFrame exiting cleanly.
9:09:45 PM: PlugInManager: UnLoading PlugIn: C:\Program Files\OpenCPN\plugins/dashboard_pi.dll
9:09:45 PM: PlugInManager: UnLoading PlugIn: C:\Program Files\OpenCPN\plugins/grib_pi.dll
9:09:45 PM: Stopping Secondary Thread
9:09:46 PM: ClosePD: 268, count_after_close = 1 for COM41
9:09:46 PM: Stopped in 1 sec.
9:09:46 PM: Stopping AIS Secondary Thread
9:09:47 PM: Stopped in 1 sec.
9:09:47 PM: ClosePD: 268, count_after_close = 0 for COM41
9:09:47 PM: and so CloseComPortPhysical
9:09:47 PM: LOGBOOK: 2011-03-24 01:09:47 UTC OFF: Lat 39.86187 Lon -75.30703 COG 0.00000 SOG 0.00
9:09:47 PM: opencpn::MyApp exiting cleanly...

21:09:52:


21:09:52: 2011-03-24
21:09:52: -------Starting opencpn-------
21:09:52: Version 2.3.1 Build 2010-12-28
21:09:52: SData_Locn is C:\Program Files\OpenCPN\
21:09:52: Using existing Config_File: C:\Documents and Settings\All Users\Application Data\opencpn\opencpn.ini
21:09:52: Setting Viewpoint Lat/Lon 39.8619, -75.307
21:09:52: Setting Ownship Lat/Lon 39.8619, -75.307
21:09:52: System default Language: en_US
9:09:52 PM: Opencpn language set to: en_US
9:09:52 PM: looking for catalog 'opencpn' in path 'C:\Program Files\OpenCPN\share/locale\en_US.WINDOWS-1252\LC_MESSAGES;C:\Program Files\OpenCPN\share/locale\;C:\Program Files\OpenCPN\share/locale\en_US.WINDOWS-1252;C:\Program Files\OpenCPN\en_US.WINDOWS-1252;C:\Program Files\OpenCPN\share/locale\en_US\LC_MESSAGES;C:\Program Files\OpenCPN\share/locale\;C:\Program Files\OpenCPN\share/locale\en_US;C:\Program Files\OpenCPN\en_US;C:\Program Files\OpenCPN\share/locale\en\LC_MESSAGES;C:\Program Files\OpenCPN\share/locale\;C:\Program Files\OpenCPN\share/locale\en;C:\Program Files\OpenCPN\en'.
9:09:52 PM: catalog file for domain 'opencpn' not found.
9:09:53 PM: Using s57data in C:\Program Files\OpenCPN\s57data
9:09:53 PM: Using Tide/Current data from: C:\Program Files\OpenCPN\tcdata\
9:09:53 PM: Setting Viewpoint Lat/Lon 39.8619, -75.307
9:09:53 PM: Setting Ownship Lat/Lon 39.8619, -75.307
9:09:53 PM: NMEA Data Source is....Serial:COM41
9:09:53 PM: AIS Data Source is....Serial:COM40
9:09:53 PM: Using WVSChart datafile: C:\Program Files\OpenCPN\wvsdata\wvs43.dat
9:09:53 PM: NMEA AutoPilot Port is....Serial:COM41
9:09:53 PM: Autopilot output device open failed: COM41

9:09:53 PM: PlugInManager searching for PlugIns in location C:\Program Files\OpenCPN\plugins
9:09:53 PM: PlugInManager: Loading PlugIn: C:\Program Files\OpenCPN\plugins/dashboard_pi.dll
9:09:53 PM: OpenPD: 268, new_count = 1 for COM41
9:09:54 PM: PlugInManager: Loading PlugIn: C:\Program Files\OpenCPN\plugins/grib_pi.dll
9:09:54 PM: Loading chart db version: V016
9:09:54 PM: Chartdb: Chart directory list follows
9:09:54 PM: Chart directory #0: C:\Documents and Settings\All Users\Documents\Sailboat\NOAA Nautical Charts\ENC\ENC_ROOT\OpenCPN
9:09:54 PM: Chart directory #1: C:\Documents and Settings\All Users\Documents\Sailboat\NOAA Nautical Charts\RNC\BSB_ROOT\OpenCPN
9:09:54 PM: GPS Watchdog Timeout is: 6 sec.
9:09:54 PM: Initializing Chart C:\Documents and Settings\All Users\Documents\Sailboat\NOAA Nautical Charts\RNC\BSB_ROOT\OpenCPN\12312\12312_1.KAP
9:10:13 PM: EnumerateSerialPorts() Found Garmin USB Driver.
9:10:22 PM: NMEA AutoPilot Port is....None
9:10:25 PM: EnumerateSerialPorts() Found Garmin USB Driver.
9:10:34 PM: NMEA AutoPilot Port is....Serial:COM41
9:10:34 PM: Re-OpenPD: 268, new_count = 2 for COM41
9:10:53 PM: LOGBOOK: 2011-03-24 01:10:53 UTC GPS Lat 39.86187 Lon -75.30703 COG 0.00000 SOG 0.00
9:11:36 PM: EnumerateSerialPorts() Found Garmin USB Driver.
9:11:47 PM: ClosePD: 268, count_after_close = 1 for COM41
9:11:47 PM: NMEA AutoPilot Port is....None
9:11:49 PM: PlugInManager: Deactivating PlugIn: C:\Program Files\OpenCPN\plugins/dashboard_pi.dll
9:11:49 PM: PlugInManager: Deactivating PlugIn: C:\Program Files\OpenCPN\plugins/grib_pi.dll
9:11:49 PM: opencpn::MyFrame exiting cleanly.
9:11:49 PM: PlugInManager: UnLoading PlugIn: C:\Program Files\OpenCPN\plugins/dashboard_pi.dll
9:11:49 PM: PlugInManager: UnLoading PlugIn: C:\Program Files\OpenCPN\plugins/grib_pi.dll
9:11:49 PM: Stopping Secondary Thread
9:11:49 PM: ClosePD: 268, count_after_close = 0 for COM41
9:11:49 PM: and so CloseComPortPhysical
9:11:50 PM: Stopped in 1 sec.
9:11:50 PM: Stopping AIS Secondary Thread
9:11:51 PM: Stopped in 1 sec.
9:11:51 PM: LOGBOOK: 2011-03-24 01:11:51 UTC OFF: Lat 39.86187 Lon -75.30703 COG 0.00000 SOG 0.00
9:11:51 PM: opencpn::MyApp exiting cleanly...
I'm not really sure why the catalog file is missing. Any hints on that would be appreciated.
__________________
RhythmDoctor is offline   Reply With Quote
Old 24-03-2011, 22:37   #42
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: How to Transmit to Autopilot on COM40 ?

RhythmDoctor....

Thanks for the log files.

It looks like this problem is a timing issue. I cannot reproduce on my (slow) VBox XP setup.
It could be that the Bluetooth SPP stack takes some time to set up and negotiate before the port is available to open as COM41, and this is inducing the problem.

I'll look on this some more.

Anyway, glad you have a workaround for now. Stay tuned for a real fix.

Ignore the missing catalog file error. Not really an error, and the message is misleading. Thanks for pointing this out.

Dave
__________________
bdbcat is offline   Reply With Quote
Old 25-03-2011, 04:30   #43
Registered User

Join Date: Jan 2011
Posts: 571
Re: How to Transmit to Autopilot on COM40 ?

Quote:
Originally Posted by bdbcat View Post
...It looks like this problem is a timing issue. I cannot reproduce on my (slow) VBox XP setup.
It could be that the Bluetooth SPP stack takes some time to set up and negotiate before the port is available to open as COM41, and this is inducing the problem...
Does the Bluetooth stack need to set up every time you launch OpenCPN, or just once when you first boot up/wake up?

FYI, I established the Bluetooth connections manually before launching OpenCPN. As you can see by the timestamps, after I got OpenCPN working the first time, I quit out of OpenCPN for only a few seconds, then launched it again. My computer was connected to the Bluetooth devices the whole time.
__________________
RhythmDoctor is offline   Reply With Quote
Old 25-03-2011, 04:48   #44
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,778
Re: How to Transmit to Autopilot on COM40 ?

RhythmDoctor,

you need to setup Bluetooth only once if the COM port connector for an external Bluetooth device at the computer was not changed.

However quitting a running OpenCPN/Bluetooth/GPS session and restarting it immediately results often into a blocked COM port still in use by the first session.

It seems to be mostly a Windows problem and not of OpenCPN.
Keep in mind that Windows is not the best choice for such things.

Gerhard
__________________
CarCode is offline   Reply With Quote
Old 25-03-2011, 05:07   #45
Registered User

Join Date: Jan 2011
Posts: 571
Re: How to Transmit to Autopilot on COM40 ?

Thanks for your great help! My intention here is not to argue with you, but to provide complete information to help diagnose the problem.

Quote:
Originally Posted by CarCode View Post
...quitting a running OpenCPN/Bluetooth/GPS session and restarting it immediately results often into a blocked COM port still in use by the first session...
I have seen that happen before, and it is accompanied by an error message in OpenCPN saying it could not open the COM port. There were no error messages in those sessions that I posted.

Also, this failure occurs the VERY FIRST time I launch OpenCPN after a reboot. In that case, there is no other program opening the ports before launching OpenCPN.
__________________

__________________
RhythmDoctor is offline   Reply With Quote
Reply

Tags
autopilot

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Autopilot bill brown Construction, Maintenance & Refit 26 24-09-2017 10:00
Autopilot danamatic OpenCPN 23 04-09-2010 07:18
Command Mic Transmit Audio newbie123 Marine Electronics 13 03-08-2010 10:49
VHF Radio Transmit Issue claddaghcan Marine Electronics 4 23-04-2010 11:46
Autopilot irwinsailor Seamanship & Boat Handling 11 21-05-2003 03:05



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 22:32.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.