Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 26-02-2015, 11:43   #886
Registered User
 
Ivanm's Avatar

Join Date: Jan 2015
Posts: 117
Re: Help / FAQ

I dropped the new usericons in every opencpn file that i can find in linux but still not working, any info on where to put these files and where to find the i cv ons that come with opencpn as i want to delete ds ome of those that i dont use

Sent from my SM-G900F using Cruisers Sailing Forum mobile app
__________________

__________________
Ivanm is offline   Reply With Quote
Old 26-02-2015, 13:33   #887
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,230
Re: Help / FAQ

Quote:
Originally Posted by Ivanm View Post
I made a file in home/$USER/.opencpn/UserIcons for Linux as in the manual but cant see the png files in opencpn to change the icon for marks maybe i did something wrong, in windows there is no problem. It is the same place that holds the conf file and navobj files

Sent from my SM-G900F using Cruisers Sailing Forum mobile app
Just restart and try again. I just tested and it works as advertised....

Thomas
__________________

__________________
cagney is offline   Reply With Quote
Old 26-02-2015, 22:26   #888
Registered User
 
Ivanm's Avatar

Join Date: Jan 2015
Posts: 117
Re: Help / FAQ

I did that but doesn't show
Any idea where to find the original icons that come installed with O

Sent from my SM-G900F using Cruisers Sailing Forum mobile app
__________________
Ivanm is offline   Reply With Quote
Old 28-02-2015, 01:25   #889
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,230
Re: Help / FAQ

Quote:
Originally Posted by Ivanm View Post
I did that but doesn't show
Any idea where to find the original icons that come installed with O

Sent from my SM-G900F using Cruisers Sailing Forum mobile app
Ivan

The original Icons are in /usr/share/opencpn/uidata/toolicons_traditional.png.
They are, as you can see, in a different format. By far the easiest way to get different icons to display, is to use what you have already tried. You just have to crack what's wrong. Perhaps you can show us the output of this command
Code:
$ls -l /home/$USER/.opencpn/UserIcons
Thomas
__________________
cagney is offline   Reply With Quote
Old 28-02-2015, 05:59   #890
Registered User
 
Ivanm's Avatar

Join Date: Jan 2015
Posts: 117
Re: Help / FAQ

Show directory doesn't

Let me just get this right, I go to home, then open . Opencpn and create a folder named Usericons with my png files here

Sent from my SM-G900F using Cruisers Sailing Forum mobile app
__________________
Ivanm is offline   Reply With Quote
Old 28-02-2015, 07:51   #891
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,230
Re: Help / FAQ

Quote:
Originally Posted by Ivanm View Post
Show directory doesn't

Let me just get this right, I go to home, then open . Opencpn and create a folder named Usericons with my png files here

Sent from my SM-G900F using Cruisers Sailing Forum mobile app
Not quite...
In /home/ivan/.opencpn you create a directory called "UserIcons", and nothing else, the case of the letters matters in Linux.

Thomas
__________________
cagney is offline   Reply With Quote
Old 28-02-2015, 09:33   #892
Registered User
 
Ivanm's Avatar

Join Date: Jan 2015
Posts: 117
Re: Help / FAQ

Easy as that UserIcons wasn't with an uppercase letter

Sent from my SM-G900F using Cruisers Sailing Forum mobile app
__________________
Ivanm is offline   Reply With Quote
Old 28-02-2015, 09:35   #893
Registered User
 
Ivanm's Avatar

Join Date: Jan 2015
Posts: 117
Re: Help / FAQ

Is there a way to change a group of icons for waypoints at once?

Sent from my SM-G900F using Cruisers Sailing Forum mobile app
__________________
Ivanm is offline   Reply With Quote
Old 04-03-2015, 03:56   #894
Registered User
 
Ivanm's Avatar

Join Date: Jan 2015
Posts: 117
Re: Help / FAQ

I managed to change waypoint icons with notepad, easily.




Sent from my SM-G900F using Cruisers Sailing Forum mobile app
__________________
Ivanm is offline   Reply With Quote
Old 04-03-2015, 03:58   #895
Registered User
 
Ivanm's Avatar

Join Date: Jan 2015
Posts: 117
Re: Help / FAQ

Is there a way to import layers of waypoints to show after a restart of Opencpn without importing the waypoints as waypoints but to keep it as a layer

Sent from my SM-G900F using Cruisers Sailing Forum mobile app
__________________
Ivanm is offline   Reply With Quote
Old 04-03-2015, 16:10   #896
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 3,966
Re: Help / FAQ

Ivan...
Yes, just save them into the Layers subdfolder in your data folder (same process as you use with the icons) as described in Layers | Official OpenCPN Homepage

Pavel
__________________
nohal is offline   Reply With Quote
Old 06-03-2015, 11:13   #897
Registered User
 
Ivanm's Avatar

Join Date: Jan 2015
Posts: 117
Re: Help / FAQ

Thanks

Sent from my SM-G900F using Cruisers Sailing Forum mobile app
__________________
Ivanm is offline   Reply With Quote
Old 06-03-2015, 11:17   #898
Registered User
 
Ivanm's Avatar

Join Date: Jan 2015
Posts: 117
Re: Help / FAQ

Just one thing that I pic up is that when I want to drop a mark with Ctl+O or Ctl+M, I forst have to click somewhere on the screen with the mouse otherwise the mark doesn't get dropped.

Sent from my SM-G900F using Cruisers Sailing Forum mobile app
__________________
Ivanm is offline   Reply With Quote
Old 06-03-2015, 11:27   #899
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,713
Re: Help / FAQ

So you say the focus is not there at the beginning.

When? How is exactly the workflow - and your OS ( Win or Linux)?

From some steps before: Did you succeed to import the OLEX waypoints? If yes, can you describe the How-to for people that might be interested?

Happy you are making progress!

Hubert
__________________
bcn is online now   Reply With Quote
Old 06-03-2015, 11:35   #900
Registered User
 
Ivanm's Avatar

Join Date: Jan 2015
Posts: 117
Re: Help / FAQ

I use Linux, yes if I use Ctl + O the mark doesn't appear on the screen, before I click on screen to center the screen, I went to the Route manager to see if the mark are there but also not, I work around this problem just make sure to remember to click and then drop mark with Ctl +O

No, still strugling with the Olex marks, emails sent to Gpsu see if they can help me

Sent from my SM-G900F using Cruisers Sailing Forum mobile app
__________________

__________________
Ivanm is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 10:04.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.