Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 26-09-2010, 21:45   #16
Registered User

Join Date: Aug 2010
Posts: 14
NTNTNT
__________________

__________________
one wolf is offline   Reply With Quote
Old 26-09-2010, 21:46   #17
Registered User

Join Date: Aug 2010
Posts: 14
Same issue

I had the same issue with my BU-353 and Win7. Things worked generally fine but after a random amount of time (typically on the order of an hour or so but never exactly the same amount of time) the data stream would just quit. My fix was to unplug the USB from one port and put it in another port, then switch the port setting in OpenCPN, then it worked again. No reboot necessary. But it was a PITA doing it many times a day over a week-long cruise.

Other than that minor inconvenience, OpenCPN was AWESOME! My 11-year old served as navigator on the laptop, which tells you how easy it is to use. I plotted the courses in advance of course.

Occasionally there was panic when he'd say "Dad, we haven't moved in a while" and I'd realize the 353 quit transmitting, so I would have to go through the steps mentioned above in a somewhat panicked state to find out where we were...
__________________

__________________
one wolf is offline   Reply With Quote
Old 26-09-2010, 22:10   #18
Registered User

Join Date: Feb 2008
Posts: 2,064
Images: 1
Check your power-saving settings to see if you are allowing Windows 7 to power off the port after a period of time.
__________________
SailFastTri is offline   Reply With Quote
Old 27-09-2010, 06:17   #19
Registered User

Join Date: Aug 2010
Posts: 14
My power settings never turn off my pc (hibernate, sleep, standby, etc.) unless the battery is <3%, which on this trip it never approached since I kept it plugged in. I don't even have a screen saver - I turn off my screen by shutting the lid manually, otherwise it stays on indefinitely.
__________________
one wolf is offline   Reply With Quote
Old 27-09-2010, 07:16   #20
Registered User

Join Date: Feb 2008
Posts: 2,064
Images: 1
Quote:
Originally Posted by one wolf View Post
My power settings never turn off my pc (hibernate, sleep, standby, etc.) unless the battery is <3%, which on this trip it never approached since I kept it plugged in. I don't even have a screen saver - I turn off my screen by shutting the lid manually, otherwise it stays on indefinitely.
Read carefully -- "power off the port". You can check this as follows:

right-click on MY COMPUTER, then choose PROPERTIES, then choose DEVICE MANAGER. Expand the serial ports list and right-click on the port your GPS is connected to, then choose PROPERTIES then click the POWER MANAGEMENT tab. There is a checkbox for "Allow the computer tlo turn off this device to save power". It should be unchecked, obviously.
__________________
SailFastTri is offline   Reply With Quote
Old 27-09-2010, 07:58   #21
Registered User

Join Date: Aug 2010
Posts: 14
Sorry, reading carefully is not one of my strong suits as my better half will attest to...

Maybe this is a Win7 thing - but there is no POWER MANAGEMENT tab - see attached screen shots.

This is 32-bit Win7 btw.
Attached Thumbnails
Click image for larger version

Name:	Capture1.jpg
Views:	97
Size:	37.1 KB
ID:	19625   Click image for larger version

Name:	Capture2.jpg
Views:	109
Size:	65.2 KB
ID:	19626  

__________________
one wolf is offline   Reply With Quote
Old 27-09-2010, 08:10   #22
Registered User

Join Date: Feb 2008
Posts: 2,064
Images: 1
OK -- just to check other possibilities....

1) is there a power management setting specific to the Prolific USB to serial adapter? (It should also be listed; under USB devices).

2) Do you have the latest update for the Prolific driver? The latest is dated 7/15/2010 here is the link to download Welcome to Prolific

3) Are you using 32-bit or 64-bit Windows 7, and did you install the right version of the driver?

Hope this helps.
__________________
SailFastTri is offline   Reply With Quote
Old 27-09-2010, 08:24   #23
Registered User

Join Date: Aug 2010
Posts: 14
1. I don't think so - see attached screenshot.

2. Yes that's the one I installed when I purchased the puck in August prior to our cruise.

3. Win7 32-bit and yes I installed the 32-bit version of the driver.

Thanks!
Attached Thumbnails
Click image for larger version

Name:	Capture3.jpg
Views:	104
Size:	61.5 KB
ID:	19627  
__________________
one wolf is offline   Reply With Quote
Old 27-09-2010, 08:53   #24
Registered User

Join Date: Feb 2008
Posts: 2,064
Images: 1
You might see the Prolific device again under "Universal serial bus controllers" (at the bottom of your screen shot).

Also you might want to verify whether the GPS device is matched for the 9600 BPS speed you have set (as per your image in post 21). It is "standard" for many GPS units to communicate at 4800 BPS. A mismatch probably wouldn't work at all, but it's possible it could be working with errors.

Resetting the adapter has worked for you as you noted above, by unplugging then re-plugging the USB adapter. Another test would be to simply change the USB com port assignment (shown in your "advanced" settings for the port) to a lower port number. That would be slightly different because it would reset the port through software in Windows without powering off the USB adapter.

Just as an aside -- nothing to do with your problem but these USB changes are probably the reason for your current assignment of Com 10. If you change to a lower port number Windows will likely give you a warning that the port is "in use", but it's really "reserved" from another time when the same adapter had been plugged in -- so you can safely over-ride the warning unless you really do have other conflicting devices using the other port assignment.
__________________
SailFastTri is offline   Reply With Quote
Old 27-09-2010, 10:14   #25
Registered User

Join Date: Sep 2010
Location: Currently Algarve Portugal
Boat: Moody 42 Ketch 1977
Posts: 14
Thank Goodness

Thanks Sea Wolf, I thought I was going insane surely we canīt be the only ones with this same issue, I have just checked all my settings and driver like you, powered up the programme, great... 15 minutes no gps.
Its really frustrating as open cpn is so brilliant. BTW, I have max sea and the problem doesnt happen with that, it will work for days.. BUT i don`t like it Open CPN is so much clearer and easier.
Thanks
John.
__________________
nostramo.moody is offline   Reply With Quote
Old 27-09-2010, 11:03   #26
Registered User

Join Date: Aug 2010
Posts: 14
Quote:
Originally Posted by SailFastTri View Post
You might see the Prolific device again under "Universal serial bus controllers" (at the bottom of your screen shot).
Right - I accidentally minimized it apparently before I captured the screen shot, but it is not there either.

Quote:
Originally Posted by SailFastTri View Post
Also you might want to verify whether the GPS device is matched for the 9600 BPS speed you have set (as per your image in post 21). It is "standard" for many GPS units to communicate at 4800 BPS. A mismatch probably wouldn't work at all, but it's possible it could be working with errors.
I will try this!

Quote:
Originally Posted by SailFastTri View Post
Resetting the adapter has worked for you as you noted above, by unplugging then re-plugging the USB adapter. Another test would be to simply change the USB com port assignment (shown in your "advanced" settings for the port) to a lower port number. That would be slightly different because it would reset the port through software in Windows without powering off the USB adapter.
I guess I will try this although if I understand what you're saying, this would only make it a little faster to reset when it quits transmitting... frankly that's not a big issue - I can do it in less than 20 seconds (especially in the middle a tight channel - ha).

Quote:
Originally Posted by SailFastTri View Post
Just as an aside -- nothing to do with your problem but these USB changes are probably the reason for your current assignment of Com 10. If you change to a lower port number Windows will likely give you a warning that the port is "in use", but it's really "reserved" from another time when the same adapter had been plugged in -- so you can safely over-ride the warning unless you really do have other conflicting devices using the other port assignment.
What's the value of doing this?
__________________
one wolf is offline   Reply With Quote
Old 27-09-2010, 13:45   #27
Registered User

Join Date: Aug 2010
Posts: 14
One other thing I will add is that the puck does not stop streaming data like this when I use it with GPS Info (GPSInfo_PC_SW_GLOBALSAT_0131). It streams for hours and hours on end. So it would appear that it's somehow related to OpenCPN but then again I don't know much about much so that could be a bad assumption.

Thanks for looking into it and all the suggestions so far though.
__________________
one wolf is offline   Reply With Quote
Old 25-11-2010, 10:08   #28
Registered User

Join Date: Nov 2009
Posts: 8
same issue for me also

with acer apire one (windows 7 starter)
and gps puck bu-353
Got latest drivers from the manufacturer website.
Followed all suggestions posted on this thread with no success:

opencpn (2.1.0) communication with puck hangs after a while and com port becomes unavailable for any other program trying to communication with bu-353.
reboot is the only way to get the port back and opencpn to communicate again with gps.

Previously, I was using opencpn and the bu353 gps receiver on another laptop (windows xp) for several month without any problem.
__________________
dehem is offline   Reply With Quote
Old 25-11-2010, 14:40   #29
Registered User

Join Date: Sep 2010
Location: Currently Algarve Portugal
Boat: Moody 42 Ketch 1977
Posts: 14
Cant be alone

Surely we cant be alone, this problem is making the program useless.
It is an open cpn problem, not gps or windows as the problem only occurs with open cpn.
__________________
nostramo.moody is offline   Reply With Quote
Old 25-11-2010, 17:18   #30
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,020
Guys,
could you have a look in the logfile? To find it, read the bottom of Installing OpenCPN | Official OpenCPN Homepage
Is there anything that looks like connected to your problems? If so, please post it as it can help to trace it down.

Pavel
__________________

__________________
nohal is online now   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with GPS and AIS Data in Ubuntu tebsin OpenCPN 29 04-07-2010 13:07



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 16:20.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.