Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-05-2013, 12:56   #1
Registered User

Join Date: Apr 2013
Posts: 12
GPS Help required.

Hello

Since the last time I update Opencpn the maus gps is not any more working.
I can check if the mause gps works and it works. The configuration of opencpn look correct but nothing happened.

I bought another one, unfortunately Win8 have some conflicts.. with the new GPS so I cant check it in Win8.
I have a Win7 there the new GPS works one time then the machine crash. The old GPS in Opencpn did nothing (the gps work)
What can I do?
__________________

__________________
nepo is offline   Reply With Quote
Old 08-05-2013, 10:42   #2
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,247
Re: GPS Help required.

Quote:
Originally Posted by nepo View Post
Hello


What can I do?
You have to tell us in detail what's going on. Sorry, we are no mind readers.....

Version of OpenCPN?
GPS make?
Exact gps configuration?
A copy of your opencpn log file would be nice.

Thomas
__________________

__________________
cagney is offline   Reply With Quote
Old 08-05-2013, 11:11   #3
Registered User

Join Date: Apr 2013
Posts: 12
Re: GPS Help required.

Hello Thomas
Opencpn version: the last one
Gps: ublock 6 maus gps
Configuration:as shown in the Opencpn description.
__________________
nepo is offline   Reply With Quote
Old 08-05-2013, 12:04   #4
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,016
Re: GPS Help required.

nepo...
You are really not making it easy to help you... The configuration has to reflect the config of your machine, which is not necessarily (in reality pretty rarely) the same as example shown in the documentation.
If you are able to get GPS working with u-center (the app that comes with most u-blocks based GPS pucks), copy it from there. My Navilock puck was set to 9600 bauds from the factory for example. And remember that only one application can use the GPS at any given time...

Pavel
__________________
nohal is offline   Reply With Quote
Old 08-05-2013, 12:06   #5
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,751
Re: GPS Help required.

Hi Nepo,

as far as I remember u-blox dose not make mice, just the chip sets and some but not all of the OEMs add the latest u-blox drivers.
So what is the make? USB?

You said that the mouse does work. How did you check this?

And please add the logfile Thomas asked for. This is the easiest way to have a hint what is going wrong. From your comments we only can guess and this is not very productive, I fear....

Version: "Latest" 3.2 or 3.2.1 or which one?

bcn
__________________
bcn is offline   Reply With Quote
Old 09-05-2013, 01:18   #6
Registered User

Join Date: Apr 2013
Posts: 12
Re: GPS Help required.

Hello, First thanks for the effort trying to help me.
I will try my best.

Version 3.0 (if I remember right the version N°) was working.
Gps maus Agps ( a NN maus)
This gps maus comes with a prog (rom agps) there I can see that the receiver works just that, It shows also the port and bauds 9600.

After I update Opencpn in Opencpn is like dead is not showing any sign of activity, nothing
I have two machines one with win 7 and 1 with win 8. The result is the same in both.
Actual version of Opencpn is 3.2.2

I bought a second maus gps (a ublox 6) but I would like to fix the old one first, the one that for sure was working before I update the prog.


09:09:22: 2013-05-09
09:09:22: ------- Starting OpenCPN -------
09:09:22: Version 3.2.2 Build 2013-05-08
09:09:22: wxWidgets version: wxWidgets 2.8.12
09:09:22: MemoryStatus: mem_total: 3684 mb, mem_initial: 14 mb
09:09:22: SData_Locn is C:\Program Files (x86)\OpenCPN\
09:09:22: Using existing Config_File: C:\ProgramData\opencpn\opencpn.ini
09:09:22: Styles loading from C:\Program Files (x86)\OpenCPN\uidata\styles.xml
09:09:22: No styles found at: C:\ProgramData\opencpn\
09:09:22: No styles found at: C:\ProgramData\opencpn\.opencpn\
09:09:22: Setting Viewpoint Lat/Lon 51.92, 8.0706
09:09:22: Setting Ownship Lat/Lon 52.0459, 8.502
09:09:22: System default Language: es_ES
9:09:22: Opencpn language set to: es_ES
9:09:22: ChartSymbols loaded from C:\Program Files (x86)\OpenCPN\s57data\chartsymbols.xml
9:09:23: Using s57data in C:\Program Files (x86)\OpenCPN\s57data
9:09:24: Setting Viewpoint Lat/Lon 51.92, 8.0706
9:09:24: Setting Ownship Lat/Lon 52.0459, 8.502
9:09:24: Opening NMEA Datastream Serial:COM3
9:09:27: PlugInManager searching for PlugIns in location C:\Program Files (x86)\OpenCPN\plugins
9:09:27: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/aisradar_pi18_v092_pi.dll
9:09:27: C:\Program Files (x86)\OpenCPN\plugins/aisradar_pi18_v092_pi.dll Version detected: 108
9:09:27: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/bsb4_win32_pi15_v12_pi.dll
9:09:27: C:\Program Files (x86)\OpenCPN\plugins/bsb4_win32_pi15_v12_pi.dll Version detected: 105
9:09:27: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/dashboard_pi.dll
9:09:27: C:\Program Files (x86)\OpenCPN\plugins/dashboard_pi.dll Version detected: 106
9:09:28: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/gecomapi_win32_pi16_v09_pi.dll
9:09:28: C:\Program Files (x86)\OpenCPN\plugins/gecomapi_win32_pi16_v09_pi.dll Version detected: 106
9:09:28: [GECOMAPI] Config params loaded: WW=392, ASH=1, DGA=1, USG=1, SB=1, WF=3, Az=0, Ti=0, Ra=108171, Opa=255
9:09:28: [GECOMAPI] Constructing the GE plugin window
9:09:28: [GECOMAPI] GE plugin - OnSize event
9:09:28: [GECOMAPI] GE resize requested
9:09:28: [GECOMAPI] GE plugin - OnShow event
9:09:28: [GECOMAPI] GE plugin - OnShow event
9:09:28: [GECOMAPI] GE plugin - OnSize event
9:09:28: [GECOMAPI] GE resize requested
9:09:28: [GECOMAPI] GE plugin - OnSize event
9:09:28: [GECOMAPI] GE resize requested
9:09:28: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/grib_pi.dll
9:09:28: C:\Program Files (x86)\OpenCPN\plugins/grib_pi.dll Version detected: 107
9:09:29: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/logbookkonni_pi.dll
9:09:29: C:\Program Files (x86)\OpenCPN\plugins/logbookkonni_pi.dll Version detected: 106
9:09:29: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/nvc_win32_pi15_v13_pi.dll
9:09:29: C:\Program Files (x86)\OpenCPN\plugins/nvc_win32_pi15_v13_pi.dll Version detected: 105
9:09:29: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/ROUTE_win32_pi18_v10_pi.dll
9:09:29: C:\Program Files (x86)\OpenCPN\plugins/ROUTE_win32_pi18_v10_pi.dll Version detected: 108
9:09:29: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/SAR_win32_pi18_v07_pi.dll
9:09:29: C:\Program Files (x86)\OpenCPN\plugins/SAR_win32_pi18_v07_pi.dll Version detected: 108
9:09:29: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/wmm_win32_pi18_v06_pi.dll
9:09:29: C:\Program Files (x86)\OpenCPN\plugins/wmm_win32_pi18_v06_pi.dll Version detected: 108
9:09:29: Warning: WMM model data file C:\Program Files (x86)\OpenCPN/plugins/WMM.COF can't be loaded, using the bundled data.
9:09:30: ChartDB Cache policy: Application target is 1024 MBytes
9:09:30: Loading chart db version: V017
9:09:30: Chartdb: Chart directory list follows
9:09:30: Chart directory #0: C:\Program Files (x86)\OpenCPN\maps\CM93_v2
9:09:30: Chart directory #1: C:\Program Files (x86)\OpenCPN\maps\Nederland
9:09:30: GPS Watchdog Timeout is: 6 sec.
9:09:30: Initializing Chart C:\Program Files (x86)\OpenCPN\maps\CM93_v2\
9:09:30: CM93Composite Chart Root is C:\Program Files (x86)\OpenCPN\maps\CM93_v2\\
9:09:30: Loaded CM93 Dictionary from C:\Program Files (x86)\OpenCPN\maps\CM93_v2\\
9:09:30: Loading CM93 cell C:\Program Files (x86)\OpenCPN\maps\CM93_v2\\03900000/B/04200000.B
9:09:33: Loading CM93 cell C:\Program Files (x86)\OpenCPN\maps\CM93_v2\\03900000/A/03900000.A
9:09:33: [GECOMAPI] SetCurrentViewPort called by OpenCPN
9:09:33: [GECOMAPI] Following the viewport to Lat=51.920000, Lon=8.070600, H=0.396384, W=1.041661, R=0.000000 requested
9:09:33: [GECOMAPI] Not detaching, asked to catch up
9:09:33: [GECOMAPI] Rotation translated to 0.000000 degrees
9:09:35: [GECOMAPI] Show boat at 52.045900, 8.502000 requested
__________________
nepo is offline   Reply With Quote
Old 09-05-2013, 01:55   #7
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,751
Re: GPS Help required.

Nepo,

you don't have the GPS test program running at the same time (or any other program that accesses to the GPS mouse) , while running O?

bcn
__________________
bcn is offline   Reply With Quote
Old 09-05-2013, 02:47   #8
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,247
Re: GPS Help required.

Quote:
Originally Posted by nepo View Post
Hello Thomas
Opencpn version: the last one
Gps: ublock 6 maus gps
Configuration:as shown in the Opencpn description.
Are you referring to his picture?


Probably not, as the picture is from a Linux box.
Can you show a similar picture of your own gps setup?

Thomas
__________________
cagney is offline   Reply With Quote
Old 10-05-2013, 00:31   #9
Registered User

Join Date: Apr 2013
Posts: 12
Re: GPS Help required.

Hello,
Here is the screen shoot
Attached Thumbnails
Click image for larger version

Name:	opencpn.png
Views:	134
Size:	165.0 KB
ID:	60616  
__________________
nepo is offline   Reply With Quote
Old 10-05-2013, 14:17   #10
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,247
Re: GPS Help required.

Nepo

Are you sure that your gps is on com3?
Your log shows that O is opening com3.
Any data if you activate the NMEA debug dialog?

Please answer "bcn":s question above.

Thomas
__________________
cagney is offline   Reply With Quote
Old 11-05-2013, 09:27   #11
Registered User

Join Date: Apr 2013
Posts: 12
Re: GPS Help required.

Hello,

I include a pic of the program that shows the gps status (where you can see the port and the baud) and a pic of the prt and div. where it shows in wich port is the gps.
Thanks for the time and help.
Attached Thumbnails
Click image for larger version

Name:	prt and div.png
Views:	94
Size:	3.8 KB
ID:	60661   Click image for larger version

Name:	agps.png
Views:	100
Size:	11.5 KB
ID:	60662  

__________________
nepo is offline   Reply With Quote
Old 11-05-2013, 09:30   #12
Registered User

Join Date: Apr 2013
Posts: 12
Re: GPS Help required.

I forgot . no data.
I installed all many times, what ever is still being...
I canīt found it. in two different machines win 7 and win 8
__________________
nepo is offline   Reply With Quote
Old 11-05-2013, 11:45   #13
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,751
Re: GPS Help required.

Nepo,

from your screenshot the u-blox is in COM8 not in COM3.

In Win7 for me works:
- plug the USB-GPS in first
- then start OpenCPN and it should read the port
- in some rare cases have a look under Configuration/Connections , toggle for example the COM port and then press "Apply"

USB (and especially Windows) in general is extremely picky about cables and physical COM ports (the connectors and plugs). Micro interruptions will make it sometimes necessary to plug off everything and reboot the PC. In a maritime environment this is especially anoying.

And never forget: A COM port can only be owned by one, single program. If one listens already to it, no other program can connect to it.

bcn
__________________
bcn is offline   Reply With Quote
Old 11-05-2013, 13:21   #14
Registered User

Join Date: Apr 2013
Posts: 12
Re: GPS Help required.

I would like to make work first (as I wrote it) the old gps.
What I show in the photo is : the prt with two gps in com 3 the old one.
By the side is the pic of the AGPS prog. wich I use to check that the gps is working (and works). The pic also shows port and baud and said that is working ok.
The screen shoot belongs to win 8 (but in win 7 is the same dead story).
May be looks all ok... and as you someone could say that is ok, but nothing happened so it canīt be ok.
I start Opencpn after plugging the gps, restart the pc. kick the pc, shout to the pc but still doing nothing...
looks like the pc is not scared about my reactions...
I really like the opencpn and I would like to make it run with the gps.
I certainly did not think that the plugging is the problem in two computer and with two different gps.
Nepo
__________________
nepo is offline   Reply With Quote
Old 11-05-2013, 14:05   #15
Registered User
 
Viking Sailor's Avatar

Join Date: Nov 2006
Location: San Francisco Bay
Boat: Fantasia 35 - s/v Feeling Good
Posts: 1,074
Re: GPS Help required.

Nepo,

The baud rate must be 4800. There must not be any programs/apps running that access/use the GPS com port when OpenCPN is started.

Good luck,

__________________

__________________
Viking Sailor is online now   Reply With Quote
Reply

Tags
gps

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 09:57.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.