Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 31-07-2011, 05:35   #301
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,019
Re: Google Earth Plugin

Hmmm...
Code:
1:21:37 PM: [GECOMAPI] Error %i while initializing GE
Tells us that there was an error starting GE. Does GE work without problems when you start it normally (without displaying any dialogs etc.)?
When you click on the plugin icon, the disk should start spinning and GE should appear in the taskbar for a short while, is it the case for you as well?
I would try to reinstall GoogleEarth as well just to make sure that the ActiveX component is registered correctly.
Will go through the initialization code once again, but there's not much I can do - I just ask Windows to create the GE instance for the plugin there...
Another place to look is the Windows event log, but unpredictable what's going to be there.

Pavel

Pavel
__________________

__________________
nohal is offline   Reply With Quote
Old 31-07-2011, 08:45   #302
Registered User

Join Date: May 2011
Boat: 50' catamaran
Posts: 432
Re: Google Earth Plugin

Quote:
Originally Posted by nohal View Post
Hmmm...
Code:
1:21:37 PM: [GECOMAPI] Error %i while initializing GE
Tells us that there was an error starting GE. Does GE work without problems when you start it normally (without displaying any dialogs etc.)?
When you click on the plugin icon, the disk should start spinning and GE should appear in the taskbar for a short while, is it the case for you as well?
I would try to reinstall GoogleEarth as well just to make sure that the ActiveX component is registered correctly.
Will go through the initialization code once again, but there's not much I can do - I just ask Windows to create the GE instance for the plugin there...
Another place to look is the Windows event log, but unpredictable what's going to be there.

Pavel

Pavel
Thank you!
Based on your post, I managed figured it out. The problem was that I had a portable version of Google Earth installed on my PC. I now installed the full install Google Earth version and then added the Google Earth Plugin v0.8 plugin to the plugins folder. Everything now seems to work.
__________________

__________________
Revelations is online now   Reply With Quote
Old 01-08-2011, 18:38   #303
Registered User
 
yachtvalhalla's Avatar

Join Date: Aug 2009
Location: Philippines
Boat: Fuji 32 Ketch
Posts: 553
Re: 2.5 works fine with GE2KAP

Quote:
Originally Posted by yachtvalhalla View Post
Whatever the cause, I am now able to use GE2KAP with 2.5.

Kudos to all.

Terry
But then it stopped working. Paul Higgins bailed me out with a workaround. Prior to having GE2KAP create a chart, go back to OpenCPN and click on the GE icon to delete it from the screen. Then in GE2KAP create the chart. Works for me on two similar machines.
Thanks Paul
Terry
__________________
VALHALLA's Mooring Page
yachtvalhalla is offline   Reply With Quote
Old 17-08-2011, 12:38   #304
Marine Service Provider

Join Date: Oct 2009
Location: In the U.S.
Boat: FP Tobago 35 [sold]
Posts: 402
Re: Google Earth Plugin

Just started using OpenCPN and the GE Plugin.

I have .8 of GE and 2.5 OpenCPN. Running on Win XP.

I can get the position marker to display my boat correctly on the GE window, however once I start moving the boat, the GE images move, but the position does not, and in turn, no track on the GE window either.

If I go into Prefs and unclick, and re-click "Show boat in GE", it will fix the problem (the position is updated and the track line begins to be displayed), but then after some time, it happens again.

Other settings:
Follow boat
Always start hidden... Unchecked
Disconnect from Viewpoint... Checked
Update plugin settings... Checked
Show boat in GE... Checked

Is there something I should look at, or some details I can provide to help sort out this issue?

Thanks for the help, and the work....
__________________
Mark (It's Irie - Sailing Blog)
The Wirie AP+ and The Wirie pro - Long Range Marine WiFi and 2/3/4G Systems
kiltym is offline   Reply With Quote
Old 18-08-2011, 01:10   #305
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,295
Re: Google Earth Plugin

Hello,

Hi Pavel,

I am still alive ... and I am still working on the help of French OpenCPN. We started to update the tutorial in French. This is progressing well.

I just watched the version 0.8 plug-in GE. (Windows XP, SP3. Netbook EeePC )

1° When I zoom in or zoom out, the ship remains visible but the track of the boat disappears and the old part of the track is never visible.

2° If I change my display to use firefox (for example) then, if I go back to OpenCPN, the problem is the same. The old track is no longer visible.

Best regards

Gilletarom.
__________________
Gilletarom is offline   Reply With Quote
Old 18-08-2011, 02:43   #306
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,019
Re: Google Earth Plugin

Quote:
Originally Posted by kiltym View Post
Just started using OpenCPN and the GE Plugin.

I have .8 of GE and 2.5 OpenCPN. Running on Win XP.

I can get the position marker to display my boat correctly on the GE window, however once I start moving the boat, the GE images move, but the position does not, and in turn, no track on the GE window either.

If I go into Prefs and unclick, and re-click "Show boat in GE", it will fix the problem (the position is updated and the track line begins to be displayed), but then after some time, it happens again.

Other settings:
Follow boat
Always start hidden... Unchecked
Disconnect from Viewpoint... Checked
Update plugin settings... Checked
Show boat in GE... Checked

Is there something I should look at, or some details I can provide to help sort out this issue?

Thanks for the help, and the work....
killtym...

Just to make sure - what do you mean by "start moving the boat"? I suppose that really you go somewhere or at least fetch OCPN a NMEA stream and not just right-click the map and do "Move boat here..."
I've observed this situation in my tests sometimes - the problem is there's no way to handle it properly. The only way to get the position to GE is to make it read a "network link" which in our case is a KML file on disk. Sometimes GE decides to stop refreshing it for some reason, but of course does not announce it anywhere. The best we could try is to force it restart reading the link every X seconds or minutes. Annoying is interfacing with GE I have to say...

Pavel
__________________
nohal is offline   Reply With Quote
Old 18-08-2011, 02:45   #307
Registered User
 
yachtvalhalla's Avatar

Join Date: Aug 2009
Location: Philippines
Boat: Fuji 32 Ketch
Posts: 553
Re: Google Earth Plugin

Quote:
Originally Posted by kiltym View Post

Other settings:
Follow boat
Always start hidden... Unchecked
Disconnect from Viewpoint... Checked
Update plugin settings... Checked
Show boat in GE... Checked
I have basically the same configuration as you (0.8,2.5,XP)) but I use some different settings. Instead of 'Follow boat' I use 'Follow chart viewport'. And I check 'Always start hidden'.

I get the boat position and track on GE HOWEVER the GE track is truncated behind the boat for the distance as shown.

Not really a problem since OpenCPN retains the track.

Terry
Attached Thumbnails
Click image for larger version

Name:	11 08 18 07 33 05.jpg
Views:	112
Size:	183.2 KB
ID:	30593  
__________________
VALHALLA's Mooring Page
yachtvalhalla is offline   Reply With Quote
Old 18-08-2011, 02:58   #308
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,019
Re: Google Earth Plugin

Terry,
maintaining just the "tail" is by design. Perhaps I will make it configurable to some extent, but making GE load more than a limited number of trackpoints repeatedly is a certain way to kill it. The "proper solution" would, even to the forementioned problem, be sending the NMEA stream to GE and let it handle it according to it's settings. Now it would need VSPE, GPSPGate, XPort or the likes, so is pretty problematic, in the future when/if OCPN's COM port handling is redone it could be a bit more realistic.

Pavel
__________________
nohal is offline   Reply With Quote
Old 18-08-2011, 03:05   #309
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,019
Re: Google Earth Plugin

Quote:
Originally Posted by Gilletarom View Post
Hello,

Hi Pavel,

I am still alive ... and I am still working on the help of French OpenCPN. We started to update the tutorial in French. This is progressing well.

I just watched the version 0.8 plug-in GE. (Windows XP, SP3. Netbook EeePC )

1° When I zoom in or zoom out, the ship remains visible but the track of the boat disappears and the old part of the track is never visible.

2° If I change my display to use firefox (for example) then, if I go back to OpenCPN, the problem is the same. The old track is no longer visible.

Best regards

Gilletarom.
Hi Gerard!
Hope your season is good
I'm afraid there's not much I could do about this - what's displayed in the GE window is GE's problem, the plugin just creates the KML data with the boat's positon and trackpoints.

Pavel
__________________
nohal is offline   Reply With Quote
Old 18-08-2011, 05:19   #310
Marine Service Provider

Join Date: Oct 2009
Location: In the U.S.
Boat: FP Tobago 35 [sold]
Posts: 402
Re: Google Earth Plugin

Quote:
Originally Posted by nohal View Post
killtym...

Just to make sure - what do you mean by "start moving the boat"? I suppose that really you go somewhere or at least fetch OCPN a NMEA stream and not just right-click the map and do "Move boat here..."
I've observed this situation in my tests sometimes - the problem is there's no way to handle it properly. The only way to get the position to GE is to make it read a "network link" which in our case is a KML file on disk. Sometimes GE decides to stop refreshing it for some reason, but of course does not announce it anywhere. The best we could try is to force it restart reading the link every X seconds or minutes. Annoying is interfacing with GE I have to say...

Pavel
Yes, physically move the boat.

Thanks for the info, wanted to make sure you are aware of it, which it seems you are. Thanks for the work, and thinking about the issue.
__________________
Mark (It's Irie - Sailing Blog)
The Wirie AP+ and The Wirie pro - Long Range Marine WiFi and 2/3/4G Systems
kiltym is offline   Reply With Quote
Old 18-08-2011, 05:27   #311
Marine Service Provider

Join Date: Oct 2009
Location: In the U.S.
Boat: FP Tobago 35 [sold]
Posts: 402
Re: Google Earth Plugin

Quote:
Originally Posted by nohal View Post
Terry,
maintaining just the "tail" is by design. Perhaps I will make it configurable to some extent, but making GE load more than a limited number of trackpoints repeatedly is a certain way to kill it. The "proper solution" would, even to the forementioned problem, be sending the NMEA stream to GE and let it handle it according to it's settings. Now it would need VSPE, GPSPGate, XPort or the likes, so is pretty problematic, in the future when/if OCPN's COM port handling is redone it could be a bit more realistic.

Pavel
So its possible to send a NMEA stream direct to GE?

Or really the other way around, configure GE to read a serial port?

If so, I would bet there are many people using some type of virtual port replicator with OpenCPN. I use VSPE and its been working just fine once things are configured OK. Its quite handy for lots of reasons.

Perhaps there could be an enhancement to allow the plugin to either use a NMEA stream or the KML file based on a "Preferences" selection?

Obviously this is all more work, and I am sure there is more to it then I understand, but if the NMEA stream is a more reliable way to handle this, I am sure some users would be happy to install a virtual port replicator to support the functionality.
__________________
Mark (It's Irie - Sailing Blog)
The Wirie AP+ and The Wirie pro - Long Range Marine WiFi and 2/3/4G Systems
kiltym is offline   Reply With Quote
Old 18-08-2011, 09:42   #312
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,295
Re: Google Earth Plugin

Quote:
Originally Posted by nohal View Post
Hi Gerard!
Hope your season is good
I'm afraid there's not much I could do about this - what's displayed in the GE window is GE's problem, the plugin just creates the KML data with the boat's positon and trackpoints.

Pavel
Hello Pavel,

45 days at sea this summer... Very good !!!

I use 2.5.0 with GE and VDR plug-ins. Trying a file that I have recorded with VDR, and GE open, I see that I said.

I cannot join the VDR file bacause it is too big when i zip it.

So the VDR file is here :

For Pavel Nohal : VDR file

So you can test the problem.

Best regards

Gilletarom.
__________________
Gilletarom is offline   Reply With Quote
Old 31-08-2011, 02:10   #313
Registered User
 
yachtvalhalla's Avatar

Join Date: Aug 2009
Location: Philippines
Boat: Fuji 32 Ketch
Posts: 553
Re: Google Earth Plugin .. problems

First problem is that the blue position 'ball' freezes though the GE display keeps moving along. I've done this about ten times with the same result. See images. In the second image, about 17 minutes after the first one, the blue ball has frozen while the boat has progressed to where the hand is displayed.

The second problem concerns being able to see the boat position on both the chart and the GE screen at the same time. This is especially the case if the 'auto follow' icon has been checked to keep the boat from running off the chart. It takes some maneuvering of the screens such as shown on the second image to get a clear presentation.

I will have to go back to Bungee to avoid these problems

(BTW ... I really like the ownship icon. Thanks MooseMoney )

Terry
Attached Thumbnails
Click image for larger version

Name:	11 08 31 09 19 02.jpg
Views:	87
Size:	162.0 KB
ID:	30992   Click image for larger version

Name:	11 08 31 09 36 52.jpg
Views:	91
Size:	122.6 KB
ID:	30993  

__________________
VALHALLA's Mooring Page
yachtvalhalla is offline   Reply With Quote
Old 31-08-2011, 02:30   #314
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,019
Re: Google Earth Plugin .. problems

Terry...
Thanks for your input...
Quote:
Originally Posted by yachtvalhalla View Post
First problem is that the blue position 'ball' freezes though the GE display keeps moving along. I've done this about ten times with the same result. See images. In the second image, about 17 minutes after the first one, the blue ball has frozen while the boat has progressed to where the hand is displayed.
Known issue, I just have to repeat once again, that there's unfortunately nothing I can do about it, as there's no way to detect that GE decided to stop reading the "network" KML file. The best I can try is to restart it every once in a while which I really don't consider a proper solution. Sure will do some more experiments next time I work on the plugin to find a solution that's acceptable.

Quote:
The second problem concerns being able to see the boat position on both the chart and the GE screen at the same time. This is especially the case if the 'auto follow' icon has been checked to keep the boat from running off the chart. It takes some maneuvering of the screens such as shown on the second image to get a clear presentation.
If I understand well your concerns, the answer is: If you keep the window floating, it covers part of the chart, that's how floating windows behave. If you want to see both the chart and GE with the boat, just dock the plugin window to the side of the chart viewport and you will not have to care about it covering the chart. I would say that's actually the only advantage the plugin really has over the Bungee solution currently

Pavel
__________________
nohal is offline   Reply With Quote
Old 31-08-2011, 21:46   #315
Registered User
 
yachtvalhalla's Avatar

Join Date: Aug 2009
Location: Philippines
Boat: Fuji 32 Ketch
Posts: 553
Re: Google Earth Plugin

Pavel ... " I would say that's actually the only advantage the plugin really has over the Bungee solution currently"

Bungee 6.2 version has that fixed now.

Terry
__________________

__________________
VALHALLA's Mooring Page
yachtvalhalla is offline   Reply With Quote
Reply

Tags
google earth

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Google Earth ? phiggins Navigation 53 31-03-2012 21:39
Editing in Google Earth sinbad7 OpenCPN 5 16-02-2011 16:10
Google Earth beau Navigation 1 24-07-2010 03:10
Turkey Blocks Google Earth & Google Maps MarkJ Europe & Mediterranean 7 04-07-2010 13:30



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 09:37.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.