Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 17-02-2016, 02:32   #106
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,774
Re: GoodAnchorage.com Plugin – Alpha Release

Quote:
Originally Posted by wdkester View Post
I just spent over 2 hours trying to detect what's causing GA problems, mostly with failing to display anchorage details. In doing so, I tried to look at anchorages in 3 areas:Bahamas, south FL and Marthas Vineyard. I also looked at Cuba but there are only 30-40 anchorages there. The basic problem is the unreliability of getting data in certain areas. I was trying to determine what conditions would cause a failure. In doing this I performed hundreds of clicks in these four areas. My reward was to have my login invalidated. A smart algorithm to detect poachers (and ignore those who are trying to help) should notice that mostly the same anchorages are being right clicked and loosen the noose (so to speak).

This is the second time it happened and I thought I was getting close to some answers. My advise to others is to try to help a little bit, but not too much.
David,
I'm not in the Caribbean but in the Mediterranean.
Please try to open e.g. this link with a browser like FireFox
Marina Cap Monastir | Good Anchorage
and tell me how long it takes to display this page.
Gerhard
__________________

__________________
CarCode is offline   Reply With Quote
Old 17-02-2016, 03:55   #107
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,016
Re: GoodAnchorage.com Plugin – Alpha Release

0.3 seconds from Tierra del Fuego, I have to say I can't see the problem you keep yelling about.


Sent from my iPhone using Cruisers Sailing Forum
__________________

__________________
nohal is offline   Reply With Quote
Old 17-02-2016, 04:09   #108
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,774
Re: GoodAnchorage.com Plugin – Alpha Release

Quote:
Originally Posted by nohal View Post
0.3 seconds from Tierra del Fuego, I have to say I can't see the problem you keep yelling about.
Interesting, for me it takes about 2 minutes with FireFox.
So I tried with Safari now and then it is also a fraction of a second only.
I'll investigate what is the blocking reason with FireFox. It is my standard browser and I never have had such a behavior with any other pages.
Of course both browsers are the latest versions.

Gerhard
__________________
CarCode is offline   Reply With Quote
Old 17-02-2016, 07:22   #109
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,363
Re: GoodAnchorage.com Plugin – Alpha Release

Maybe Sean or TransmitterDan can look at this plugin and figure out what the problem is, provided the server has been fixed.
Dietmar can you please advise when you think the server is running well? Then I'll email Sean and TDan.
__________________
rgleason is offline   Reply With Quote
Old 17-02-2016, 08:22   #110
Marine Service Provider
 
dietmar's Avatar

Join Date: Aug 2008
Location: SV Carinthia - West Coast
Boat: Lagoon 440 44'
Posts: 21
Send a message via AIM to dietmar Send a message via Skype™ to dietmar
Re: GoodAnchorage.com Plugin – Alpha Release

The server from my 8 years cruising perspective and looking at the webpages on a very slow marina wifi or even 2.5G networks - is running fine. Same for the 4.0 version of the plugin - I have tested the new version of the plugin and want to add several improvements beyond just performance - just making it work with 4.2 does not enhance that.

We'll see how this develops over time.

Dietmar
__________________
Dietmar Petutschnig / Captain & Yachmaster Ocean
Good Anchorage / SV Carinthia
dietmar is offline   Reply With Quote
Old 18-02-2016, 09:19   #111
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,363
Re: GoodAnchorage.com Plugin – Alpha Release

User Manual External Plugins - GoodAnchorage:
GoodAnchorage | Official OpenCPN Homepage


Forum Thread:
GoodAnchorage.com Plugin – Alpha Release

Website: for free registration to be used with the plugin.
Good Anchorage
Dietmar built the website and plugin. Sean helped with the plugin.


github
https://github.com/goodanchorage/goodanchorage_pi
pavel's fork https://github.com/nohal/goodanchorage_pi/network
sean's fork https://github.com/seandepagnier/goodanchorage_pi

goodanchorage_pi for Opencpnv4.2 is uploaded to
Opencpn Beta File Thingie under 4.2.0 Win PI folder.
rguser, rgpass

https://tgp-architects.com/files/
__________________
rgleason is offline   Reply With Quote
Old 18-02-2016, 20:07   #112
Registered User
 
transmitterdan's Avatar

Join Date: Oct 2011
Boat: Valiant 42
Posts: 4,019
Re: GoodAnchorage.com Plugin – Alpha Release

I am not sure what the problem is exactly. Rick asked me to try the plugin so I built a debug version and am running in my fork of O 4.2. It does not crash although it does cause a few wx alerts. When I moved the chart to Georgetown Grand Cayman and double clicked then after a few seconds one anchorage showed up. Then I zoomed out and this is what I see all around Cuba, Haiti and DR.

I am using a 3G hotspot in a fairly crummy location so my download speed is about 100-200k bits per second. It takes some time but it seems to work in this test case. If you are working in Windows and have Wireshark you might sniff the packets and see what you are sending and what you get back. My guess is that the TCP system is getting upset with turnaround times or some other local network related issue. Whether the plugin can fix these issues I cannot say but first we have to see the problem before we can fix it.

I had a few problems like this last year when we work working on chart downloader. Wireshark helped a lot in seeing the conversations and identifying what was going wrong. It is an excellent tool for debugging networking software.
Attached Thumbnails
Click image for larger version

Name:	2016-02-18.png
Views:	79
Size:	120.0 KB
ID:	119250  
__________________
transmitterdan is online now   Reply With Quote
Old 19-02-2016, 06:54   #113
Registered User
 
transmitterdan's Avatar

Join Date: Oct 2011
Boat: Valiant 42
Posts: 4,019
Re: GoodAnchorage.com Plugin – Alpha Release

I tried in another location and get the error message about nonsense from the server. Attached is the request and response from the server that precipitated the error message box. (remove .pdf to see the text of the request/response)

I am not a json expert. The wxJSONReader:Parse() function declares there are 18 errors in the server response thus the message box. I hope this helps.
Attached Files
File Type: pdf r1.txt.pdf (12.2 KB, 15 views)
__________________
transmitterdan is online now   Reply With Quote
Old 19-02-2016, 08:24   #114
Registered User

Join Date: Jan 2007
Location: Minneapolis
Boat: Irwin 37 CC
Posts: 660
Re: GoodAnchorage.com Plugin – Alpha Release

Quote:
Originally Posted by transmitterdan View Post
I am not sure what the problem is exactly. Rick asked me to try the plugin so I built a debug version and am running in my fork of O 4.2. It does not crash although it does cause a few wx alerts. When I moved the chart to Georgetown Grand Cayman and double clicked then after a few seconds one anchorage showed up. Then I zoomed out and this is what I see all around Cuba, Haiti and DR.

I am using a 3G hotspot in a fairly crummy location so my download speed is about 100-200k bits per second. It takes some time but it seems to work in this test case. If you are working in Windows and have Wireshark you might sniff the packets and see what you are sending and what you get back. My guess is that the TCP system is getting upset with turnaround times or some other local network related issue. Whether the plugin can fix these issues I cannot say but first we have to see the problem before we can fix it.

I had a few problems like this last year when we work working on chart downloader. Wireshark helped a lot in seeing the conversations and identifying what was going wrong. It is an excellent tool for debugging networking software.
TDan, The problem I was having occurs when you right click on one of the anchor icons. Many of the anchorages fail to return the waypoint window. It seems to be different in different areas. New England seemed to work better than S Florida.
__________________
David Kester
Pegasus IV
wdkester is offline   Reply With Quote
Old 19-02-2016, 09:30   #115
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,363
Re: GoodAnchorage.com Plugin – Alpha Release

Thanks TDan,

I downloaded wireshark (2nd time I have used it) and tried to filter out extraneous messages on this public router, using my assigned wireless IP address and was able to find my requests and responses when I double click to get new anchorages from Goodanchorages.

If you have any suggestions regarding use of wireshark, what works for you, it might be helpful, but it is quite interesting seeing the flow. I don't yet know how you found the r1.txt message, but perhaps Dietmar will be able to fix the json so it works better.

On a decent wireless network connection, it seems to me that the anchorage icons are downloading much better than before. I don't know what to attribute this too.

But the json error TDan found might be something that needs to be fixed, also I can confirm what WDkester says about difficulty getting extended information for a given anchorage.

I will continue to try to learn wireshark while testing GoodAnchorage, and hope that I will uncover something more.

Thanks TDan, that was very helpful.
__________________
rgleason is offline   Reply With Quote
Old 19-02-2016, 13:45   #116
Marine Service Provider

Join Date: Dec 2014
Posts: 46
Re: GoodAnchorage.com Plugin – Alpha Release

The problem is with Unicode parsing of anchorage titles by the JSON parser. Just my hunch.
__________________
GoodAnchorageLawsuit.com
Skipper Web is offline   Reply With Quote
Old 19-02-2016, 16:44   #117
Registered User
 
transmitterdan's Avatar

Join Date: Oct 2011
Boat: Valiant 42
Posts: 4,019
Re: GoodAnchorage.com Plugin – Alpha Release

The code turns off wx Unicode parsing. And it works in most places which is strange. I'll take a look at this later.
__________________
transmitterdan is online now   Reply With Quote
Old 19-02-2016, 20:08   #118
Registered User
 
transmitterdan's Avatar

Join Date: Oct 2011
Boat: Valiant 42
Posts: 4,019
Re: GoodAnchorage.com Plugin – Alpha Release

It is probably a Unicode issue. There are escaped characters in the response from the server. I'm guessing the Json parser cannot understand them.
__________________
transmitterdan is online now   Reply With Quote
Old 20-02-2016, 03:01   #119
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,774
Re: GoodAnchorage.com Plugin – Alpha Release

I have given up to use or investigate goodanchorage further on. There is probabely some crap with the server and astonishing one of my browsers shows a 2 minutes time delay while another one not when trying to contact the server. This is repeatable. Maybe the reason could be a large header of 157 lines of javascript includes and files which each html file is sending from the server. This is suspicious and a good reason to keep away from this.
Because there are better solutions also with a greater database of ports I don't need to use goodanchorage.

Gerhard
__________________
CarCode is offline   Reply With Quote
Old 20-02-2016, 04:27   #120
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,363
Re: GoodAnchorage.com Plugin – Alpha Release

Dietmar, TDan and Gerhard have given you some potential places for you to check/improve. Please advise. Thanks guys for your help!
__________________

__________________
rgleason is offline   Reply With Quote
Reply

Tags
anchor, lease, plug

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Open CPN GoodAnchorage.com Plugin – Alpha Release dietmar Commercial Posts 0 23-01-2015 15:54
Need Alpha Autopilot Motor Fisher34 Marine Electronics 6 24-08-2006 11:01
RF Noise from Mastervolt Alpha Pro BachAndByte Electrical: Batteries, Generators & Solar 4 21-08-2004 05:33



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 14:17.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.