Cruisers Forum

Join CruisersForum Today

Thread Tools Rate Thread Display Modes
Old 28-05-2010, 19:20   #1
Registered User

Join Date: May 2010
Posts: 4
GLL Invalid Field Count Error


I am attempting to set up opencpn with my furuno gp-500 gps (old I know). I can see the nmea data coming in, but in the opencpn.log file I see a "GLL, Invalid FieldCount" error.

The GLL sentence comes in as follows: "$GPGLL, 3730.554, N, 122.700, W"

I understand there is supposed to be more after the coordinates, like a checksum. Is this likely a GPS problem or something else I may be able to work out? This GPS has worked reliably with Capn Voyager.

I would post a screen shot but since I'm on an iPhone I can't. I did post one a few days back on page 2 of the "GPS not seen" thread. I am now using a different computer and am plugged directly into a serial port, no more USB adapter.

Thanks for any advice!
Eclipse145 is offline   Reply With Quote
Old 28-05-2010, 19:49   #2
Marine Service Provider
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,470


The GLL sentence you are receiving is an archaic form, in that it does not include the fix-time value. This harks from the old loran days, when accurate time was not provided by the receiver. Some early GPS receivers choose to emulate a loran receiver in this manner.

But it is what you have, and it works with other ECSs, so I suppose we should allow this sentence. I'll make the update in the next Beta, a couple of days from now.

Can the Furuno be persuaded to send more data? Any config options like "Emulate Loran", etc.... How about other sentences, like RMC. These may be too modern, though....

The current Beta 527 works fine without checksums.

bdbcat is offline   Reply With Quote
Old 31-05-2010, 20:30   #3
Registered User

Join Date: May 2010
Posts: 4
Thanks for the info! Sounds great, I'll have to check out one of the newer beta's and report back. It will probably be next weekend before I am back on the boat.

The GPS does not have any such options, all I can really do is set the interval between sentences.

Eclipse145 is offline   Reply With Quote

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Navigation Error = Almost Lost the Lot Scare_Rab The Sailor's Confessional 17 03-11-2010 23:09
Bluechart error? cal40john Navigation 8 24-02-2009 22:08
404 Error Sunspot Baby Forum Tech Support & Site Help 47 14-11-2007 14:34

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 02:59.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.