Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 30-05-2013, 16:51   #1
Registered User

Join Date: Feb 2011
Posts: 242
Glitch Trying to Upgrade 3.2.2 on Ubuntu 12.04

Not sure if I'm trying the best method to upgrade. Running 32 bit 12.04 and had opencpn 3.0.2 installed, didn't uninstall first. Downloaded the deb file, opened it with
Ubuntu Software Center and clicked Upgrade. The error messages are below:


(Reading database ... (Reading database ... 5% (Reading database ... 10% (Reading database ... 15% (Reading database ... 20% (Reading database ... 25% (Reading database ... 30% (Reading database ... 35% (Reading database ... 40% (Reading database ... 45% (Reading database ... 50% (Reading database ... 55% (Reading database ... 60% (Reading database ... 65% (Reading database ... 70% (Reading database ... 75% (Reading database ... 80% (Reading database ... 85% (Reading database ... 90% (Reading database ... 95% (Reading database ... 100% (Reading database ... 318624 files and directories currently installed.)
Preparing to replace opencpn 3.0.2 (using .../opencpn_3.2.2-1_i386.deb) ...
Unpacking replacement opencpn ...
dpkg: error processing /home/david/Downloads/opencpn_3.2.2-1_i386.deb (--install):
trying to overwrite '/usr/lib/opencpn/libdashboard_pi.so', which is also in package opencpn-plugins 2.5.0+dfsg-0
dpkg-deb (subprocess): data: internal gzip write error: Broken pipe
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg-deb (subprocess): failed in write on buffer copy for failed to write to pipe in copy: Broken pipe
Errors were encountered while processing:
/home/david/Downloads/opencpn_3.2.2-1_i386.deb
__________________

__________________
dave777 is offline   Reply With Quote
Old 30-05-2013, 17:10   #2
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,016
Re: glitch trying to upgrade 3.2.2 on Ubuntu 12.04

Dave...
How did a package called opencpn-plugins 2.5.0+dfsg-0 get installed on your system??? It's normally included in the OSGeo live DVD and should not be on any normal Ubuntu system.
Anyway, uninstall it and also consider using our Launchpad PPA to stay up to date on Ubuntu.

Pavel
__________________

__________________
nohal is offline   Reply With Quote
Old 31-05-2013, 19:45   #3
Registered User

Join Date: Feb 2011
Posts: 242
Re: glitch trying to upgrade 3.2.2 on Ubuntu 12.04

Quote:
Originally Posted by nohal View Post
Dave...
How did a package called opencpn-plugins 2.5.0+dfsg-0 get installed on your system??? It's normally included in the OSGeo live DVD and should not be on any normal Ubuntu system.
Anyway, uninstall it and also consider using our Launchpad PPA to stay up to date on Ubuntu.

Pavel
Hi Pavel,

I don't recall what steps I used previously to install. But I had version 2.x prior to 3.x. I'll see if I can uninstall just that package.

I'll also look at the Launchpad link.

Thanks again
__________________
dave777 is offline   Reply With Quote
Old 06-06-2013, 16:20   #4
Registered User

Join Date: Feb 2011
Posts: 242
Re: glitch trying to upgrade 3.2.2 on Ubuntu 12.04

Quote:
Originally Posted by dave777 View Post
Hi Pavel,

I don't recall what steps I used previously to install. But I had version 2.x prior to 3.x. I'll see if I can uninstall just that package.

I'll also look at the Launchpad link.

Thanks again
The addins package removed OK. But after adding the ppa and trying apt-get update i got:

Fetched 19.1 MB in 19s (977 kB/s)
W: Failed to fetch http://ppa.launchpad.net/opencpn/ope...recise/Release Unable to find expected entry 'precise/source/Sources' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.

Maybe ill try it later with sftware cnter
__________________
dave777 is offline   Reply With Quote
Old 06-06-2013, 17:19   #5
Registered User

Join Date: Feb 2011
Posts: 242
Re: glitch trying to upgrade 3.2.2 on Ubuntu 12.04

Quote:
Originally Posted by dave777 View Post
The addins package removed OK. But after adding the ppa and trying apt-get update i got:

Fetched 19.1 MB in 19s (977 kB/s)
W: Failed to fetch http://ppa.launchpad.net/opencpn/ope...recise/Release Unable to find expected entry 'precise/source/Sources' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.

Maybe ill try it later with sftware cnter
Had to uninstall the whole data package (tides), may have been an unnecessary install to begin with. Downloading the most recent .deb file and opening with software center worked. Had to reset some of the chart directories, but otherwise working fine.
__________________
dave777 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Free Routing Software. qtVlm fblc Navigation 614 21-11-2017 07:28
Help / FAQ bdbcat OpenCPN 1327 18-11-2017 03:50
Development Debugging Environment - Setup Help rgleason OpenCPN 577 11-11-2017 06:02
The Precise Pangolin or Ubuntu 12.04 cagney OpenCPN 34 22-05-2012 11:18
upgrade from 2.4 to 2.5 on ubuntu? sdowney717 OpenCPN 5 31-12-2011 08:31



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 20:11.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.