Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 24-03-2013, 09:01   #1
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
GE plugin not working in v. 3.2

I have downloaded the latest gecomapi_win32_pi16_v010_pi.dll and
copied it to the plugin directory in C://ProgramData/plugins/ but it is not
showing up in OpenCPN. It is not showing in the listing of plugins?

Ideas anyone?

Tore
__________________

__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline   Reply With Quote
Old 24-03-2013, 09:21   #2
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,018
Re: GE plugin not working in v. 3.2

Tore...
The right place for the plugins is "C:\Program Files\OpenCPN\plugins" on 32bit Windows or "C:\Program Files (x86)\OpenCPN\plugins" for 64bit...

Pavel
__________________

__________________
nohal is offline   Reply With Quote
Old 24-03-2013, 11:21   #3
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Re: GE plugin not working in v. 3.2

Pavel..

Yes,I know,I have copied the plugin to BOTH directories but the only two plugins which are displayed are Grib and Dashboard??

Tore
Attached Thumbnails
Click image for larger version

Name:	ScreenHunter_237 Mar. 24 14.19.jpg
Views:	58
Size:	31.5 KB
ID:	57765   Click image for larger version

Name:	ScreenHunter_238 Mar. 24 14.19.jpg
Views:	61
Size:	32.9 KB
ID:	57766  

Click image for larger version

Name:	ScreenHunter_239 Mar. 24 14.20.jpg
Views:	64
Size:	19.2 KB
ID:	57767   Click image for larger version

Name:	ScreenHunter_240 Mar. 24 14.20.jpg
Views:	62
Size:	31.1 KB
ID:	57768  

__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline   Reply With Quote
Old 24-03-2013, 11:26   #4
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,018
Re: GE plugin not working in v. 3.2

Tore...
Did you restart OpenCPN after copying the DLL into the plugins folder? Can I see your logfile?

Pavel
__________________
nohal is offline   Reply With Quote
Old 24-03-2013, 12:52   #5
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Re: GE plugin not working in v. 3.2

Yes I restarted a couple of times..
Tore


Quote:
________

11:53:27: 2013-03-18
11:53:27: ------- Starting OpenCPN -------
11:53:27: Version 3.1.1411 Build 2013-02-11
11:53:27: wxWidgets version: wxWidgets 2.8.12
11:53:27: MemoryStatus: mem_total: 2013 mb, mem_initial: 8 mb
11:53:27: SData_Locn is C:\INSTALLED PROGS\OpenCPN\
11:53:27: Using existing Config_File: C:\ProgramData\opencpn\opencpn.ini
11:53:27: Styles loading from C:\INSTALLED PROGS\OpenCPN\uidata\styles.xml
11:53:27: No styles found at: C:\ProgramData\opencpn\
11:53:27: No styles found at: C:\ProgramData\opencpn\.opencpn\
11:53:27: Setting Viewpoint Lat/Lon 58.0234, 7.7061
11:53:27: Setting Ownship Lat/Lon -23.4445, -45.0745
11:53:27: System default Language: pt_BR
11:53:27 AM: Opencpn language set to: en_US
11:53:28 AM: ChartSymbols loaded from C:\INSTALLED PROGS\OpenCPN\s57data\chartsymbols.xml
11:53:28 AM: Using s57data in C:\INSTALLED PROGS\OpenCPN\s57data
11:53:28 AM: Setting Viewpoint Lat/Lon 58.0234, 7.7061
11:53:28 AM: Setting Ownship Lat/Lon -23.4445, -45.0745
11:53:28 AM: Opening NMEA Datastream Serial:COM3
11:53:28 AM: PlugInManager searching for PlugIns in location C:\INSTALLED PROGS\OpenCPN\plugins
11:53:28 AM: PlugInManager: Loading PlugIn: C:\INSTALLED PROGS\OpenCPN\plugins/aisradar_pi18_v092_pi.dll
11:53:28 AM: C:\INSTALLED PROGS\OpenCPN\plugins/aisradar_pi18_v092_pi.dll Version detected: 108
11:53:28 AM: PlugInManager: Loading PlugIn: C:\INSTALLED PROGS\OpenCPN\plugins/dashboard_pi.dll
11:53:28 AM: C:\INSTALLED PROGS\OpenCPN\plugins/dashboard_pi.dll Version detected: 106
11:53:28 AM: PlugInManager: Loading PlugIn: C:\INSTALLED PROGS\OpenCPN\plugins/ge2kap_pi.dll
11:53:28 AM: C:\INSTALLED PROGS\OpenCPN\plugins/ge2kap_pi.dll Version detected: 107
11:53:28 AM: [GE2KAP] Requesting toolbar icon insertion
11:53:28 AM: [GE2KAP] Init Creating new plugin window
11:53:28 AM: [GE2KAP] ge2kap Init
11:53:28 AM: [GE2KAP] On_Text_Changed ENTERED gpx filename:
11:53:28 AM: [GE2KAP] Init Created new plugin window version:GE2KAP_PLUGIN_1.2
11:53:28 AM: PlugInManager: Loading PlugIn: C:\INSTALLED PROGS\OpenCPN\plugins/gecomapi_win32_pi16_v09_pi.dll
11:53:28 AM: C:\INSTALLED PROGS\OpenCPN\plugins/gecomapi_win32_pi16_v09_pi.dll Version detected: 106
11:53:28 AM: [GECOMAPI] Config params loaded: WW=599, ASH=1, DGA=1, USG=1, SB=1, WF=3, Az=0, Ti=15, Ra=2055, Opa=255
11:53:28 AM: [GECOMAPI] Constructing the GE plugin window
11:53:28 AM: [GECOMAPI] GE plugin - OnSize event
11:53:28 AM: [GECOMAPI] GE resize requested
11:53:28 AM: [GECOMAPI] GE plugin - OnShow event
11:53:28 AM: [GECOMAPI] GE plugin - OnShow event
11:53:28 AM: [GECOMAPI] GE plugin - OnSize event
11:53:28 AM: [GECOMAPI] GE resize requested
11:53:28 AM: [GECOMAPI] GE plugin - OnSize event
11:53:28 AM: [GECOMAPI] GE resize requested
11:53:28 AM: [GECOMAPI] GE plugin - OnSize event
11:53:28 AM: [GECOMAPI] GE resize requested
11:53:28 AM: PlugInManager: Loading PlugIn: C:\INSTALLED PROGS\OpenCPN\plugins/grib_pi.dll
11:53:28 AM: C:\INSTALLED PROGS\OpenCPN\plugins/grib_pi.dll Version detected: 107
11:53:28 AM: PlugInManager: Loading PlugIn: C:\INSTALLED PROGS\OpenCPN\plugins/kmloverlay-test_pi.dll
11:53:28 AM: Error: Failed to load shared library 'C:\INSTALLED PROGS\OpenCPN\plugins/kmloverlay-test_pi.dll' (error 126: não foi possível encontrar o módulo especificado.)
11:53:28 AM: PlugInManager: Cannot load library: C:\INSTALLED PROGS\OpenCPN\plugins/kmloverlay-test_pi.dll
11:53:28 AM: PlugInManager: Loading PlugIn: C:\INSTALLED PROGS\OpenCPN\plugins/logbookkonni_pi.dll
11:53:28 AM: C:\INSTALLED PROGS\OpenCPN\plugins/logbookkonni_pi.dll Version detected: 106
11:53:28 AM: [GECOMAPI] GE plugin - OnSize event
11:53:28 AM: [GECOMAPI] GE resize requested
11:53:28 AM: ChartDB Cache policy: Application target is 1006 MBytes
11:53:28 AM: Loading chart db version: V017
11:53:28 AM: Chartdb: Chart directory list follows
11:53:28 AM: Chart directory #0: E:\CM93
11:53:28 AM: Chart directory #1: E:\CHARTS
11:53:29 AM: GPS Watchdog Timeout is: 6 sec.
11:53:29 AM: Initializing Chart E:\CM93\
11:53:29 AM: CM93Composite Chart Root is E:\CM93\\
11:53:29 AM: Loaded CM93 Dictionary from E:\CM93\\
11:53:29 AM: Getting .gpx layer files from: C:\ProgramData\opencpn\layers
11:53:29 AM: New layer 1: BRAZIL-POIS
11:53:33 AM: Error: Can not enumerate files in directory 'C:\ProgramData\opencpn\layers\desktop.ini' (error 267: o nome do diretório é inválido.)
11:53:33 AM: Error: Can not enumerate files in directory 'C:\ProgramData\opencpn\layers\desktop.ini' (error 267: o nome do diretório é inválido.)
11:53:33 AM: New layer 2: East_Mediterranean
11:53:33 AM: New layer 3: Marine.Poi
11:53:33 AM: New layer 4: NORWEGIAN POIS
11:53:38 AM: New layer 5: N_Europe
11:53:38 AM: New layer 6: UK POIS
11:53:38 AM: New layer 7: USA
11:53:38 AM: New layer 8: West Caribbean
11:53:38 AM: New layer 9: WX_WORLD
11:53:38 AM: Loading CM93 cell E:\CM93\\03900000/B/04200000.B
11:53:38 AM: [GE2KAP] GE2KAP Viewport: Clat=58.0234, Clon=7.7061, Width=876, Height=628 Rotation=0
11:53:38 AM: [GE2KAP] Viewport UL= 58.370040,6.788585 LR= 57.673368,8.623615 LL= 57.673368,6.788585 UR= 58.370040,8.623615
11:53:38 AM: [GECOMAPI] SetCurrentViewPort called by OpenCPN
11:53:38 AM: [GECOMAPI] Following the viewport to Lat=58.023400, Lon=7.706100, H=0.696673, W=1.835030, R=0.000000 requested
11:53:38 AM: [GECOMAPI] Not detaching, asked to catch up
11:53:38 AM: [GECOMAPI] Rotation translated to 0.000000 degrees
11:53:38 AM: [GECOMAPI] Show boat at -23.444500, -45.074500 requested
11:53:39 AM: [GECOMAPI] Show boat at -23.444500, -45.074500 requested
11:53:40 AM: [GECOMAPI] Show boat at -23.444500, -45.074500 requested
11:53:41 AM: [GECOMAPI] Show boat at -23.444500, -45.074500 requested
11:53:42 AM: [GECOMAPI] Show boat at -23.444500, -45.074500 requested
11:53:43 AM: [GECOMAPI] Show boat at -23.444500, -45.074500 requested
11:53:43:

________

11:53:43: 2013-03-18
11:53:43: ------- Starting OpenCPN -------
__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline   Reply With Quote
Old 24-03-2013, 13:06   #6
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,018
Re: GE plugin not working in v. 3.2

Tore...
Besides being almost a week old, this log shows clearly that you were using an older version of the GE plugin, located C:\INSTALLED PROGS\OpenCPN\plugins/gecomapi_win32_pi16_v09_pi.dll
and it was working without problems...
Aren't you using more than one side-by-side installations of OpenCPN????

Pavel
__________________
nohal is offline   Reply With Quote
Old 24-03-2013, 14:17   #7
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Re: GE plugin not working in v. 3.2

Pavel..

The file was HUGE and I could not send it so I cut obviously the wrong end of it..

I have installed OpenCPN only in this directory: C:/INSTALLED PROGRAMS/opencpn/
Could that have something to do with not finding the plugin files?
But there again,they are also available as a default from C:/ProgramData/opencpn/plugins/

The files are showing in the directories but only Dashboard and Grib are showing in the Options of OpenCPN?

Tore
__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline   Reply With Quote
Old 24-03-2013, 14:33   #8
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,018
Re: GE plugin not working in v. 3.2

Tore...
Plugins do not belong to C:/ProgramData/opencpn/plugins/ - the program never looks for them in this location.
In your case they should (probably) be in C:/INSTALLED PROGRAMS/opencpn/plugins - but to be sure I need to see the end of your logfile, not it's week old beginning...

Pavel
__________________
nohal is offline   Reply With Quote
Old 24-03-2013, 20:11   #9
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Re: GE plugin not working in v. 3.2

Pavel..

I re installed OpenCPN in c:/program files/opencpn/ and made sure all the plugin files
were in the plugin directory. After this,all worked fine thanks..

I thought the layers,UserIcons and plugins had to also be in C:/ProgramFiles as a default start for OpenCPN?

Tore
__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline   Reply With Quote
Old 24-03-2013, 21:38   #10
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,018
Re: GE plugin not working in v. 3.2

Tore...
On Windows Vista and later, user data belong to C:\ProgramData\OpenCPN - plugins, being program libraries, belong to the plugins subdirectory of OpenCPN program installation. The same applies on all systems, just the locations differ.

Pavel
__________________
nohal is offline   Reply With Quote
Old 25-03-2013, 21:32   #11
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,394
Re: GE plugin not working in v. 3.2

Tore, join the club. We've all done these exercises. It's lucky Nohal is sooo patient. I must say I have learned a lot from your posts.
__________________

__________________
rgleason is online now   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 14:57.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.