Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 18-04-2013, 10:02   #1
Registered User
 
VirtualVagabond's Avatar

Join Date: Oct 2009
Location: Australia
Boat: CT 54... for our sins!
Posts: 2,084
em-trak B100 and Open CPN 'no speak'

I started a thread in the Navigation forum yesterday that I probably should have started here.
I am trying to get an em-trak B100 AIS to work with Open CPN.

New cheapy Laptop has Windows 8.
I've installed the software from the B100 disc (called pro-AIS) and it's receiving data from vessels around here so that side is working.

Open CPN works fine with a Garmin 18s GPS puck, so that part is working too. Obviously the B100 has its own GPS and VHF antennas so I don't use the Garmin puck when using the AIS.

I have been into "connections" and the B100 port is Com3.

How can I get these two to 'play nice'?

Vic
__________________

__________________
One must live the way one thinks, or end up thinking the way one lives - Paul Bourget

www.windwanderer.weebly.com
VirtualVagabond is offline   Reply With Quote
Old 19-04-2013, 04:48   #2
Sponsoring Vendor
 
Neptune's Gear's Avatar

Community Sponsor

Join Date: Oct 2012
Location: Gulf Harbour, New Zealand
Boat: Farr Phase 4, 12.8m
Posts: 992
Re: em-trak B100 and Open CPN 'no speak'

Using the software that came with the unit just checks that it is working. Just check what port it's on, port speed setting etc. Then close the software, start OCPN, under settings make sure you are listening to that port at the right speed etc. The two applications cannot share the port simultaenously
Neptune's Gear is offline   Reply With Quote
Old 19-04-2013, 07:21   #3
Registered User
 
VirtualVagabond's Avatar

Join Date: Oct 2009
Location: Australia
Boat: CT 54... for our sins!
Posts: 2,084
Re: em-trak B100 and Open CPN 'no speak'

Quote:
Originally Posted by NZ8720 View Post
Using the software that came with the unit just checks that it is working. Just check what port it's on, port speed setting etc. Then close the software, start OCPN, under settings make sure you are listening to that port at the right speed etc. The two applications cannot share the port simultaenously
Thanks. That may be the solution, I've had both open together.

Vic

PS. I looked closely at the Far Phase 4. Good boat. Are you in Aus?
__________________
One must live the way one thinks, or end up thinking the way one lives - Paul Bourget

www.windwanderer.weebly.com
VirtualVagabond is offline   Reply With Quote
Old 19-04-2013, 15:25   #4
Sponsoring Vendor
 
Neptune's Gear's Avatar

Community Sponsor

Join Date: Oct 2012
Location: Gulf Harbour, New Zealand
Boat: Farr Phase 4, 12.8m
Posts: 992
Re: em-trak B100 and Open CPN 'no speak'

No, in New Zealand. Have a look at www.paulins.net if you are interested in the boat. We have over 40,000 miles in her now, and have been more than happy
Neptune's Gear is offline   Reply With Quote
Old 21-04-2013, 13:23   #5
Registered User
 
VirtualVagabond's Avatar

Join Date: Oct 2009
Location: Australia
Boat: CT 54... for our sins!
Posts: 2,084
Re: em-trak B100 and Open CPN 'no speak'

Quote:
Originally Posted by NZ8720 View Post
No, in New Zealand. Have a look at www.paulins.net if you are interested in the boat. We have over 40,000 miles in her now, and have been more than happy
Enjoyed the pics.
And the AIS is working perfectly now.
Thanks

Vic
__________________
One must live the way one thinks, or end up thinking the way one lives - Paul Bourget

www.windwanderer.weebly.com
VirtualVagabond is offline   Reply With Quote
Old 25-08-2013, 17:00   #6
Registered User

Join Date: Sep 2007
Location: Near Myrtle Beach SC
Boat: Downeaster 38 / Beneteau F235
Posts: 29
Send a message via Yahoo to audeojude
Re: em-trak B100 and Open CPN 'no speak'

I just installed the B100 with its sister antenna splitter unit and it is working great with OpenCPN on Ubuntu 12.10 Linux. I configured the baud rate at 9600 as that is what windows assigned the usb port that was setup when you plug the ais unit in with the included USB cable. The port under Linux that my system assigned it is ttyACM0
__________________

__________________
audeojude is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 07:17.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.