Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 13-03-2013, 14:53   #1
Registered User

Join Date: Mar 2013
Posts: 20
debian squeeze build errors

I am trying build on an android with debian kit (squeeze). I resolved all build dependencies, but now 'make' fails with the following ( sorry for the bad formatting ). Looks like something wrong with wxWidgets. Any suggestions?


/usr/bin/c++ -DARMHF -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -DwxUSE_GUI=0 -DUSE_GLU_TESS -DocpnUSE_GTK_OPTIMIZE -DocpnHAS_GTK -DOCPN_USE_PORTAUDI
O -DTIXML_USE_STL -DUSE_S57 -DUSE_GARMINHOST -pthread -isystem /usr/lib/wx/include/base-unicode-release-2.8 -isystem /usr/include/wx-2.8 -I/home/Downl
oads/OpenCPN/OpenCPN/include -I/home/Downloads/OpenCPN/OpenCPN/src -I/usr/include/gtk-2.0 -I/usr/lib/arm-linux-gnueabi/glib-2.0/include -I/usr/include
/glib-2.0 -I/usr/lib/arm-linux-gnueabi/gtk-2.0/include -I/usr/include/cairo -I/usr/include/pango-1.0/pango -I/usr/include/atk-1.0/atk -I/home/Download
s/OpenCPN/OpenCPN/src/nmea0183 -I/home/Downloads/OpenCPN/OpenCPN/src/mygdal -I/home/Downloads/OpenCPN/OpenCPN/src/garmin/jeeps -Wall -Wno-unused -fe
xceptions -rdynamic -g -fno-strict-aliasing `pkg-config --cflags --libs gtk+-2.0` -o CMakeFiles/GARMINHOST.dir/src/garmin/jeeps/garmin_wrapper.cpp.o
-c /home/Downloads/OpenCPN/OpenCPN/src/garmin/jeeps/garmin_wrapper.cpp
In file included from /home/Downloads/OpenCPN/OpenCPN/include/navutil.h:49,
from /home/Downloads/OpenCPN/OpenCPN/src/garmin/jeeps/garmin_wrapper.h:32,
from /home/Downloads/OpenCPN/OpenCPN/src/garmin/jeeps/garmin_wrapper.cpp:22:
/home/Downloads/OpenCPN/OpenCPN/include/s52s57.h:236: error: field 'second' has incomplete type
/home/Downloads/OpenCPN/OpenCPN/include/s52s57.h: In constructor 'wxColorHashMap_wxImplementation_Pair::wxColorHash Map_wxImplementation_Pair(const wxS
tring&, const wxColour&)':
/home/Downloads/OpenCPN/OpenCPN/include/s52s57.h:236: error: class 'wxColorHashMap_wxImplementation_Pair' does not have any field named 'second'
/home/Downloads/OpenCPN/OpenCPN/include/s52s57.h:236: error: invalid use of incomplete type 'struct wxColour'
/usr/include/wx-2.8/wx/gdicmn.h:32: error: forward declaration of 'struct wxColour'
/home/Downloads/OpenCPN/OpenCPN/include/s52s57.h: In member function 'wxColour& wxColorHashMap:perator[](const wxString&)':
/home/Downloads/OpenCPN/OpenCPN/include/s52s57.h:236: error: invalid use of incomplete type 'struct wxColour'
/usr/include/wx-2.8/wx/gdicmn.h:32: error: forward declaration of 'struct wxColour'
/home/Downloads/OpenCPN/OpenCPN/include/s52s57.h: In member function 'wxColorHashMap::Insert_Result wxColorHashMap::insert(const wxColorHashMap_wxImpl
ementation_Pair&)':
/home/Downloads/OpenCPN/OpenCPN/include/s52s57.h:236: error: 'const class wxColorHashMap_wxImplementation_Pair' has no member named 'second'
In file included from /home/Downloads/OpenCPN/OpenCPN/include/chart1.h:40,
from /home/Downloads/OpenCPN/OpenCPN/include/chcanv.h:42,
from /home/Downloads/OpenCPN/OpenCPN/include/navutil.h:50,
from /home/Downloads/OpenCPN/OpenCPN/src/garmin/jeeps/garmin_wrapper.h:32,
from /home/Downloads/OpenCPN/OpenCPN/src/garmin/jeeps/garmin_wrapper.cpp:22:
/home/Downloads/OpenCPN/OpenCPN/include/ocpn_types.h: At global scope:
/home/Downloads/OpenCPN/OpenCPN/include/ocpn_types.h:135: error: 'wxColor' does not name a type
In file included from /home/Downloads/OpenCPN/OpenCPN/include/chcanv.h:42,
from /home/Downloads/OpenCPN/OpenCPN/include/navutil.h:50,
from /home/Downloads/OpenCPN/OpenCPN/src/garmin/jeeps/garmin_wrapper.h:32,
from /home/Downloads/OpenCPN/OpenCPN/src/garmin/jeeps/garmin_wrapper.cpp:22:
/home/Downloads/OpenCPN/OpenCPN/include/chart1.h:111: error: 'wxTB_FLAT' was not declared in this scope
/home/Downloads/OpenCPN/OpenCPN/include/chart1.h:111: error: 'wxTB_DOCKABLE' was not declared in this scope

......

many more wxWidgets related errors follow.
__________________

__________________
skkeith is offline   Reply With Quote
Old 13-03-2013, 16:35   #2
Registered User

Join Date: May 2012
Location: Live aboard 19 years
Boat: Norsea, center cockpit/aft cabin, 27'0"
Posts: 354
Re: debian squeeze build errors

skkeith,

Did you use source code to install wxWidgets, or from a repository? I am not familiar with 'debian kit' or which repositories are defined in your /etc/apt/sources list. Which version of wxWidgets is installed? If it was installed using apt or aptitude you can find out by running apt-get install libwxbase* This will tell you whether or not the most recent version is installed and give you an opportunity to install if it's not. If you have more problems please see my instructions for installing Linux and OpenCPN on an android tablet here: Building on Motorola Xoom | Official OpenCPN Homepage

armido
__________________

__________________
armido is offline   Reply With Quote
Old 13-03-2013, 19:12   #3
Registered User

Join Date: Mar 2013
Posts: 20
Re: debian squeeze build errors

I installed everything with apt-get. I used debian-kit because 'linux deploy' recommended in the 'building on Motorola Xoom' article fails to create my loop device, not sure why, it just says 'failed'.

Anyway, the problem with wxWidgets was cmake related. I saw some similar thread and executed a 'cmake --build' instead of 'make' and the wxWidgets errors went away. However the build finally failed finding the arm-linux-gnueabi libraries, even though I used your CmakeCache.txt. There were no libraries in /usr/lib/arm-linux-gnueabi, and when I tried to apt-get to re-install them apt-get said the latest were already installed.

Anyway, I am impressed enough with how far I got that I am re-starting from scratch and I will at least take better notes this time and post results.
__________________
skkeith is offline   Reply With Quote
Old 13-03-2013, 23:54   #4
Registered User

Join Date: Mar 2013
Posts: 20
Re: debian squeeze build errors

I got past all the build errors by starting over from scratch and only installing the dependencies specified. I actually got the application to run fine until I tried to specify a chart directory. When I specify even a single ENC chart the app goes into the 'ingesting' phase for a while, then crashes. Sometimes it will come back up and show a green square where the chart is but zooming in on the square will not show the chart data.

I am installing in a somewhat non-standard way because I am using 'debian pack', but everything built fine, and the base map comes up fine, so I tend to think the problem is elsewhere. Can I get some advice in regards to diagnosing this kind of crash?
__________________
skkeith is offline   Reply With Quote
Old 14-03-2013, 04:53   #5
Registered User

Join Date: May 2012
Location: Live aboard 19 years
Boat: Norsea, center cockpit/aft cabin, 27'0"
Posts: 354
Re: debian squeeze build errors

skkeith,

Move away from the ENC charts to .bsb and CM93 charts. You'll either have to delete or move the folder they're in from your 'charts' folder. If you don't have .bsb or CM93 charts they can be downloaded from the net for free. NOAA has the .bsb charts. If you PM Salty Paws he can give you a link for the CM93 chart download. I can't recall but it was either the USCG or NOAA charts (not .bsb) charts that caused me the same problem.

armido
__________________
armido is offline   Reply With Quote
Old 14-03-2013, 05:09   #6
Registered User

Join Date: May 2012
Location: Live aboard 19 years
Boat: Norsea, center cockpit/aft cabin, 27'0"
Posts: 354
Re: debian squeeze build errors

skkeith,

Use this link to download the .bsb/kap charts Chart Downloader for NOAA RNC&#174

armido
__________________
armido is offline   Reply With Quote
Old 14-03-2013, 13:17   #7
Registered User

Join Date: Mar 2013
Posts: 20
Re: debian squeeze build errors

Well that worked, thanks. I got everything working on my Motorola Atrix HD. Only thing is I wanted vector charts in the first place, so I actually failed in my attempt. The ENC vector charts do work with the windows version, and look really nice, I would be willing to contribute debug time if we can make progress on this issue.

I also learned some things in this process that might be useful for other people:

#1 - adb.exe is a much easier way to enter the shell commands. There is a linux version as well, probably contained in your root kit to begin with. If your desktop is connected via usb to your phone/tablet and you have the latest drivers installed on the desktop, and you have 'usb debugging' enabled on the phone, then 'adb shell' will give you a shell over the usb.

#2 - I think the 'debian kit' download from google store runs faster than 'linux deploy', and it has way better documentation.

Thanks everyone who has contributed to the great project!
__________________
skkeith is offline   Reply With Quote
Old 14-03-2013, 19:24   #8
Registered User

Join Date: May 2012
Location: Live aboard 19 years
Boat: Norsea, center cockpit/aft cabin, 27'0"
Posts: 354
Re: debian squeeze build errors

skkeith,

Want vector charts? http://www.cruisersforum.com/forums/...oad-77905.html

Since you abandoned your attempt to install Linux using Linux Deploy apparently without trying to find an answer to the 'fail' message received when trying to create a loop file, saying what you have about using adb from a computer is unjustified. There is nothing difficult about using a terminal on a tablet - especially with step by step instructions. The only people I'm aware of that have had trouble didn't follow instructions and attempted to use a different installer. 'Debian kit' worked for you and that's great. People who follow my instructions should have no problems, and if they do I and others - including the developer of Linux Deploy - are available to help. I've helped you haven't I? The sooner folks reveal they are encountering problems the less time they will waste getting it done.

I looked up the specs on your Atrix. 8 gigabyte ROM, 4.7 available to the user, expandable to 32 gigabyte with an external micro SD card. So unless you were creating a loop file on an external card - there was insufficient space for an 8 gigabyte loop file which I recommend. Could be why you received a 'fail' result.

armido
__________________
armido is offline   Reply With Quote
Old 18-03-2013, 11:57   #9
Registered User

Join Date: Mar 2013
Posts: 20
Re: debian squeeze build errors

* Thanks for your reply, and also thanks for your detailed instructions. Your write up is what enabled this to work.

* I did get linux deploy working fine, it was trying to create the device on the internal sdcard not the external one. After tweaking it a bit it worked fine, however the X server runs slower than the 'debian kit', so I would still go with Debian Kit, the compile and install is the same on both kits.

* Thanks for the charts.

* As for 'trouble' on the terminal, I was just saying for some people it might be simpler to type on a keyboard will a full size monitor...

Thanks again for all your help.
__________________

__________________
skkeith is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 08:02.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.