Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-06-2011, 02:55   #1
Senior Cruiser
 
sailorF54's Avatar

Cruisers Forum Supporter

Join Date: Dec 2009
Location: Perros-Guirec, France
Boat: Jeanneau Sunshine 36
Posts: 833
Crash on first start-up: 2.3.1 and 606 (Vista)

A French user has reported (baffling to me) crashes on first launch of OpenCpn (both stable 2.3.1 and beta 606) after installation (Vista)
The install log doesn't seem to report anything fishy (see file)
The ProgramData opencpn folder is there but empty
The error message when crashing is (unfortunately) in French
(from Windows I suppose ?)
"l'application n'a pu démarrer car sa configuration côte à côte est incorrecte."
which roughly translates as
'This application couldn't start because its side-by-side configuration is not correct'

He is seeking help through me...

PS Googling seems to point out towards vc files from vcredist_x86.exe
Attached Files
File Type: doc ans_file_186517.txt.doc (22.6 KB, 34 views)
__________________
sailorF54 is offline   Reply With Quote
Old 10-06-2011, 03:25   #2
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,019
Re: Crash on first start-up: 2.3.1 and 606 (Vista)

This really usually means problems with the MSVC redistributable.
Steps to try (as Administrator):
- Turn off antivirus software (Especially Norton seems not liking people installing software)
- Go to Add/Remove Programs
- Uninstall "Microsoft Visual C++ 2008 Redistributable" (There can be quite a few of them with different version numbers - I have 4 + 1 update. Being desperate I would remove all of them)
- Install vcredist_x86.exe manually (The SP1 version from Download details: Microsoft Visual C++ 2008 SP1 Redistributable Package (x86))
- Install OpenCPN
- Turn the antivirus back on
- Pray
- Start OpenCPN

Pavel
__________________
nohal is offline   Reply With Quote
Old 10-06-2011, 03:46   #3
Senior Cruiser
 
sailorF54's Avatar

Cruisers Forum Supporter

Join Date: Dec 2009
Location: Perros-Guirec, France
Boat: Jeanneau Sunshine 36
Posts: 833
Re: Crash on first start-up: 2.3.1 and 606 (Vista)

Thanks a lot Pavel

In the meantime he has solved his problem simply by right-clicking 'installing as administrator' ...
Anyway, the procedure in on record for others...
__________________
sailorF54 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCPN Version 2.4 Beta Build 606 bdbcat OpenCPN 34 19-06-2011 10:52
Crash Test - Dehler 31 yacht hoppy Off Topic Forum 1 06-03-2011 03:36
Crash Blankets and Hull Damage Stillraining General Sailing Forum 14 30-08-2010 19:09
Boat Crash Testing Stillraining General Sailing Forum 3 08-11-2009 21:56
Windows Vista,Constant Crash!!!!!!!!!! Ram Marine Electronics 2 22-02-2007 11:06



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 23:23.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.